Формулы и функции

Функция ЕСЛИ

Функция ЕСЛИ

Примечание: Мы стараемся как можно оперативнее обеспечивать вас актуальными справочными материалами на вашем языке. Эта страница переведена автоматически, поэтому ее текст может содержать неточности и грамматические ошибки. Для нас важно, чтобы эта статья была вам полезна. Просим вас уделить пару секунд и сообщить, помогла ли она вам, с помощью кнопок внизу страницы. Для удобства также приводим ссылку на оригинал (на английском языке).

Функция если — одна из самых популярных функций в Excel, которая позволяет выполнять логические сравнения между значением и ожидаемым действием.

Поэтому у функции ЕСЛИ возможны два результата. Первый результат возвращается в случае, если сравнение истинно, второй — если сравнение ложно.

Например, функция =ЕСЛИ(C2="Да";1;2) означает следующее: ЕСЛИ(С2="Да", то вернуть 1, в противном случае вернуть 2).

Браузер не поддерживает видео. Установите Microsoft Silverlight, Adobe Flash Player или Internet Explorer 9.

Функция ЕСЛИ, одна из логических функций, служит для возвращения разных значений в зависимости от того, соблюдается ли условие.

ЕСЛИ(лог_выражение; значение_если_истина; [значение_если_ложь])

Например:

  • =ЕСЛИ(A2>B2;"Превышение бюджета";"ОК")

  • =ЕСЛИ(A2=B2;B4-A4;"")

Имя аргумента

Описание

лог_выражение    (обязательно)

Условие, которое нужно проверить.

значение_если_истина    (обязательно)

Значение, которое должно возвращаться, если лог_выражение имеет значение ИСТИНА.

значение_если_ложь    (необязательно)

Значение, которое должно возвращаться, если лог_выражение имеет значение ЛОЖЬ.

Простые примеры функции ЕСЛИ

Ячейка D2 содержит формулу =ЕСЛИ(C2="Да";1;2)
  • =ЕСЛИ(C2="Да";1;2)

В примере выше ячейка D2 содержит формулу: ЕСЛИ(C2 = Да, то вернуть 1, в противном случае вернуть 2)

Ячейка D2 содержит формулу =ЕСЛИ(C2=1;"ДА";"НЕТ")
  • =ЕСЛИ(C2=1;"Да";"Нет")

В этом примере формула в ячейке D2 выглядит следующим образом: если (C2 = 1, а затем возвращается значение "Да", в противном случае возвращает "нет"), то функция если может быть использована для вычисления как текста, так и значений. Его также можно использовать для оценки ошибок. Проверка не ограничивается только на предмет того, является ли один элемент другим и возвращает один результат, можно использовать математические операторы и выполнять дополнительные вычисления в зависимости от условий. Можно также объединить несколько функций если, чтобы выполнить несколько сравнений.

Ячейка D2 содержит формулу =ЕСЛИ(C2>B2;"Превышение бюджета","В пределах бюджета")
  • =ЕСЛИ(C2>B2;"Превышение бюджета";"В пределах бюджета")

В примере выше функция ЕСЛИ в ячейке D2 означает: ЕСЛИ(C2 больше B2, то вернуть текст "Превышение бюджета", в противном случае вернуть текст "В пределах бюджета")

Ячейка E2 содержит формулу =ЕСЛИ(C2>B2;C2-B2;"")
  • =ЕСЛИ(C2>B2;C2-B2;0)

На рисунке выше мы возвращаем не текст, а результат математического вычисления. Формула в ячейке E2 означает: ЕСЛИ(значение "Фактические" больше значения "Плановые", то вычесть сумму "Плановые" из суммы "Фактические", в противном случае ничего не возвращать).

Ячейка F7 содержит формулу ЕСЛИ(E7="Да";F5*0,0825;0)
  • =ЕСЛИ(E7="Да";F5*0,0825;0)

В этом примере формула в ячейке F7 означает: ЕСЛИ(E7 = "Да", то вычислить общую сумму в ячейке F5 и умножить на 8,25 %, в противном случае налога с продажи нет, поэтому вернуть 0)

Примечание: Если вы используете текст в формулах, заключайте его в кавычки (пример: "Текст"). Единственное исключение — слова ИСТИНА и ЛОЖЬ, которые Excel распознает автоматически.

Распространенные неполадки

Проблема

Возможная причина

0 (ноль) в ячейке

Не указан аргумент значение_если_истина или значение_если_ложь. Чтобы возвращать правильное значение, добавьте текст двух аргументов или значение ИСТИНА/ЛОЖЬ.

"#ИМЯ?" в ячейке

Как правило, это указывает на ошибку в формуле.

Дополнительные сведения

Вы всегда можете задать вопрос специалисту Excel Tech Community, попросить помощи в сообществе Answers community, а также предложить новую функцию или улучшение на веб-сайте Excel User Voice.

См. также

Операторы и приоритеты в Excel

Использование вложенных функций в формуле

Использование функции если, чтобы проверить, является ли ячейка пустой

Использование функции если, чтобы проверить, является ли ячейка пустой

Видео: дополнительные функции если

Функция IFS (Office 365, Excel 2016 и более поздние версии)

Расширенные функции если — работа с вложенными формулами и предотвращение

Обучающие видео: дополнительные функции если

Функция СЧЁТЕСЛИ будет подсчитывать значения по одному условию

Функция СЧЁТЕСЛИМН подсчитывает значения с учетом нескольких условий

Функция СУММЕСЛИ будет суммировать значения на зависимости от одного условия

Функция СУММЕСЛИМН будет суммировать значения на разных условиях

Функция и

Функция or

Функция ВПР

Общие сведения о формулах в Excel

Как избежать неработающих формул

ошибок в формулах с помощью функции проверки ошибок

Логические функции

Функции Excel (по алфавиту)

Функции Excel (по категориям)

Совершенствование навыков работы с Office
Перейти к обучению
Первоочередный доступ к новым возможностям
Присоединиться к программе предварительной оценки Office

Были ли сведения полезными?

Спасибо за ваш отзыв!

Благодарим за отзыв! Возможно, будет полезно связать вас с одним из наших специалистов службы поддержки Office.

×