Создание схем с помощью визуализатора данных

Примечание:  Мы стараемся как можно оперативнее обеспечивать вас актуальными справочными материалами на вашем языке. Эта страница переведена автоматически, поэтому ее текст может содержать неточности и грамматические ошибки. Для нас важно, чтобы эта статья была вам полезна. Просим вас уделить пару секунд и сообщить, помогла ли она вам, с помощью кнопок внизу страницы. Для удобства также приводим ссылку на оригинал (на английском языке) .

Вы хотели бы автоматически создавать подробные и элегантные блок-схемы Visio из книг Excel? Это можно сделать с помощью шаблонов визуализатора данных. С каждым шаблоном связана книга Excel, которая используется для преобразования обрабатываемых данных в блок-схему Visio. Вы также можете использовать собственный шаблон Excel, сопоставить данные Excel с фигурами в мастере создания схем на основе данных и создать схему автоматически. Кроме того, вы можете добавить дополнительные столбцы с данными в документе Excel, которые преобразуются в данные на фигуре Visio.

Visio также поддерживает двустороннюю синхронизацию между схемой Visio и книгой Excel. Это позволяет не только создавать блок-схему путем изменения данных в Excel и обновления схемы в Visio, но и вносить изменения в схему Visio, а затем обновлять данные Excel из нее. 

Обзор визуализатора данных

Шаблоны визуализатора данных доступны только в Visio Online (план 2) по Monthly Channel. Если вы не знаете, какую версию Visio используете, в меню Файл выберите пункт Учетная запись и нажмите кнопку О программе Visio. Дополнительные сведения о версии Visio, которая предоставляется по подписке, см. на странице Visio Online (план 2).

Если шаблоны визуализатора данных отсутствуют или у вас есть другие вопросы о начале работы, см. страницу Часто задаваемые вопросы о визуализаторе данных.

Примечание: Она предоставляется только по подписке на Office 365. Если вы подписаны на Office 365, убедитесь в том, что у вас установлена последняя версия Office. ИТ-специалисты, управляющие процессом обновления Office 365, могут узнать о том, какие обновления доступны в каждом канале, на странице выпусков обновлений.

В этой статье

Создание схем с помощью визуализатора данных

Подготовка

Обдумайте свои идеи и предварительно проработайте их на бумаге или с помощью рукописного ввода. Этот черновик послужит отправной точкой, и вам будет проще выполнить следующие действия.

Чтобы создать схему с помощью визуализатора данных, можно работать одновременно в Excel и Visio. Вы можете открыть два окна на устройстве с Windows или, если вам так удобнее, подключить второй монитор. Сравнивая содержимое окон Excel и Visio, вы поймете, получается ли у вас то, что задумано.

Рекомендация.    Просмотрите следующее видео по Microsoft Office, чтобы увидеть эту функцию в действии: Визуализатор данных: демонстрация.

Этап 1. Выбор шаблона визуализатора данных

  1. Откройте Visio или выберите Файл > Создать, если вы изменяете схему.

  2. Выберите Шаблоны.

    Команда "Шаблоны"
  3. Выберите Блок-схема.

    Команда "Блок-схема"
  4. Выберите простой блок-схемы — средство визуализации данных, Функциональная блок-схема - средство визуализации данных или Схема аудита — средство визуализации данных.

    Шаблоны визуализатора данных

    В левом верхнем углу шаблона визуализатора данных есть значок Excel.

Дополнительные сведения о блок-схемах и их фигурах см. в статьях Создание простой блок-схемы и Создание функциональной блок-схемы.

Этап 2. Создание книги Excel

  1. В окне предварительного просмотра шаблона щелкните Шаблон данных Excel.

    Выбор ссылки "Шаблон данных Excel"

    Примечание:    если вы хотите использовать образцы шаблонов Excel, приведенные в этой статье для примера, их можно скачать по указанным ниже ссылкам.

  2. Нажмите Файл > Сохранить, укажите компьютер, сервер в сети или библиотеку документов SharePoint, введите имя файла и нажмите кнопку Сохранить.

  3. Чтобы добавить новый лист, в нижней части книги щелкните значок Новый лист Кнопка "Новый лист" .

  4. Создайте таблицу Excel. Дополнительные сведения о работе с таблицами Excel см. в статьях Общие сведения о таблицах, Создание и удаление таблицы Excel и Как добавить или удалить строку или столбец в таблице.

  5. Добавление столбцов и строк в таблице, в которой используются для создания схемы Visio. Существуют специальные требования к заголовки столбцов таблицы Excel и значения. Используйте раздел Столбцы Excel как взаимодействуют с компонентами блок-схемы Visio как Наглядное руководство.

Этап 3. Добавление дополнительных данных фигур в таблицу Excel (необязательно)

  1. В шаблоне Excel просмотрите вкладку Схема процесса Столбцы в таблице Excel выделены синим и зеленым цветами. Цвет служит визуальной подсказкой, которая иллюстрирует различие между столбцами.

    Синие столбцы используются для создания блок-схемы в Visio. Кроме того, все столбцы служат источником данных фигур.

  2. Чтобы добавить дополнительные данные фигур, добавьте один или несколько столбцов в таблицу Excel.

    Зеленые столбцы содержат дополнительные данные, которые можно добавить к каждой фигуре. Вы можете добавить любое количество дополнительных столбцов. По умолчанию эти данные не отображаются на схеме, если вы не добавите рисунки, связанные с данными. Чтобы просмотреть данные фигуры на схеме Visio, выберите Данные > Окно данных фигуры. Дополнительные сведения о данных фигур и рисунках, связанных с данными, см. в статьях Добавление данных в фигуры и Рисунки, связанные с данными: обзор.

Этап 4. Создание схемы Visio с помощью мастера

  1. Вернитесь в Visio, в окне предварительного просмотра шаблона выберите единицу измерения и нажмите кнопку Создать.

  2. На первой странице мастера Создание диаграммы на основе данных сделайте следующее:

    1. В разделе Какую схему вы хотите создать на основе данных? выберите шаблон Простая блок-схема, Функциональная блок-схема (горизонтальная) или Функциональная блок-схема (вертикальная).

    2. В разделе Выберите книгу Excel: выберите книгу из списка последних открытых книг или нажмите кнопку Обзор, чтобы найти файл, созданный на этапе 2.

    3. В разделе Выберите таблицу или настраиваемый диапазон в книге: выберите таблицу Excel, содержащую данные процесса.

    4. Нажмите кнопку Готово. При этом будут приняты все значения по умолчанию, подставленные на остальных страницах мастера в Visio.

В результате схема будет создана автоматически внутри контейнера. В зависимости от размера блок-схемы могут быть добавлены дополнительные страницы Visio.

Этап 5. Сохранение схемы Visio

  • Нажмите Файл > Сохранить, найдите нужную папку, введите имя файла и нажмите кнопку Сохранить.

Рекомендуем хранить файлы Excel и Visio в одной папке, так как это две части одного целого.

Этап 6. Синхронизация данных и схемы

После создания схемы с помощью визуализатора данных в нее можно вносить изменения. Visio поддерживает двустороннюю синхронизацию между исходными данными и схемой.

Совет:    после завершения работы с файлами синхронизируйте их. Если вы вносите изменения в данные Excel, обновите схему, и наоборот: если вы вносите изменение в содержимое схемы, обновите данные Excel.

Изменение данных в Excel и последующее обновление схемы

  1. Внесите изменения в исходные данные в таблице Excel. Вы можете добавить, обновить или удалить строки.

  2. Сохраните книгу Excel.

  3. В Visio щелкните контейнер схемы, чтобы открыть вкладку "Конструктор" в области Работа с данными на ленте, затем щелкните элемент Обновить схему.

В результате изменения, внесенные в книгу Excel, будут отражены на схеме Visio. Обратите внимание на перечисленные ниже аспекты.

  • Если вы внесли в схему изменения, которые могут быть потеряны после обновления, в Visio откроется диалоговое окно конфликтов обновления схемы.

  • При обновлении переносятся изменения только для тех фигур и соединений, которые находятся в контейнере.

  • Изменения форматирования, внесенные вами для фигур и соединительных линий в контейнере, сохраняются.

  • Следите за тем, чтобы все фигуры и соединительные линии схемы оставались внутри контейнера. Объекты, расположенные на странице, но вне контейнера, при обновлении не изменяются. Дополнительные сведения о контейнерах см. в статье Пояснение структуры схем с помощью контейнеров и списков.

Изменение содержимого схемы и последующее обновление данных в Excel

  1. Внесите изменения в схему Visio. Вы можете добавить, обновить или удалить фигуры или соединительные линии.

  2. Сохраните и закройте книгу Excel, если она находится на настольном компьютере или сетевом файловом сервере.

  3. Щелкните контейнер схемы, чтобы открыть вкладку "Конструктор" в области Работа с данными на ленте, затем щелкните элемент Обновить данные источника.

В результате изменения, внесенные в схему Visio, отразятся в книге Excel. Если это может привести к потере данных в Excel, в Visio появится диалоговое окно конфликтов обновления исходных данных. Чтобы избежать проблем, соблюдайте приведенные ниже рекомендации.

  • Перед внесением изменений сохраните резервную копию данных Excel.

  • В книге Excel в качестве источника данных используйте таблицу Excel, а не произвольный диапазон. Если в диалоговом окне Обновить данные источника выбрать команду Перезаписать, Visio преобразует произвольный диапазон в таблицу Excel.

  • Не используйте формулы в исходных данных Excel. Если в диалоговом окне Обновить данные источника выбрать команду Перезаписать, Visio преобразует формулу в результат формулы.

  • Вы создали схему с помощью следующего параметра в мастере создания схем на основе данных (столбцы данных сопоставляются с функциями и этапами): Сопоставление > Дополнительные параметры > Сохраните порядок значений столбцов из данных для создания > Функция или дорожка или Этап или временная шкала. В этом случае Visio требуется дополнительный столбец данных, представляющий связь между фигурами. Если в диалоговом окне Обновить данные источника выбрать команду Перезаписать, добавляется дополнительный столбец.

  • Вы создали функциональную блок-схему с помощью дорожек и шагов на основе порядка значений в Excel. Вы создали схему с помощью следующего параметра в мастере создания схем на основе данных (столбцы данных подключены к шагам процесса и действиям): Сопоставление > Укажите, как подключать шаги процесса/дейстивя > Подключать последовательно. В этом случае Visio требуется дополнительный столбец данных, представляющий связь между фигурами. Если вы измените порядок дорожек или шагов в схеме, порядок изменится и в исходных данных. Если в диалоговом окне Обновить данные источника выбрать команду Перезаписать, дорожки и шаги на схеме перестают соответствовать порядку данных в книге Excel.

Этап 7. Настройка взаимодействия между таблицей Excel и схемой Visio (необязательно)

Иногда требуется настроить процесс создания схем с помощью визуализатора данных. Например, в соответствии со стандартом, принятым в организации, вам могут быть нужны другие фигуры. Вы также можете использовать при сопоставлении столбцы в таблице Excel, имеющие другие имена.

  1. После того как вы нажали Создать, чтобы открыть мастер Создание диаграммы на основе данных, и ввели значения на первой странице (см. этап 4), вы можете нажимать Далее и Назад для перехода между страницами мастера.

  2. Чтобы просмотреть сведения о настройке каждого параметра на странице, нажмите Справка (?). Дополнительные сведения см. в статье Использование мастера "Создание диаграммы на основе данных".

К началу страницы

Взаимодействие между столбцами Excel и компонентами блок-схемы Visio

Чтобы разобраться, каким образом каждый столбец Excel используется при создании схемы в Visio, обратитесь к пошаговому обзору снимка экрана ниже.

Идентификатор шага процесса.   Это число, которое идентифицирует каждую фигуру блок-схемы. Этот столбец является обязательным, и каждое его значение в таблице Excel должно быть уникальным и не пустым. Это значение не отображается на блок-схеме.

Взаимосвязь карты процесса Excel и блок-схемы Visio: Идентификатор шага процесса

Описание шага процесса.   Это текст, добавляемый к каждой фигуре блок-схемы.

Взаимосвязь карты процесса Excel и блок-схемы Visio: Описание шага процесса

Идентификатор следующего шага.   Это идентификатор шага процесса, соответствующий следующей фигуре в последовательности. Для фигуры ветвления существуют два следующих шага, и их идентификаторы указываются через запятую, например: 4,5. Следующих шагов может быть и больше двух.

Взаимосвязь карты процесса Excel и блок-схемы Visio: Идентификатор следующего шага

Метка соединителя.   Для фигур ветвления метки соединителей представлены в виде текста, разделенного запятыми, например: Да,Нет. В примере "Да" соответствует идентификатору 4, а "Нет" — 5.

Взаимосвязь карты процесса Excel и блок-схемы Visio: Метка соединителя

Тип фигуры.   Это тип фигуры, который вы хотите использовать на схеме Visio, например Процесс или Решение. Рекомендуем использовать раскрывающиеся списки, чтобы можно было выбирать только правильные варианты.

Взаимосвязь карты процесса Excel и блок-схемы Visio: Тип фигуры

Функция и этап.   Это функция (или дорожка) и этап (или временная шкала), к которым относится каждая фигура. Этот столбец нужен только для функциональной блок-схемы, а при создании простой блок-схемы мастер его игнорирует.

Взаимосвязь карты процесса Excel и блок-схемы Visio: Функция и этап

К началу страницы

Создание схемы визуализатора данных с помощью других наборов элементов

Помимо шаблонов средство визуализации данных, можно также использовать наборы элементов из других шаблонов при создании диаграммы средство визуализации данных. Например, процесс для создания схем финансовых операций и управления запасами. Существует других программой процесс наборов элементов включая BPMN основные и объектов потока рабочих шаблонов. Можно даже добавить произвольных фигур с помощью набора элементов Мои фигуры. Дополнительные сведения в статье Создание, сохранение и совместное использование настраиваемых наборов элементов.

  1. Откройте схему (простую или функциональную блок-схему), которую вы создали с помощью визуализатора данных.

  2. Нажмите кнопку Создать, чтобы открыть мастер Создание диаграммы на основе данных, и после ввода значений на первой странице нажимайте кнопку Далее, пока не перейдете на страницу сопоставления фигур.

  3. Добавьте один или несколько наборов элементов с помощью параметра Дополнительные фигуры.

  4. Выберите любую фигуру и сопоставьте ей значения из столбца Тип фигуры, перетащив его.

К началу страницы

Добавление в схему рисунков, связанных с данными

Чтобы сделать схему нагляднее, можно добавить в нее рисунки, связанные с данными, которые позволят визуально представить данные фигур. Вы фактически можете превратить схему в информационную панель процесса и использовать рисунки, связанные с данными, для отображения ключевых показателей эффективности (КПЭ), основанных на данных фигур, в виде оригинальных значков.

  1. Откройте схему, созданную с помощью визуализатора данных.

    Выберите контейнер, в который вы хотите добавить рисунки, связанные с данными.

  2. На вкладке Данные установите флажок Поля рисунков, связанных с данными.

  3. Выберите поля рисунков, связанных с данными, которые вы хотите добавить в схему.

    Добавление в схему Visio, созданную с помощью визуализатора данных, рисунков, связанных с данными

    Рисунки, связанные с данными, будут применены ко всей схеме. Чтобы скрыть рисунки, связанные с данными, для определенных фигур, оставьте значения столбцов данных для этих строк в книге Excel пустыми.

  4. При необходимости можно задать дополнительные параметры на вкладке Данные. Дополнительные сведения см. в статье Рисунки, связанные с данными: обзор.

К началу страницы

Дальнейшие действия

Возможно, после создания схемы с помощью визуализатора данных вас заинтересуют следующие задачи:

  • Темы.    Тема в Visio представляет собой набор цветов и эффектов, которые можно применить к документу одним щелчком мыши. С помощью тем документам можно легко придать профессиональный вид. Дополнительные сведения см. в статье Применение тем для профессионального оформления документов.

  • Макет.    В Visio есть руководства и автоматические инструменты, которые помогают выровнять и равномерно распределить фигуры на схеме. Благодаря этому ваш документ выглядит четко и профессионально. Дополнительные сведения см. в статье Выравнивание и расстановка фигур на схеме.

  • Экспорт.    Вы можете экспортировать схему, созданную с помощью визуализатора данных, и связанную с ней книгу Excel в пакет шаблона Visio (VTPX). В пакете шаблона Visio сохраняются параметры схемы, наборы элементов и данные, на основе которых другие пользователи смогут быстро создавать собственные схемы с помощью визуализатора данных. Они могут установить пакет шаблона на своих компьютерах. Дополнительные сведения см. в статье Экспорт и установка пакета шаблона "Визуализатор данных".

К началу страницы

Совершенствование навыков работы с Office
Перейти к обучению
Первоочередный доступ к новым возможностям
Присоединиться к программе предварительной оценки Office

Были ли сведения полезными?

Спасибо за ваш отзыв!

Благодарим за отзыв! Возможно, будет полезно связать вас с одним из наших специалистов службы поддержки Office.

×