Создание модели базы данных (также известна как диаграмма «сущность-связь»)

Создание модели базы данных (также известна как диаграмма «сущность-связь»)

Примечание:  Мы стараемся как можно оперативнее обеспечивать вас актуальными справочными материалами на вашем языке. Эта страница переведена автоматически, поэтому ее текст может содержать неточности и грамматические ошибки. Для нас важно, чтобы эта статья была вам полезна. Просим вас уделить пару секунд и сообщить, помогла ли она вам, с помощью кнопок внизу страницы. Для удобства также приводим ссылку на оригинал (на английском языке) .

С помощью шаблона схеме модели базы данных можно создать модель или реконструирование существующей базы данных в модели с помощью какой-либо из реляционных или объект понятиями реляционных моделирования. Используйте набор элементов отношений сущностей в модели базы данных, основанных на SQL92 и более ранних стандартах. С помощью объектно-реляционной набор элементов, имеет дополнительные фигуры для работы с типами в модели базы данных, основанных на SQL99 и более поздние версии стандартов.

Database model example

С помощью шаблона схеме модели базы данных можно создать модель или реконструирование существующей базы данных в модели с помощью какой-либо из реляционных или объект понятиями реляционных моделирования. Используйте набор элементов отношений сущностей в модели базы данных, основанных на SQL92 и более ранних стандартах. С помощью объектно-реляционной набор элементов, имеет дополнительные фигуры для работы с типами в модели базы данных, основанных на SQL99 и более поздние версии стандартов.

В этой статье описывается, как можно создать модель базы данных и что можно сделать с помощью модели после ее создания.

Не удается найти возможности модели базы данных?

Не каждый edition Microsoft Visio функции модели базы данных. Если не удается найти функций, описанных в этой статье процедуры, скорее у вас есть edition Visio, которая не включать их.

  • Microsoft Visio стандартный не включает шаблон схемы модели базы данных.

  • Выпусках Microsoft Visio профессиональный и расширенный поддерживает возможности обратного проектирования шаблона схеме модели базы данных (с помощью существующей базы данных для создания модели в Visio), но не поддерживает вперед инженерные функции (с помощью Visio модель базы данных для создания кода SQL).

  1. Чтобы начать схеме модели базы данных, выполните одно из указанных ниже действий.

    Создание новой схемы модели с нуля

    Если у вас нет существующей базы данных, которую требуется использовать в качестве отправной точки, можно начать с пустой модели базы данных и добавить собственные таблицы и связи.

    1. Откройте вкладку Файл.

    2. Нажмите кнопку Создать, нажмите кнопку программного обеспечения и баз данных и дважды щелкните Схеме модели базы данных.

    3. На вкладке базы данных в группе Управление нажмите кнопку Параметры отображения.

    4. В диалоговом окне Параметры документа базы данных выберите набор символ, который вы хотите использовать и другие параметры таблицы и связей между и нажмите кнопку ОК.

    Использование существующей базы данных в качестве отправной точки

    При наличии, который нужно смоделировать, что можно понять лучше или использовать в качестве отправной точки для новой модели базы данных, можно использовать мастер структурную обратный извлечь схемы или структуру базы данных и создание новой модели.

    Перед запуском мастера:

    1. Если вы являетесь обратного инженерные книги Microsoft Excel, прежде чем запускать мастер необходимо откройте книгу, а имя группы (или диапазон) ячейки, которые содержит заголовки столбцов. Если вы хотите использовать несколько листов, просто имя группы ячеек столбца на каждом листе. Эти диапазоны рассматриваются как таблицы в мастере. Дополнительные сведения о том, как имя диапазона ячеек приведены в разделе справки Excel под названием задайте именованные ссылки на ячейки или диапазоны.

    2. Для достижения наилучших результатов Установка драйвера по умолчанию в реконструирование перед запуском мастера обратного структурную целевую базу данных. Это действие гарантирует мастера правильно карты собственных типов данных и что весь код, который извлекается с помощью мастера неправильно отображаются в окне кода.

    3. Откройте вкладку Файл.

    4. Нажмите кнопку Создать, нажмите кнопку программного обеспечения и баз данных и дважды щелкните Схеме модели базы данных.

    5. На вкладке базы данных в группе модель щелкните Реконструировать.

    6. На первом экране мастера реконструирования выполните указанные ниже действия.

      1. Выберите драйвер базы данных для вашей системы управления базой данных (СУБД). Если вы уже не связан драйвер базы данных Visio с определенной источник данных ODBC, нажмите кнопку Параметры.

        Примечание: Если вы выполняете реконструирование листа Excel, выберите универсальный драйвер ODBC.

      2. Выберите источник данных из базы данных, который вы хотите изменить. Если вы уже не создан источника данных для существующей базы данных, нажмите кнопку Создать, чтобы сделать это сейчас.

        Когда новый источник будет создан, его имя появится в списке Источники данных.

      3. Завершив настройку параметров, нажмите кнопку Далее.

    7. Следуйте инструкциям в диалоговых окнах любой щелчка.

      Например в диалоговом окне Подключение источника данных введите имя пользователя и пароль и нажмите кнопку ОК.

      Примечание: Если вы используете универсальный драйвер ODBC, может появиться сообщение об ошибке, которое указывает, что обратный реконструирования сведения может быть неполным. В большинстве случаев это не проблема, просто нажмите кнопку ОК и продолжить работу мастера.

    8. Установите флажки для тех типов данных, которые нужно извлечь, и нажмите кнопку Далее.

      Примечание: Некоторые элементы может быть недоступна (затемнены) так, как базы данных управления системы поддерживают не все типы элементов, которые можно извлечь мастера.

    9. Установите флажки для таблиц (и представлений, если они есть), которые нужно извлечь, или нажмите Выделить все, чтобы извлечь все элементы, и нажмите кнопку Далее.

      Примечание: Если обратного инженерные лист Excel и не появились в этом списке, скорее всего, вам нужно имя, которое содержит заголовки столбцов на листе диапазон ячеек.

    10. Если установлен флажок Хранимые процедуры, выберите процедуры, которые нужно извлечь, или нажмите кнопку Выделить все, чтобы извлекать их все, а затем нажмите кнопку Далее.

    11. Выберите параметр нужно реконструируемых элементов для автоматически добавляться к текущей странице.

      Примечание: Вы можете мастер автоматически создать рисунок, кроме выводит список реконструируемых элементов в окне таблиц и представлений. Если вы решили не имеют рисунок, созданный автоматически, можно перетащить элементы из окна таблиц и представлений на страницу документа можно вручную собрать модели базы данных.

    12. Просмотрите параметры, чтобы убедиться, что извлекаются информацию, а затем нажмите кнопку Готово.

      Мастер извлекает выбранные данные и отображает замечания о процедуре извлечения в окне вывода.

    Импорт и уточнение существующей модели

    При наличии существующей VisioModeler или Эрвин ПЛАТИНА модели, можно импортировать его, чтобы создать схему Visio модели базы данных. Эта возможность ограничен VisioModeler 2.0 или более поздние версии файлов модели (.imd) словарь и категории PLATINUM Эрвин 2.6, 3.0 и 3,52 .erx файлы.

    1. Откройте вкладку Файл.

    2. Нажмите кнопку Создать, нажмите кнопку программного обеспечения и баз данных и дважды щелкните Схеме модели базы данных.

    3. На вкладке базы данных в группе модели нажмите кнопку Импорт и выберите тип модели.

    4. Введите путь и имя файла, который вы хотите импортировать, или нажмите кнопку Обзор, чтобы найти файл модели модели и нажмите кнопку Открыть.

    5. В диалоговом окне Импорт нажмите кнопку ОК.

      Visio импортирует файл и в окне вывода отображается ход выполнения. Импортированные таблицы отображаются в окне таблиц и представлений.

    6. В окне таблиц и представлений выберите таблицы, которые нужно смоделировать и перетащите их на страницу документа.

  2. После создания схеме модели базы данных начинает работу уточнение схему. Можно добавить и настроить таблиц и представлений, создание связей и настройка столбцов и типов данных.

    Таблицы

    Используйте фигуру сущность для создания таблицы на диаграмме.

    1. Из набора элементов « Сущность-связь » или Объектно-реляционной Перетащите фигуру сущность документа.

    2. Дважды щелкните фигуру, чтобы открыть окно Свойств базы данных.

    3. В разделе категории выберите пункт Определение и введите имя для таблицы.

    4. В разделе категории нажмите кнопку колонки, введите имя и выберите тип данных.

    5. Установите флажок бы требования для столбцов, которые не могут иметь нулевые значения.

    6. Установите флажок первичного ключа (первичный ключ) для столбцов, однозначно определяющее каждой строки в таблице базы данных.

    7. В разделе категории нажмите кнопку индексы, переключателей, установите флажок или Расширенный для создания этих необязательных элементов.

    Столбцы

    Чтобы добавить или изменить свойства для столбцов, включая типы данных и первичных ключей с помощью окна Свойств базы данных.

    1. Дважды щелкните таблицу на диаграмме.

    2. В окне Свойств базы данных в группе категории нажмите кнопку столбцы.

    3. Щелкните первую пустую ячейку Физическое имя и введите имя.

    4. Чтобы изменить тип данных для столбца, щелкните поле столбца Тип данных и выберите тип данных из списка или введены в список. Например можно ввести decimal(8,2) или char(30).

    5. Чтобы избежать пустых значений, установите флажок бы требования .

    6. Чтобы указать, что столбец является первичным ключом, установите флажок первичного ключа.

    7. Чтобы просмотреть дополнительные свойства столбца помимо тех, которые отображаются при нажатии кнопки категории столбцов, выберите столбец и нажмите кнопку Изменить.

    Связи

    Первичные и внешние ключи используют связи позволяет баз данных в соответствии с строки в одной таблице с помощью строки в связанной таблице. На диаграмме можно отобразить эти отношения. Кроме того, можно установить их количество элементов (например, один ко многим) и использовать Кроу Народная метров, реляционная или IDEF1X нотации для отображения элементов. Не удается отобразить отношения многие ко многим с любого из этих примечаний в шаблоне схеме модели базы данных.

    1. Создайте связь между таблицами.

      1. Убедитесь в том, что обеих таблиц, отображаются на диаграмме. Если вы обратного разработке модели из существующей базы данных, возможно, потребуется перетащите один или оба из окна таблиц и представлений на странице документа.

      2. Дважды щелкните таблицу, которую требуется наличие первичным ключом отношения.

      3. В окне Свойств базы данных в группе категории нажмите кнопку столбцы.

      4. В сетке щелкните столбец, который вы хотите использовать для каждой строки в таблице однозначно определяющее и установите флажок первичного ключа, чтобы установить его в качестве первичного ключа.

      5. Из набора элементов Реляционных объектов или Отношений сущностей Перетащите фигуру связи и перетащите его на пустом месте страницы.

      6. Подключите выше окончания таблицу с родительской таблице.

      7. Подключите другой конец дочерней таблицы.

        Если второй таблицы еще не содержит столбец с тем же именем в качестве первичного ключа, моделей добавляет его во второй таблице как внешний ключ.

        Примечание: Если на исчезают линии связи, на вкладке базы данных в группе Управление нажмите кнопку Параметры отображения. На вкладке " Схема данных " в группе Показать установите флажок связи.

    2. Настройка связи размерности отношений:

      1. Дважды щелкните связь.

      2. В окне Свойств базы данных в разделе категории щелкните Разное.

      3. В разделе количество элементов выберите наиболее подходящую отношения элементов. Связи "один ко многим" лучше ноль или больше или один или несколько. Связи "один к одному" лучшим является ноль или один или только одно.

  3. Чтобы сделать другие уточнений к диаграмме (например, создание индексов, контроля и триггеров) сделайте следующее:

    Создание индексов

    Индексы повысить производительность или скорость базы данных при выполнении запроса.

    1. Открытие схемы модели базы данных.

    2. Дважды щелкните таблицу, к которому вы хотите добавить индекс и в окне Свойств базы данных в списке категории выберите пункт индексы.

    3. Выберите команду Создать.

    4. В диалоговом окне Создать индекс введите имя индекс и нажмите кнопку ОК.

    5. В списке Тип указателя выберите параметр для создания индекса уникальные или повторяющиеся.

    6. В списке Доступные столбцы выберите имя каждого столбца, который вы хотите включить в индекс и нажмите кнопку Добавить >.

    7. В списке Индексированных столбцов установите флажок Asc для создания индекса, который содержит сортировку по возрастанию или снимите флажок, чтобы создать индекс, который содержит Сортировка по убыванию.

      Обновлены схеме модели базы данных.

    Создание представлений.

    Представление можно считать сохраненного запроса. Представления — особенно удобно при необходимости несколько раз доступ к те же данные из нескольких таблиц, или если вы хотите предоставить данные для пользователей не сообщив их изменение фактической таблицы.

    Из набора элементов Отношений сущностей или Реляционных объекта Перетащите фигуру представление на страницу документа.

    Настройки расширенных свойств для таблиц и представлений

    В зависимости от системе управления базой данных (СУБД) может иметь возможность настройки расширенных свойств для таблиц или представлений, чтобы определить, где они хранятся.

    Дважды щелкните таблицу или просмотр расширенные свойства которого требуется задать и в окне Свойства базы данных в списке категории выберите пункт Расширенный.

    Создание правил контроля

    Убедитесь, что в определенный диапазон значений данных, вводимых в столбец с помощью контроля. Например можно создать предложение проверки, которые требуют данные в столбец с именем «Возраст» быть более 65.

    1. Дважды щелкните таблицу, чтобы открыть окно Свойств базы данных.

    2. В разделе категории щелкните столбцы и выберите столбец, который вы хотите добавить предложение проверки для.

    3. Нажмите кнопку Изменить.

    4. На вкладке Проверка диалогового окна Свойств столбца введите ограничения, которые вы хотите.

      Предложения проверки добавляется окна кода в разделе Локальный код.

    Создание хранимых процедур и пользовательских функций

    Используйте хранимых процедур и пользовательских функций для создания пакетов код, который вы можете повторно использовать многократно выполнять те же действия. Основные двух разница между что пользовательская функция возвращает значение, тогда как хранимая процедура выполняет код без возврата значения.

    1. На вкладке базы данных в группе Показать или скрыть установите флажок кода для открытия окна кода.

    2. Нажмите кнопку Глобального кода и нажмите кнопку Создать.

    3. На вкладке СвойстваРедактор кода выберите нужный тип код, который вы хотите создать и введите имя для кода.

    4. На вкладке " текст " введите код и нажмите кнопку ОК.

    Создание переключателей

    Переключатели вызвать код SQL, указанный в триггер для запуска при возникновении определенного события в базе данных.

    1. Дважды щелкните таблицу, чтобы открыть окно Свойств базы данных.

    2. В разделе категории нажмите кнопку Переключатели и нажмите кнопку Добавить.

    3. На вкладке " Свойства " введите имя для триггера.

    4. На вкладке " текст " введите код и нажмите кнопку ОК.

      Триггер добавляется окна кода в разделе Локальный код.

В этой статье описывается, как можно создать модель базы данных и что можно сделать с помощью модели после ее создания. Для быстрого запуска, в меню файл выберите команду Создать, выберите пункт программного обеспечения и баз данных и нажмите кнопку Схеме модели базы данных.

Не удается найти возможности модели базы данных?

Скорее всего выпуск Microsoft Office Visio не содержит функции, которые вы ищете. Чтобы узнать, какой версией Visio у вас есть, нажмите кнопку Сведения о Microsoft Office Visio в меню Справка. Название выпуска находится в верхней строке текста в диалоговом окне.

  • В выпуске Microsoft Office Visio Стандартный отсутствует шаблон "Схема модели базы данных".

  • Microsoft Office Visio профессиональный поддерживает обратного инженерные функции шаблона схеме модели базы данных (с помощью существующей базы данных для создания модели в Visio), но не поддерживает вперед инженерные функции (с помощью Visio базы данных модель для создания кода SQL).

  • Полный набор функций для моделирования баз данных, включая возможности реконструирования и прямой разработки, доступен в выпуске Visio for Enterprise Architects. Visio for Enterprise Architects входит в подписку MSDN Premium, которая предлагается вместе с продуктом Visual Studio Professional и ролевыми выпусками системы Visual Studio Team System.

  1. Чтобы начать схеме модели базы данных, выполните одно из указанных ниже действий.

    Создание новой схемы модели с нуля

    Если у вас нет существующей базы данных, которую требуется использовать в качестве отправной точки, можно начать с пустой модели базы данных и добавить собственные таблицы и связи.

    1. В меню Файл последовательно наведите указатель мыши на пункты Создать и Программы и базы данных и выберите пункт Схема модели базы данных.

    2. В меню базы данных выберите пункт Параметры и выберите команду документ.

    3. В диалоговом окне Параметры документа базы данных выберите набор символ, который вы хотите использовать и другие параметры таблицы и связей между и нажмите кнопку ОК.

    Использование существующей базы данных в качестве отправной точки

    При наличии, который нужно смоделировать, что можно понять лучше или использовать в качестве отправной точки для новой модели базы данных, можно использовать мастер структурную обратный извлечь схемы или структуру базы данных и создание новой модели.

    Примечание: Перед запуском мастера:

    1. Если вы являетесь обратного инженерные в Microsoft Office Excel, прежде чем запускать мастер необходимо откройте книгу, а имя группы (или диапазон) ячейки, которые содержит заголовки столбцов. Если вы хотите использовать несколько листов, просто имя группы ячеек столбца на каждом листе. Эти диапазоны рассматриваются как таблицы в мастере. Дополнительные сведения о том, как имя диапазона ячеек, читайте статью в вашей Microsoft Office Excel помогут определить под названием с именем ссылки на ячейки или диапазоны.

    2. Для достижения наилучших результатов Установка драйвера по умолчанию в реконструирование перед запуском мастера обратного структурную целевую базу данных. Это действие гарантирует мастера правильно карты собственных типов данных и что весь код, который извлекается с помощью мастера неправильно отображаются в окне кода.

    3. В меню Файл последовательно наведите указатель мыши на пункты Создать и Программы и базы данных и выберите пункт Схема модели базы данных.

    4. В меню База данных выберите команду Реконструировать.

    5. На первом экране мастера реконструирования выполните указанные ниже действия.

      1. Выберите драйвер базы данных Microsoft Office Visio для вашей системы управления базой данных (СУБД). Если вы уже не связан драйвер базы данных Visio с определенной источник данных ODBC, нажмите кнопку Параметры.

        Примечание: Если вы выполняете реконструирование листа Excel, выберите универсальный драйвер ODBC.

      2. Выберите источник данных из базы данных, который вы хотите изменить. Если вы уже не создан источника данных для существующей базы данных, нажмите кнопку Создать, чтобы сделать это сейчас.

        Когда новый источник будет создан, его имя появится в списке Источники данных.

      3. Завершив настройку параметров, нажмите кнопку Далее.

    6. Следуйте инструкциям в диалоговых окнах любой щелчка.

      Например в диалоговом окне Подключение источника данных введите имя пользователя и пароль и нажмите кнопку ОК. Если источник данных не защищен паролем, просто нажмите кнопку ОК.

      Примечание: Если вы используете универсальный драйвер ODBC, может появиться сообщение об ошибке, которое указывает, что обратный реконструирования сведения может быть неполным. В большинстве случаев это не проблема, просто нажмите кнопку ОК и продолжить работу мастера.

    7. Установите флажки для тех типов данных, которые нужно извлечь, и нажмите кнопку Далее.

      Примечание: Некоторые элементы может быть недоступна (затемнены) так, как базы данных управления системы поддерживают не все типы элементов, которые можно извлечь мастера.

    8. Установите флажки для таблиц (и представлений, если они есть), которые нужно извлечь, или нажмите Выделить все, чтобы извлечь все элементы, и нажмите кнопку Далее.

      Примечание: Если обратного инженерные лист Excel и не появились в этом списке, скорее всего, вам нужно имя, которое содержит заголовки столбцов на листе диапазон ячеек.

    9. Если на шаге 3 вы установили флажок Хранимые процедуры, выберите процедуры, которые нужно извлечь, или щелкните Выделить все, чтобы извлечь их все, а затем нажмите кнопку Далее.

    10. Выберите параметр нужно реконструируемых элементов для автоматически добавляться к текущей странице.

      Примечание: Вы можете мастер автоматически создать рисунок, кроме выводит список реконструируемых элементов в окне таблиц и представлений. Если вы решили не имеют рисунок, созданный автоматически, можно перетащить элементы из окна таблиц и представлений на страницу документа можно вручную собрать модели базы данных.

    11. Просмотрите параметры, чтобы убедиться, что извлекаются информацию, а затем нажмите кнопку Готово.

      Мастер извлекает выбранные данные и отображает замечания о процедуре извлечения в окне вывода.

    Импорт и уточнение существующей модели

    При наличии существующей VisioModeler или Эрвин ПЛАТИНА модели, можно импортировать его, чтобы создать схему Visio модели базы данных. Эта возможность ограничен VisioModeler 2.0 или более поздние версии файлов модели (.imd) словарь и категории PLATINUM Эрвин 2.6, 3.0 и 3,52 .erx файлы.

    1. В меню Файл последовательно наведите указатель мыши на пункты Создать и Программы и базы данных и выберите пункт Схема модели базы данных.

    2. В меню базы данных выберите пункт Импорт и нажмите кнопку Импорт < тип модели >.

    3. Введите путь и имя файла, который вы хотите импортировать, или нажмите кнопку Обзор, чтобы найти файл модели модели и нажмите кнопку Открыть.

    4. В диалоговом окне Импорт нажмите кнопку ОК.

      Visio импортирует файл и в окне вывода отображается ход выполнения. Импортированные таблицы отображаются в окне таблиц и представлений.

    5. В окне таблиц и представлений выберите таблицы, которые нужно смоделировать и перетащите их на страницу документа.

  2. После создания схеме модели базы данных начинает работу уточнение схему. Можно добавить и настроить таблиц и представлений, создание связей и настройка столбцов и типов данных.

    Таблицы

    Используйте фигуру сущность для создания таблицы на диаграмме.

    1. Из набора элементов « Сущность-связь » или Объектно-реляционной Перетащите фигуру сущность документа.

    2. Дважды щелкните фигуру, чтобы открыть окно свойств базы данных.

    3. В разделе категории выберите пункт Определение и введите имя для таблицы.

    4. В разделе категории нажмите кнопку колонки, введите имя и выберите тип данных.

    5. Установите флажок бы требования для столбцов, которые не могут иметь нулевые значения.

    6. Установите флажок первичного ключа (первичный ключ) для столбцов, однозначно определяющее каждой строки в таблице базы данных.

    7. В разделе категории нажмите кнопку индексы, переключателей, установите флажок или Расширенный для создания этих необязательных элементов.

    Столбцы

    Чтобы добавить или изменить свойства для столбцов, включая типы данных и первичных ключей с помощью окна свойств базы данных.

    1. Дважды щелкните таблицу на диаграмме.

    2. В окне свойств базы данных в группе категории нажмите кнопку столбцы.

    3. Щелкните первую пустую физическое имя ячейки и введите имя.

    4. Чтобы изменить тип данных для столбца, щелкните поле столбца Тип данных и выберите тип данных из списка или введены в список. Например можно ввести decimal(8,2) или char(30).

    5. Чтобы избежать пустых значений, установите флажок бы требования .

    6. Чтобы указать, что столбец является первичным ключом, установите флажок первичного ключа.

    7. Чтобы просмотреть дополнительные свойства столбца помимо тех, которые отображаются при нажатии кнопки категории столбцов, выберите столбец и нажмите кнопку Изменить.

    Связи

    Первичные и внешние ключи используют связи позволяет баз данных в соответствии с строки в одной таблице с помощью строки в связанной таблице. На диаграмме можно отобразить эти отношения. Кроме того, можно установить их количество элементов (например, один ко многим) и использовать Кроу Народная метров, реляционная или IDEF1X нотации для отображения элементов. Не удается отобразить отношения многие ко многим с любого из этих примечаний в шаблоне схеме модели базы данных.

    1. Создайте связь между таблицами.

      1. Убедитесь в том, что обеих таблиц, отображаются на диаграмме. Если вы обратного разработке модели из существующей базы данных, возможно, потребуется перетащите один или оба из окна таблиц и представлений на странице документа.

      2. Дважды щелкните таблицу, которую требуется наличие первичным ключом отношения.

      3. В окне свойств базы данных в группе категории нажмите кнопку столбцы.

      4. В сетке щелкните столбец, который вы хотите использовать для каждой строки в таблице однозначно определяющее и установите флажок первичного ключа, чтобы установить его в качестве первичного ключа.

      5. Из набора элементов Реляционных объектов или Отношений сущностей Перетащите фигуру связи и перетащите его на пустом месте страницы.

      6. Подключите выше окончания таблицу с родительской таблице.

      7. Подключите другой конец дочерней таблицы.

        Если второй таблицы еще не содержит столбец с тем же именем в качестве первичного ключа, моделей добавляет его во второй таблице как внешний ключ.

        Примечание: Если на исчезают линии связи, в меню базы данных выберите пункт Параметры и выберите документ. На вкладке " Схема данных " в группе Показать установите флажок связи.

    2. Настройка связи размерности отношений:

      1. Дважды щелкните связь.

      2. В окне свойств базы данных в разделе категории щелкните Разное.

      3. В разделе количество элементов выберите наиболее подходящую отношения элементов. Связи "один ко многим" лучше ноль или больше или один или несколько. Связи "один к одному" лучшим является ноль или один или только одно.

  3. Чтобы сделать другие уточнений к диаграмме (например, создание индексов, контроля и триггеров) сделайте следующее:

    Создание индексов

    Индексы повысить производительность или скорость базы данных при выполнении запроса.

    1. Открытие схемы модели базы данных.

    2. Дважды щелкните таблицу, к которому вы хотите добавить индекс и в окне свойств базы данных в списке категории выберите пункт индексы.

    3. Выберите команду Создать.

    4. В диалоговом окне Создать индекс введите имя индекс и нажмите кнопку ОК.

    5. В списке Тип указателя выберите параметр для создания индекса уникальные или повторяющиеся.

    6. В списке Доступные столбцы выберите имя каждого столбца, который вы хотите включить в индекс и нажмите кнопку Добавить >.

    7. В списке Индексированных столбцов установите флажок Asc для создания индекса, который содержит сортировку по возрастанию или снимите флажок, чтобы создать индекс, который содержит Сортировка по убыванию.

      Обновлены схеме модели базы данных.

    Создание представлений.

    Представление можно считать сохраненного запроса. Представления — особенно удобно при необходимости несколько раз доступ к те же данные из нескольких таблиц, или если вы хотите предоставить данные для пользователей не сообщив их изменение фактической таблицы.

    Из набора элементов Отношений сущностей или Реляционных объекта Перетащите фигуру представление на страницу документа.

    Настройки расширенных свойств для таблиц и представлений

    В зависимости от системе управления базой данных (СУБД) может иметь возможность настройки расширенных свойств для таблиц или представлений, чтобы определить, где они хранятся.

    Дважды щелкните таблицу или просмотр расширенные свойства которого требуется задать и в окне Свойства базы данных в списке категории выберите пункт Расширенный.

    Создание правил контроля

    Убедитесь, что в определенный диапазон значений данных, вводимых в столбец с помощью контроля. Например можно создать предложение проверки, которые требуют данные в столбец с именем «Возраст» быть более 65.

    1. Дважды щелкните таблицу, чтобы открыть окно свойств базы данных.

    2. В разделе категории щелкните столбцы и выберите столбец, который вы хотите добавить предложение проверки для.

    3. Нажмите кнопку Изменить.

    4. На вкладке Проверка диалогового окна Свойств столбца введите ограничения, которые вы хотите. Дополнительные сведения о нужные значения отображается диалоговое столбцов и свойства поля (вкладка «Проверка»).

      Предложения проверки добавляются окна кода в разделе Локальный код.

    Создание хранимых процедур и пользовательских функций

    Используйте хранимых процедур и пользовательских функций для создания пакетов код, который вы можете повторно использовать многократно выполнять те же действия. Основные двух разница между что пользовательская функция возвращает значение, тогда как хранимая процедура выполняет код без возврата значения.

    1. В меню базы данных выберите пункт представление и нажмите кнопку код, чтобы открыть окно программы.

    2. Нажмите кнопку Глобального кода и нажмите кнопку Создать.

    3. На вкладке СвойстваРедактор кода выберите нужный тип код, который вы хотите создать и введите имя для кода.

    4. На вкладке " текст " введите код и нажмите кнопку ОК.

    Создание переключателей

    Переключатели вызвать код SQL, указанный в триггер для запуска при возникновении определенного события в базе данных.

    1. Дважды щелкните таблицу, чтобы открыть окно свойств базы данных.

    2. В разделе категории нажмите кнопку Переключатели и нажмите кнопку Добавить.

    3. На вкладке " Свойства " введите имя для триггера.

    4. На вкладке " текст " введите код и нажмите кнопку ОК.

      Триггер добавляется окна кода в разделе Локальный код.

Совершенствование навыков работы с Office
Перейти к обучению
Первоочередный доступ к новым возможностям
Присоединиться к программе предварительной оценки Office

Были ли сведения полезными?

Спасибо за ваш отзыв!

Благодарим за отзыв! Возможно, будет полезно связать вас с одним из наших специалистов службы поддержки Office.

×