Создание гистограммы в Excel

Примечание: Мы стараемся как можно оперативнее обеспечивать вас актуальными справочными материалами на вашем языке. Эта страница переведена автоматически, поэтому ее текст может содержать неточности и грамматические ошибки. Для нас важно, чтобы эта статья была вам полезна. Просим вас уделить пару секунд и сообщить, помогла ли она вам, с помощью кнопок внизу страницы. Для удобства также приводим ссылку на оригинал (на английском языке).

Гистограмма — это столбчатая диаграмма, которая показывает частоту повторяемости значений.

Примечание: В этой статье рассматривается только создание гистограмм. Сведения о диаграммах Парето (отсортированных гистограммах) см. в статье Создание диаграммы Парето.

  1. Выделите данные.

    (Это типичный пример данных для гистограммы.)

    Данные, использованные для создания образца гистограммы выше
  2. Выберите Вставка > Вставить диаграмму статистики > Гистограмма.

    Команда "Гистограмма", появляющаяся при нажатии кнопки "Вставка статистической диаграммы"

    Гистограмму также можно создать с помощью вкладки Все диаграммы в разделе Рекомендуемые диаграммы.

Советы: 

  • На вкладках Конструктор и Формат можно настроить внешний вид диаграммы.

  • Если они не отображаются, щелкните в любом месте гистограммы, чтобы добавить на ленту область Работа с диаграммами.

Вкладки "Конструктор" и "Формат" в разделе "Работа с диаграммами"

  1. Правой кнопкой мыши щелкните горизонтальную ось диаграммы, выберите Формат оси, а затем щелкните Параметры оси.

    Команда "Формат оси" в контекстном меню
  2. Руководствуясь приведенной ниже таблицей, вы сможете выбрать параметры, которые нужно задать в области задач Формат оси.

    Параметр

    Описание

    По категориям

    Выберите этот вариант, если категории (горизонтальная ось) текстовые, а не числовые. На гистограмме одинаковые категории будут сгруппированы, а значения на оси значений — просуммированы.

    Совет: Чтобы подсчитать количество появлений текстовых строк, добавьте столбец и укажите в нем значение "1", а затем отобразите гистограмму и выберите параметр По категориям.

    Автоматическая

    Это вариант по умолчанию для гистограмм. Длина интервала вычисляется по формуле Скотта.

    Длина интервала

    Введите положительное десятичное число, задающее количество точек данных в каждом диапазоне.

    Количество интервалов

    Введите количество интервалов гистограммы (включая интервалы для значений, выходящих за верхнюю и нижнюю границы).

    Выход за верхнюю границу интервала

    Установите этот флажок, чтобы создать интервал для всех значений, превышающих значение в поле справа. Чтобы изменить его, введите в поле другое десятичное число.

    Выход за нижнюю границу интервала

    Установите этот флажок, чтобы создать интервал для всех значений, не превышающих значение в поле справа. Чтобы изменить его, введите в поле другое десятичное число.

    Область задач "Формат оси"

Совет: Дополнительные сведения о гистограммах и их пользе для визуализации статистических данных см. в этой записи о гисторамме, диаграммах Парето и "ящик с усами" блога группы разработчиков Excel. Дополнительные сведения о других новых типах диаграмм приведены в этой записи блога.

Вариант "Автоматическая" (формула Скотта)   

Формула для параметра "Автоматически"

Формула Скотта минимизирует отклонение вариационного ряда на гистограмме по сравнению с набором данных, исходя из предположения о нормальном распределении данных.

Вариант "Выход за верхнюю границу интервала"   

Формула для параметра ячейки "Переполнение"

Вариант "Выход за нижнюю границу интервала"   

Формула для параметра "Выход за нижнюю границу интервала"
  1. Загрузите надстройку "Пакет анализа". Дополнительные сведения см. в статье Загрузка надстройки "Пакет анализа" в Excel.

  2. В один столбец на листе введите исходные данные. При необходимости добавьте в первую ячейку подпись.

    Используйте количественные числовые данные, например, количество элементов или результаты тестов. Мастер гистограмм не будет работать с такими количественными числовыми данными, как идентификационные номера, введенные в виде текста.

  3. В следующий столбец введите интервалы в возрастающем порядке. При необходимости добавьте в первую ячейку подпись.

    Используйте собственные интервалы, поскольку они могут лучше соответствовать целям вашего анализа. Если вы не введете их, мастер гистограмм создаст равномерно распределенные интервалы, используя минимальное и максимальное значение во введенном диапазоне в качестве начальной и конечной точек.

  4. Откройте вкладку Данные и выберите команду Анализ данных.

    Кнопки "Анализ данных" и "Поиск решения"

  5. Выберите пункт Гистограмма и нажмите кнопку OK.

    Диалоговое окно "Анализ данных"

  6. В разделе Ввод выполните указанные ниже действия:

    1. В поле Формировать список по диапазону введите ссылку на ячейку с диапазоном данных, который содержит исходные числа.

    2. В поле Интервал карманов введите ссылку на ячейку с диапазоном, который содержит числа интервала.

      Если на листе использовались подписи столбцов, можно включать их в ссылки на ячейки.

      Совет: Вместо того, чтобы вводить ссылки вручную,можно нажать кнопку Кнопка "Свернуть" , чтобы временно свернуть диалоговое окно для выбора диапазонов на листе. При повторном нажатии этой кнопки диалоговое окно опять разворачивается.

  7. Если подписи столбцов были включены в ссылки на ячейки, установите флажок Подписи.

  8. В группе Параметры вывода выберите местоположение выходных данных.

    Гистограмму можно расположить на том же листе, новом листе в текущей книге или в новой книге.

  9. Установите один или несколько флажков:

    Парето (отсортированная гистограмма). Отображает частоту данных по убыванию.

    Суммарный процент    . Отображает суммарные проценты и добавляет в гистограмму строку суммарных процентов.

    Вывод диаграммы    . Отображает встроенную гистограмму.

  10. Нажмите кнопку ОК.

    Если вы хотите настроить свой гистограммы, можно изменить текст подписей и щелкните в любом месте диаграммы Гистограмма, чтобы в правой части диаграммы с помощью кнопок Элементы диаграммы, Стили диаграмм и Фильтры диаграммы.

  1. Выделите данные.

    (Это типичный пример данных для гистограммы.)

    Данные, использованные для создания образца гистограммы выше
  2. На вкладке Вставка нажмите кнопку Диаграмма.

    Кнопка "Диаграмма" в группе "Иллюстрации"на вкладке "Вставка" в Word
  3. В диалоговом окне Вставка диаграммы в разделе Все диаграммы выберите пункт Гистограмма, а затем нажмите кнопку ОК.

Советы: 

  • С помощью параметров на вкладках Конструктор и Формат настройте внешний вид диаграммы.

  • Если они не отображаются, щелкните в любом месте гистограммы, чтобы добавить на ленту область Работа с диаграммами.

Вкладки "Конструктор" и "Формат" в разделе "Работа с диаграммами"

  1. Правой кнопкой мыши щелкните горизонтальную ось диаграммы, выберите Формат оси, а затем щелкните Параметры оси.

    Команда "Формат оси" в контекстном меню
  2. Руководствуясь приведенной ниже таблицей, вы сможете выбрать параметры, которые нужно задать в области задач Формат оси.

    Параметр

    Описание

    По категориям

    Выберите этот вариант, если категории (горизонтальная ось) текстовые, а не числовые. На гистограмме одинаковые категории будут сгруппированы, а значения на оси значений — просуммированы.

    Совет: Чтобы подсчитать количество появлений текстовых строк, добавьте столбец и укажите в нем значение "1", а затем отобразите гистограмму и выберите параметр По категориям.

    Автоматическая

    Это вариант по умолчанию для гистограмм.

    Длина интервала

    Введите положительное десятичное число, задающее количество точек данных в каждом диапазоне.

    Количество интервалов

    Введите количество интервалов гистограммы (включая интервалы для значений, выходящих за верхнюю и нижнюю границы).

    Выход за верхнюю границу интервала

    Установите этот флажок, чтобы создать интервал для всех значений, превышающих значение в поле справа. Чтобы изменить его, введите в поле другое десятичное число.

    Выход за нижнюю границу интервала

    Установите этот флажок, чтобы создать интервал для всех значений, не превышающих значение в поле справа. Чтобы изменить его, введите в поле другое десятичное число.

    Область задач "Формат оси"

Совет: Дополнительные сведения о гистограммах и их пользе для визуализации статистических данных см. в этой записи о гисторамме, диаграммах Парето и "ящик с усами" блога группы разработчиков Excel. Дополнительные сведения о других новых типах диаграмм приведены в этой записи блога.

Выполните следующие действия для создания гистограммы в Excel для Mac:

  1. Выделите данные.

    (Это типичный пример данных для гистограммы.)

    Данные, использованные для создания образца гистограммы выше
  2. На ленте откройте вкладку Вставка, щелкните значок Значок статистической диаграммы (Статистические) и в разделе Гистограмма выберите Гистограмма.

Советы: 

  • На вкладках Конструктор и Формат можно настроить внешний вид диаграммы.

  • Если они не отображаются, щелкните в любом месте гистограммы, чтобы добавить их на ленту.

Чтобы создать гистограмму в Excel 2011 для Mac, потребуется скачать стороннюю надстройку. См. статью Не удается найти пакет анализа в Excel 2011 для Mac.

В Excel Online можно просмотреть гистограмму (это Столбчатая диаграмма, которая показывает частоту повторяемости значений), но его не удается создать, поскольку она требует пакет анализа — Excel, в которое не поддерживается в Excel Online.

Если у вас есть классическое приложение Excel, можно использовать кнопку изменить в Excel для открытия Excel на рабочий стол и Создайте гистограмму.

Кнопка "Изменить в Excel"

  1. Коснитесь данных, чтобы выделить их.

    Данные, использованные для создания образца гистограммы выше
  2. Если вы используете телефон, коснитесь значка правки  Значок правки , чтобы отобразить ленту, а затем откройте вкладку Главная.

  3. Выберите элементы Вставка > Диаграммы > Гистограмма.

    При необходимости вы можете настроить элементы диаграммы.

    Примечание: Эта функция доступна только при наличии подписки на Office 365. Если у вас есть подписка на Office 365, убедитесь, что у вас установлена последняя версия Office.

    Попробуйте поработать с Office 365 или последней версией Excel

  1. Коснитесь данных, чтобы выделить их.

    Данные, использованные для создания образца гистограммы выше
  2. Если вы используете телефон, коснитесь значка правки  Значок правки , чтобы отобразить ленту, а затем выберите вкладку Главная.

  3. Выберите элементы Вставка > Диаграммы > Гистограмма.

Чтобы создать гистограмму в Excel, предоставляют два типа данных — данные, которые требуется проанализировать и количеством интервалов, представляющих интервалы, на которые вы хотите измерить частоту. Необходимо организовать данные в двух столбцов на листе. Эти столбцы должны содержать следующие данные:

  • Введенные данные.    Это данные, которые вы хотите проанализировать с помощью мастера гистограмм.

  • Числовые интервалы.    Они представляют диапазоны, на основании которых мастер гистограмм проводит оценку введенных данных во время их анализа.

При использовании инструмента гистограммы Excel подсчитывает количество точек данных в каждой ячейке данных. Точки данных включается в конкретной ячейке, если число больше, чем наименьшего привязан и равно или меньше, чем наибольшее присоединенной для данных ячейки. Если опустить интервал карманов Excel создает набор равномерно распределенные интервалов между минимальные и максимальные значения входных данных.

Результат анализа гистограммы отображается на новом листе (или в новой книге) и содержит таблицу и гистограмму, которая отражает данные этой таблицы.

Дополнительные сведения

Вы всегда можете задать вопрос специалисту Excel Tech Community, попросить помощи в сообществе Answers community, а также предложить новую функцию или улучшение на веб-сайте Excel User Voice.

Совершенствование навыков работы с Office
Перейти к обучению
Первоочередный доступ к новым возможностям
Присоединиться к программе предварительной оценки Office

Были ли сведения полезными?

Спасибо за ваш отзыв!

Благодарим за отзыв! Возможно, будет полезно связать вас с одним из наших специалистов службы поддержки Office.

×