Перейти к основному контенту
Office

Создание, выполнение, изменение и удаление макроса в Office для Mac

Примечание: Мы стараемся как можно оперативнее обеспечивать вас актуальными справочными материалами на вашем языке. Эта страница переведена автоматически, поэтому ее текст может содержать неточности и грамматические ошибки. Для нас важно, чтобы эта статья была вам полезна. Просим вас уделить пару секунд и сообщить, помогла ли она вам, с помощью кнопок внизу страницы. Для удобства также приводим ссылку на оригинал (на английском языке).

Чтобы сэкономить время на выполнении часто повторяющихся задач, можно записать соответствующую последовательность действий в виде макроса. Затем, когда вам потребуется выполнить такую задачу, вы сможете вызвать макрос, и он сделает все за вас.

Word

В Word 2016 для Mac можно создать макрос с сочетанием клавиш, запустить макрос и удалить макрос, который больше не нужен.

  1. В меню Вид последовательно выберите пункты Макросы и Записать макрос.

    Чтобы начать создание макроса, на вкладке "Вид" нажмите кнопку "Макрос" и выберите команду "Запись макроса".
  2. Введите имя макроса или примите имя по умолчанию, предлагаемое Word.

    Введите имя макроса в соответствующем поле или примите имя, предложенное приложением Word.
  3. Чтобы использовать этот макрос во всех новых документах, убедитесь в том, что в списке Сохранить макрос в выбран пункт Все документы (Обычный).

  4. Нажмите кнопку Клавиатура, чтобы назначить макросу сочетание клавиш.

    В Word откроется диалоговое окно Настройка клавиатуры.

  5. Введите сочетание клавиш в поле Нажмите новое сочетание клавиш.

    После нажатия сочетания клавиш в Word отображается команда или макрос, уже назначенный этому сочетанию (если есть).

    При нажатии сочетания клавиш в Word отображается команда или действие, назначенные в данный момент этому сочетанию, если таковые имеются.

  6. Если выбранное сочетание клавиш уже назначено, удалите его в поле Нажмите новое сочетание клавиш и выберите другое сочетание.

    Найдя свободное сочетание клавиш, переходите к следующему шагу.

    Word определяет, что вы нажали сочетание клавиш, еще не назначенное команде или макросу.
  7. Чтобы использовать это сочетание клавиш во всех новых документах, убедитесь в том, что в поле Сохранить изменения в выбран глобальный шаблон Normal.dotm.

    Выберите файл Normal.dotm, чтобы макрос был доступен для использования во вновь создаваемых документах.
  8. Нажмите кнопку Назначить.

  9. Когда вы будете готовы к записи макроса, нажмите кнопку ОК.

  10. Последовательно выберите нужные команды или нажмите нужные клавиши.

    Word записывает щелчки мышью и нажатия клавиш, но не выделение текста мышью. Чтобы выделить текст при записи макроса, используйте клавиатуру.

  11. Чтобы остановить запись, в меню Вид последовательно выберите пункты Макросы и Остановить запись.

    Чтобы остановить запись макроса, выберите команду "Остановить запись" в меню "Макросы".

Запустить макрос можно с помощью назначенного ему сочетания клавиш или из списка Макросы.

  1. В меню Вид последовательно выберите пункты Макросы и Просмотр макросов.

    Для просмотра и редактирования связанных с документом макросов выберите команду "Макросы".
  2. В списке Имя макроса выберите макрос, который хотите запустить.

  3. Нажмите кнопку Запустить.

    Выбрав макрос в списке "Имя макроса", нажмите "Выполнить", чтобы запустить его.

  1. В меню Вид последовательно выберите пункты Макросы и Просмотр макросов.

    Для просмотра и редактирования связанных с документом макросов выберите команду "Макросы".
  2. Убедитесь в том, что в списке Макросы в указано расположение макроса, который вы хотите удалить.

    Выберите в списке место расположения макросов, которые хотите просмотреть.

    В списке содержится имя документа, открытого в текущем окне, а также глобальный шаблон и команды Word.

  3. В поле Имя макроса выберите макрос, который нужно удалить, а затем щелкните значок минуса под списком.

    Выберите макрос, который требуется удалить, а затем щелкните значок минуса под списком.
  4. Когда в Word появится подтверждение на удаление макроса, нажмите кнопку Да.

Excel

В Excel 2016 для Mac можно создать макрос с сочетанием клавиш, запустить макрос и удалить макрос, который больше не нужен.

При записи макроса все необходимые действия записываются средством записи макроса. Такими действиями может быть ввод текста или чисел, выбор ячеек или команд на ленте или в меню, форматирование, выделение ячеек, строк или столбцов, а также выделение ячеек путем перетаскивания указателя мыши.

Примечание: Команды для записи, создания и удаления макросов, а также другие дополнительные функции также доступны на вкладке " разработчик " на ленте. Дополнительные сведения об использовании вкладки "Разработчик" можно найти в разделе Использование вкладки "Разработчик" для создания и удаления макроса в Excel 2016 для Mac.

  1. Выберите Сервис _гт_ макрос _гт_ запись New.

    Выберите "Инструменты", "макрос" и "записать новый макрос"

  2. В поле Имя макроса укажите имя макроса.

    Введите имя макроса, его расположение и сочетание клавиш

  3. Чтобы создать сочетание клавиш для макроса, введите букву в поле Option + cmd .

  4. Выберите расположение макроса в раскрывающемся списке.

    Чтобы сохранить макрос

    Команда

    В документе, в котором создается макрос

    Эта книга

    Во всех открытых документах

    Новая книга

    Для непрерывной доступности при использовании Excel

    Личная книга макросов

  5. Необязательно Добавьте описание макроса.

  6. Когда вы будете готовы к записи, нажмите кнопку ОК.

  7. Последовательно выберите нужные команды или нажмите нужные клавиши.

  8. Чтобы остановить запись, выберите Сервис _гт_ макрос _гт_ остановить запись. (Этот шаг не будет записан в макросе.)

    Нажмите кнопку Остановить запись.

Чтобы запустить макрос, нажмите назначенный ему сочетаний клавиш или запустите макрос в диалоговом окне " макросы ".

  1. На вкладке Вид нажмите кнопку Макросы.

  2. В контекстном меню выберите пункт Макросы, а затем — Книга.

  3. Выберите макрос из списка и нажмите кнопку Выполнить.

    Диалоговое окно "Макросы" в Excel для Mac

  1. Выберите Сервис _гт_ макросы _гт_ макросы.

    Выберите макрос и щелкните Макросы.

  2. Выберите макрос, который нужно удалить, а затем нажмите клавишу со знаком "минус".

    Выберите имя макроса и щелкните знак "минус"

  3. Появится сообщение С запросом подтверждения. Нажмите кнопку Да, чтобы подтвердить удаление.

    Подтверждение удаления

Вы также можете удалить макрос с вкладки разработчик .

  1. На вкладке Разработчик нажмите кнопку Макросы.

  2. Выберите в списке макрос, который требуется удалить, и нажмите кнопку "Удалить".

    Выберите макрос и щелкните знак минуса, чтобы удалить его.

Word

Чтобы автоматизировать периодически повторяющиеся задачи, в приложении Word можно быстро создать макрос. Кроме того, в Microsoft Visual Basic для приложений можно использовать редактор Visual Basic, чтобы написать собственные скрипты макросов или скопировать макросы или их части в новые макросы.

При записи макроса записываются все действия, необходимые для выполнения действий, которые необходимо выполнить для выполнения макроса. Тем не менее, возвращение на вкладку для остановки записи макроса не записывается.

  1. На вкладке Разработчик в разделе Visual Basic выберите элемент Запись.

    Вкладка Word "Разработчик", группа "Visual Basic"

    Если вкладка "Разработчик" недоступна:

    1. В правой части ленты нажмите кнопку Всплывающее меню "Действие" и выберите пункт Параметры ленты.

    2. В разделе Настройки установите флажок Разработчик.

  2. В поле Имя макроса укажите имя макроса.

  3. Во всплывающем окне Сохранить в выполните одно из следующих действий:

    Чтобы сохранить макрос

    Команда

    В документе, в котором создается макрос

    [имя документа] (документ)

    Во всех открытых документах

    Все документы (обычные)

  4. Нажмите кнопку ОК, а затем выполните действия, которые нужно записать.

  5. На вкладке Разработчик в разделе Visual Basic выберите команду Остановить.

Для создания макросов можно использовать встроенный редактор Visual Basic.

  1. На вкладке Разработчик в разделе Visual Basic выберите элемент Редактор.

    Вкладка Word "Разработчик", группа "Visual Basic"

    Если вкладка "Разработчик" недоступна:

    1. В правой части ленты нажмите кнопку Всплывающее меню "Действие" и выберите пункт Параметры ленты.

    2. В разделе Настройки установите флажок Разработчик.

  2. Если требуется вставить модуль, в редакторе Visual Basic в меню Вставка выберите пункт Модуль.

  3. В окне кода модуля введите или скопируйте необходимый код макроса.

  4. По завершении выберите в меню Word команду Закрыть и вернуться в Microsoft Word.

  1. На вкладке Разработчик в разделе Visual Basic выберите элемент Макрос.

    Вкладка Word "Разработчик", группа "Visual Basic"

    Если вкладка "Разработчик" недоступна:

    1. В правой части ленты нажмите кнопку Всплывающее меню "Действие" и выберите пункт Параметры ленты.

    2. В разделе Настройки установите флажок Разработчик.

  2. Выберите в списке макрос, который требуется выполнить, а затем запустите команду Выполнить.

Для изменения макросов используется редактор Visual Basic.

  1. На вкладке Разработчик в разделе Visual Basic выберите элемент Макрос.

    Вкладка Word "Разработчик", группа "Visual Basic"

    Если вкладка "Разработчик" недоступна:

    1. В правой части ленты нажмите кнопку Всплывающее меню "Действие" и выберите пункт Параметры ленты.

    2. В разделе Настройки установите флажок Разработчик.

  2. Выберите в списке макрос, который требуется изменить, а затем нажмите кнопку Изменить.

    Откроется редактор Visual Basic.

  3. Внесите необходимые изменения.

  4. По завершении выберите в меню Word команду Закрыть и вернуться в Microsoft Word.

  1. На вкладке Разработчик в разделе Visual Basic выберите элемент Макрос.

    Вкладка Word "Разработчик", группа "Visual Basic"

    Если вкладка "Разработчик" недоступна:

    1. В правой части ленты нажмите кнопку Всплывающее меню "Действие" и выберите пункт Параметры ленты.

    2. В разделе Настройки установите флажок Разработчик.

  2. Выберите в списке макрос, который требуется скопировать, а затем нажмите кнопку Изменить.

    Откроется редактор Visual Basic.

  3. В окне редактора Visual Basic выделите строки макроса, которые нужно скопировать.

    Совет: Чтобы скопировать макрос целиком, включите в выделение строки Sub и End Sub.

  4. В меню Правка выберите команду Копировать.

  5. В поле Проект окна кода выберите модуль, в который требуется вставить код.

  6. В меню Изменить выберите пункт Вставить.

  1. На вкладке Разработчик в разделе Visual Basic выберите элемент Макрос.

    Вкладка Word "Разработчик", группа "Visual Basic"

    Если вкладка "Разработчик" недоступна:

    1. В правой части ленты нажмите кнопку Всплывающее меню "Действие" и выберите пункт Параметры ленты.

    2. В разделе Настройки установите флажок Разработчик.

  2. Выберите в списке макрос, который требуется удалить, а затем нажмите кнопку Удалить.

PowerPoint

Для автоматизации повторяющихся задач можно создать макрос в PowerPoint с помощью Visual Basic для приложений.

Для создания макросов можно использовать встроенный редактор Visual Basic.

  1. На вкладке Разработчик в разделе Visual Basic выберите элемент Редактор.

    Вкладка PowerPoint "Разработчик", группа "Visual Basic"

    Если вкладка "Разработчик" недоступна:

    1. В правой части ленты нажмите кнопку Всплывающее меню "Действие" и выберите пункт Параметры ленты.

    2. В разделе Настройки установите флажок Разработчик.

  2. Если требуется вставить модуль, в редакторе Visual Basic в меню Вставка выберите пункт Модуль.

  3. В окне кода модуля введите или скопируйте необходимый код макроса.

  4. По завершении выберите в меню PowerPoint команду Закрыть и вернуться в Microsoft PowerPoint.

  1. На вкладке Разработчик в разделе Visual Basic выберите элемент Макрос.

    Вкладка PowerPoint "Разработчик", группа "Visual Basic"

    Если вкладка "Разработчик" недоступна:

    1. В правой части ленты нажмите кнопку Всплывающее меню "Действие" и выберите пункт Параметры ленты.

    2. В разделе Настройки установите флажок Разработчик.

  2. Выберите в списке макрос, который требуется выполнить, а затем запустите команду Выполнить.

Для изменения макросов используется редактор Visual Basic.

  1. На вкладке Разработчик в разделе Visual Basic выберите элемент Макрос.

    Вкладка PowerPoint "Разработчик", группа "Visual Basic"

    Если вкладка "Разработчик" недоступна:

    1. В правой части ленты нажмите кнопку Всплывающее меню "Действие" и выберите пункт Параметры ленты.

    2. В разделе Настройки установите флажок Разработчик.

  2. Выберите в списке макрос, который требуется изменить, а затем нажмите кнопку Изменить.

    Откроется редактор Visual Basic.

  3. Внесите необходимые изменения.

  4. По завершении выберите в меню PowerPoint команду Закрыть и вернуться в Microsoft PowerPoint.

  1. На вкладке Разработчик в разделе Visual Basic выберите элемент Макрос.

    Вкладка PowerPoint "Разработчик", группа "Visual Basic"

    Если вкладка "Разработчик" недоступна:

    1. В правой части ленты нажмите кнопку Всплывающее меню "Действие" и выберите пункт Параметры ленты.

    2. В разделе Настройки установите флажок Разработчик.

  2. Выберите в списке макрос, который требуется скопировать, а затем нажмите кнопку Изменить.

    Откроется редактор Visual Basic.

  3. В окне редактора Visual Basic выделите строки макроса, которые нужно скопировать.

    Совет: Чтобы скопировать макрос целиком, включите в выделение строки Sub и End Sub.

  4. В меню Правка выберите команду Копировать.

  5. В поле Проект окна кода выберите модуль, в который требуется вставить код.

  6. В меню Изменить выберите пункт Вставить.

  1. На вкладке Разработчик в разделе Visual Basic выберите элемент Макрос.

    Вкладка PowerPoint "Разработчик", группа "Visual Basic"

    Если вкладка "Разработчик" недоступна:

    1. В правой части ленты нажмите кнопку Всплывающее меню "Действие" и выберите пункт Параметры ленты.

    2. В разделе Настройки установите флажок Разработчик.

  2. Выберите в списке макрос, который требуется удалить, а затем нажмите кнопку Удалить.

Excel

Чтобы автоматизировать периодически повторяющиеся задачи, в приложении Excel можно быстро создать макрос. Кроме того, в Microsoft Visual Basic для приложений можно использовать редактор Visual Basic, чтобы написать собственные скрипты макросов или скопировать макросы или их части в новые макросы.

Все действия, которые должен выполнять макрос, записываются. Тем не менее, возвращение на вкладку для остановки записи макроса не записывается.

  1. На вкладке Разработчик в разделе Visual Basic выберите элемент Запись.

    Вкладка Excel "Разработчик", группа "Visual Basic"

    Если вкладка "Разработчик" недоступна:

    1. В правой части ленты нажмите кнопку Всплывающее меню "Действие" и выберите пункт Параметры ленты.

    2. В разделе Настройки установите флажок Разработчик.

  2. В поле Имя макроса укажите имя макроса.

    Совет: Чтобы создать сочетание клавиш для запуска макроса, введите букву в поле Option+Cmd+.

  3. Во всплывающем окне Сохранить в выполните одно из следующих действий:

    Чтобы сохранить макрос

    Команда

    В документе, в котором создается макрос

    Эта книга

    Во всех открытых документах

    Новая книга

    Для непрерывной доступности при использовании Excel

    Личная книга макросов

    Личная книга макросов расположена на странице Users/ username/Library/Application Support support/Microsoft/Office/Excel.

  4. Нажмите кнопку ОК, а затем выполните действия, которые нужно записать.

  5. На вкладке Разработчик в разделе Visual Basic повторно выберите элемент Запись.

Для создания макросов можно использовать встроенный редактор Visual Basic.

  1. На вкладке Разработчик в разделе Visual Basic выберите элемент Редактор.

    Вкладка Excel "Разработчик", группа "Visual Basic"

    Если вкладка "Разработчик" недоступна:

    1. В правой части ленты нажмите кнопку Всплывающее меню "Действие" и выберите пункт Параметры ленты.

    2. В разделе Настройки установите флажок Разработчик.

  2. Если требуется вставить модуль, в редакторе Visual Basic в меню Вставка выберите пункт Модуль.

  3. В окне кода модуля введите или скопируйте необходимый код макроса.

  4. По завершении выберите в меню Excel команду Закрыть и вернуться в Microsoft Excel.

  1. На вкладке Разработчик в разделе Visual Basic выберите элемент Макрос.

    Вкладка Excel "Разработчик", группа "Visual Basic"

    Если вкладка "Разработчик" недоступна:

    1. В правой части ленты нажмите кнопку Всплывающее меню "Действие" и выберите пункт Параметры ленты.

    2. В разделе Настройки установите флажок Разработчик.

  2. Выберите в списке макрос, который требуется выполнить, а затем запустите команду Выполнить.

    Совет: Чтобы запустить макрос с помощью клавиатуры, нажмите клавиши OPTION+ Клавиша COMMAND +<буква, указанная при создании сочетания>.

Для изменения макросов используется редактор Visual Basic.

  1. На вкладке Разработчик в разделе Visual Basic выберите элемент Макрос.

    Вкладка Excel "Разработчик", группа "Visual Basic"

    Если вкладка "Разработчик" недоступна:

    1. В правой части ленты нажмите кнопку Всплывающее меню "Действие" и выберите пункт Параметры ленты.

    2. В разделе Настройки установите флажок Разработчик.

  2. Выберите в списке макрос, который требуется изменить, а затем нажмите кнопку Изменить.

    Откроется редактор Visual Basic.

  3. Внесите необходимые изменения.

  4. По завершении выберите в меню Excel команду Закрыть и вернуться в Microsoft Excel.

После выполнения описанных ниже действий макрос будет запускаться при каждом открытии книги, в которой он содержится.

  1. На вкладке Разработчик в разделе Visual Basic выберите элемент Запись.

    Вкладка Excel "Разработчик", группа "Visual Basic"

    Если вкладка "Разработчик" недоступна:

    1. В правой части ленты нажмите кнопку Всплывающее меню "Действие" и выберите пункт Параметры ленты.

    2. В разделе Настройки установите флажок Разработчик.

  2. В поле Имя макроса введите Auto_Open.

  3. Во всплывающем окне Сохранить в выполните одно из следующих действий:

    Чтобы сохранить макрос

    Команда

    В документе, в котором создается макрос

    Эта книга

    Во всех открытых документах

    Новая книга

    Для непрерывной доступности при использовании Excel

    Личная книга макросов

  4. Нажмите кнопку ОК, а затем выполните действия, которые нужно записать.

  5. На вкладке Разработчик в разделе Visual Basic повторно выберите элемент Запись.

  6. В меню Файл выберите пункт Сохранить как.

  7. Во всплывающем меню Формат выберите пункт Книга Excel с поддержкой макросов (.xlsm) и нажмите кнопку Сохранить.

  1. На вкладке Разработчик в разделе Visual Basic выберите элемент Макрос.

    Вкладка Excel "Разработчик", группа "Visual Basic"

    Если вкладка "Разработчик" недоступна:

    1. В правой части ленты нажмите кнопку Всплывающее меню "Действие" и выберите пункт Параметры ленты.

    2. В разделе Настройки установите флажок Разработчик.

  2. Выберите в списке макрос, который требуется скопировать, а затем нажмите кнопку Изменить.

    Откроется редактор Visual Basic.

  3. В окне редактора Visual Basic выделите строки макроса, которые нужно скопировать.

    Совет: Чтобы скопировать макрос целиком, включите в выделение строки Sub и End Sub.

  4. В меню Правка выберите команду Копировать.

  5. В поле Проект окна кода выберите модуль, в который требуется вставить код.

  6. В меню Изменить выберите пункт Вставить.

  1. На вкладке Разработчик в разделе Visual Basic выберите элемент Макрос.

    Вкладка Excel "Разработчик", группа "Visual Basic"

    Если вкладка "Разработчик" недоступна:

    1. В правой части ленты нажмите кнопку Всплывающее меню "Действие" и выберите пункт Параметры ленты.

    2. В разделе Настройки установите флажок Разработчик.

  2. Выберите в списке макрос, который требуется удалить, а затем нажмите кнопку Удалить.

Совершенствование навыков работы с Office
Перейти к обучению
Первоочередный доступ к новым возможностям
Присоединиться к программе предварительной оценки Office

Были ли сведения полезными?

Спасибо за ваш отзыв!

Благодарим за отзыв! Возможно, будет полезно связать вас с одним из наших специалистов службы поддержки Office.

×