Перейти к основному контенту
Office
Создание базы данных

Создание базы данных

Примечание: Мы стараемся как можно оперативнее обеспечивать вас актуальными справочными материалами на вашем языке. Эта страница переведена автоматически, поэтому ее текст может содержать неточности и грамматические ошибки. Для нас важно, чтобы эта статья была вам полезна. Просим вас уделить пару секунд и сообщить, помогла ли она вам, с помощью кнопок внизу страницы. Для удобства также приводим ссылку на оригинал (на английском языке).

В этой статье описана обычная процедура запуска Access и создания базы данных, которая будет использоваться на компьютере, а не в Интернете. В ней рассказано о том, как создать классическую базу данных на основе шаблона или с нуля с собственными таблицами, формами, отчетами и другими объектами. Кроме того, в статье рассмотрены способы импорта существующих данных в новую базу данных.

В этой статье

Обзор

Создание базы данных с помощью шаблона

Создание базы данных без использования шаблона

Копирование данных из другого источника в таблицу Access

Импорт, добавление или связывание данных из другого источника

Добавление части приложения

Открытие существующей базы данных Access

Используете Access 2007?

Обзор

При первом запуске Access, а также при закрытии базы данных без завершения работы Access отображается представление Microsoft Office Backstage.

Представление Backstage является отправным пунктом для создания новых и открытия существующих баз данных, просмотра релевантных статей на сайте Office.com и т. д., то есть для выполнения любых операций с файлом базы данных или вне базы данных, но не в ней.

Создание базы данных

При открытии Access в представлении Backstage откроется вкладка создать . На вкладке " Создание " можно создать новую базу данных несколькими способами.

  • Пустая база данных    Если хотите, вы можете начать с нуля. Это хороший вариант, если у вас есть особые требования к проектированию или у вас есть необходимые данные, которые нужно разместить или добавить.

  • Шаблон, установленный в Access    Вы можете использовать шаблон, если вы запускаете новый проект и хотите начать с головного офиса. Access сопровождается несколькими шаблонами, установленными по умолчанию.

  • Шаблон с сайта Office.com.    В дополнение к шаблонам, поставляемым с Access, много других шаблонов доступно на сайте Office.com. Для их использования даже не нужно открывать браузер, потому что эти шаблоны доступны на вкладке Создать.

Добавление объектов в базу данных

При работе с базой данных в нее можно добавлять поля, таблицы и части приложения.

Части приложения — это функция, позволяющая использовать несколько связанных объектов базы данных как один объект. Например, часть приложения может состоять из таблицы и формы, основанной на ней. С помощью части приложения можно одновременно добавить в базу данных таблицу и форму.

Также можно создавать запросы, формы, отчеты, макросы — любые объекты базы данных, необходимые для работы.

Создание базы данных с помощью шаблона

В Access есть разнообразные шаблоны, которые можно использовать как есть или в качестве отправной точки. Шаблон — это готовая к использованию база данных, содержащая все таблицы, запросы, формы, макросы и отчеты, необходимые для выполнения определенной задачи. Например, существуют шаблоны, которые можно использовать для отслеживания вопросов, управления контактами или учета расходов. Некоторые шаблоны содержат примеры записей, демонстрирующие их использование.

Если один из этих шаблонов вам подходит, с его помощью обычно проще и быстрее всего создать необходимую базу данных. Однако если необходимо импортировать в Access данные из другой программы, возможно, будет проще создать базу данных без использования шаблона. Так как в шаблонах уже определена структура данных, на изменение существующих данных в соответствии с этой структурой может потребоваться много времени.

  1. Если база данных открыта, нажмите на вкладке Файл кнопку Закрыть. В представлении Backstage откроется вкладка Создать.

  2. На вкладке Создать доступно несколько наборов шаблонов. Некоторые из них встроены в Access, а другие шаблоны можно скачать с сайта Office.com. Дополнительные сведения см. в следующем разделе.

  3. Выберите шаблон, который вы хотите использовать.

  4. Приложение Access предложит имя файла базы данных в поле имя файла — при желании вы можете изменить имя файла. Чтобы сохранить базу данных в другой папке, расположенной под полем Имя файла, щелкните Изображение кнопки , перейдите в папку, в которой вы хотите ее сохранить, и нажмите кнопку ОК. Кроме того, вы можете создать и связать базу данных с сайтом SharePoint.

    Примечание: Несмотря на то, что они используют SharePoint, база данных для настольных компьютеров, связанная с сайтом SharePoint, отличается от веб-базы данных с помощью служб Access. Чтобы использовать базу данных для настольных систем, необходимо установить Access. Веб-базу данных можно использовать в веб-браузере.

  5. Нажмите кнопку Создать.

    Access создаст базу данных на основе выбранного шаблона, а затем откроет ее. Для многих шаблонов при этом отображается форма, в которую можно начать вводить данные. Если шаблон содержит примеры данных, вы можете удалить каждую из этих записей, щелкнув область маркировки (затененное поле или полосу слева от записи) и выполнив действия, указанные ниже.

    На вкладке Главная в группе Записи нажмите кнопку Удалить. Выноска 4

  6. Щелкните первую пустую ячейку в форме и приступайте к вводу данных. Для открытия других необходимых форм или отчетов используйте область навигации. Некоторые шаблоны содержат форму навигации, которая позволяет перемещаться между разными объектами базы данных.

Дополнительные сведения о работе с шаблонами см. в статье Создание базы данных Access на компьютере с помощью шаблона.

К началу страницы

Создание базы данных без использования шаблона

Если вы не заинтересованы в использовании шаблона, вы можете создать базу данных, создав собственные таблицы, формы, отчеты и другие объекты базы данных. В большинстве случаев это состоит из следующих элементов:

  • Ввести, вставить или импортировать данные в таблицу, которая создается вместе с базой данных, и повторить эту процедуру для новых таблиц, которые создаются с помощью команды Таблица на вкладке Создание.

  • Импортировать данные из других источников, при этом создав таблицы.

Создание пустой базы данных

  1. На вкладке Файл щелкните Создать и выберите вариант Пустая база данных.

  2. В поле Имя файла введите имя файла. Чтобы сохранить файл в другой папке, отличной от используемой по умолчанию, нажмите кнопку Поиск расположения для размещения базы данных Изображение кнопки (рядом с полем Имя файла), откройте нужную папку и нажмите кнопку ОК.

  3. Щелкните Создать.

    Access создаст базу данных с пустой таблицей "Таблица1" и откроет ее в режиме таблицы. Курсор будет помещен в первую пустую ячейку столбца Щелкните для добавления.

  4. Чтобы добавить данные, начните вводить их или вставьте из другого источника (см. раздел Копирование данных из другого источника в таблицу Access).

Ввод данных в режиме таблицы — это очень похоже на работу на листе Excel. При вводе данных будет создана структура таблицы. При добавлении нового столбца в таблицу в таблице определяется новое поле. Microsoft Access автоматически задает тип данных каждого поля в зависимости от введенных данных.

Если на этом этапе вводить данные в таблицу "Таблица1" не нужно, нажмите кнопку Закрыть Изображение кнопки . Если вы внесли изменения в таблицу, будет предложено сохранить их. Нажмите кнопку Да, чтобы сохранить изменения, кнопку Нет, чтобы не сохранять их, или кнопку Отмена, чтобы оставить таблицу открытой.

Совет:  Access ищет файл с именем Blank.accdb в папке [диск установки]:\Program Files\Microsoft Office\Templates\1049\Access\. Если он существует, Blank.accdb используется как шаблон для всех новых пустых баз данных, за исключением веб-баз данных. Все новые базы данных наследуют содержимое этого файла. Это отличный способ распространения содержимого по умолчанию, например номеров компонентов или заявлений об отказе от ответственности и политик компании. Следует помнить, что файл Blank.accdb не влияет на создание новых пустых веб-баз данных.

Важно: Если хотя бы один раз закрыть таблицу "Таблица1" без сохранения, она будет удалена полностью, даже если в нее введены данные.

Добавление таблицы

Добавление таблиц к существующей базе данных осуществляется командами группы Таблицы на вкладке Создать.

Изображение ленты Access

Создание таблицы в режиме таблицы.    В режиме таблицы можно начать ввод данных сразу, структура таблицы при этом будет создаваться автоматически. Полям присваиваются имена с последовательными номерами ("Поле1", "Поле2" и т. д.), а тип данных автоматически задается с учетом вводимых данных.

  1. на вкладке Создание в группе Таблицы нажмите кнопку Таблица. Выноска 4

    Access создаст таблицу и выделит первую пустую ячейку в столбце Щелкните для добавления.

  2. На вкладке Поля в группе Добавление и удаление выберите нужный тип поля. Если нужный тип поля не отображается, нажмите кнопку Другие поля Изображение кнопки .

  3. Откроется список часто используемых типов полей. Выберите необходимый тип поля, и Access добавит в таблицу новое поле в точке вставки.

    Поле можно переместить путем перетаскивания. При этом в таблице появляется вертикальная полоса вставки, указывающая место, где будет расположено поле.

  4. Чтобы добавить данные, начните вводить их в первую пустую ячейку или вставьте из другого источника (см. раздел Копирование данных из другого источника в таблицу Access).

  5. Для переименования столбца (поля) дважды щелкните его заголовок и введите новое название.

    Присвойте полям значимые имена, чтобы при просмотре области Список полей было понятно, что содержится в каждом поле.

  6. Чтобы переместить столбец, щелкните его заголовок для выделения столбца и перетащите столбец в нужное место. Можно выделить несколько смежных столбцов и перетащить их одновременно. Чтобы выделить несколько смежных столбцов, щелкните заголовок первого столбца, а затем, удерживая нажатой клавишу SHIFT, щелкните заголовок последнего столбца.

Создание таблицы в режиме конструктора.    В режиме конструктора сначала следует создать структуру таблицы. Затем можно переключиться в режим таблицы для ввода данных или ввести данные, используя другой способ, например вставить данные из буфера обмена или импортировать их.

  1. На вкладке Создание в группе Таблицы нажмите кнопку Конструктор таблиц. Изображение кнопки

  2. Для каждого поля в таблице введите имя в столбце Имя поля, а затем в списке Тип данных выберите тип данных.

  3. При желании можно ввести описание для каждого поля в столбце Описание. Это описание будет отображаться в строке состояния, когда в режиме таблицы курсор будет находиться в данном поле. Описание также отображается в строке состояния для любых элементов управления в форме или отчете, которые создаются путем перетаскивания этого поля из области списка полей, и любых элементов управления, которые создаются для этого поля при использовании мастера отчетов или мастера форм.

  4. Когда все необходимые поля будут добавлены, сохраните таблицу:

    • На вкладке Файл щелкните Сохранить.

  5. Вы можете в любой момент ввести данные в таблицу, переключив ее в режим таблицы и щелкнув первую пустую ячейку. Вы также можете вставить данные из другого источника, как описано в разделе копирование данных из другого источника в таблицу Access.

Задание свойств полей в режиме конструктора.    Независимо от способа создания таблицы рекомендуется проверить и задать свойства полей. Хотя некоторые свойства доступны в режиме таблицы, другие можно настроить только в режиме конструктора. Чтобы перейти в режим конструктора, в области навигации щелкните таблицу правой кнопкой мыши и выберите пункт Конструктор. Чтобы отобразить свойства поля, щелкните его в сетке конструктора. Свойства отображаются под сеткой конструктора в области Свойства поля.

Щелкните свойство поля, чтобы просмотреть его описание рядом со списком Свойства поля. Более подробные сведения можно получить, нажав кнопку справки.

В следующей таблице описаны некоторые наиболее часто изменяемые свойства полей.

Свойство

Описание

Размер поля

Для текстовых полей это свойство указывает максимально допустимое количество знаков, сохраняемых в поле. Максимальное значение: 255. Для числовых полей это свойство определяет тип сохраняемых чисел ("Длинное целое", "Двойное с плавающей точкой" и т. д.). Для более рационального хранения данных рекомендуется выделять для хранения данных наименьший необходимый размер памяти. Если потребуется, это значение позже можно изменить.

Формат поля

Это свойство определяет формат отображения данных. Оно не влияет на фактические данные, сохраняемые в этом поле. Вы можете выбрать встроенный формат или задать собственный.

Маска ввода

Это свойство используется для определения общего шаблона для ввода любых данных в поле. Это позволяет обеспечить правильный ввод и нужное количество знаков для всех данных. Для получения справки по созданию маски ввода нажмите кнопку Кнопка "Построитель" справа от поля свойства.

Значение по умолчанию

Это свойство позволяет задать стандартное значение, которое будет отображаться в этом поле при добавлении новой записи. Например, для поля "Дата/время", в котором необходимо записывать дату добавления записи, в качестве значения по умолчанию можно ввести "Date()" (без кавычек).

Обязательное поле

Это свойство указывает, обязательно ли вводить значение в поле. Если для него задано значение Да, невозможно будет добавить запись, если в это поле не введено значение.

К началу страницы

Копирование данных из другого источника в таблицу Access

Если ваши данные хранятся в другой программе, например Excel, их можно скопировать и вставить в таблицу Access. Как правило, этот метод работает лучше всего, если данные уже разделены на столбцы, как в таблице Excel. Если данные находятся в текстовом редакторе, перед копированием рекомендуется разделить столбцы данных с помощью табуляции или преобразовать данные в таблицу. Если необходимо изменить данные или выполнить с ними другие операции (например, разделить полное имя на имя и фамилию), рекомендуется сделать это перед копированием данных, особенно если вы не знакомы с Access.

При вставке данных в пустую таблицу приложение Access задает тип данных для каждого поля в зависимости от того, какие данные в нем находятся. Например, если во вставляемом поле содержатся только значения даты, для этого поля используется тип данных "Дата/время". Если же вставляемое поле содержит только слова "Да" и "Нет", для этого поля выбирается тип данных "Логический".

Access применяет имена к полям в зависимости от того, что оно найдено в первой строке вставленных данных. Если первая строка вставленных данных похожа на следующую строку, Access определяет, что первая строка является частью данных и присваивает полям общие имена (F1, F2 и т. д.). Если первая строка вставленных данных не похожа на приведенные ниже строки, Access определяет, что первая строка состоит из имен полей. Access называет поля соответствующим образом и не включает первую строку данных.

В Access имена присваиваются полям автоматически, поэтому во избежание путаницы поля следует переименовать. Это можно сделать следующим образом:

  1. Нажмите клавиши CTRL+S, чтобы сохранить таблицу.

  2. В режиме таблицы дважды щелкните заголовок каждого столбца и введите описательное имя поля для каждого столбца.

  3. Еще раз сохраните таблицу.

Примечание: Кроме того, для изменения имен полей можно переключиться в режим конструктора. Для этого в области навигации щелкните таблицу правой кнопкой мыши и выберите пункт Конструктор. Чтобы вернуться в режим таблицы, дважды щелкните таблицу в области навигации.

К началу страницы

Импорт, добавление или связывание данных из другого источника

Возможно, у вас есть данные, хранящиеся в другой программе, которые вы хотите импортировать в новую таблицу Access или добавить в существующую. Кроме того, если ваши коллеги хранят данные в других программах, может потребоваться создать связь с такими данными. В обоих случаях работа с данными из других источников не представляет сложности. Вы можете импортировать данные из листа Excel, таблицы в другой базе данных Access, списка SharePoint и других источников. Процесс импорта для разных источников немного различается, однако всегда начинается так, как описано ниже.

  1. В Access на вкладке Внешние данные в группе Импорт и связи выберите команду для типа файла, который необходимо импортировать.

    Группа "Импорт и связи" на вкладке "Внешние данные"

    Например, чтобы импортировать данные с листа Excel, нажмите кнопку Excel. Если вы не видите нужный тип программы, нажмите кнопку Дополнительно.

    Примечание: Если не удается найти нужный тип формата в группе Импорт и связи, может потребоваться запустить программу, в которой созданы эти данные, а затем сохранить в ней данные в файле общего формата (например, как текстовый файл с разделителями) перед импортом данных в Access.

  2. В диалоговом окне Внешние данные нажмите кнопку Обзор, чтобы найти исходный файл данных, или введите в поле Имя файла полный путь к нему.

  3. Выберите нужный вариант (все программы позволяют импортировать, а некоторые из них добавим или присоединиться) в разделе Укажите, где и где вы хотите хранить данные в текущей базе данных. Вы можете создать новую таблицу, которая использует импортированные данные или (с некоторыми программами), добавить данные в существующую таблицу или создать связанную таблицу, которая будет поддерживать связь с данными в исходной программе.

  4. Если будет запущен мастер, следуйте инструкциям на экране. На последней странице мастера нажмите кнопку Готово.

    При импорте объектов или связывании таблиц из базы данных Access открывается диалоговое окно Импорт объектов или Связь с таблицами. Выберите нужные элементы и нажмите кнопку ОК.

    Точная последовательность действий зависит от выбранного способа обработки данных: импорт, добавление или связывание.

  5. Access предложит сохранить сведения о только что завершенной операции импорта. Если вы планируете повторить ее, нажмите кнопку Сохранить шаги импорта и введите нужные сведения. Позже для повторения этой операции достаточно будет нажать кнопку Сохраненные операции импорта Изображение кнопки на вкладке Внешние данные в группе Импорт и связи. Если вы не хотите сохранять сведения об операции, нажмите кнопку Закрыть.

Если вы решили импортировать таблицу, Access импортирует данные в новую таблицу и отображает ее в группе Таблицы в области навигации. Если выбрано добавление данных к существующей таблице, данные добавляются к ней. Если вы связываете данные, в группе Таблицы в области навигации создается связанная таблица.

К началу страницы

Добавление части приложения

Части приложения можно использовать для расширения функциональности баз данных. Часть приложения может быть просто отдельной таблицей, а может включать несколько объектов, таких как таблицы и связанные формы.

Например, часть приложения "Примечания" состоит из таблицы с полем идентификатора, имеющим тип "Счетчик", поля даты и поля MEMO. Ее можно добавить в базу данных и использовать как есть или с минимальными изменениями.

  1. Откройте базу данных, в которую вы хотите добавить часть приложения.

  2. Откройте вкладку Создание.

  3. В группе Шаблоны нажмите кнопку Части приложения. Появится список доступных частей.

  4. Щелкните часть приложения, которую вы хотите добавить.

К началу страницы

Открытие существующей базы данных Access

  1. На вкладке Файл нажмите кнопку Открыть.

  2. В диалоговом окне Открытие файла базы данных найдите базу данных, которую нужно открыть.

  3. Выполните одно из следующих действий.

    • Чтобы открыть базу данных в режиме по умолчанию, дважды щелкните ее (режим по умолчанию может быть указан в диалоговом окне Параметры Access или установлен административной политикой).

    • Нажмите кнопку Открыть, чтобы открыть базу данных для общего доступа в многопользовательской среде и предоставить другим пользователям возможность выполнять в ней чтение и запись.

    • Щелкните стрелку рядом с кнопкой Открыть и выберите вариант Открыть для чтения, чтобы открыть базу данных только для чтения, то есть для просмотра без возможности внесения изменений. При этом другие пользователи смогут выполнять запись в базу данных.

    • Щелкните стрелку рядом с кнопкой Открыть и выберите вариант Монопольно, чтобы открыть базу данных в монопольном режиме. Если ее затем попытается открыть другой пользователь, он получит сообщение "Файл уже используется".

    • Щелкните стрелку рядом с кнопкой Открыть и выберите вариант Монопольно для чтения, чтобы открыть базу данных только для чтения. Другие пользователи при этом смогут открывать базу данных только для чтения.

Примечание: Вы можете напрямую открывать файлы данных внешних форматов, например dBASE, Microsoft Exchange или Excel. Кроме того, можно открыть напрямую любой источник данных ODBC, например Microsoft SQL Server. Access автоматически создаст базу данных Access в одной папке с файлом данных и добавит ссылки на все таблицы внешней базы данных.

Советы

  • Чтобы открыть одну из недавно использовавшихся баз данных, щелкните Последние на вкладке Файл и выберите имя файла базы данных. Access откроет базу данных, используя параметры, которые применялись при ее открытии в прошлый раз. Если список последних использовавшихся файлов не отображается, щелкните Параметры на вкладке Файл. В диалоговом окне Параметры Access нажмите кнопку Параметры клиента. В разделе Вывод на экран укажите количество документов, которые необходимо отобразить в списке "Последние документы" (не больше 50).

    Вы также можете показывать последние базы данных на панели навигации в представлении Backstage, чтобы получить доступ с помощью двух щелчков мыши: 1), а затем откройте последнюю базу данных, которую вы хотите открыть, в формате 2. В нижней части вкладки " последние " установите флажок Быстрый доступ к этому количеству последних баз данных и настройте количество отображаемых баз данных.

  • При открытии базы данных с помощью команды Открыть на вкладке Файл можно просмотреть список ярлыков недавно открывавшихся баз данных, нажав в диалоговом окне Открыть кнопку Последние.

К началу страницы

Используете Access 2007?

При первом запуске Access или закрытии базы данных без выхода из Access отображается окно Приступая к работе с Microsoft Office Access.

Страница "Приступая к работе с Microsoft Office Access"

Это начальная страница, на которой можно создать новую базу данных, открыть существующую или ознакомиться с информацией с сайта Microsoft Office Online.

В Access предлагаются разнообразные шаблоны, с помощью которых можно быстро создать базу данных. Шаблон — это готовая к использованию база данных, содержащая все таблицы, запросы, формы и отчеты, необходимые для выполнения определенной задачи. Например, существуют шаблоны, которые можно использовать для отслеживания вопросов, управления контактами или учета расходов. Некоторые шаблоны содержат примеры записей, демонстрирующие их использование. Шаблоны баз данных можно использовать без изменений или настроить в соответствии с конкретными потребностями.

Если один из этих шаблонов вам подходит, с его помощью обычно проще и быстрее всего создать необходимую базу данных. Однако если необходимо импортировать в Access данные из другой программы, возможно, будет проще создать базу данных без использования шаблона. Так как в шаблонах уже определена структура данных, на изменение существующих данных в соответствии с этой структурой может потребоваться много времени.

  1. Если вы открыли базу данных, нажмите кнопку Microsoft Office , а затем — кнопку Закрыть базу данных Изображение кнопки , чтобы открыть страницу Начало работы с Microsoft Office Access .

  2. Некоторые популярные шаблоны отображаются в центре страницы Приступая к работе с Microsoft Office Access и становятся доступны при выборе ссылок в области " категории шаблонов ". Дополнительные шаблоны можно загрузить с веб-сайта Office Online. Дополнительные сведения см. в следующем разделе.

  3. Щелкните шаблон, который вы хотите использовать.

  4. Приложение Access предложит имя файла базы данных в поле имя файла — при желании вы можете изменить имя файла. Чтобы сохранить базу данных в другой папке, расположенной под полем Имя файла, щелкните Изображение кнопки , перейдите в папку, в которой вы хотите ее сохранить, и нажмите кнопку ОК. Кроме того, вы можете создать и связать базу данных с сайтом SharePoint.

  5. Нажмите кнопку Создать (или Загрузить — для скачивания шаблона Office Online).

    Access создаст или скачает, а затем откроет базу данных. Появится форма, в которой можно начать ввод данных. Если шаблон содержит примеры данных, вы можете удалить каждую из этих записей, щелкнув область маркировки (затененное поле или полосу слева от записи) и выполнив действия, указанные ниже.

    На вкладке Главная в группе Записи нажмите кнопку Удалить. Выноска 4

  6. Щелкните первую пустую ячейку в форме и приступайте к вводу данных. Для открытия других необходимых форм или отчетов используйте область навигации.

Если на странице Приступая к работе с Microsoft Office Access нет нужного шаблона, то при наличия подключения к Интернету можно найти на сайте Office Online другие шаблоны.

  1. На странице Приступая к работе с Microsoft Office Access в разделе Дополнительно на веб-узле Office Online щелкните пункт Шаблоны.

    В окне браузера отобразится домашняя страница "Шаблоны" на сайте Office Online.

  2. Используйте средства поиска и навигации Office Online для поиска нужного шаблона Access, а затем следуйте инструкциям по его скачиванию. При этом файл базы данных скачивается на компьютер, а затем открывается в новом экземпляре Access. В большинстве случаев шаблоны разрабатываются таким образом, чтобы сразу открывалась форма ввода данных и можно было немедленно приступить к их вводу.

Дополнительные сведения о работе с шаблонами см. в статье Создание базы данных Access на компьютере с помощью шаблона.

К началу страницы

Если вы не заинтересованы в использовании шаблона, вы можете создать базу данных, создав собственные таблицы, формы, отчеты и другие объекты базы данных. В большинстве случаев обычно используется один или оба следующих варианта:

  • Ввести, вставить или импортировать данные в таблицу, которая создается вместе с базой данных, и повторить эту процедуру для новых таблиц, которые создаются с помощью команды Таблица на вкладке Создание.

  • Импортировать данные из других источников, при этом создав таблицы.

  1. На странице Приступая к работе с Microsoft Office Access в группе Новая пустая база данных выберите пункт Пустая база данных.

    Кнопка "Пустая база данных"

  2. В области Пустая база данных в поле Имя файла введите имя файла. Если имя файла указано без расширения, расширение будет добавлено автоматически. Чтобы сохранить файл в другой папке, отличной от используемой по умолчанию, нажмите кнопку Поиск расположения для размещения базы данных Изображение кнопки (рядом с полем Имя файла), откройте нужную папку и нажмите кнопку ОК.

  3. Щелкните Создать.

    Access создаст базу данных с пустой таблицей "Таблица1" и откроет ее в режиме таблицы. Курсор будет помещен в первую пустую ячейку столбца Добавить поле.

  4. Чтобы добавить данные, начните вводить их или вставьте данные из другого источника (см. раздел Копирование данных из другого источника в таблицу Microsoft Access).

Ввод данных в режиме таблицы напоминает работу с листом Microsoft Office Excel 2007. Структура таблицы создается при вводе данных — при каждом добавлении нового столбца в таблицу определяется новое поле. Access автоматически определяет тип данных каждого поля на основе введенных данных.

Если на этом этапе вводить данные в таблицу "Таблица1" не нужно, нажмите кнопку Закрыть Изображение кнопки . Если вы внесли изменения в таблицу, будет предложено сохранить их. Нажмите кнопку Да, чтобы сохранить изменения, кнопку Нет, чтобы не сохранять их, или кнопку Отмена, чтобы оставить таблицу открытой.

Важно: Если хотя бы один раз закрыть таблицу "Таблица1" без сохранения, она будет удалена полностью, даже если в нее введены данные.

Добавление таблиц к существующей базе данных осуществляется командами группы Таблицы на вкладке Создать.

Изображение ленты Access

Создание таблицы в режиме таблицы.    В режиме таблицы можно начать ввод данных сразу, структура таблицы при этом будет создаваться автоматически. Полям присваиваются имена с последовательными номерами ("Поле1", "Поле2" и т. д.), а тип данных автоматически задается с учетом вводимых данных.

  1. на вкладке Создание в группе Таблицы нажмите кнопку Таблица. Выноска 4

    Access создаст таблицу и выделит первую пустую ячейку в столбце Добавить поле.

    Примечание: Если столбец Добавить поле не отображается, возможно, вместо режима таблицы выбран режим конструктора. Чтобы переключиться в режим таблицы, дважды щелкните таблицу в области навигации. Access предложит сохранить новую таблицу, а затем переключится в режим таблицы.

  2. На вкладке Таблица в группе Поля и столбцы щелкните Новое поле. Изображение кнопки

    Откроется область Шаблоны полей, которая содержит список наиболее часто используемых типов полей. Если дважды щелкнуть одно из этих полей или перетащить его на лист, Access добавит поле с указанным именем, а его свойствам будут присвоены значения, соответствующие выбранному типу поля. Эти свойства можно изменить позднее. Поле необходимо перетащить в область листа, содержащую данные. При этом появится вертикальная линия вставки, показывающая расположение поля.

  3. Чтобы добавить данные, начните вводить их в первую пустую ячейку или вставьте из другого источника (см. раздел Копирование данных из другого источника в таблицу Access).

  4. Чтобы переименовать столбец (поле), дважды щелкните его заголовок и введите новое имя.

    Рекомендуется присваивать полям значимые имена, чтобы при просмотре области Список полей было понятно, что содержится в каждом поле.

  5. Чтобы переместить столбец, щелкните его заголовок для выделения столбца и перетащите в нужное место.

    Вы можете выделить несколько смежных столбцов и перетащить их одновременно. Чтобы выделить несколько смежных столбцов, щелкните заголовок первого столбца, а затем, удерживая нажатой клавишу SHIFT, щелкните заголовок последнего столбца.

Создание таблицы в режиме конструктора.    В режиме конструктора сначала следует создать структуру новой таблицы. Затем можно переключиться в режим таблицы для ввода данных или ввести данные, используя другой способ, например вставить данные из буфера обмена или импортировать их.

  1. На вкладке Создание в группе Таблицы нажмите кнопку Конструктор таблиц. Изображение кнопки

  2. Для каждого поля в таблице введите имя в столбце Имя поля, а затем в списке Тип данных выберите тип данных.

    Примечание: Если столбцы Имя поля и Тип данных не отображаются, возможно, вместо режима конструктора выбран режим таблицы. Чтобы перейти в режим конструктора, в области навигации щелкните таблицу правой кнопкой мыши и выберите пункт Конструктор Выноска 4 . Access предложит ввести имя для новой таблицы, а затем переключится в режим конструктора.

  3. При желании можно ввести описание для каждого поля в столбце Описание. Это описание будет отображаться в строке состояния, когда в режиме таблицы курсор будет находиться в данном поле. Описание также отображается в строке состояния для любых элементов управления в форме или отчете, которые создаются путем перетаскивания этого поля из области списка полей, и любых элементов управления, которые создаются для этого поля при использовании мастера отчетов или мастера форм.

  4. Когда все необходимые поля будут добавлены, сохраните таблицу:

    • Нажмите кнопку Microsoft Office и выберите Сохранить или нажмите клавиши CTRL+S Изображение кнопки .

  5. Вы можете в любой момент ввести данные в таблицу, переключив ее в режим таблицы и щелкнув первую пустую ячейку. Вы также можете вставить данные из другого источника, как описано в разделе копирование данных из другого источника в таблицу Access.

Создание таблицы на основе шаблона.    В Access есть шаблоны для часто используемых типов таблиц. Одним щелчком мыши можно создать полную и готовую к использованию структуру таблицы. При необходимости вы можете добавлять или удалять поля.

  1. На вкладке Создание в группе Таблицы щелкните Шаблоны таблиц и выберите из списка один из доступных шаблонов.

  2. Чтобы добавить данные, начните вводить их в первую пустую ячейку или вставьте из другого источника (см. раздел Копирование данных из другого источника в таблицу Access).

    • Удаление столбца    

      1. Щелкните заголовок столбца правой кнопкой мыши и выберите пункт Удалить столбец Изображение кнопки .

    • Добавление столбца    

      1. На вкладке Таблица в группе Поля и столбцы щелкните Новое поле. Изображение кнопки

      2. Откроется область Шаблоны полей, которая содержит список наиболее часто используемых типов полей. Если дважды щелкнуть одно из этих полей или перетащить его на лист, Access добавит поле с указанным именем, а его свойствам будут присвоены значения, соответствующие выбранному типу поля. Эти свойства можно изменить позднее. Поле необходимо перетащить в область листа, содержащую данные. При этом появится вертикальная линия вставки, показывающая расположение поля.

  3. Сохраните таблицу:

    • Нажмите кнопку Microsoft Office и выберите Сохранить или нажмите клавиши CTRL+S Изображение кнопки .

Задание свойств полей в режиме конструктора.    Независимо от способа создания таблицы рекомендуется проверить и задать свойства полей. Это можно сделать только в режиме конструктора. Чтобы перейти в режим конструктора, в области навигации щелкните таблицу правой кнопкой мыши и выберите пункт Конструктор. Чтобы отобразить свойства поля, щелкните его в сетке конструктора. Свойства отображаются под сеткой конструктора в области Свойства поля.

Щелкните свойство поля, чтобы просмотреть его описание рядом со списком Свойства поля. Дополнительную информацию можно получить, нажав клавишу F1.

В следующей таблице описаны некоторые наиболее часто изменяемые свойства полей.

Свойство

Описание

Размер поля

Для текстовых полей это свойство указывает максимально допустимое количество знаков, сохраняемых в поле. Максимальное значение: 255. Для числовых полей это свойство определяет тип сохраняемых чисел ("Длинное целое", "Двойное с плавающей точкой" и т. д.). Для более рационального хранения данных рекомендуется выделять для хранения данных наименьший необходимый размер памяти. Если потребуется, это значение позже можно изменить.

Формат поля

Это свойство определяет формат отображения данных. Оно не влияет на фактические данные, сохраняемые в этом поле. Вы можете выбрать встроенный формат или задать собственный.

Маска ввода

Это свойство используется для определения общего шаблона для ввода любых данных в поле. Это позволяет обеспечить правильный ввод и нужное количество знаков для всех данных. Для получения справки по созданию маски ввода нажмите кнопку Кнопка "Построитель" справа от поля свойства.

Значение по умолчанию

Это свойство позволяет задать стандартное значение, которое будет отображаться в этом поле при добавлении новой записи. Например, для поля "Дата/время", в котором необходимо записывать дату добавления записи, в качестве значения по умолчанию можно ввести "Date()" (без кавычек).

Обязательное поле

Это свойство указывает, обязательно ли вводить значение в поле. Если для него задано значение Да, невозможно будет добавить запись, если в это поле не введено значение.

К началу страницы

Если ваши данные хранятся в другой программе, например Office Excel 2007, их можно скопировать и вставить в таблицу Access. Как правило, этот метод работает лучше всего, если данные уже разделены на столбцы, как в таблице Excel. Если данные находятся в текстовом редакторе, перед копированием рекомендуется разделить столбцы данных с помощью табуляции или преобразовать данные в таблицу. Если необходимо изменить данные или выполнить с ними другие операции (например, разделить полное имя на имя и фамилию), рекомендуется сделать это перед копированием данных, особенно если вы не знакомы с Access.

При вставке данных в пустую таблицу приложение Access задает тип данных для каждого поля в зависимости от того, какие данные в нем находятся. Например, если во вставляемом поле содержатся только значения даты, для этого поля используется тип данных "Дата/время". Если же вставляемое поле содержит только слова "Да" и "Нет", для этого поля выбирается тип данных "Логический".

Access применяет имена к полям в зависимости от того, что оно найдено в первой строке вставленных данных. Если первая строка вставленных данных похожа на следующую строку, Access определяет, что первая строка является частью данных и присваивает полям универсальные имена (F1, F2 и т. д.). Если первая строка вставленных данных не похожа на приведенные ниже строки, Access определяет, что первая строка состоит из имен полей. Access называет поля соответствующим образом и не включает первую строку данных.

В Access имена присваиваются полям автоматически, поэтому во избежание путаницы поля следует переименовать. Это можно сделать следующим образом:

  1. Сохраните таблицу.

    • Нажмите кнопку Microsoft Office и выберите Сохранить или нажмите клавиши CTRL+S Изображение кнопки .

  2. В режиме таблицы дважды щелкните заголовок каждого столбца и введите допустимое имя поля. Может показаться, что при этом происходит замена данных, однако в строке заголовка столбца содержатся имена полей, а не данные.

  3. Еще раз сохраните таблицу.

Примечание: Кроме того, для изменения имен полей можно переключиться в режим конструктора. Для этого в области навигации щелкните таблицу правой кнопкой мыши и выберите пункт Конструктор. Чтобы вернуться в режим таблицы, дважды щелкните таблицу в области навигации.

К началу страницы

Возможно, у вас есть данные, хранящиеся в другой программе, которые вы хотите импортировать в новую таблицу Access или добавить в существующую. Кроме того, если ваши коллеги хранят данные в других программах, может потребоваться создать связь с такими данными. В обоих случаях работа с данными из других источников не представляет сложности. Вы можете импортировать данные из листа Excel, таблицы в другой базе данных Access, списка SharePoint и других источников. Процесс импорта для разных источников немного различается, однако всегда начинается так, как описано ниже.

  1. В Access на вкладке Внешние данные в группе Импорт выберите команду для типа файла, который необходимо импортировать.

    Изображение ленты Access

    Например, чтобы импортировать данные с листа Excel, нажмите кнопку Excel. Если вы не видите нужный тип программы, нажмите кнопку Дополнительно.

    Примечание: Если не удается найти нужный тип формата в группе Импорт, может потребоваться запустить программу, в которой созданы эти данные, а затем сохранить в этой программе данные в файле общего формата (например, как текстовый файл с разделителями) перед импортом данных в Access.

  2. В диалоговом окне Внешние данные нажмите кнопку Обзор, чтобы найти исходный файл данных, или введите в поле Имя файла полный путь к нему.

  3. Выберите нужный вариант (все программы позволят вам импортировать данные, а некоторые из них допускают Добавление или связывание) в разделе Укажите, как и где вы хотите хранить в текущей базеданных. Вы можете создать новую таблицу, которая использует импортированные данные или (с некоторыми программами), добавить данные в существующую таблицу или создать связанную таблицу, которая будет поддерживать связь с данными в исходной программе.

  4. Если будет запущен мастер, следуйте инструкциям на экране. На последней странице мастера нажмите кнопку Готово.

    При импорте объектов или связывании таблиц из базы данных Access открывается диалоговое окно Импорт объектов или Связь с таблицами. Выберите нужные элементы и нажмите кнопку ОК.

    Точная последовательность действий зависит от выбранного способа обработки данных: импорт, добавление или связывание.

  5. Access предложит сохранить сведения о только что завершенной операции импорта. Если вы планируете повторить ее, нажмите кнопку Сохранить шаги импорта и введите нужные сведения. Позже для повторения этой операции достаточно будет нажать кнопку Сохраненные операции импорта Изображение кнопки на вкладке Внешние данные в группе Импорт. Если вы не хотите сохранять сведения об операции, нажмите кнопку Закрыть.

Если вы решили импортировать таблицу, Access импортирует данные в новую таблицу и отображает ее в группе Таблицы в области навигации. Если выбрано добавление данных к существующей таблице, данные добавляются к ней. Если вы связываете данные, в группе Таблицы в области навигации создается связанная таблица.

К началу страницы

  1. Нажмите кнопку Microsoft Office и выберите Открыть.

  2. В диалоговом окне Открытие файла базы данных найдите базу данных, которую нужно открыть.

  3. Выполните одно из следующих действий.

    • Чтобы открыть базу данных в режиме по умолчанию, дважды щелкните ее (режим по умолчанию может быть указан в диалоговом окне Параметры Access или установлен административной политикой).

    • Нажмите кнопку Открыть, чтобы открыть базу данных для общего доступа в многопользовательской среде и предоставить другим пользователям возможность выполнять чтение и запись в базу данных.

    • Щелкните стрелку рядом с кнопкой Открыть и выберите вариант Открыть для чтения, чтобы открыть базу данных только для чтения, то есть для просмотра без возможности внесения изменений. При этом другие пользователи смогут выполнять запись в базу данных.

    • Щелкните стрелку рядом с кнопкой Открыть и выберите вариант Монопольно, чтобы открыть базу данных в монопольном режиме. Если ее затем попытается открыть другой пользователь, он получит сообщение "Файл уже используется".

    • Щелкните стрелку рядом с кнопкой Открыть и выберите вариант Монопольно для чтения, чтобы открыть базу данных только для чтения. Другие пользователи при этом смогут открывать базу данных только для чтения.

Если не удается найти базу данных, которую вы хотите открыть    

  1. Щелкните значок Мой компьютер в диалоговом окне Открытие файла базы данных или выберите Мой компьютер в раскрывающемся списке Папка.

  2. В списке дисков щелкните правой кнопкой мыши диск, на котором может находиться база данных, и выберите команду Найти.

  3. Введите условие поиска в диалоговом окне Результаты поиска и нажмите кнопку Поиск для поиска базы данных.

  4. Если база данных найдена, дважды щелкните ее, чтобы открыть.

  5. Чтобы база данных открылась, необходимо нажать кнопку Отмена в диалоговом окне Открытие файла базы данных. Затем закройте диалоговое окно Результаты поиска.

Примечание: Вы можете напрямую открывать файлы данных внешних форматов, например dBASE, Paradox, Microsoft Exchange или Excel. Кроме того, можно открыть напрямую любой источник данных ODBC, например Microsoft SQL Server или Microsoft FoxPro. Access автоматически создаст базу данных Access в одной папке с файлом данных и добавит ссылки на все таблицы внешней базы данных.

  • Для открытия одной из баз данных, которые открывались недавно, щелкните ее имя файла в списке Открыть последнюю базу данных на странице Приступая к работе с Microsoft Office Access. Access откроет базу данных, используя параметры, которые применялись при ее открытии в прошлый раз. Если список недавно использовавшихся файлов не отображается, нажмите кнопку Microsoft Office , а затем — Параметры Access. В диалоговом окне Параметры Access выберите пункт Дополнительно. В разделе Вывод на экран укажите количество документов, которые необходимо отобразить в списке "Последние документы" (не больше девяти).

  • Если вы открываете базу данных нажатием кнопки Microsoft Office , а затем с помощью команды открыть , вы можете просмотреть список ярлыков баз данных, которые вы ранее открыли, щелкнув Мои недавние документы в окне Open (открыть ). диалоговое окно.

К началу страницы

При создании новой пустой базы данных Access открывает новую таблицу, в которой можно вводить данные, но не создает никаких других объектов в базе данных. Если вы хотите, чтобы другие объекты (например, формы, отчеты, макросы или дополнительные таблицы) присутствовали во всех создаваемых базах данных, вы можете создать настраиваемый пустой шаблон, содержащий эти объекты. После того как вы создадите новую базу данных, в следующий раз они уже будут содержать эти объекты в шаблоне. В дополнение к этим объектам шаблон может включать таблицы, заполненные данными, а также особые параметры конфигурации, свойства базы данных, ссылки или код, которые должны быть доступны во всех новых базах данных.

Например предположим, что у вас есть набор макросов, которые должны использоваться во всех проектах. Если создать пустой шаблон с этими макросами, они будут автоматически добавляться во все создаваемые в Access базы данных.

Пустые шаблоны можно создать в виде файлов следующих форматов: Office Access 2007, Access 2002–2003 или Access 2000. Шаблон должен называться Blank.accdb в случае использования файлов формата Office Access 2007 и Blank.mdb для форматов файлов предыдущих версий.

  • Если по умолчанию используется формат Access 2000 или Access 2002–2003, файл пустого шаблона получит имя Blank.mdb. Новая база данных будет создана в том же формате, что и файл Blank.mdb. Например, если по умолчанию используется формат Access 2000, а шаблон с именем Blank.mdb имеет формат файла Access 2002–2003, все новые базы данных будут создаваться в формате Access 2002–2003.

  • Если по умолчанию используется формат Access 2007, файл пустого шаблона получит имя Blank.accdb.

Изменение формата файлов, используемого по умолчанию

  1. Нажмите кнопку Microsoft Office  и щелкните Параметры Access.

  2. В диалоговом окне Параметры Access выберите пункт Основные.

  3. В группе Создание баз данных в раскрывающемся списке Формат файла по умолчанию выберите нужный формат.

Чтобы создать пустой шаблон, выполните одно из следующих действий:

  • Создайте пустую базу данных (назовите ее "Пустая" или дайте ей любое временное имя), а затем импортируйте или создайте объекты, которые должны быть в шаблоне.

  • Создайте копию существующей базы данных, в которой есть нужные для шаблона объекты, а затем удалите лишние объекты.

Когда нужные для шаблона объекты будут готовы, сохраните базу данных:

  1. Нажмите кнопку Microsoft Office  и выберите команду Сохранить как.

  2. В группе Сохранить базу данных в другом формате выберите формат файла для шаблона.

  3. В диалоговом окне Сохранить как откройте одну из следующих двух папок:

    • Папка "системный шаблон"    Например, C:\Program Files\Microsoft Office\Templates\1033\Access

    • Папка шаблонов пользователей    Ниже приведены некоторые примеры.

      • В Windows Vista     C appdata\local\temp. Наме\аппдата\роаминг\микрософт\темплатес

      • В Microsoft Windows Server 2003 или Microsoft Windows XP    C:\Documents and Settings Наме\аппликатион Data\Microsoft\Templates

        Примечание: Пустой шаблон в системной папке переопределяет пустые шаблоны в любых пользовательских папках.

  4. В поле Имя файла введите Blank.accdb (или Blank.mdb, если создается шаблон одной из предыдущих версий), а затем нажмите кнопку Сохранить.

Теперь, когда вы создаете новую пустую базу данных, в новом шаблоне объекты будут включены в любую новую базу данных, созданную по умолчанию. Приложение Access откроет новую таблицу в режиме таблицы, как и при создании новых пустых баз данных без использования шаблона.

Чтобы прекратить использование пустого шаблона, удалите или переименуйте файл Blank.accdb (или файл Blank.mdb, если используется одна из предыдущих версий программы Access).

К началу страницы

Совершенствование навыков работы с Office
Перейти к обучению
Первоочередный доступ к новым возможностям
Присоединиться к программе предварительной оценки Office

Были ли сведения полезными?

Спасибо за ваш отзыв!

Благодарим за отзыв! Возможно, будет полезно связать вас с одним из наших специалистов службы поддержки Office.

×