Перейти к основному контенту
Office
Связывание проектов для создания главного проекта

Связывание проектов для создания главного проекта

Подписка на Office 365, Project профессиональный 2019, Project профессиональный 2016, Office 2013, Office 2010

Примечание: Мы стараемся как можно оперативнее обеспечивать вас актуальными справочными материалами на вашем языке. Эта страница переведена автоматически, поэтому ее текст может содержать неточности и грамматические ошибки. Для нас важно, чтобы эта статья была вам полезна. Просим вас уделить пару секунд и сообщить, помогла ли она вам, с помощью кнопок внизу страницы. Для удобства также приводим ссылку на оригинал (на английском языке).

Чтобы улучшить организацию больших проектов, вы можете связать несколько файлов проектов, создав систему из главного проекта и подпроектов (внешние зависимости). Например, главный проект по строительству может включать файлы подпроектов по водопроводным, электромонтажным и столярным работам.

Связывание файлов в Project

  1. Создайте в Project отдельные файлы для каждого подпроекта, а затем откройте или создайте проект, который нужно сделать главным.

  2. В главном проекте нажмите Вид > Диаграмма Ганта.

  3. В поле Название задачи нажмите на строку, под которой нужно вставить подпроект. Его можно вставить в любой строке списка задач главного проекта.

  4. Выберите Проект > Подпроект.

    Вкладка ленты "Проект", на которой отображается команда "Вставить подпроект".

  5. В окне Вставка проекта выберите подпроект, который нужно вставить.

    • Чтобы вставить несколько подпроектов, нажмите и удерживайте клавишу CTRL и нажимайте подпроекты в нужном порядке.

    • В большинстве случаев флажок для параметра Связать с проектом должен быть установленным, чтобы изменения в подпроекте отображались в главном проекте и наоборот. Но если вы хотите просто скопировать подпроект в главный проект, не устанавливая между файлами динамическую связь, снимите этот флажок.

  6. Нажмите кнопку Вставить или, чтобы вставить проект в формате только для чтения, нажмите на стрелку на кнопке Вставить, а затем выберите команду Вставить только для чтения. При вставке проекта в таком формате будет создана связь между двумя проектами, но обновление подпроекта в главном проекте выполняться не будет. При этом в случае обновления непосредственно файла подпроекта внесенные изменения будут отображены в главном проекте. Параметр Вставить только для чтения доступен только после установки флажка Связать с проектом.

Как избежать дублирования имен ресурсов в связанных проектах

Если связать проекты, в которых используются ресурсы с одинаковыми именами, вы создадите их копии, что может привести к ошибкам. Чтобы избежать этого, в диалоговом окне Вставка проекта снимите флажок Связать с проектом. Таким образом вы гарантируете использование сведений о ресурсах (например, ставок оплаты и календарей ресурсов) из главного проекта в подпроекте.

Примечание: При обновлении несвязанного подпроекта в главном проекте внесенные изменения не будут отображаться в исходном файле подпроекта.

Переупорядочение подпроектов в главном проекте

Если вы добавили подпроект в главный проект и хотите переупорядочить список задач, вы можете переместить вставленный проект вверх или вниз по списку задач.

  1. Нажмите кнопку Просмотреть диаграмму Ганта_гт_.

  2. Выберите идентификатор из суммарная задача, представляющего вставленный проект, который вы хотите переместить.

  3. Щелкните правой кнопкой мыши и выберите команду Вырезать , чтобы удалить вставленный проект.

    Примечание: Вызвав и вставив задачу, вы измените уникальный идентификатор задачи (она отличается от идентификатор задачи, которая находится в левом столбце таблицы), после того как она будет вставлена в список задач в другом расположении. Чтобы переместить задачу, не меняя уникальный идентификатор, перетащите ее в новое место в списке задач. Чтобы перетащить задачу, наведите указатель мыши на идентификатор задачи в поле "идентификатор". Когда указатель примет вид крестообразной стрелки, перетащите задачу на новое место. Эти данные удаляются только из плана проекта, а не удаляются до тех пор, пока вы не вставьте их снова.

  4. Выберите ИДЕНТИФИКАЦИОНный номер задачи, под которой вы хотите добавить проект в список задач.

    Примечание: При вставке или вставке проекта под другим вставленным проектом, для которого отображается только суммарная задача проекта, проект, который вы вставляете или вставляете, добавляется на том же уровне, что и вставленный проект над ним. Тем не менее, если вставить или вставить под вставленным проектом, в котором отображаются все задачи, то проект, который вы вставляете или вставляете, станет подпроектом вставленного проекта над ним.

  5. Нажмите кнопку Вставить , чтобы вставить проект над выделенной строкой.

Эти инструкции относятся к Microsoft Project 2007.

Когда следует использовать перекрестные связи между проектами, а не зависимости?

Если в вашем проекте есть задача, зависящая от задачи из другого проекта, используйте перекрестные связи, чтобы связать даты этих задач. Если впоследствии сроки задачи из другого проекта сместятся, эти изменения отразятся на вашей задаче. Если ваш проект зависит от какого-либо аспекта другого проекта, и эта зависимость не связана с определенной задачей, используйте зависимости между проектами, чтобы точно определить, в чем заключается вклад каждого проекта в связь.

  1. Откройте проекты с задачами, которые вы хотите связать.

    В одном из проектов откройте меню Окно и выберите Упорядочить все.

  2. Выберите задачу, для которой хотите создать зависимость с внешним предшественником.

  3. Нажмите кнопку сведения о задаче Изображение кнопки и откройте вкладку предшественники .

  4. В столбце ID введите имя проекта и идентификатор задачи внешнего предшественника, отделенные обратной косой чертой. Например, введите Project1\1 для задачи с идентификатором 1 в файле «проект1».

По умолчанию вы получаете уведомление об изменении данных в проекте, связанном с внешними данными. Внешние задачи-предшественники и последователи, а также влияние на календарный план отображаются при открытии проекта с внешними связями, и вы можете выбрать, какие изменения будут внесены.

  • Для установления связи с внешней задачей оба проекта следует предварительно сохранить.

  • При связывании задач в разных проектах, которые хранятся в Microsoft Office Project Server, идентификатор задачи предшественника должен быть правильно отформатирован. В диалоговом окне сведения о задаче на вкладке Предшественники в СТОЛБЦЕ идентификатор необходимо указать идентификатор задачи, как показано в следующем примере: _лт__гт_ \ проект1 \ 42. В этом примере проект1 — это имя проекта, содержащего предшественника, а 42 — идентификатор задачи-предшественника.

  • Задачи с внешними связями отображаются затененными в списке задач. Дважды щелкнув задачу с внешним предшественником или последователем, вы откроете проект, содержащий внешнюю задачу (если он доступен).

Задачи из разных проектов связаны, но данные отличаются

Если вы используете команду " Вставить ссылку " в диалоговом окне "Специальная Вставка " (меню "Правка ") для подключения задач, в Project используется связывание и внедрение объектов (OLE) для создания подключения. Связаны только выбранные поля. Однако у задачи может быть больше полей с данными, которые влияют на планирование задачи, и эти поля могут быть скрыты, если используется представление с разделением экрана.

При необходимости создать зависимость между задачами из разных проектов, для соблюдения календарного плана следует создать внешние зависимости, а не связи.

Если вы выбрали пункт Связать, выделите отдельные поля, а не целые строки, и создайте связь только для нужных сведений, чтобы избежать конфликтов в календарном плане.

Подробнее

Вложенные планы: главные проекты и подпроекты

Совершенствование навыков работы с Office
Перейти к обучению
Первоочередный доступ к новым возможностям
Присоединиться к программе предварительной оценки Office

Были ли сведения полезными?

Спасибо за ваш отзыв!

Благодарим за отзыв! Возможно, будет полезно связать вас с одним из наших специалистов службы поддержки Office.

×