Перейти к основному контенту
Office

Преобразование базы данных в формат файла ACCDB

Примечание: Мы стараемся как можно оперативнее обеспечивать вас актуальными справочными материалами на вашем языке. Эта страница переведена автоматически, поэтому ее текст может содержать неточности и грамматические ошибки. Для нас важно, чтобы эта статья была вам полезна. Просим вас уделить пару секунд и сообщить, помогла ли она вам, с помощью кнопок внизу страницы. Для удобства также приводим ссылку на оригинал (на английском языке).

Access создает базы данных в формате ACCDB. Этот формат поддерживает такие возможности, как многозначные поля, макросы данных и публикация в службах Access.

Базы данных, созданные в версиях Microsoft Office Access 2003, Access 2002, Access 2000 и Access 97, можно преобразовать в формат файла ACCDB. Однако следует иметь в виду, что в версиях приложения Access, предшествующих Access 2007, невозможно открыть базы данных в формате ACCDB или установить с ними связь.

Кроме того, в формате ACCDB отсутствует поддержка репликации и защиты на уровне пользователя. Если нужно открыть общий доступ к базе данных для пользователей, работающих в Access 2003 или более ранней версии приложения, либо требуется применять репликацию или защиту на уровне пользователя, необходимо сохранить базу данных в формате MDB.

Примечание: Несмотря на то, что они используют один и тот же формат файла, некоторые функции в Access 2010 и более поздних версиях нельзя использовать в Access 2007. Дополнительные сведения можно найти в разделе Использование Access 2007 для открытия базы данных, созданной или измененной в более поздних версиях.

В этой статье

Преобразование базы данных Access 2000 или Access 2002–2003 в формат ACCDB

Преобразование базы данных Access 97 в формат ACCDB

Использование Access 2007 для открытия базы данных, созданной или измененной в более поздних версиях

Преобразование базы данных Access 2000 или Access 2002–2003 в формат ACCDB

Чтобы преобразовать базу данных Access 2000 или Access 2002–2003 (MBD) в формат ACCDB, необходимо открыть ее в приложении Access 2007, Access 2010, Access 2013 или Access 2016 и сохранить в формате ACCDB.

  1. На вкладке Файл выберите команду Открыть.

  2. Откройте базу данных Access 2000 или Access 2002–2003 (MBD), которую необходимо преобразовать.

    Примечание: Если появится диалоговое окно Улучшение базы данных, это означает, что файл базы данных имеет более ранний формат, чем Access 2000. Дальнейшие инструкции см. в разделе Преобразование базы данных Access 97 в формат ACCDB.

  3. На вкладке Файл выберите команду Сохранить как и нажмите Сохранить базу данных как.

  4. Выберите тип файла Access и нажмите Сохранить как.

    Если при нажатии кнопки Сохранить как открыты какие-либо объекты базы данных, то появляется сообщение о необходимости закрыть их перед созданием копии. Чтобы закрыть объекты, нажмите кнопку Да, а чтобы отменить процедуру в целом, нажмите кнопку Нет. При необходимости будет выведен запрос на сохранение изменений.

  5. В диалоговом окне Сохранение введите имя файла в поле Имя файла и нажмите кнопку Сохранить.

    В приложении Access будет создана копия базы данных, которая затем и откроется. Исходная же база данных закрывается автоматически.

Преобразование базы данных Access 97 в формат ACCDB

В Access 2013 и последующих версиях больше невозможно непосредственно преобразовывать базы данных Access 97 (формат MDB) в формат ACCDB. Тем не менее, можно открыть базу данных Access 97 в предыдущей версии Access, а затем сохранить базу данных во формате, который можно открыть в Access 2013. Например, чтобы с помощью приложения Access 2003 открыть базу данных Access 97, а затем преобразовать ее в формат, который можно открыть в Access 2013, выполните следующее:

  1. откройте базу данных Access 97 в Access 2003;

  2. нажмите Сервис > Служебные программы > Преобразовать базу данных > в формат Access 2002–2003;

  3. введите имя для базы данных и нажмите кнопку Сохранить;

  4. закройте Access 2003 и откройте Access 2013;

  5. откройте базу данных и нажмите Файл > Сохранить как > База данных Access (ACCDB) > Сохранить как > Сохранить.

Для преобразования базы данных Access 97 в формат ACCDB можно также использовать Access 2007 или Access 2010. Когда вы открываете базу данных Access 97 в одном из этих двух продуктов, открывается мастер улучшения базы данных, помогающий преобразовать базу данных в формат ACCDB.

Использование Access 2007 для открытия базы данных, созданной или измененной в более поздних версиях

Поскольку в Access 2016, Access 2013, Access 2010 и Access 2007 используется один и тот же формат файла, вы можете использовать Access 2007 для открытия базы данных, созданной в Access 2010, Access 2013 или Access 2016, без предварительного использования команды Сохранить как . Однако Access 2016, Access 2013 и Access 2010 включают некоторые функции, требующие доступа к 2016, Access 2013 и Access 2010 для выполнения. В некоторых случаях при попытке использовать базу данных в Access 2007 может возникнуть одно из указанных ниже действий.

  • невозможно изменить объект, в котором используется новая функция;

  • невозможно открыть объект, в котором используется новая функция;

  • базу данных не удается открыть в Access 2007.

К началу страницы

Совершенствование навыков работы с Office
Перейти к обучению
Первоочередный доступ к новым возможностям
Присоединиться к программе предварительной оценки Office

Были ли сведения полезными?

Спасибо за ваш отзыв!

Благодарим за отзыв! Возможно, будет полезно связать вас с одним из наших специалистов службы поддержки Office.

×