Подготовка источника данных Excel к слиянию в Word

Важно :  Данная статья переведена с помощью машинного перевода, см. Отказ от ответственности. Используйте английский вариант этой статьи, который находится здесь, в качестве справочного материала.

Важным шагом при настройке слияния в Word является подготовка источника данных. Вы можете использовать существующий источник данных Excel или создать новый, импортировав TXT- или CSV-файл. После настройки и подготовки источника данных можно выполнить слияние почты с помощью динамический обмен данными (DDE) с мастером слияния или вручную.

Если у вас нет источника данных Excel для слияния, вы можете использовать список контактов или адресную книгу в TXT- или CSV-файле. Мастер импорта текста поможет вам извлечь данные из файла в Excel.

  1. Откройте Excel.

  2. На вкладке Данных щелкните Получение внешних данных > Из текста.

    На вкладке "Данные" выделен параметр "Из текста".

  3. Выберите нужный файл в формате CSV или TXT и нажмите кнопку Импорт.

  4. В мастере импорта текста в области Формат исходных данных выберите С разделителями.

    Получение внешних данных из текста, мастер импорта текста, шаг 1 из 3

  5. При необходимости установите флажок Мои данные содержат заголовки над областью Предварительный просмотр файла, а затем нажмите кнопку Далее.

  6. В разделе Разделители установите нужный флажок (например, "знак табуляции" или "запятая") и нажмите кнопку Далее.

    Параметры разделителей выделены в мастере импорта текста.

    Совет : В области Образец разбора данных вы можете увидеть, как результаты будут выглядеть в виде таблицы.

  7. В области Образец разбора данных выберите столбец, содержащий почтовые индексы, а затем в списке Формат данных столбца выберите Текстовый.

    В мастере импорта текста выделен параметр "Текст" в разделе "Формат данных столбца".

    Примечания : 

    • Доступны форматы Общий, Текстовый и Дата. Каждый раз, когда вы применяете формат данных к столбцу, в его заголовке отображается имя формата.

    • Столбец, содержащий числовые данные, например процентные или денежные значения, можно отформатировать только после импорта файла. См. раздел "Форматирование числовых данных в Excel" ниже.

  8. При необходимости повторите действие 7, выбрав столбец, который вы хотите изменить, и нужный формат данных.

  9. Нажмите кнопку Finish (Готово).

  10. В диалоговом окне Импорт данных примите значение по умолчанию (имеющийся лист), а затем нажмите кнопку ОК.

    В диалоговом окне "Импорт данных" укажите, нужно ли добавить данные в существующую книгу (значение по умолчанию) или на новый лист.

    Внимание : В диалоговом окне Импорт данных указывается адрес выбранной ячейки. Данные импортируются, начиная с этой ячейки.

  11. Добавив данные, сохраните источник с новым именем файла.

Форматирование числовых данных в Excel

Отформатируйте все числовые данные, например процентные или денежные значения, в новых и существующих источниках данных Excel, которые предполагается использовать при слиянии в Word. Чтобы сохранить числовые данные, которые вы отформатировали как процентные или денежные значения, при слиянии, следуйте инструкциям в разделе "Шаг 2. Слияние с помощью DDE".

В источнике данных Excel, который вы хотите использовать в качестве списка рассылки в Word, проверьте правильность форматирования столбцов с числовыми данными. Например, примените нужный формат, такой как денежный.

  1. Откройте источник данных Excel.

  2. Выберите столбец, который вы хотите отформатировать.

  3. На вкладке Главная в группе Число в щелкните стрелку раскрывающегося списка Числовой формат (Общий) и выберите нужное значение.

    На вкладке "Главная" Excel в группе "Число" в щелкните стрелку раскрывающегося списка "Общий" и выберите нужное значение.

  4. При необходимости повторите шаги 2 и 3.

  5. После завершения нажмите кнопку Сохранить.

Если в источнике данных Excel есть числа, отформатированные как процентные или денежные значения, они могут потерять форматирование во время слияния. Чтобы получить необходимый результат при слиянии и сохранить формат числовых данных в Excel, используйте DDE.

Формат данных Excel в сравнении с полем слияния при использовании DDE и без него

Примечание : Если вы решили не использовать DDE, выполните инструкции в статье Использование слияния для массовой рассылки сообщений электронной почты.

  1. Откройте Word и выберите Файл > Параметры > Дополнительно.

  2. Перейдите к разделу Общие и установите флажокПодтверждать преобразование формата файла при открытии.

    Параметр ''Подтверждать преобразование формата файла при открытии''

  3. Нажмите кнопку ОК.

  4. На вкладке Рассылки щелкните Начать слияние > Пошаговый мастер слияния.

    В Word на вкладке "Рассылки" щелкните "Начать слияние" и выберите "Пошаговый мастер слияния".

  5. На панели слияния в разделе Выбор получателей выберите пункт использовать существующий список.

    При выборе мастера слияния в группе "Слияние" в Word открывается область задач "Слияние".

  6. В разделе Использовать существующий список нажмите кнопку Обзор и откройте отформатированную электронную таблицу.

  7. В диалоговом окне Преобразование источника данных установите флажок Отобразить все, а затем выберите пункт Листы MS Excel с помощью DDE (*.xls) и нажмите кнопку ОК.

    Диалоговое окно ''Преобразование источника данных''

  8. В диалоговом окне Microsoft Excel выберите Весь лист и нажмите кнопку ОК.

    Диалоговое окно Microsoft Excel в Word

  9. В диалоговом окне Получатели слияния нажмите кнопку ОК.

    Диалоговое окно "Получатели слияния", в котором показана электронная таблица Excel, используемая в качестве источника данных для списка рассылки

  10. Выполните слияние для создания писем, сообщений электронной почты, наклеек или конвертов.

Совет : Можно сделать так, чтобы при каждом открытии файла данных в Word не выводились запросы. После подключения к списку рассылки выберите Файл > Параметры > Дополнительно. В разделе Общие снимите флажок Подтверждать преобразование формата файла при открытии.

Примечание : Отказ от ответственности относительно машинного перевода. Данная статья была переведена с помощью компьютерной системы без участия человека. Microsoft предлагает эти машинные переводы, чтобы помочь пользователям, которые не знают английского языка, ознакомиться с материалами о продуктах, услугах и технологиях Microsoft. Поскольку статья была переведена с использованием машинного перевода, она может содержать лексические,синтаксические и грамматические ошибки.

Совершенствование навыков
Перейти к обучению
Первоочередный доступ к новым возможностям
Присоединиться к программе предварительной оценки Office

Были ли сведения полезными?

Спасибо за ваш отзыв!

Благодарим за отзыв! Возможно, будет полезно связать вас с одним из наших специалистов службы поддержки Office.

×