Исправление ошибки #ССЫЛКА!

Исправление ошибки #ССЫЛКА!

Примечание: Мы стараемся как можно оперативнее обеспечивать вас актуальными справочными материалами на вашем языке. Эта страница переведена автоматически, поэтому ее текст может содержать неточности и грамматические ошибки. Для нас важно, чтобы эта статья была вам полезна. Просим вас уделить пару секунд и сообщить, помогла ли она вам, с помощью кнопок внизу страницы. Для удобства также приводим ссылку на оригинал (на английском языке).

Ошибка #REF! показывает, что формула ссылается на недопустимую ячейку. Это чаще всего происходит, если ячейки, на которые ссылаются формулы, удаляются или вставляются.

Пример ошибки #ССЫЛКА! из-за удаления столбца

В следующем примере в столбце E используется формула =СУММ(B2;C2;D2).

Если в формуле используются явные ссылки на ячейки, например =СУММ(B2;C2;D2), то удаление столбца может вызывать ошибку #ССЫЛКА!.

Если вы удалили столбец B, C или D, это приведет к #REF! ошибку. В этом случае мы будем удалять столбец C (2007 Sales), и формула теперь читает = Sum (B2, #REF!, C2). При использовании явных ссылок на ячейки, разделенных запятыми (в которых вы указываете на каждую ячейку по отдельности) и удалении строки или столбца, на которые указывает ссылка, приложение Excel не сможет решить эту проблему, поэтому возвращает #REF! ошибку. Это основная причина, по которой использование явных ссылок на ячейки в функциях не рекомендуется.

Пример ошибки #ССЫЛКА! из-за удаления столбца.

Решение

  • Если вы случайно удалили строки или столбцы, вы можете немедленно нажать кнопку "Отменить" на панели быстрого доступа (или нажать клавиши CTRL+Z), чтобы восстановить их.

  • Измените формулу таким образом, чтобы она использовала ссылку на диапазон, а не отдельные ячейки, например = Sum (B2: D2). Теперь вы можете удалить любой столбец в диапазоне сумм, и Excel автоматически настроит формулу. Вы также можете использовать = Sum (B2: B5) для суммирования строк.

Пример функции ВПР с неправильными ссылками на диапазоны

В следующем примере функция =ВПР(A8;A2:D5;5;ЛОЖЬ) вернет ошибку #ССЫЛКА!, так как она выполняет поиск возвращаемого значения в столбце 5, но указан диапазон A:D, который содержит только 4 столбца.

Пример формулы ВПР с неправильным диапазоном.  Формула имеет вид =ВПР(A8;A2:D5;5;ЛОЖЬ).  Пятого столбца в диапазоне ВПР нет, поэтому значение 5 вызывает ошибку #ССЫЛКА!.

Решение

Измените диапазон, чтобы он был больше, или уменьшите значение подстановки столбца в соответствии с диапазоном ссылок. = ВПР (A8; a2: "5; ложь") является допустимым диапазоном ссылок, как если бы был = ВПР (A8, a2: Д5, 4, ложь).

Пример функции ИНДЕКС с неправильной ссылкой на строку или столбец

В этом примере формула =ИНДЕКС(B2:E5;5;5) возвращает ошибку #ССЫЛКА!, так как диапазон в ней содержит 4 строки и 4 столбца, а запрашивается значение ячейки в пятой строке и пятом столбце.

Пример формулы ИНДЕКС с недопустимой ссылкой на диапазон.  Формула имеет вид =ИНДЕКС(B2:E5;5;5), но диапазон содержит всего 4 строки и 4 столбца.

Решение

Настройте ссылки на строки или столбцы так, чтобы они находящегося в диапазоне подстановки ИНДЕКСов. = Индекс (B2: ячейка, 4, 4) возвращает допустимый результат.

Пример ссылки на закрытую книгу с использованием функции ДВССЫЛ

В следующем примере функция INDIRECT пытается сослаться на закрытую книгу, что приводит к ошибке #ССЫЛКА!.

Пример ошибки #ССЫЛКА! из-за использования функции ДВССЫЛ для ссылки на закрытую книгу.

Решение

Откройте книгу, на которую указывает ссылка. Эта же ошибка возникает, если вы указываете на закрытую книгу с динамическим массивом.

Проблемы OLE

Если вы использовали ссылку OLE и она возвращает ошибку #ССЫЛКА!, запустите программу, которая вызывает ссылку.

Примечание. OLE — это технология, которая используется для обмена информацией между приложениями.

Проблемы DDE

Если вы использовали раздел динамического обмена данными (DDE), возвращающий #REF! ошибка, сначала убедитесь, что вы ссылаетесь на правильную тему. Если вы по-прежнему получаете #REF! ошибка Проверьте Параметры центра управления безопасностью для внешнего содержимого, как описано в блоке блокирование или разблокирование внешнего содержимого документов Office.

Примечание. Динамический обмен данными (DDE)— это установленный протокол для обмена данными между программами Microsoft Windows.

Проблемы с макросами

Если макрос вводит в лист функцию, которая ссылается на ячейку над функцией, а ячейка, содержащая эту функцию, находится в строке 1, функция возвращает #REF! из-за отсутствия ячеек над строкой 1. Проверьте функцию, указывающую на то, что аргумент ссылается на недействительную ячейку или диапазон ячеек. Для этого может потребоваться изменение макроса в редакторе Visual Basic (VBE), чтобы учесть эту ситуацию.

Дополнительные сведения

Вы всегда можете задать вопрос специалисту Excel Tech Community, попросить помощи в сообществе Answers community, а также предложить новую функцию или улучшение на веб-сайте Excel User Voice.

См. также

Общие сведения о формулах в Excel

Рекомендации, позволяющие избежать появления неработающих формул

Поиск ошибок в формулах

Функции Excel (по алфавиту)

Функции Excel (по категориям)

Совершенствование навыков работы с Office
Перейти к обучению
Первоочередный доступ к новым возможностям
Присоединиться к программе предварительной оценки Office

Были ли сведения полезными?

Спасибо за ваш отзыв!

Благодарим за отзыв! Возможно, будет полезно связать вас с одним из наших специалистов службы поддержки Office.

×