Перейти к основному контенту
Office

Исправление ошибки #ЗНАЧ! в функциях ИНДЕКС и ПОИСКПОЗ

Примечание: Мы стараемся как можно оперативнее обеспечивать вас актуальными справочными материалами на вашем языке. Эта страница переведена автоматически, поэтому ее текст может содержать неточности и грамматические ошибки. Для нас важно, чтобы эта статья была вам полезна. Просим вас уделить пару секунд и сообщить, помогла ли она вам, с помощью кнопок внизу страницы. Для удобства также приводим ссылку на оригинал (на английском языке).

В этой статье описываются распространенные ситуации, в которых может возникнуть ошибка #ЗНАЧ! при использовании функций ИНДЕКС и ПОИСКПОЗ вместе в формуле. Одной из наиболее распространенных причин использования функций ИНДЕКС и ПОИСКПОЗ в сочетании друг с другом является необходимость найти значение в случае, когда функция ВПР неприменима, например, если длина искомого значения превышает 255 символов.

Проблема: формула не была введена как массив

Если вы используете ИНДЕКС как формулу массива вместе с функцией ПОИСКПОЗ для извлечения значения, вам необходимо преобразовать формулу в формулу массива. В противном случае возникнет ошибка #ЗНАЧ!.

РешенияСочетание функций ИНДЕКС и ПОИСКПОЗ следует использовать как формулу массива, то есть нужно нажать клавиши CTRL+SHIFT+ВВОД. При этом формула будет автоматически заключена в фигурные скобки {}. Если вы попытаетесь ввести их вручную, Excel отобразит формулу как текст.

Если при использовании функций ИНДЕКС и ПОИСКПОЗ длина искомого значения превышает 255 символов, его необходимо вводить как формулу массива.  В ячейке F3 содержится формула =ИНДЕКС(B2:B4;ПОИСКПОЗ(ИСТИНА;A2:A4=F2;0);0), которая вводится путем нажатия клавиш CTRL+SHIFT+ВВОД

Примечание: Если у вас установлена текущая версия Office 365, вы можете просто ввести формулу в выходную ячейку, а затем нажать клавишу Ввод , чтобы подтвердить формулу как формулу динамического массива. В противном случае необходимо ввести формулу в качестве устаревшей формулы массива, сначала выбрав выходную ячейку, введя формулу в выходную ячейку, а затем нажав клавиши CTRL + SHIFT + ВВОД , чтобы подтвердить его. Excel автоматически вставляет фигурные скобки в начале и конце формулы. Дополнительные сведения о формулах массива см. в статье Использование формул массива: рекомендации и примеры.

Дополнительные сведения

Вы всегда можете задать вопрос специалисту Excel Tech Community, попросить помощи в сообществе Answers community, а также предложить новую функцию или улучшение на веб-сайте Excel User Voice.

См. также

Функция индекс

Функция ПОИСКПОЗ

Поиск значений с помощью функций ВПР, индекс и Match

Общие сведения о формулах в Excel

Как избежать неработающих формул

Обнаружение ошибок в формулах

Все функции Excel (по алфавиту)

Все функции Excel (по категориям)

Совершенствование навыков работы с Office
Перейти к обучению
Первоочередный доступ к новым возможностям
Присоединиться к программе предварительной оценки Office

Были ли сведения полезными?

Спасибо за ваш отзыв!

Благодарим за отзыв! Возможно, будет полезно связать вас с одним из наших специалистов службы поддержки Office.

×