Исправление ошибки #ЗНАЧ! в функции СЦЕПИТЬ

Примечание: Мы стараемся как можно оперативнее обеспечивать вас актуальными справочными материалами на вашем языке. Эта страница переведена автоматически, поэтому ее текст может содержать неточности и грамматические ошибки. Для нас важно, чтобы эта статья была вам полезна. Просим вас уделить пару секунд и сообщить, помогла ли она вам, с помощью кнопок внизу страницы. Для удобства также приводим ссылку на оригинал (на английском языке).

Важно: В Excel 2016, Excel Mobile и Excel Online функция СЦЕПИТЬ заменена функцией СЦЕП. Функция СЦЕПИТЬ пока еще доступна для обратной совместимости, однако рекомендуем использовать вместо нее функцию СЦЕП, так как ее возможности шире.

Одной из наиболее распространенных ситуаций возникновения ошибки #ЗНАЧ! при использовании функции СЦЕПИТЬ является попытка сформировать строку, которая включает в себя ссылку на ячейку с ошибкой, например #ЗНАЧ!.

В приведенном ниже примере мы хотим сцепить ячейки D2, E2 и F2, но в ячейке E2 имеется ошибка #ЗНАЧ!.

Ошибка #ЗНАЧ! в функции СЦЕПИТЬ

Ошибка в E2 приводит к тому, что функция выводит #VALUE! ошибку. Чтобы приложение работало успешно, необходимо заменить ошибку значением, отличным от ошибки. Вы можете создать формулу, которая проверяет наличие ошибки в ссылке на ячейку и, если она есть, отобразить текстовую строку, в которой отображается 0 вместо ошибки (или можно заменить собственный текст на 0, но вам потребуется заключить текст в кавычки — "ваш текст").

Следующая формула будет работать правильно:

=ЕСЛИ(ЕОШИБКА(E2);СЦЕПИТЬ(D2;" ";0;" ";F2))

Использование функций ЕСЛИ и ЕОШИБКА для сцепления строк в качестве обходного пути при возникновении ошибки #ЗНАЧ!

Как это работает? Функция если использует функцию ЕСЛИОШИБКА, чтобы определить, возникает ли ошибка в E2, и, если есть, функция СЦЕПИТЬ объединяет значения из D2, E2 и F2 (функция заменяет ошибку на 0) и отображает полученную текстовую строку. Обратите внимание, что для разделения значений в формуле используются пробелы ("").

Исправление ошибки #VALUE! в функции СЦЕПИТЬ в Excel 2003 и более ранних версиях

Если вы получаете #VALUE! Ошибка в Office Excel 2003 или более ранних версиях, необходимо снять флажок "вычисление формулы перехода (ТФЕ)" в Excel. Выполните действия, описанные в #VALUE! ошибка при объединении ячеек для устранения проблемы.

У вас есть вопрос об определенной функции?

Задать вопрос на форуме сообщества, посвященном Excel

Помогите нам улучшить Excel

У вас есть предложения по улучшению следующей версии Excel? Если да, ознакомьтесь с темами на портале пользовательских предложений для Excel.

См. также

Исправление ошибки #ЗНАЧ!

Функция СЦЕПИТЬ

Функция СЦЕП

Общие сведения о формулах в Excel

Рекомендации, позволяющие избежать появления неработающих формул

Поиск ошибок в формулах

Все функции Excel (по алфавиту)

Функции Excel (по категориям)

Совершенствование навыков работы с Office
Перейти к обучению
Первоочередный доступ к новым возможностям
Присоединиться к программе предварительной оценки Office

Были ли сведения полезными?

Спасибо за ваш отзыв!

Благодарим за отзыв! Возможно, будет полезно связать вас с одним из наших специалистов службы поддержки Office.

×