Исправление ошибки #ЗНАЧ! в функции СРЗНАЧ или СУММ

Примечание: Мы стараемся как можно оперативнее обеспечивать вас актуальными справочными материалами на вашем языке. Эта страница переведена автоматически, поэтому ее текст может содержать неточности и грамматические ошибки. Для нас важно, чтобы эта статья была вам полезна. Просим вас уделить пару секунд и сообщить, помогла ли она вам, с помощью кнопок внизу страницы. Для удобства также приводим ссылку на оригинал (на английском языке).

Если функция СРЗНАЧ или СУММ ссылается на ячейки, содержащие ошибки #ЗНАЧ!, формула также вызовет ошибку #ЗНАЧ!.

Ошибка #ЗНАЧ! в функции СРЗНАЧ

Чтобы не учитывать ошибки, мы создадим формулу, пропускающую ошибочные значения в диапазоне и рассчитывающую среднее для остальных значений.

Чтобы решить эту проблему, мы используем функцию СРЗНАЧ в сочетании с функциями ЕСЛИ и ЕОШИБКА для определения наличия ошибок в указанном диапазоне. В данном конкретном случае требуется формула массива:

=СРЗНАЧ(ЕСЛИ(ЕОШИБКА(B2:D2);"";B2:D2))

Примечание: Это формула массива, которую необходимо ввести с помощью клавиш CTRL + SHIFT + ВВОД. Excel автоматически заключает формулу в фигурные скобки {}. Если попытаться ввести их самостоятельно, Excel будет отображать формулу в виде текста.

Функция массива в СРЗНАЧ для исправления ошибки #ЗНАЧ!

Примечание: Приведенная выше формула будет работать не только в случае ошибок #ЗНАЧ!, но и в случае ошибок #Н/Д, #ПУСТО!, #ДЕЛ/0! и других.

Таким же образом можно использовать функцию СУММ:

=СУММ(ЕСЛИ(ЕОШИБКА(B2:D2);"";B2:D2))

У вас есть вопрос об определенной функции?

Задать вопрос на форуме сообщества, посвященном Excel

Помогите нам улучшить Excel

У вас есть предложения по улучшению следующей версии Excel? Если да, ознакомьтесь с темами на портале пользовательских предложений для Excel.

См. также

Исправление ошибки #ЗНАЧ!

Функция СРЗНАЧ

Функция СУММ

Общие сведения о формулах в Excel

Рекомендации, позволяющие избежать появления неработающих формул

Поиск ошибок в формулах

Все функции Excel (по алфавиту)

Функции Excel (по категориям)

Совершенствование навыков работы с Office
Перейти к обучению
Первоочередный доступ к новым возможностям
Присоединиться к программе предварительной оценки Office

Были ли сведения полезными?

Спасибо за ваш отзыв!

Благодарим за отзыв! Возможно, будет полезно связать вас с одним из наших специалистов службы поддержки Office.

×