Перейти к основному контенту
Office
Использование Excel 2013 для создания отчета Project Online

Использование Excel 2013 для создания отчета Project Online

Microsoft Excel 2013 позволяет подключаться к данным Project Online и на их основе создавать отчеты. После того как отчеты будут сохранены в библиотеке в Project Online, их можно просмотреть в окне браузера с помощью Excel в Интернете.

Важно: Перед выполнением действий, описанных в этой статье, важно сначала предоставить доступ к отчетам в Project Online . Это одноразовый этап настройки, который позволит вашим отчетам правильно обновляться в Excel в Интернете.

В этой статье описано, как с помощью Excel 2013 подключиться к данным Project Online и отобразить список проектов в отчете сводной таблицы. С помощью Excel 2013 и подключения OData к данным Project Online можно решать гораздо более сложные задачи, но начать лучше с простого примера.

В данной статье описаны указанные ниже этапы.

Этап 1. Создание подключения к данным Project Online в Excel 2013

Первым делом нужно создать в Excel 2013 подключение, указывающее на данные Project Online.

Ниже описано, как создать подключение.

  1. В Excel 2013 выберите пункты Файл > Создать > Пустая книга.

  2. На вкладке Данные в группе Получение внешних данных выберите Из других источников > Из веб-канала данных OData.

  3. В разделе 1. Расположение веб-канала данныхв поле Ссылка или файл введите адрес веб-сайта (URL-адрес) своего экземпляра Project Web App и добавьте после него /_api/ProjectData/.

    Например, если ваше приложение Project Web App расположено по адресу https://contoso.sharepoint.com/sites/pwa, введите https://contoso.sharepoint.com/sites/pwa/_api/ProjectData/ в поле Ссылка или файл.

  4. Выполните вход с учетными данными Microsoft Office 365.

  5. В диалоговом окне Мастер подключения к данным установите флажок рядом с надписью Проекты и нажмите кнопку Далее.

  6. На этапе Сохраните файл подключения данных и завершите работу нажмите кнопку Готово.

  7. В диалоговом окне Импорт данных выберите пункт Отчет сводной таблицы и нажмите кнопку ОК.

Вот и все. Теперь вы подключены к данным Project Online.

Этап 2. Выбор данных, включаемых в отчет

Следующий этап — это выбрать части данных проектов , которые нужно включить в отчет, а затем разработать сам отчет. В этом очень простом примере мы выберем две точки данных: имена проектов и имена ответственных за них.

Чтобы создать простой отчет сводной таблицы, выполните указанные ниже действия.

  1. На панели Поля сводной таблицы в правой части окна Excel 2013 установите флажки Имя проекта и Ответственный за проект.

  2. Настройте отчет сводной таблицы с помощью параметров на вкладках Анализ и Конструктор в разделе Работа со сводными таблицами ленты.

Этап 3. Сохранение отчета в Project Online

После построения отчета необходимо сохранить его в Project Online, чтобы его можно было легко открыть позже с помощью Excel в Интернете.

Чтобы сохранить отчет сводной таблицы в Project Online, выполните указанные ниже действия.

  1. В Excel 2013 откройте вкладку Файл.

  2. Нажмите кнопку Сохранить как, выберите пункт SharePoint и нажмите кнопку Обзор.

  3. В верхней части экрана в строке, где указано текущее расположение, щелкните URL-адрес правой кнопкой мыши и выберите пункт Изменить адрес.

  4. Введите URL-адрес сайта Project Web App в поле расположения и нажмите клавишу ВВОД.

    Например, введите https://contoso.sharepoint.com/sites/pwa и нажмите клавишу ВВОД.

  5. Дважды щелкните библиотеку Отчеты PWA.

  6. Дважды щелкните папку Английский (США).

  7. Введите имя нового отчета в поле Имя файла и нажмите кнопку Сохранить.

После сохранения отчета в библиотеке "Отчеты PWA" Project Online закройте его в Excel 2013. Теперь можно перейти к отчету в веб-браузере и открыть его в Project Online.

Этап 4. Открытие отчета в Project Online

После сохранения отчета в Project Online можно перейти в библиотеку отчетов PWA и открыть отчет с помощью Excel в Интернете. Так можно просмотреть отчет с последними данными проекта на любом устройстве с доступом к Project Online.

Чтобы открыть отчет в Excel в Интернете, выполните указанные ниже действия.

  1. В Project Web App нажмите кнопку Отчеты на панели быстрого запуска.

  2. Выберите пункт Английский (США).

  3. Щелкните имя отчета, чтобы открыть его в Excel в Интернете.

Примечание:  Эта страница переведена автоматически, поэтому ее текст может содержать неточности и грамматические ошибки. Для нас важно, чтобы эта статья была вам полезна. Была ли информация полезной? Для удобства также приводим ссылку на оригинал (на английском языке).

Совершенствование навыков работы с Office
Перейти к обучению
Первоочередный доступ к новым возможностям
Присоединиться к программе предварительной оценки Office

Были ли сведения полезными?

Спасибо за ваш отзыв!

Благодарим за отзыв! Возможно, будет полезно связать вас с одним из наших специалистов службы поддержки Office.

×