Использование функции ЕСЛИ для проверки ячейки на наличие символов

Примечание: Мы стараемся как можно оперативнее обеспечивать вас актуальными справочными материалами на вашем языке. Эта страница переведена автоматически, поэтому ее текст может содержать неточности и грамматические ошибки. Для нас важно, чтобы эта статья была вам полезна. Просим вас уделить пару секунд и сообщить, помогла ли она вам, с помощью кнопок внизу страницы. Для удобства также приводим ссылку на оригинал (на английском языке).

Иногда требуется проверить, пуста ли ячейка. Обычно это делается, чтобы формула не выводила результат при отсутствии входного значения.

Ячейка E2 содержит формулу =ЕСЛИ(D2=1;"Да";ЕСЛИ(D2=2;"Нет";"Возможно"))

В данном случае мы используем ЕСЛИ вместе с функцией ЕПУСТО:

  • =ЕСЛИ(ЕПУСТО(D2);"Пустая";"Не пустая")

Эта формула означает: ЕСЛИ(ячейка D2 пуста, вернуть текст "Пустая", в противном случае вернуть текст "Не пустая"). Вы также можете легко использовать собственную формулу для состояния "Не пустая". В следующем примере вместо функции ЕПУСТО используются знаки "". "" — фактически означает "ничего".

Проверка пустоты ячейки — ячейка E2 содержит формулу =ЕСЛИ(ЕПУСТО(D2);"Пустая";"Не пустая")

=ЕСЛИ(D3="";"Пустая";"Не пустая")

Эта формула означает: ЕСЛИ(в ячейке D3 ничего нет, вернуть текст "Пустая", в противном случае вернуть текст "Не пустая"). Вот пример распространенного способа использования знаков "", при котором формула не вычисляется, если зависимая ячейка пуста:

  • =ЕСЛИ(D3="";"";ВашаФормула())

    Если (D3 — Nothing, возвращается Nothing, в противном случае вычисляется формула).

Совершенствование навыков работы с Office
Перейти к обучению
Первоочередный доступ к новым возможностям
Присоединиться к программе предварительной оценки Office

Были ли сведения полезными?

Спасибо за ваш отзыв!

Благодарим за отзыв! Возможно, будет полезно связать вас с одним из наших специалистов службы поддержки Office.

×