Изменение соединительных линий, стрелок и точек

Изменение соединительных линий, стрелок и точек

У вас есть различные возможности редактирования соединительных линий и работы с ними. Вы можете изменять толщину, стиль и кривизну линии, управлять внешним видом конечных точек и стрелок, придавать соединительной линии изогнутую, ломанную или прямую форму и управлять точками соединения различными способами.

Совет   . Команды в группе Инструменты на вкладке Главная позволяют переводить Visio в различные состояния и режимы, что иногда вызывает сложности. Используйте клавиатуру для переключения между инструментами Указатель Выделение объектов (нажмите клавиши CTRL+1) и Соединительная линия Изображение кнопки (нажмите клавиши CTRL+3). Независимо от того, какой инструмент вы используете, например Блок текста или Точка соединения, несколько раз нажмите клавишу ESC, чтобы вернуться к инструменту Указатель (кроме Visio 2010).

Эта статья в основном относится к стандартной фигуре Динамическая соединительная линия, которая может автоматически изменять направление для огибания других фигур. Существует несколько типов соединительных линий, например, большинство из набора элементов Дополнительные фигуры \ Дополнительные решения Visio \ Соединительные линии, которые не изменяют направление автоматически.

Что необходимо сделать   

Придание соединительной линии изогнутой, ломаной или прямой формы

Добавление стрелок или других наконечников к соединительной линии

Изменение толщины, стиля или кривизны соединительной линии

Изменение направления соединительной линии на противоположное

Изменение направления или пересечение соединительных линий

Другие способы работы с точками соединения

См. также

Придание соединительной линии изогнутой, ломаной или прямой формы

Вы можете изменить отдельную соединительную линию или изменить форму по умолчанию для всех новых соединительных линий.

Изменение соединительной линии

  1. Выделите соединительную линию.

  2. На вкладке Конструктор в группе Макет выберите Соединительные линии, затем выберите прямоугольную соединительную линию, прямую соединительную линию или кривую соединительную линию в зависимости от нужного стиля.

  3. Кроме того, можно изменить стиль соединительной линии в меню действий для фигуры "Соединительная линия", вызываемом щелчком правой кнопки мыши.

Изменение формы по умолчанию для новых соединительных линий

  • Установка прямоугольной, прямой или изогнутой формы в качестве формы по умолчанию:

    • Visio Online (план 2), 2016, 2013   . Отменить выделение всех фигур с помощью выбора страницы. Откройте вкладку Конструктор , затем перейдите в раскрывающееся меню Соединительные линии в группе Макет. Выберите Прямой угол, Прямые линии или Кривые линии.

    • Или выберите вкладку Файл, выберите пункт Печать, затем Параметры страницы, перейдите на вкладку Макеты и маршруты, затем в списке Вид выберите Прямая или Кривая.

    • 2010    Выберите вкладку Файл > Печать > Предварительный просмотр > Параметры страницы, выберите вкладку Макеты и маршруты, затем в списке Вид выберите Прямая или Кривая.

К началу страницы

Добавление стрелок или других наконечников к соединительной линии

Вы можете добавлять к соединительной линии стрелки, точки или другие наконечники.

  1. Выделите соединительную линию.

  2. Выполните одно из следующих действий:

    • Visio Online (план 2), 2016, 2013   . Выберите вариант Формат фигуры в меню действий, вызываемом правой кнопкой мыши. Или на вкладке Главная в группе Стили фигур выберите Линия, затем выберите Параметры линии.

    • 2010   На вкладке Главная в группе Фигура выберите Линия, затем выберите Стрелки.

  3. Выполните одно из следующих действий:

    • Visio Online (план 2), 2016, 2013   . В области Формат фигуры в разделе Линия выберите параметр Сплошная линия, затем выберите тип, размер и тип завершения.

      Параметры конечных точек соединительных линий
    • 2010    Выберите Другие стрелки, в окне Линия выберите тип, размер и тип завершения, затем нажмите кнопку ОК.

      Концы стрелок

К началу страницы

Изменение толщины, стиля или кривизны соединительной линии

  1. Выделите соединительную линию.

  2. Выполните одно из следующих действий:

    • Visio Online (план 2), 2016, 2013   . Выберите вариант Формат фигуры в меню действий, вызываемом правой кнопкой мыши. Или на вкладке Главная в группе Стили фигур выберите Линия, затем выберите Параметры линии.

    • 2010   На вкладке Главная в группе Фигура выберите Линия, затем выберите Параметры линии.

  3. Выполните одно из следующих действий:

    • Visio Online (план 2), 2016, 2013   . В области Формат фигуры в разделе Линия выберите толщину, стиль и кривизну линии.

      Параметры стиля соединительных линий
    • 2010    В окне Линия выберите толщину, стиль и кривизну линии, затем нажмите кнопку ОК.

      Толщина линии и другие параметры

К началу страницы

Изменение направления соединительной линии на противоположное

Примечание. Для некоторых типов схем, например, для различных технологических схем, важным является направление соединения. Поэтому для таких соединительных линий должна использоваться команда Обратить концы вместо изменения формата концов. Кнопку команды Обратить концы можно легко добавить на ленту с помощью функции Файл \ Параметры \ Настройка ленты . Эта команда дает возможность изменить направление всех выбранных соединительных линий на противоположное.

Или, чтобы изменить направление соединительной линии без использования команды Обратить концы, добавьте новую стрелку на том конце линии, где ее нет, и удалите стрелку на другом конце.

  1. Выделите соединительную линию.

  2. Выполните одно из следующих действий:

    • Visio Online (план 2), 2016, 2013   . На вкладке Главная в группе Стили фигурвыберите Линия, затем выберите Параметры линии.

    • 2010   На вкладке Главная в группе Фигура выберите Линия, затем выберите Параметры линии.

  3. Выполните одно из следующих действий:

    • Visio Online (план 2), 2016, 2013   . В области Формат фигуры в разделе Линия выберите:

      • Тип начальной стрелки и выполните действие 4.

      • Тип конечной стрелки и выполните действие 4.

      Параметры для изменения направления стрелок на противоположное
    • 2010    В окне Линия выберите:

      • Тип начальной стрелки и выполните действие 4.

      • Тип конечной стрелки и выполните действие 4.

      Начальная и конечная стрелки
  4. Чтобы добавить, изменить или удалить стрелку в начале и конце выделенной соединительной линии, выберите стрелку или вариант Нет в меню стрелок.

    В меню выберите стиль стрелки или значение "Нет".

К началу страницы

Изменение направления или пересечение соединительных линий

В большинстве случаев вы можете использовать поведение соединительной линии по умолчанию. Но бывают случаи, когда вам нужно самостоятельно задать направление и пересечение соединительных линий на своей схеме.

Совет    Используйте функцию Масштаб, чтобы лучше разглядеть мелкие детали и более точно управлять точками: Увеличить (нажмите клавиши ALT+F6), Уменьшить (нажмите клавиши ALT+SHIFT+F6) и Вписать в окно (нажмите клавиши CTRL+SHIFT+W).

  • Выполните одно или несколько из указанных ниже действий:

    • Чтобы соединить соединительную линию с другой соединительной линией, сначала добавьте ее к фигуре, а затем перетащите к нужной соединительной линии.

      Соединение с соединительной линией
    • Чтобы изменить направление соединительной линии, выделите ее, а затем перетащите среднюю точку в новое положение.

      Изменение направления соединительной линии
    • Чтобы изменить положение соединительной линии с шагом в один пиксель, выделите соединительную линию, затем нажмите SHIFT+КЛАВИШИ СО СТРЕЛКАМИ в необходимом направлении.

      Перемещение соединительной линии с шагом в пиксель

Примечание    Сведения о создании дерева см. в статье Создание дерева.

К началу страницы

Другие способы работы с точками соединения

В следующих разделах мы рассмотрим несколько способов управления точками соединения.

Совет    Используйте функцию Масштаб, чтобы лучше разглядеть мелкие детали и более точно управлять точками: Увеличить (нажмите клавиши ALT+F6), Уменьшить (нажмите клавиши ALT+SHIFT+F6) и Вписать в окно (нажмите клавиши CTRL+SHIFT+W).

Обзор точек соединения

Точка соединения — это специальная точка на фигуре, к которой "приклеиваются" соединительные линии и другие фигуры. После приклеивания соединительной линии или фигуры к точке соединения они остаются соединенными даже при перемещении одной из фигур.

Точки соединения становятся видимыми при попытке соединить две фигуры. Вы видите эти точки при наведении на фигуру инструмента Соединительная линия, а также при подведении соединительной линии к фигуре, у которой имеется хотя бы одна точка соединения.

Соединительная линия рядом с кругом, на котором обозначены точки соединения

Примечание.    Приклеивать соединительные линии можно не только к точкам соединения. Их, как и линии, можно также приклеивать к маркерам, вершинам и контурам фигур. Дополнительные сведения см. в статье Диалоговое окно "Привязать и приклеить".

Использование соединений точка-точка или динамических соединений

В Visio для фигур доступны два вида соединений: точка-точка (иногда называемое статическим соединением) и динамическое. Для разных концов соединительной линии можно использовать разные типы соединения. Если вы используете Автосоединение или команду Соединить фигуры для обоих концов соединителя применяется динамическое соединение. При выборе точки соединения соединительной линии с фигурой вручную вы можете задать тип соединения.

На схеме, показанной ниже, между фигурами A и C используется соединение точка-точка, и при перемещении фигуры C соединитель, выходящий из фигуры A, остается приклеенным к одной и той же точке. Фигура B, в свою очередь, соединена с фигурой C с помощью динамического соединения, поэтому при перемещении фигуры C соединитель прикрепляется к ближайшей точке соединения.

Фигура A соединяется с фигурой C по принципу "точка-точка", а фигура B — с помощью динамического соединения.

Создание соединения точка-точка   

В случае соединения точка-точка соединительная линия остается приклеенной к определенной точке фигуры даже при ее перемещении или вращении.

  1. Перетащите точку соединения на первой фигуре к точке соединения на второй фигуре.

  2. После соединения фигур конечные точки соединительной линии становятся зелеными.

Приклейте соединительную линию к определенной точке фигуры, чтобы зафиксировать ее.

Создание динамического соединения   

В случае динамического соединения при перемещении или вращении фигуры соединительная линия будет прикрепляться к точке соединения, ближайшей к ее началу.

  1. Расположите соединительную линию в центре первой фигуры и дождитесь появления зеленой рамки вокруг фигуры.

  2. Удерживайте нажатой кнопку мыши и перетащите указатель в центр второй фигуры.

  3. Когда вокруг второй фигуры появится зеленая рамка, отпустите кнопку мыши.

Приклейте соединительную линию к фигуре, и она будет динамически перемещаться между ее точками.

Добавление точки соединения на фигуру

Если фигура, к которой требуется приклеить соединительную линию, не имеет в нужном месте точки соединения, вы можете легко ее создать.

  1. Выделите фигуру.

  2. На вкладке Главная в группе Инструменты выберите инструмент Точка соединения Изображение кнопки .

  3. Если точки соединения не видны, на вкладке Вид в группе Визуальные подсказки установите флажок Точки соединения.

  4. Нажав клавишу CTRL, щелкните место, в которое нужно добавить точку соединения. Новая точка соединения автоматически выделяется после добавления.

  5. Для возврата к обычному редактированию на вкладке Главная в группе Инструменты выберите инструмент Указатель  Выделение объектов .

Добавление точки соединения на фигуру

Перемещение точки соединения на фигуре

Если точка соединения расположена неудобно, ее можно переместить.

  1. Выделите фигуру.

  2. На вкладке Главная в группе Инструменты выберите инструмент Точка соединения Изображение кнопки .

  3. Если точки соединения не видны, на вкладке Вид в группе Визуальные подсказки установите флажок Точки соединения.

  4. Нажмите клавишу CTRL и перетащите точку соединения, которую вы хотите переместить.

  5. Для возврата к обычному редактированию на вкладке Главная в группе Инструменты выберите инструмент Указатель  Выделение объектов .

Если не удается переместить точки соединения именно туда, куда требуется, попробуйте изменить параметры привязки. Дополнительные сведения см. в статье Регулирование силы привязки и ее отключение.

Удаление точки соединения

Иногда точка соединения мешает. В этом случае вы можете ее удалить.

  1. Выделите фигуру с точкой соединения, которую хотите удалить.

  2. На вкладке Главная в группе Инструменты выберите инструмент Точка соединения.

  3. Если вы не видите точки соединения, на вкладке Вид в группе Визуальные подсказки установите флажок Точки соединения.

  4. Щелкните точку соединения, которую вы хотите удалить. Она станет пурпурной.

  5. Нажмите клавишу DELETE.

  6. Для перехода к обычному редактированию на вкладке Главная в группе Инструменты щелкните инструмент Указатель Выделение объектов .

Удаление точки соединения

Скрытие точек соединения

Иногда, чтобы лучше разглядеть схему, вам нужно скрыть точки соединения.

  • На вкладке Вид в группе Визуальные подсказки снимите флажок Точки соединения.

Добавление текста рядом с точкой соединения

Добавить текст непосредственно к точке соединения невозможно. Однако можно добавить текст к фигуре, а затем поместить его рядом с точкой соединения.

  1. Выделите фигуру, на которую хотите добавить текст, и начинайте ввод текста. Вводимый текст появляется на фигуре.

  2. Выберите инструмент Главная \ Инструменты \ Блок текста Значок ''Блок текста'' (CTRL+SHIFT+4)

  3. Будет выбран блок текста

    Выбранный блок текста
  4. Перетащите блок текста, чтобы переместить его и измените его размер, при необходимости

    Перемещение и изменение размера блока текста

Выберите инструмент Указатель Выделение объектов (CTRL+1), если вы хотите выйти из инструмента Блок текста

Другой способ – создание нескольких фигур с уникальными названиями, каждая с одной соединительной точкой, с их последующей группировкой для создания большей фигуры. Точки соединения по-прежнему будут использоваться.

Создание нескольких именованных точек соединения

Точка соединения типа "внутрь", "наружу" или "внутрь и наружу"

Используйте точки соединения "внутрь" и "наружу", чтобы управлять "притягиванием" конечных точек соединительных линий к фигурам.

  1. Выделите фигуру.

  2. На вкладке Главная в группе Инструменты выберите инструмент Точка соединения Изображение кнопки .

  3. Если точки соединения не видны, на вкладке Вид в группе Визуальные подсказки установите флажок Точки соединения.

  4. Если требуется точка соединения типа "внутрь", "наружу" или "внутрь и наружу", щелкните правой кнопкой мыши точку соединения и выберите пункт:

    • Внутрь     Чаще всего используется точка соединения типа внутрь. Она "притягивает" к себе конечные точки соединительных линий, а также точки соединения типов наружу и внутрь и наружу на двумерных фигурах.

    • Наружу     Чтобы приклеить двумерную фигуру к другой фигуре, используйте точку соединения типа наружу. Точка соединения типа "наружу" "притягивается" к точкам соединения типа "внутрь".

    • Внутрь и наружу     Если какую-либо фигуру необходимо приклеить к другим фигурам, но пока еще неизвестно, как именно, используйте точку соединения внутрь и наружу.

К началу страницы

Работа с точками соединения

В следующих разделах мы рассмотрим несколько способов управления точками соединения.

Обзор точек соединения

Фигура с четырьмя точками соединения

Фигура с четырьмя точками соединения

Добавление точек соединения

Если фигура, к которой требуется приклеить соединительную линию или другую фигуру, не имеет в нужном месте точки соединения, ее можно легко создать.

  1. Если точки соединения не отображаются, на вкладке Вид щелкните Точки соединения.

  2. Выделите фигуру.

    Примечание: Пока фигура не выделена, добавить к ней точку соединения невозможно. Фигура выделена, если вокруг нее есть зеленая пунктирная граница.

  3. Щелкните инструмент Точка соединения Изображение кнопки .

    Если вы не видите инструмент Точка соединения, щелкните стрелку вниз рядом с инструментом Соединительная линия Изображение кнопки , затем щелкните инструмент Точка соединения  Изображение кнопки .

  4. Нажмите клавишу CTRL, а затем щелкните место, куда нужно добавить точку соединения.

  5. Если требуется точка соединения типа «внутрь», «наружу» или «внутрь и наружу», щелкните правой кнопкой мыши точку соединения и выберите пункт Внутрь, Наружу или Внутрь и наружу.

    • Как правило, бывает нужна точка соединения типа «внутрь». Она «притягивает» к себе конечные точки соединительных линий, а также соединительные точки типа «наружу» и «внутрь и наружу» двумерных фигур.

    • Чтобы приклеить двумерную фигуру к другой фигуре, используйте точку соединения типа наружу. Точка соединения типа «наружу» «притягивается» к точкам соединения типа «внутрь».

    • Если какую-либо фигуру необходимо приклеить к другим фигурам, но пока еще неизвестно, как именно, используйте точку соединения «внутрь и наружу».

  6. Чтобы вернуться в обычный режим правки, щелкните инструмент Указатель  Кнопка "Указатель" .

Добавление текста рядом с точкой соединения

К сожалению, добавить текст непосредственно к точке соединения невозможно. Однако можно добавить текст к фигуре, а затем поместить его рядом с точкой соединения.

  1. Выделите фигуру.

  2. Начните вводить текст. Вводимый текст появится на фигуре.

  3. Щелкните инструмент Блок текста Изображение кнопки .

    Если вы не видите инструмент Блок текста, щелкните стрелку вниз рядом с инструментом Текст  Кнопка "Текст" , затем щелкните инструмент Блок текста  Изображение кнопки .

  4. Перетащите текст.

Совет: Если на фигуре имеется управляющий маркер Управляющий маркер , текст фигуры можно переместить быстрее.

Перемещение точек соединения

Если точка соединения расположена неудобно, ее можно переместить.

  1. Выделите фигуру.

    Примечание: Пока фигура не выделена, переместить точку соединения невозможно. Фигура выделена, если вокруг нее есть зеленая пунктирная граница.

  2. Щелкните инструмент Точка соединения Изображение кнопки .

    Если вы не видите инструмент Точка соединения, щелкните стрелку вниз рядом с инструментом Соединительная линия Изображение кнопки , затем щелкните инструмент Точка соединения  Изображение кнопки .

  3. Перетащите точку соединения.

    Если вы не видите точки соединения, на вкладке Вид щелкните Точки соединения.

  4. Чтобы вернуться в обычный режим правки, щелкните инструмент Указатель  Кнопка "Указатель" .

Если не удается переместить точки соединения именно туда, куда требуется, попробуйте изменить параметры привязки:

  • В меню Сервис щелкните Привязать и приклеить, затем на вкладке Общие в разделе Привязка выберите необходимые параметры.

Удаление и скрытие точек соединения

Иногда точки соединения мешают работе. В этом случае их можно удалить или скрыть.

Удаление точки соединения на фигуре

  1. Выделите фигуру.

    Примечание: Пока фигура не выделена, удалить точку соединения невозможно. Фигура выделена, если вокруг нее есть зеленая пунктирная граница.

  2. Щелкните инструмент Точка соединения Изображение кнопки .

    Если вы не видите инструмент Точка соединения, щелкните стрелку вниз рядом с инструментом Соединительная линия Изображение кнопки , затем щелкните инструмент Точка соединения  Изображение кнопки .

  3. Щелкните точку соединения, которую вы хотите удалить. Она станет пурпурной.

    Если вы не видите точки соединения, на вкладке Вид щелкните Точки соединения.

  4. Нажмите клавишу DELETE.

  5. Чтобы вернуться в обычный режим правки, щелкните инструмент Указатель  Кнопка "Указатель" .

Скрытие точки соединения

  • В меню Вид щелкните Точки соединения.

К началу страницы

Добавление стрелок или других наконечников к соединительной линии

Вы можете добавлять к соединительной линии стрелки, точки или другие наконечники.

  1. Выделите соединительную линию.

  2. В меню Формат выберите пункт Линия.

  3. В разделе Концы линий выберите нужный тип и размер наконечника.

  4. Нажмите кнопку ОК.

Совет: Инструмент Концы линий также можно использовать на панели инструментов Форматирование.

Придание соединительной линии изогнутой, ломаной или прямой формы

Изменение соединительной линии на схеме

  1. Щелкните правой кнопкой мыши соединительную линию.

  2. Выберите пункт Кривая соединительная линия, Прямоугольная соединительная линия или Прямая соединительная линия.

Примечание.    Вы не можете добавить маркеры для прямых или ломанных соединительных линий, но можете сделать это для кривых соединительных линий с помощью инструмента Карандаш  Изображение кнопки .

Изменение формы по умолчанию для новых соединительных линий

  • Чтобы соединительная линия по умолчанию имела кривую или прямую форму, в меню Файл выберите пункт Параметры страницы, щелкните вкладку Макеты и маршруты и в списке Вид выберите Прямая или Кривая.

Изменение направления соединительной линии на противоположное

Если вам нужно изменить направление соединительной линии, добавьте новую стрелку на том конце линии, где ее нет, и удалите стрелку на другом конце.

  1. Выделите соединительную линию, которую нужно изменить.

  2. На вкладке Главная в группе Фигура выберите вариант Линия и наведите указатель на элемент Стрелки, чтобы открыть меню Стрелки.

    В группе "Стили фигур" в меню "Линия" выберите пункт "Стрелки".
  3. Внизу меню Стрелки выберите элемент Другие стрелки.

    В нижней части меню "Стрелки" выберите команду "Другие стрелки".

    В Visio отображается область задач Формат фигуры с развернутой группой Линия.

  4. Чтобы добавить, изменить или удалить стрелку в начале выделенной соединительной линии, выберите стрелку или вариант Нет в меню стрелок для типа начальной стрелки.

    Добавьте, измените или удалите стрелку для выбранной соединительной линии.

    В меню стрелок для выделенной соединительной линии отображается текущий стиль выделенной стрелки или вариант Нет.

    В меню выберите стиль стрелки или значение "Нет".
  5. Чтобы добавить, изменить или удалить стрелку в конце выделенной соединительной линии, выберите стрелку или вариант Нет в меню стрелок для типа конечной стрелки.

См. также

Добавление и изменение текста соединителя

Добавление соединительных линий между фигурами

Включение и выключение приклеивания

Создание пользовательской соединительной линии

Добавление и удаление значков пересечения соединительных линий

Обучение работе с Visio

Все, что нужно знать о соединителях в классической версии Visio (блог команды разработчиков Visio)

Совершенствование навыков работы с Office
Перейти к обучению
Первоочередный доступ к новым возможностям
Присоединиться к программе предварительной оценки Office

Были ли сведения полезными?

Спасибо за ваш отзыв!

Благодарим за отзыв! Возможно, будет полезно связать вас с одним из наших специалистов службы поддержки Office.

×