Запись макросов в Visio

Примечание:  Мы стараемся как можно оперативнее обеспечивать вас актуальными справочными материалами на вашем языке. Эта страница переведена автоматически, поэтому ее текст может содержать неточности и грамматические ошибки. Для нас важно, чтобы эта статья была вам полезна. Просим вас уделить пару секунд и сообщить, помогла ли она вам, с помощью кнопок внизу страницы. Для удобства также приводим ссылку на оригинал (на английском языке) .

Создайте макрос для автоматизации шагов или процессы, которые можно выполнить несколько раз. Команды для записи макросов, на вкладке "Разработчик".

Примечание: Макросы можно триггер предупреждений системы безопасности, так как создан и используется в вредоносных целях. Дополнительные сведения о рисках о макросах и что делать с появляется предупреждение системы безопасности: Включение и отключение макросов в файлах Office.

  1. На вкладке Разработчик щелкните Запись макроса. (Если вы не видите вкладки "Разработчик", см. раздел "Отображение вкладки «Разработчик»" ниже.)

    Команды макросов

  2. В поле Имя макроса введите имя макроса.

  3. В поле Сочетание клавиш укажите клавиши, которые можно использовать с клавишей CONTROL для запуска макроса.

  4. В поле Сохранить в щелкните документ, в котором вы хотите сохранить макрос.

  5. В поле Описание введите описание макроса.

  6. Нажмите ОК, чтобы начать запись макроса.

  7. Выполните действия, которые вы хотите включить в макрос. На вкладке Разработчик при необходимости нажмите кнопку Пауза.

    При записи макроса вы можете щелкать мышью команды и параметры, а также работать с формами и объектами в рисунках.

  8. Чтобы остановить запись макроса, щелкните Остановить запись на вкладке Разработчик.

Вы также можете приостановить или возобновить запись макроса при помощи панели инструментов Запись.

Чтобы просмотреть получившийся код, в меню Инструменты наведите указатель мыши на пункт Макросы, нажмите кнопку Макросы, затем имя макроса, после чего выберите команду Изменить.

Отображение вкладки "Разработчик"

  1. На вкладке Файл выберите раздел Параметры.

  2. Выберите пункт Настройка ленты.

  3. В разделе Настройка ленты в списке Основные вкладки установите флажок Разработчик.

    Вкладка Разработчик появится в конце ленты напротив вкладки Файл.

Совершенствование навыков работы с Office
Перейти к обучению
Первоочередный доступ к новым возможностям
Присоединиться к программе предварительной оценки Office

Были ли сведения полезными?

Спасибо за ваш отзыв!

Благодарим за отзыв! Возможно, будет полезно связать вас с одним из наших специалистов службы поддержки Office.

×