Дополнительные сведения о функции СУММ

Примечание: Мы стараемся как можно оперативнее обеспечивать вас актуальными справочными материалами на вашем языке. Эта страница переведена автоматически, поэтому ее текст может содержать неточности и грамматические ошибки. Для нас важно, чтобы эта статья была вам полезна. Просим вас уделить пару секунд и сообщить, помогла ли она вам, с помощью кнопок внизу страницы. Для удобства также приводим ссылку на оригинал (на английском языке).

Дополнительные сведения о функции СУММ

Если вам нужно быстро получить сумму диапазона ячеек, вам достаточно просто выделить диапазон и посмотреть на правый нижний угол окна Excel.

Снимок экрана: выделение диапазона ячеек и просмотр строки состояния


В строке состояния отображается информация о том, что вы выбрали, является ли она одной или несколькими ячейками. Если вы щелкнете правой кнопкой мыши строку состояния, появится всплывающее диалоговое окно со всеми доступными параметрами. Если выбрать какие-либо из них, в строке состояния появятся соответствующие значения для выбранного диапазона. 

Проще всего добавить формулу сумм на листе с помощью мастера автоСуммирования. Выделите пустую ячейку, расположенную над диапазоном, для которого вы хотите вычислить сумму, и на вкладках "Главная" или "Формула" на ленте нажмите кнопку " Автосумма _Гт_ Sum". Мастер автоСуммирования автоматически определит диапазон для суммирования и создаст формулу. Оно также может работать по горизонтали, если выделить ячейку слева или справа от диапазона, который требуется суммировать. Обратите внимание, что он не будет работать на несмежных диапазонах, но мы перейдем к следующему разделу.

Используйте мастер автосуммирования для автоматического создания формулы СУММ.  Выделите диапазон сверху/снизу или справа/слева от суммируемого диапазона, затем на ленте откройте вкладку "Формула" и выберите "Автосумма" > "Сумма".


В диалоговом окне "автоСумма" можно также выбрать другие стандартные функции, такие как:

Автосуммирование по вертикали

В ячейке B6 показана формула автосуммирования =СУММ(B2:B5)

Мастер автосуммирования автоматически определяет ячейки B2:B5 в качестве диапазона для суммирования. Вам нужно только нажать клавишу ВВОД для подтверждения. Если вам нужно добавить или исключить несколько ячеек, удерживайте нажатой клавишу SHIFT и нажимайте соответствующую клавишу со стрелкой, пока не выделите нужный диапазон, а затем нажмите клавишу ВВОД.

Руководство по функциям IntelliSense: сумм (число1; [число2];...) перемещаемый тег под функцией — это руководство по IntelliSense. Если щелкнуть сумму или имя функции, будет переводится на синяя гиперссылка, и откроется раздел справки для этой функции. Если щелкнуть отдельные элементы функций, будет выделена соответствующая ей репрезентативная единица в формуле. В этом случае выделено только значение B2: B5, так как в этой формуле есть только одна ссылка на номер. Для любой функции будет отображаться тег IntelliSense.

Автосуммирование по горизонтали

В ячейке D2 показана формула автосуммирования =СУММ(B2:C2)

Использовании функции СУММ с несмежными диапазонами.  Ячейка C8 содержит формулу =СУММ(C2:C3;C5:C6). При использовании именованных диапазонов формула примет вид =СУММ(Неделя1;Неделя2).

Мастер автосуммирования обычно работает только со смежными диапазонами, так что если ваш диапазон для суммирования содержит пустые строки или столбцы, Excel остановится на первом пропуске. В этом случае вам нужно использовать функцию СУММ по выделению, в которое вы последовательно добавляете отдельные диапазоны. В данном примере, если у вас есть данные в ячейке B4, Excel создаст формулу =СУММ(C2:C6), поскольку распознает смежный диапазон.

Чтобы быстро выделить несколько несмежных диапазонов, нажмите CTRL + щелчок левой кнопкой мыши. Сначала введите "=СУММ(", затем выбирайте разные диапазоны, а Excel будет автоматически добавлять между ними точку запятой в качестве разделителя. По завершении нажмите клавишу ВВОД.

Совет. чтобы быстро добавить функцию сумм в ячейку, можно использовать сочетание клавиш ALT + = . Все, что вам нужно, — это выбрать диапазон (-ы).

Примечание. в приложении Excel выделены различные диапазоны функций по цвету и они совпадают в самой формуле, поэтому C2: C3 — один цвет, а C5 — C6. Excel выполнит эти действия для всех функций, если указанный диапазон не находится на другом листе или в другой книге. Для расширенной доступности специальных возможностей можно использовать именованНые диапазоны, например "Неделя1", "Week2" и т. д., а затем ссылаться на них в формуле:

=СУММ(Неделя1;Неделя2)

  1. Функцию СУММ можно использовать вместе с другими функциями. Ниже приведен пример, в котором вычисляется среднее значение суммы за все указанные месяцы.

    Использование СУММ с другими функциями.  Ячейка M2 содержит формулу =СУММ(A2:L2)/СЧЁТЗ(A2:L2).  Примечание: для простоты столбцы с мая по ноябрь скрыты.
    • =СУММ(A2:L2)/СЧЁТЗ(A2:L2)

  2. Эта формула получает сумму ячеек A2:L2 и делит ее на количество непустых ячеек в диапазоне A2:L2 (ячейки с мая по декабрь пусты).

  1. Иногда требуется суммировать определенную ячейку на нескольких листах. Может возникнуть желание щелкнуть каждый лист и ячейку, а затем просто использовать "+", чтобы добавить значения ячеек, но это утомительно и может привести к возникновению ошибок.

    • =Лист1!A1+Лист2!A1+Лист3!A1

    С помощью трехмерной функции СУММ это можно сделать гораздо проще:

    Трехмерное суммирование — ячейка D2 содержит формулу =СУММ(Лист1:Лист3!A2)
    • =СУММ(Лист1:Лист3!A1)

    Эта формула будет суммировать ячейку A1 на всех листах с первого по третий.

    Это особенно пригодится в ситуации, когда для каждого месяца (с января по декабрь) используется отдельный лист, а вам нужно подвести общий итог на листе сводки.

    Трехмерное суммирование с использованием именованных листов.  Ячейка D2 содержит формулу =СУММ(Январь:Декабрь!A2)
    • =СУММ(Январь:Декабрь!A2)

    Эта формула будет суммировать ячейку A2 на каждом листе с января по декабрь.

    Примечания: Если названия листов содержат пробелы, например "Продажи января", необходимо использовать апострофы, указывая эти названия в формуле. Обратите внимание на апострофы ПЕРЕД названием первого листа и ПОСЛЕ названия последнего.

    • =СУММ('Продажи января:Продажи декабря'!A2)

    Метод 3D также можно использовать с другими функциями: СРЗНАЧ, МИН, МАКС и т. д.

    • =СРЗНАЧ(Лист1:Лист3!A1)

    • =МИН(Лист1:Лист3!A1)

    • =МАКС(Лист1:Лист3!A1)

В Excel можно с легкостью выполнять математические операции — как по отдельности, так и в сочетании с функциями Excel, например СУММ. В таблице ниже перечислены операторы, которые могут вам пригодиться, а также связанные с ними функции. Операторы можно вводить как с помощью цифрового ряда на клавиатуре, так и с помощью цифровой клавиатуры, если она у вас есть. Например, с помощью клавиш Shift + 8 можно ввести знак звездочки (*) для умножения.

Оператор

Операция

Примеры

+

Сложение

=1+1

=A1+B1

=СУММ(A1:A10)+10

=СУММ(A1:A10)+B1

-

Вычитание

=1-1

=A1-B1

=СУММ(A1:A10)-10

=СУММ(A1:A10)-B1

*

Умножение

=1*1

=A1*B1

=СУММ(A1:A10)*10

=СУММ(A1:A10)*B1

=ПРОИЗВЕД(1;1) — функция ПРОИЗВЕД

/

Деление

=1/1

=A1/B1

=СУММ(A1:A10)/10

=СУММ(A1:A10)/B1

=ЧАСТНОЕ(1;1) — функция ЧАСТНОЕ

^

Возведение в степень

=1^1

=A1^B1

=СУММ(A1:A10)^10

=СУММ(A1:A10)^B1

=СТЕПЕНЬ(1;1) — функция СТЕПЕНЬ

Дополнительные сведения см. в статье Использование Microsoft Excel в качестве калькулятора.

Другие примеры

  1. Допустим, вам нужно применить процент скидки к суммируемому диапазону ячеек.

    Использование операторов с функцией СУММ.  Ячейка B16 содержит формулу =СУММ(A2:A14)*-25%.  В правильной конструкции формулы вместо -25 % должна быть указана ссылка на ячейку, например =СУММ(A2:A14)*E2
    • =СУММ(A2:A14)*-25%

    Вы получаете 25 % от суммируемого диапазона, но значение 25 % введено прямо в формуле, так что если позже вам потребуется его изменить, найти его будет непросто. Гораздо лучше будет поместить значение 25 % в ячейку (где его будет легко найти и изменить) и использовать ссылку на нее, например:

    • =СУММ(A2:A14)*E2

    Если нужно не умножить, а разделить, просто укажите вместо знака "*" знак "/": =СУММ(A2:A14)/E2

  2. Функция СУММ — сложение и вычитание

    а. Чтобы прибавить или вычесть значение из функции СУММ, используйте знаки "+" и "-", например:

    • =СУММ(A1:A10)+E2

    • =СУММ(A1:A10)-E2

См. также

СУММ

Совершенствование навыков работы с Office
Перейти к обучению
Первоочередный доступ к новым возможностям
Присоединиться к программе предварительной оценки Office

Были ли сведения полезными?

Спасибо за ваш отзыв!

Благодарим за отзыв! Возможно, будет полезно связать вас с одним из наших специалистов службы поддержки Office.

×