Диаграммы

Добавление тренда или линии среднего значения к диаграмме

Добавление тренда или линии среднего значения к диаграмме

Примечание: Мы стараемся как можно оперативнее обеспечивать вас актуальными справочными материалами на вашем языке. Эта страница переведена автоматически, поэтому ее текст может содержать неточности и грамматические ошибки. Для нас важно, чтобы эта статья была вам полезна. Просим вас уделить пару секунд и сообщить, помогла ли она вам, с помощью кнопок внизу страницы. Для удобства также приводим ссылку на оригинал (на английском языке).

Добавление линии тренда на диаграмму для отображения трендов визуальных данных.

Браузер не поддерживает видео. Установите Microsoft Silverlight, Adobe Flash Player или Internet Explorer 9.

Примечание: Эти действия применимы к Office 2013 и более поздним версиям. Ищете инструкции для Office 2010?

Добавление линии тренда

  1. Выделите диаграмму.

  2. Щелкните значок "+" в правом верхнем углу диаграммы.

  3. Выберите пункт Линия тренда.

Форматирование линии тренда

  1. В области Формат линии тренда выберите параметр линии тренда, чтобы выбрать нужную линию тренда для диаграммы. Форматирование линии тренда — это статистический способ измерения данных
    :_з0з_

  2. Задайте значение в полях вперед и назад для проецирования данных в будущее.

Добавление линии тренда или скользящего среднего на диаграмму в Office 2010

  1. На диаграмме без накопления, плоской диаграмме, диаграмме с областями, линейчатой диаграмме, гистограмме, графике, биржевой, точечной или пузырьковой диаграмме щелкните ряд данных, для которого требуется добавить линию тренда или линейную фильтрацию, или выполните указанные ниже действия, чтобы выбрать ряд данных из списка элементов диаграммы.

    1. Щелкните диаграмму.

      Будут отображены средства Работа с диаграммами, включающие вкладки Конструктор, Макет и Формат.

    2. На вкладке Формат в группе Текущий фрагмент щелкните стрелку рядом с полем Элементы диаграммы, а затем выберите нужный элемент диаграммы.

      Группа "Текущий фрагмент" на вкладке "Макет" ("Работа с диаграммами")

  2. Примечание: Если выбрана диаграмма с несколькими рядами данных, но сам ряд данных не выбран, откроется диалоговое окно Добавление линии тренда. В поле со списком выберите нужный ряд данных, а затем нажмите кнопку ОК.

  3. На вкладке Макет в группе Анализ выберите пункт Линия тренда.

    Группа "Анализ" на вкладке "Макет" ("Работа с диаграммами")

  4. Выполните одно из указанных ниже действий.

    1. Выберите подходящий предопределенный параметр линии тренда.

      Примечание: Линия тренда будет применена без возможности выбора конкретных параметров.

    2. Нажмите Дополнительные параметры линии тренда, а затем в категории Параметры линии тренда в разделе Построение линии тренда (аппроксимация и сглаживание) выберите нужный тип линии тренда.

    Используемый тип

    Применение

    Линейная

    Создание прямой линии тренда путем расчета по методу наименьших квадратов с помощью следующего уравнения:

    уравнение

    где m — это наклон, а b — смещение.

    Логарифмическая

    Построение логарифмической линии тренда путем расчета точек методом наименьших квадратов с помощью следующего уравнения:

    уравнение

    где c и b — константы, а «ln» — натуральный логарифм.

    Полиномиальная

    Построение полиномиальной или криволинейной линии тренда путем расчета точек методом наименьших квадратов с помощью следующего уравнения:

    уравнение

    Здесь b и Переменная  — константы.

    Степенная

    Построение степенной линии тренда путем расчета точек методом наименьших квадратов с помощью следующего уравнения:

    формула

    где c и b — константы.

    Примечание: При наличии нулевых или отрицательных значений данных этот параметр недоступен.

    Экспоненциальная

    Построение экспоненциальной линии тренда путем расчета точек методом наименьших квадратов с помощью следующего уравнения:

    уравнение

    где c и b — константы, e — основание натурального логарифма.

    Примечание: При наличии нулевых или отрицательных значений данных этот параметр недоступен.

    Линейная фильтрация

    Построение линии тренда с линейной фильтрацией по следующей формуле: формула

    Примечание: Число точек, образующих линию тренда с скользящее среднее, равно общему числу точек ряда за вычетом числа, указанного для параметра "Точки".

    Величина достоверности аппроксимации

    Построение линии тренда с указанием на диаграмме величина достоверности аппроксимации, вычисляемой по следующей формуле:

    уравнение

    Этот параметр линии тренда располагается на вкладке Параметры диалогового окна Добавление линии тренда или Формат линии тренда.

    Примечание: Отображаемая вместе с линией тренда величина достоверности аппроксимации не является скорректированной. Для логарифмической, степенной и экспоненциальной линий тренда в Excel используется видоизмененная модель регрессии.

    • Если выбран тип Полиномиальная, введите в поле Степень наибольшую степень для независимой переменной.

    • Если выбран тип Линейная фильтрация, введите в поле Точки число точек, используемых для расчета линейного фильтра.

    • Если скользящее среднее добавляется к точечной диаграмме, оно основывается на порядке расположения значений X. Для получения нужного результата перед добавлением скользящего среднего, возможно, потребуется отсортировать значения X.

    • При добавлении линии тренда в график, гистограмму, диаграмму с областями или линейчатую диаграмму линия тренда рассчитывается исходя из предположения, что значения x равны 1, 2, 3, 4, 5, 6 и т. д. Такое допущение делается вне зависимости от того, являются ли значения x числовыми или текстовыми. Чтобы рассчитать линию тренда на основе числовых значений x, следует использовать точечную диаграмму.

    • В Excel название линии тренда назначается автоматически, но его можно изменить. В диалоговом окне Формат линии тренда в категории Параметры линии тренда в разделе Название аппроксимирующей (сглаженной) кривой выберите параметр Другое, а затем укажите название в поле Другое.

Советы: 

  • Кроме того, можно добавить линейную фильтрацию, которая сглаживает отклонения в данных и более четко показывает форму линии тренда.

  • Если изменить диаграмму или ряд данных таким образом, что они больше не будут поддерживать соответствующую линию тренда (например, если изменить тип диаграммы на объемную диаграмму или изменить представление отчет сводной диаграммы или связанный отчет сводной таблицы), линия тренда больше не будет отображаться на диаграмме.

  • Для данных в строке (без диаграммы) наиболее точные прямые или экспоненциальные линии тренда можно создать с помощью автозаполнения или статистических функций, таких как РОСТ() или ТЕНДЕНЦИЯ().

  1. На диаграмме без накопления, плоской диаграмме, диаграмме с областями, линейчатой диаграмме, гистограмме, графике, биржевой, точечной или пузырьковой диаграмме щелкните линию тренда, которую необходимо изменить, или выполните следующие действия, чтобы выбрать ее из списка элементов диаграммы.

    1. Щелкните диаграмму.

      Будут отображены средства Работа с диаграммами, включающие вкладки Конструктор, Макет и Формат.

    2. На вкладке Формат в группе Текущий фрагмент щелкните стрелку рядом с полем Элементы диаграммы, а затем выберите нужный элемент диаграммы.

      Группа "Текущий фрагмент" на вкладке "Макет" ("Работа с диаграммами")

  2. На вкладке Макет в группе Анализ выберите пункт Линия тренда, а затем нажмите Дополнительные параметры линии тренда.

    Группа "Анализ" на вкладке "Макет" ("Работа с диаграммами")

  3. Чтобы изменить параметры цвета, типа или тени линии тренда, выберите категорию Цвет линии, Тип линии или Тень и задайте нужные значения.

  1. На диаграмме без накопления, плоской диаграмме, диаграмме с областями, линейчатой диаграмме, гистограмме, графике, биржевой, точечной или пузырьковой диаграмме щелкните линию тренда, которую необходимо изменить, или выполните следующие действия, чтобы выбрать ее из списка элементов диаграммы.

    1. Щелкните диаграмму.

      Будут отображены средства Работа с диаграммами, включающие вкладки Конструктор, Макет и Формат.

    2. На вкладке Формат в группе Текущий фрагмент щелкните стрелку рядом с полем Элементы диаграммы, а затем выберите нужный элемент диаграммы.

      Группа "Текущий фрагмент" на вкладке "Макет" ("Работа с диаграммами")

  2. На вкладке Макет в группе Анализ выберите пункт Линия тренда, а затем нажмите Дополнительные параметры линии тренда.

    Группа "Анализ" на вкладке "Макет" ("Работа с диаграммами")

  3. Чтобы указать число периодов для включения в прогноз, в разделе Прогноз укажите число периодов в поле вперед на или назад на.

  1. На диаграмме без накопления, плоской диаграмме, диаграмме с областями, линейчатой диаграмме, гистограмме, графике, биржевой, точечной или пузырьковой диаграмме щелкните линию тренда, которую необходимо изменить, или выполните следующие действия, чтобы выбрать ее из списка элементов диаграммы.

    1. Щелкните диаграмму.

      Будут отображены средства Работа с диаграммами, включающие вкладки Конструктор, Макет и Формат.

    2. На вкладке Формат в группе Текущий фрагмент щелкните стрелку рядом с полем Элементы диаграммы, а затем выберите нужный элемент диаграммы.

      Группа "Текущий фрагмент" на вкладке "Макет" ("Работа с диаграммами")

  2. На вкладке Макет в группе Анализ выберите пункт Линия тренда, а затем нажмите Дополнительные параметры линии тренда.

    Группа "Анализ" на вкладке "Макет" ("Работа с диаграммами")

  3. Установите флажок пересечение кривой с осью Y в точке, а затем в поле пересечение кривой с осью Y в точке введите значение, чтобы задать точку пересечения линии тренда с вертикальной осью (осью значений).

    Примечание: Это можно сделать только при использовании экспоненциальной, прямой или полиномиальной линии тренда.

  1. На диаграмме без накопления, плоской диаграмме, диаграмме с областями, линейчатой диаграмме, гистограмме, графике, биржевой, точечной или пузырьковой диаграмме щелкните линию тренда, которую необходимо изменить, или выполните следующие действия, чтобы выбрать ее из списка элементов диаграммы.

    1. Щелкните диаграмму.

      Будут отображены средства Работа с диаграммами, включающие вкладки Конструктор, Макет и Формат.

    2. На вкладке Формат в группе Текущий фрагмент щелкните стрелку рядом с полем Элементы диаграммы, а затем выберите нужный элемент диаграммы.

      Группа "Текущий фрагмент" на вкладке "Макет" ("Работа с диаграммами")

  2. На вкладке Макет в группе Анализ выберите пункт Линия тренда, а затем нажмите Дополнительные параметры линии тренда.

    Группа "Анализ" на вкладке "Макет" ("Работа с диаграммами")

  3. Чтобы показать на диаграмме уравнение линии тренда, установите флажок показывать уравнение на диаграмме.

    Примечание: Уравнения линии тренда нельзя показать для скользящего среднего.

Совет: Формула линии тренда округляется для удобства чтения. Тем не мене число десятичных знаков в подписи выбранной линии тренда можно настроить в поле Число десятичных знаков на вкладке Число диалогового окна Формат подписи линии тренда (вкладка Формат, группа Текущий фрагмент, кнопка Формат выделенного фрагмента).

  1. На диаграмме без накопления, плоской диаграмме, диаграмме с областями, линейчатой диаграмме, гистограмме, графике, биржевой, точечной или пузырьковой диаграмме щелкните линию тренда, для которой требуется показать величина достоверности аппроксимации, или выполните указанные ниже действия, чтобы выбрать линию тренда из списка элементов диаграммы.

    1. Щелкните диаграмму.

      Будут отображены средства Работа с диаграммами, включающие вкладки Конструктор, Макет и Формат.

    2. На вкладке Формат в группе Текущий фрагмент щелкните стрелку рядом с полем Элементы диаграммы, а затем выберите нужный элемент диаграммы.

      Группа "Текущий фрагмент" на вкладке "Макет" ("Работа с диаграммами")

  2. На вкладке Макет в группе Анализ выберите пункт Линия тренда, а затем нажмите Дополнительные параметры линии тренда.

    Группа "Анализ" на вкладке "Макет" ("Работа с диаграммами")

  3. На вкладке Параметры линии тренда установите флажок поместить на диаграмму величину достоверности аппроксимации (R^2).

Примечание: Для скользящего среднего величину достоверности аппроксимации отобразить нельзя.

  1. На диаграмме без накопления, плоской диаграмме, диаграмме с областями, линейчатой диаграмме, гистограмме, графике, биржевой, точечной или пузырьковой диаграмме щелкните линию тренда, которую необходимо удалить, или выполните следующие действия, чтобы выбрать линию тренда из списка элементов диаграммы.

    1. Щелкните диаграмму.

      Будут отображены средства Работа с диаграммами, включающие вкладки Конструктор, Макет и Формат.

    2. На вкладке Формат в группе Текущий фрагмент щелкните стрелку рядом с полем Элементы диаграммы, а затем выберите нужный элемент диаграммы.

      Группа "Текущий фрагмент" на вкладке "Макет" ("Работа с диаграммами")

  2. Выполните одно из указанных ниже действий.

    1. На вкладке Макет в группе Анализ нажмите Линия тренда, а затем выберите пункт Нет.

      Группа "Анализ" на вкладке "Макет" ("Работа с диаграммами")

    2. Нажмите клавишу DELETE.

Совет: Кроме того, удалить линию тренда можно сразу после того, как она была добавлена на диаграмму, нажав кнопку Отменить  Кнопка "Отменить" на панели быстрого доступа или клавиши CTRL+Z.

Добавление линии тренда

  1. В меню Вид выберите пункт Разметка страницы.

  2. Выберите на диаграмме ряд данных, к которому вы хотите добавить линию тренда, а затем откройте вкладку конструктор диаграмм.

    Например, щелкните одну из линий графика. Будут выделены все маркеры данных этого ряда.

    Вкладка "конструктор диаграмм"

  3. На вкладке конструктор диаграмм нажмите кнопку Добавить элемент диаграммы и выберите пункт линия тренда.

    Добавление линии тренда

  4. Выберите один из вариантов линии тренда или нажмите кнопку Дополнительные параметры линии тренда.

    Параметры линии тренда

    Вы можете выбрать один из следующих вариантов:

    • Экспоненциальный

    • Линейная

    • Логарифмическая

    • Полиномиальная

    • Степень

    • Линейная фильтрация

    Вы также можете задать имя линии тренда и выбрать параметры прогнозирования.

Удаление линии тренда

  1. В меню Вид выберите пункт Разметка страницы.

  2. Щелкните диаграмму с линией тренда, а затем откройте вкладку конструктор диаграмм.

    Вкладка "конструктор диаграмм"

  3. Нажмите кнопку Добавить элемент диаграммы, выберите пункт линия тренда, а затем — нет.

    Удаление трандлине

    Также можно щелкнуть линию тренда и нажать кнопку DELETE.

Дополнительные сведения

Вы всегда можете задать вопрос специалисту Excel Tech Community, попросить помощи в сообществе Answers community, а также предложить новую функцию или улучшение на веб-сайте Excel User Voice.

См. также

Параметры линии тренда в Office

Создание диаграммы от начала и до конца

Форматирование элементов диаграммы

Добавление меток данных на диаграмму

Совершенствование навыков работы с Office
Перейти к обучению
Первоочередный доступ к новым возможностям
Присоединиться к программе предварительной оценки Office

Были ли сведения полезными?

Спасибо за ваш отзыв!

Благодарим за отзыв! Возможно, будет полезно связать вас с одним из наших специалистов службы поддержки Office.

×