Перейти к основному контенту
Office
Добавление соединительных линий между фигурами

Добавление соединительных линий между фигурами

Подписка на Office 365, Office 2019, Office 2016, Office 2013, Office 2010

В Visio есть очень удобные инструменты для соединения фигур в документе. В приложении предусмотрена функция автосоединения, с помощью которой фигуры можно соединять прямо при добавлении, а также доступен инструмент "Соединительная линия" для соединения ранее добавленных фигур. Кроме того, вы можете изменять фигуры, которые отображаются на мини-панели инструментов, а также включать и отключать автосоединение.

Автоматическое соединение фигуры

Соединение фигур на странице

Соединение с фигурой на другой странице

Настройка внешнего вида соединительных линий с помощью тем

Использование других фигур соединительных линий

Изменение фигур на мини-панели инструментов "Автосоединение"

Включение и отключение автосоединения

Автоматическое соединение фигуры

Один из способов соединения фигур состоит в том, чтобы позволить Visio автоматически создавать соединительные линии при добавлении фигур на страницу. Это особенно удобно при создании блок-схем.

  1. Включите функцию автосоединения. Для этого на вкладке Вид в группе Визуальные подсказки установите флажок Автосоединение.

  2. Перетащите фигуру из области Фигуры на страницу.

  3. Наведите указатель мыши на исходную фигуру и удерживайте его, пока вокруг фигуры не появятся стрелки автосоединения.

    Если включена функция автосоединения, наведите указатель мыши на фигуру, чтобы отобразить стрелки.
  4. Наведите указатель мыши на стрелку, указывающую в том направлении, в котором требуется добавить фигуру.

    При наведении указателя мыши на стрелку автосоединения отображается мини-панель с вариантами фигур для добавления.

    Появится мини-панель инструментов с первыми четырьмя экспресс-фигурами, доступными в наборе элементов Экспресс-фигуры. Если навести указатель мыши на фигуру на этой панели инструментов, будет показано предварительное расположение новой фигуры на странице.

  5. Щелкните фигуру, которую хотите добавить.

  6. Если вы хотите продолжить добавление фигур, наведите указатель мыши на стрелку автосоединения рядом с новой фигурой и повторите действия.

    При наведении указателя мыши на вставленную фигуру отображаются стрелки автосоединения для добавления других объектов.

К началу страницы

Соединение фигур на странице

Совет: Команды в группе Инструменты на вкладке Главная позволяют переводить Visio в различные состояния и режимы, что иногда вызывает сложности. Используйте клавиатуру для переключения между инструментами Указатель  Выделение объектов (нажмите клавиши CTRL+1) и Соединительная линия  Изображение кнопки (нажмите клавиши CTRL+3). Независимо от того, какой инструмент вы используете, например Блок текста или Точка соединения, несколько раз нажмите клавишу ESC, чтобы вернуться к инструменту Указатель.

  1. На вкладке Главная в группе Инструменты щелкните Соединительная линия  Изображение кнопки или нажмите клавиши CTRL+3.

  2. Щелкните фигуру и перетащите соединительную линию на другую фигуру.

  3. Завершив создание соединения, на вкладке Главная в группе Инструменты щелкните Указатель  Выделение объектов или нажмите клавиши CTRL+1.

С помощью инструмента "Соединительная линия" можно соединить между собой две точки разных фигур.

Кроме того, можно добавить на ленту команду Соединить фигуры, которая позволяет соединить несколько фигур в порядке их выбора.

Совет: Чтобы добавить на ленту полезные команды, которых на ней нет, выберите Файл > Параметры > Настроить ленту.

К началу страницы

Соединение с фигурой на другой странице

Вы можете использовать соединительные линии только между фигурами на одной странице. Чтобы добавить соединение с фигурой на другой странице, используйте фигуру Ссылка на другую страницу (для создания гиперссылки с одной страницы на другую) или добавьте гиперссылку и действие по двойному щелчку для любой фигуры (чтобы обеспечить переход на другую страницу того же документа).

Использование ссылки на другую страницу

  1. Откройте набор Фигуры простой блок-схемы и перетащите фигуру Ссылка на другую страницу на текущую страницу.

    Фигура "Ссылка на другую страницу"
  2. В диалоговом окне Ссылка на другую страницу нажмите кнопку ОК, чтобы добавить фигуру на текущую страницу и новую страницу.

  3. На новой странице продолжайте создавать свою схему.

  4. Чтобы изменить внешний вид фигуры Ссылка на другую страницу, щелкните ее правой кнопкой мыши и выберите пункт Исходящая, Входящая, Круг или Стрелка.

Для перемещения между страницами дважды щелкните фигуру Ссылка на другую страницу на любой из страниц. Дополнительные сведения см. в статье Диалоговое окно "Ссылка на другую страницу".

Использование гиперссылки и двойного щелчка

  1. Щелкните правой кнопкой мыши любую фигуру или нажмите клавиши CTRL+K, а затем выберите пункт Гиперссылка.

  2. Нажмите кнопку Обзор рядом с полем Субадрес, а затем выберите в раскрывающемся списке Страница нужную страницу.

    Диалоговое окно "Гиперссылка"

    Примечание: Для гиперссылки можно также задать имя фигуры на странице назначения. На вкладке Разработчик нажмите кнопку Имя фигуры. В поле Имя оставьте значение по умолчанию или измените его, а затем нажмите кнопку ОК.

  3. Чтобы настроить для фигуры действие по двойному щелчку, на вкладке Разработчик нажмите кнопку Поведение.

  4. Откройте вкладку Двойной щелчок, установите переключатель перейти к странице и выберите в раскрывающемся списке нужную страницу.

    Действие по двойному щелчку в Visio

    Примечание: Эту операцию следует выполнять только после изменения имен страниц, так как они не обновляются автоматически.

К началу страницы

Настройка внешнего вида соединительных линий с помощью тем

По умолчанию соединители выглядят как обычные линии, но с помощью тем к ним можно применить оформление, например наконечники стрелок. Встроенные темы можно найти в коллекции Темы на вкладке Конструктор. Сведения об изменении атрибутов соединительной линии, таких как стиль, цвет, толщина и т. д., см. в статье Изменение фигур соединительных линий.

Примечания: 

  • Чтобы просмотреть другие варианты оформления, откройте вкладку Конструктор. В группе Варианты щелкните стрелку раскрывающегося списка и выберите пункт Соединительные линии.

Использование других фигур соединительных линий

Любые фигуры соединителей, например те, что доступны в наборе элементов Дополнительные фигуры > Дополнительные решения Visio > Соединители, можно использовать для соединения фигур вместо стандартной динамической соединительной линии. Их можно перетащить на страницу или выбрать в инструментах Соединитель и Соединить фигуры. Кроме того, ими можно заменить уже имеющиеся соединители.

  1. Откройте набор элементов с нужными фигурами.

  2. Выберите на странице соединительные линии, которые вы хотите заменить.

  3. На вкладке Главная в группе Редактирование нажмите кнопку Изменить фигуру, а затем выберите нужную фигуру соединительной линии.

Примечание: Функция Изменить фигуру впервые появилась в Visio 2013, тогда как инструменты Соединительная линия и Соединить фигуры существовали еще до Visio 2007.

К началу страницы

Изменение фигур на мини-панели инструментов "Автосоединение"

Фигуры на мини-панели инструментов берутся из набора Экспресс-фигуры для схемы. На мини-панели инструментов отображается до четырех фигур. Вы можете настраивать фигуры, которые отображаются на мини-панели инструментов. В следующей процедуре в качестве примера используется Простая диаграмма.

  1. По умолчанию фигурами на мини-панели инструментов являются первые четыре фигуры из набора, который расположен сразу после набора Экспресс-фигуры. Например, ниже показаны первые 4 фигуры в наборе Простые фигуры.

    Мини-панель инструментов с основными фигурами по умолчанию
  2. Чтобы отобразить другие фигуры на мини-панели инструментов для конкретного набора, вы можете перетащить их вверх списка набора. Например, вы можете перетащить фигуры Четырехконечная звезда, Пятиконечная звезда, Шестиконечная звезда и Семиконечная звезда вверх списка набора Простые фигуры.

    Мини-панель инструментов с новыми основными фигурами
  3. Кроме того, вы можете изменить порядок наборов, перетаскивая их в верхнюю или нижнюю часть области "Фигуры". Подмножество этих фигур отображается в наборе "Экспресс-фигуры" в том же порядке, что они располагаются в области "Фигуры". Например, если перетащить набор Декоративные фигуры так, чтобы она располагался сразу после набора Экспресс-фигуры на панели Фигуры, порядок фигур в наборе Экспресс-фигуры изменится.

    Мини-панель инструментов с новым набором вследствие изменения порядка

    Примечание: Когда вы закрываете и повторно открываете схему, в области "Фигуры" автоматически восстанавливается порядок по умолчанию, что отражается на расположении фигур в наборе "Экспресс-фигуры".

  4. Чтобы использовать другой набор для мини-панели инструментов в качестве исходного, в наборе Экспресс-фигуры выберите фигуру из подмножества фигур необходимого набора. Например, выберите Диаграмма Венна в наборе График и математические фигуры.

    Мини-панель инструментов с новым набором вследствие выбора

Совет: Чтобы вернуться к стандартной последовательности фигур в наборе, в области Фигуры щелкните имя набора правой кнопкой мыши и выберите пункт Восстановить набор элементов.

Примечание: Не во всех наборах есть фигуры, которые можно использовать на мини-панели инструментов. Например, фигуры в наборе Стрелки не отображаются на мини-панели инструментов.

К началу страницы

Включение и отключение автосоединения

Вы можете включать и отключать автосоединение для текущего документа или для всех документов Visio по умолчанию.

Включение и отключение автосоединения для активной схемы

  • На вкладке Вид в группе Визуальные подсказки установите или снимите флажок Автосоединение.

    На вкладке "Вид" установите или снимите флажок "Автосоединение", чтобы включить или отключить автосоединение.

Если флажок Автосоединение недоступен, проверьте, включена ли функция автосоединения для всех схем. Ниже описано, как это сделать.

Включение и отключение автосоединения для всех схем

  1. Откройте вкладку Файл и выберите пункт Параметры.

  2. В окне Параметры Visio выберите пункт Дополнительно.

  3. Чтобы включить автосоединение, в разделе Параметры правки установите флажок Разрешить автосоединение. Чтобы отключить автосоединение, снимите флажок Разрешить автосоединение.

    Установите или снимите флажок "Разрешить автосоединение", чтобы включить или выключить функцию автосоединения для всех схем и документов.
  4. Нажмите кнопку ОК.

К началу страницы

Соединение фигур с помощью автосоединения

Один из способов соединения фигур состоит в том, чтобы позволить Visio автоматически создавать соединители при добавлении фигур в документ. Это особенно удобно при создании блок-схем.

Чтобы автоматически соединять добавляемые фигуры с существующими, сделайте следующее.

Использование автосоединения при перетаскивании фигур на страницу

  1. Перетащите фигуру из набора элементов на страницу документа и поместите ее рядом с другой фигурой.

    Фигура, расположенная вблизи другой фигуры

  2. Не отпуская кнопку мыши, наведите указатель на один из голубых треугольников. Треугольник станет синим.

    Наведите указатель на синий треугольник, и он станет темно-синим.

  3. Отпустите кнопку мыши. Фигура появится на странице документа, и добавится соединительная линия, "склеивающая" две фигуры.

    Фигура появляется на странице документа, и добавляется соединительная линия, "склеивающая" обе фигуры.

Совет: Если вы не любите перетаскивать фигуры, можно использовать другой способ. Выберите фигуру в наборе, наведите указатель на фигуру в документе, затем щелкните один из синих треугольников, которые появятся рядом с этой фигурой.

Использование автосоединения для фигур на странице

  1. Наведите указатель на фигуру, которую вы хотите соединить с другой фигурой.

    Указатель на фигуре, которую требуется соединить с другой фигурой.

  2. Наведите указатель на синий треугольником, находящийся ближе всего к фигуре, с которой требуется выполнить соединение.

    Указатель, расположенный над синим треугольником, который находится ближе всего к фигуре, с которой требуется выполнить соединение.

    Треугольник становится темно-синим, а вокруг фигуры, с которой требуется выполнить соединение, появляется красная рамка.

    Примечание: Если красная рамка не появляется вокруг фигуры, с которой вы хотите выполнить соединение, эта фигура может быть слишком далеко. Переместите ее ближе и повторите попытку.

  3. Щелкните синий треугольник. Добавляется соединительная линия и "склеивает" обе фигуры.

    Фигура появляется на странице документа, и добавляется соединительная линия, "склеивающая" обе фигуры.

Включение и отключение функции "Автосоединение"

Вы можете включить и отключить функцию автосоединения как для всех документов Visio, так и только для текущего документа. Для всех документов:

  1. В меню Сервис выберите команду Параметры.

  2. Откройте вкладку Общие.

  3. В разделе параметров Окно документа установите флажок Разрешить автосоединение.

Только для текущего документа:

  • На панели инструментов Стандартная щелкните инструмент Автосоединение.

    Примечание: Если после этого функция Автосоединение не включится, убедитесь, что в диалоговом окне Параметры установлен флажок Разрешить автосоединение.

Соединение фигур с помощью соединительной линии

Одним из наиболее удобных способов добавления и приклеивания соединительной линии является использование инструмента Соединительная линия  Изображение кнопки на панели инструментов Стандартная.

  1. На панели инструментов Стандартная щелкните инструмент Соединительная линия  Изображение кнопки .

  2. Выполните одно из указанных ниже действий:

    • Чтобы соединительная линия оставалась приклеенной к конкретной точке на фигуре, перетащите точку соединения  Изображение точки соединения — синий значок "X" на первой фигуре к точке соединения на второй фигуре. После соединения фигур конечные точки соединительной линии становятся красными. Это называется соединением точка-точка. В случае соединения точка-точка во время перемещения фигур соединительная линия остается приклеенной к одной точке.

    • Чтобы соединительная линия соединялась с ближайшей доступной точкой соединения, разместите инструмент Соединительная линия в центре первой фигуры и дождитесь, пока вокруг нее появится красная рамка. Удерживайте нажатой кнопку мыши и перетащите указатель в центр второй фигуры. Когда вокруг второй фигуры появится красная рамка, отпустите кнопку мыши. Это называется соединением фигура к фигуре. В случае соединения фигура к фигуре соединительная линия остается приклеенной к фигуре, но соединяется с ближайшей точкой соединения при перемещении одной из фигур. Если нет доступных точек соединения, соединительная линия соединяется с ближайшей стороной.

      Примечание: Кроме того, вы можете создавать такие соединения между фигурами, где один конец соединительной линии соединен с точкой соединения, а другой конец — с фигурой (и наоборот).

  3. На панели инструментов Стандартная щелкните инструмент Указатель  Кнопка "Указатель" , чтобы вернуться в обычный режим правки.

    Примечания: 

    • Чтобы добавить соединительную линию от одной фигуры к нескольким фигурам, вам необходимо добавить несколько соединителей. Формы соединительной линии с несколькими ветвями не существует.

    • Если вы хотите создать соединение точка-точка и у вас возникают проблемы с точным размещением соединительной линии, попробуйте использовать другие параметры привязки и склеивания:

    • В меню Сервис щелкните Привязать и приклеить, затем на вкладке Общие выберите необходимые параметры.

      Если вы выполняете соединение с контуром, маркером или вершиной фигуры, в случае отсутствия точки соединения, она добавляется автоматически.

Переключение между соединениями "фигура к фигуре" и "точка-точка"

С помощью соединительных линий вы можете соединять точку на одной фигуре с точкой на другой фигуре или соединять фигуры целиком. Вы также можете создавать соединения, когда один конец соединительной линии приклеен к точке на фигуре, а другой конец — к фигуре целиком.

  1. Перетащите конечную точку соединительной линии от фигуры.

  2. Выполните одно из указанных ниже действий:

    • Чтобы приклеить конечную точку соединительной линии к точке соединения на фигуре, перетащите конечную точку на одну из точек соединения фигуры и дождитесь, когда вокруг этой точки соединения появится красная рамка.

    • Чтобы приклеить конечную точку соединительной линии к фигуре целиком, перетащите конечную точу в середину фигуры и дождитесь, когда вокруг всей фигуры появится красная рамка.

См. также

Добавление и изменение текста соединителя

Создание пользовательской соединительной линии

Включение и выключение приклеивания

Обучение работе с Visio

Все, что нужно знать о соединителях в классической версии Visio (блог команды разработчиков Visio)

Совершенствование навыков работы с Office
Перейти к обучению
Первоочередный доступ к новым возможностям
Присоединиться к программе предварительной оценки Office

Были ли сведения полезными?

Спасибо за ваш отзыв!

Благодарим за отзыв! Возможно, будет полезно связать вас с одним из наших специалистов службы поддержки Office.

×