Функция СУММПРОИЗВ

В этой статье описаны синтаксис формулы и использование функции СУММПРОИЗВ в Microsoft Excel.

Описание

Перемножает соответствующие элементы заданных массивов и возвращает сумму произведений.

Синтаксис

СУММПРОИЗВ(массив1;[массив2];[массив3];…)

Аргументы функции СУММПРОИЗВ описаны ниже.

  • Массив1     Обязательный. Первый массив, компоненты которого нужно перемножить, а затем сложить результаты.

  • Массив2, массив3...     Необязательный. От 2 до 255 массивов, компоненты которых нужно перемножить, а затем сложить результаты.

Примечания

  • Аргументы, которые являются массивами, должны иметь одинаковые размерности. В противном случае функция СУММПРОИЗВ возвращает значение ошибки #ЗНАЧ!.

  • Функция СУММПРОИЗВ трактует нечисловые элементы массивов как нулевые.

Пример

Скопируйте образец данных из следующей таблицы и вставьте их в ячейку A1 нового листа Excel. Чтобы отобразить результаты формул, выделите их и нажмите клавишу F2, а затем — клавишу ВВОД. При необходимости измените ширину столбцов, чтобы видеть все данные.

Массив 1

Массив 2

3

4

2

7

8

6

6

7

1

9

5

3

Формула

Описание

Результат

=СУММПРОИЗВ(A2:B4; D2:E4)

Перемножает все компоненты двух массивов и возвращает сумму произведений — т. е. 3*2 + 4*7 + 8*6 + 6*7 + 1*5 + 9*3 (156)

156

Совершенствование навыков
Перейти к обучению
Первоочередный доступ к новым возможностям
Присоединиться к программе предварительной оценки Office

Были ли сведения полезными?

Спасибо за ваш отзыв!

Благодарим за отзыв! Возможно, будет полезно связать вас с одним из наших специалистов службы поддержки Office.

×