Функция СУММЕСЛИ

Функция СУММЕСЛИ используется, если необходимо просуммировать значения диапазона, соответствующие указанному условию. Предположим, например, что в столбце с числами необходимо просуммировать только значения, превышающие 5. Для этого можно использовать следующую формулу: =СУММЕСЛИ(B2:B25;">5")

Браузер не поддерживает видео. Установите Microsoft Silverlight, Adobe Flash Player или Internet Explorer 9.

Это видео — часть учебного курса Сложение чисел в Excel 2013.

Советы : 

  • При необходимости условия можно применить к одному диапазону, а просуммировать соответствующие значения из другого диапазона. Например, формула =СУММЕСЛИ(B2:B5; "Иван"; C2:C5) суммирует только те значения из диапазона C2:C5, для которых соответствующие значения из диапазона B2:B5 равны "Иван".

  • Если необходимо выполнить суммирование ячеек в соответствии с несколькими условиями, используйте функцию СУММЕСЛИМН.

Синтаксис

СУММЕСЛИ(диапазон; условие; [диапазон_суммирования])

Аргументы функции СУММЕСЛИ описаны ниже.

  • Диапазон   . Обязательный аргумент. Диапазон ячеек, оцениваемых на соответствие условиям. Ячейки в каждом диапазоне должны содержать числа, имена, массивы или ссылки на числа. Пустые ячейки и ячейки, содержащие текстовые значения, пропускаются. Выбранный диапазон может содержать даты в стандартном формате Excel (см. примеры ниже).

  • Условие   . Обязательный аргумент. Условие в форме числа, выражения, ссылки на ячейку, текста или функции, определяющее, какие ячейки необходимо суммировать. Например, условие может быть представлено в таком виде: 32, ">32", B5, "32", "яблоки" или СЕГОДНЯ().

    Важно : Все текстовые условия и условия с логическими и математическими знаками необходимо заключать в двойные кавычки ("). Если условием является число, использовать кавычки не требуется.

  • Диапазон_суммирования   . Необязательный аргумент. Ячейки, значения из которых суммируются, если они отличаются от ячеек, указанных в качестве диапазона. Если аргумент диапазон_суммирования опущен, Excel суммирует ячейки, указанные в аргументе диапазон (те же ячейки, к которым применяется условие).

  • В аргументе условие можно использовать подстановочные знаки: вопросительный знак (?) и звездочку (*). Вопросительный знак соответствует одному любому символу, а звездочка — любой последовательности символов. Если требуется найти непосредственно вопросительный знак (или звездочку), необходимо поставить перед ним знак "тильда" (~).

Примечания

  • Функция СУММЕСЛИ возвращает неправильные результаты, если она используется для сопоставления строк длиннее 255 символов или применяется к строке #ЗНАЧ!.

  • Аргумент диапазон_суммирования может не совпадать по размерам с аргументом диапазон. При определении фактических ячеек, подлежащих суммированию, в качестве начальной используется верхняя левая ячейка аргумента диапазон_суммирования, а затем суммируются ячейки части диапазона, соответствующей по размерам аргументу диапазон. Пример:

Диапазон

Диапазон суммирования

Фактические ячейки

A1:A5

B1:B5

B1:B5

A1:A5

B1:B3

B1:B5

A1:B4

C1:D4

C1:D4

A1:B4

C1:C2

C1:D4

Однако если аргументы диапазон и диапазон_суммирования функции СУММЕСЛИ содержат разное число ячеек, пересчет листа может занять больше времени, чем ожидалось.

Примеры

Пример 1

Скопируйте образец данных из следующей таблицы и вставьте их в ячейку A1 нового листа Excel. Чтобы отобразить результаты формул, выделите их и нажмите клавишу F2, а затем — клавишу ВВОД. При необходимости измените ширину столбцов, чтобы видеть все данные.

Стоимость имущества

Комиссионные

Данные

100 000,00 ₽

7 000,00 ₽

250 000,00 ₽

200 000,00 ₽

14 000,00 ₽

300 000,00 ₽

21 000,00 ₽

400 000,00 ₽

28 000,00 ₽

Формула

Описание

Результат

=СУММЕСЛИ(A2:A5;">160000";B2:B5)

Сумма комиссионных за имущество стоимостью больше 160 000.

63 000,00 ₽

=СУММЕСЛИ(A2:A5; ">160000")

Сумма по имуществу стоимостью больше 160 000.

900 000,00 ₽

=СУММЕСЛИ(A2:A5;300000;B2:B5)

Сумма комиссионных за имущество стоимостью 300 000.

21 000,00 ₽

=СУММЕСЛИ(A2:A5;">" &C2;B2:B5)

Сумма комиссионных за имущество, стоимость которого превышает значение в ячейке C2.

49 000,00 ₽

Пример 2

Скопируйте образец данных из приведенной ниже таблицы и вставьте его в ячейку A1 нового листа Excel. Чтобы отобразить результаты формул, выделите их и нажмите клавишу F2, а затем — клавишу ВВОД. Кроме того, вы можете настроить ширину столбцов в соответствии с содержащимися в них данными.

Категория

Продукты

Объем продаж

Овощи

Помидоры

2 300,00 ₽

Овощи

Сельдерей

5 500,00 ₽

Фрукты

Апельсины

800,00 ₽

Масло

400,00 ₽

Овощи

Морковь

4 200,00 ₽

Фрукты

Яблоки

1 200,00 ₽

Формула

Описание

Результат

=СУММЕСЛИ(A2:A7;"Фрукты";C2:C7)

Объем продаж всех продуктов категории "Фрукты".

2 000,00 ₽

=СУММЕСЛИ(A2:A7;"Овощи";C2:C7)

Объем продаж всех продуктов категории "Овощи".

12 000,00 ₽

=СУММЕСЛИ(B2:B7;"*ы";C2:C7)

Объем продаж всех продуктов, названия которых заканчиваются на "ы" ("Помидоры" и "Апельсины").

3 100,00 ₽

=СУММЕСЛИ(A2:A7;"";C2:C7)

Объем продаж всех продуктов, категория для которых не указана.

400,00 ₽

К началу страницы

У вас есть вопрос об определенной функции?

Задать вопрос на форуме сообщества, посвященном Excel

Помогите нам улучшить Excel

У вас есть предложения по улучшению следующей версии Excel? Если да, ознакомьтесь с темами на портале пользовательских предложений для Excel.

См. также

Функция СУММЕСЛИМН суммирует все аргументы, которые удовлетворяют нескольким условиям

СУММКВ суммирует значения после возведения их в квадрат

Функция СЧЁТЕСЛИ подсчитывает только значения, которые удовлетворяют одному условию

Функция СЧЁТЕСЛИМН подсчитывает только значения, которые удовлетворяют нескольким условиям

Функция ЕСЛИМН (Office 365, Excel 2016 и более поздние версии)

Обзор формул в Excel

Как избежать появления неработающих формул

Поиск ошибок в формулах

Математические и тригонометрические функции

Функции Excel (по алфавиту)

Функции Excel (по категориям)

Использование функций СУММЕСЛИ, СЧЁТЕСЛИ и связанных с ними функций для экспресс-анализа данных (бесплатное ознакомительное видео)

Совершенствование навыков
Перейти к обучению
Первоочередный доступ к новым возможностям
Присоединиться к программе предварительной оценки Office

Были ли сведения полезными?

Спасибо за ваш отзыв!

Благодарим за отзыв! Возможно, будет полезно связать вас с одним из наших специалистов службы поддержки Office.

×