Функция И

И — одна из логических функций, с помощью которой можно определить, все ли проверяемые условия принимают значение ИСТИНА.

Пример

Примеры использования функции И

Функция И возвращает значение ИСТИНА, если в результате вычисления всех аргументов получается значение ИСТИНА, и значение ЛОЖЬ, если вычисление хотя бы одного из аргументов дает значение ЛОЖЬ.

Обычно функция И используется для расширения возможностей других функций, выполняющих логическую проверку. Например, функция ЕСЛИ выполняет логическую проверку и возвращает одно значение, если при проверке получается значение ИСТИНА, и другое значение, если при проверке получается значение ЛОЖЬ. Использование функции И в качестве аргумента лог_выражение функции ЕСЛИ позволяет проверять несколько различных условий вместо одного.

Синтаксис

И(логическое_значение1;[логическое_значение2];…)

Функция И имеет следующие аргументы:

Аргумент

Описание

Логическое_значение1

Обязательный аргумент. Первое проверяемое условие, вычисление которого дает значение ИСТИНА или ЛОЖЬ.

Логическое_значение2;...

Необязательный аргумент. Дополнительные проверяемые условия, вычисление которых дает значение ИСТИНА или ЛОЖЬ. Условий может быть не более 255.

Примечания

  • Аргументы должны давать в результате логические значения (такие как ИСТИНА или ЛОЖЬ) либо быть массивами или ссылками, содержащими логические значения.

  • Если аргумент, который является ссылкой или массивом, содержит текст или пустые ячейки, то такие значения игнорируются.

  • Если в указанном интервале отсутствуют логические значения, функция И возвращает ошибку #ЗНАЧ!

Примеры

Ниже представлено несколько общих примеров использования функции И, как отдельно, так и в сочетании с функцией ЕСЛИ.

Примеры совместного использования функций ЕСЛИ и И

Формула

Описание

=И(A2>1;A2<100)

Возвращает значение ИСТИНА, если число в ячейке A2 больше 1 И меньше 100. В противном случае возвращает значение ЛОЖЬ.

=ЕСЛИ(И(A2<A3;A2<100);A2;"Значение вне допустимого диапазона.")

Возвращает значение ячейки A2, если оно меньше значения ячейки A3 И не превышает 100. В противном случае возвращает сообщение "Значение вне допустимого диапазона.".

=ЕСЛИ(И(1<A3;A3<100);A3;"Значение вне допустимого диапазона.")

Возвращает значение ячейки A3, если оно больше 1 И не превышает 100. В противном случае возвращает сообщение "Значение вне допустимого диапазона". Сообщения можно заменить любыми другими.

Вычисление премии

Ниже приводится решение довольно распространенной задачи: с помощью функций ЕСЛИ и И определяется, заработал ли продавец премию, а также рассчитывается ее размер.

Пример вычисления премии с продаж при помощи функций ЕСЛИ и И  Формула в ячейке E14: "=ЕСЛИ(И(B14>=$B$7;C14>=$B$5);B14*$B$8;0)"
  • =ЕСЛИ(И(B14>=$B$7,C14>=$B$5),B14*$B$8,0) — ЕСЛИ общие продажи больше или равны (>=) целевым продажам И число договоров больше или равно (>=) целевому, общие продажи умножаются на процент премии. В противном случае возвращается значение 0.

Дополнительные сведения

Вы всегда можете задать вопрос специалисту Excel Tech Community, попросить помощи в сообществе Answers community, а также предложить новую функцию или улучшение на веб-сайте Excel User Voice.

См. также:

Видео: усложненные функции ЕСЛИ
Использование вложенных функций в формуле
Функция ЕСЛИ
Функция ИЛИ
Функция НЕ
Полные сведения о формулах в Excel
Рекомендации, позволяющие избежать появления неработающих формул
Поиск ошибок в формулах
Сочетания клавиш в Excel 2016 для Windows
Сочетания клавиш в Excel 2016 для Mac
Логические функции (ссылка)
Функции Excel (по алфавиту)
Функции Excel (по категориям)

Совершенствование навыков
Перейти к обучению
Первоочередный доступ к новым возможностям
Присоединиться к программе предварительной оценки Office

Были ли сведения полезными?

Спасибо за ваш отзыв!

Благодарим за отзыв! Возможно, будет полезно связать вас с одним из наших специалистов службы поддержки Office.

×