Функция ИЛИ

ИЛИ — одна из логических функций, с помощью которой можно определить наличие условий, которые принимают значение ИСТИНА.

Пример

Примеры использования функции ИЛИ

Функция ИЛИ возвращает значение ИСТИНА, если в результате вычисления хотя бы одного из ее аргументов получается значение ИСТИНА, и значение ЛОЖЬ, если в результате вычисления всех ее аргументов получается значение ЛОЖЬ.

Обычно функция ИЛИ используется для расширения возможностей других функций, выполняющих логическую проверку. Например, функция ЕСЛИ выполняет логическую проверку и возвращает одно значение, если при проверке получается значение ИСТИНА, и другое значение, если при проверке получается значение ЛОЖЬ. Использование функции ИЛИ в качестве аргумента "лог_выражение" функции ЕСЛИ позволяет проверять несколько различных условий вместо одного.

Синтаксис

ИЛИ(логическое_значение1;[логическое значение2];...)

Аргументы функции ИЛИ описаны ниже.

Аргумент

Описание

Логическое_значение1

Обязательный аргумент. Первое проверяемое условие, вычисление которого дает значение ИСТИНА или ЛОЖЬ.

Логическое_значение2;...

Необязательный аргумент. Дополнительные проверяемые условия, вычисление которых дает значение ИСТИНА или ЛОЖЬ. Условий может быть не более 255.

Примечания

  • Аргументы должны принимать логические значения (ИСТИНА или ЛОЖЬ) либо быть массивами либо ссылками, содержащими логические значения.

  • Если аргумент, который является ссылкой или массивом, содержит текст или пустые ячейки, то такие значения игнорируются.

  • Если заданный диапазон не содержит логических значений, функция ИЛИ возвращает значение ошибки #ЗНАЧ!.

  • Можно воспользоваться функцией ИЛИ в качестве формулы массива, чтобы проверить, имеется ли в нем то или иное значение. Чтобы ввести формулу массива, нажмите клавиши CTRL+SHIFT+ВВОД.

Примеры

Ниже представлено несколько общих примеров использования функции ИЛИ как отдельно, так и в сочетании с функцией ЕСЛИ.

Примеры совместного использования функций ИЛИ и ЕСЛИ


Формула

Описание

=ИЛИ(A2>1;A2<100)

Возвращает значение ИСТИНА, если число в ячейке A2 больше 1 ИЛИ меньше 100. В противном случае возвращает значение ЛОЖЬ.

=ЕСЛИ(ИЛИ(A3>1;A3<100);A3;"Значение вне допустимого диапазона")

Возвращает значение ячейки A3, если оно меньше 100 ИЛИ больше 1. В противном случае возвращает сообщение "Значение вне допустимого диапазона".

=ЕСЛИ(ИЛИ(A2<0;A2>50);A2;"Значение вне допустимого диапазона")

Возвращает значение ячейки A2, если оно меньше 0 ИЛИ превышает 50. В противном случае возвращает сообщение "Значение вне допустимого диапазона".

Расчет комиссионных

Ниже приводится решение довольно распространенной задачи: с помощью функций ЕСЛИ и ИЛИ определяется, заработал ли торговый сотрудник комиссионные, а также вычисляется их размер.

Пример использования функций ЕСЛИ и ИЛИ для вычисления комиссионных выплат
  • =ЕСЛИ(ИЛИ(B14>=$B$4;C14>=$B$5);B14*$B$6;0)ЕСЛИ общие продажи больше целевых продаж или равны им (>=) ИЛИ число договоров больше целевого или равно ему (>=), общие продажи умножаются на процент премии. В противном случае возвращается значение 0.

Дополнительные сведения

Вы всегда можете задать вопрос специалисту Excel Tech Community, попросить помощи в сообществе Answers community, а также предложить новую функцию или улучшение на веб-сайте Excel User Voice.

См. также

Видео: расширенное применение функции ЕСЛИ

Использование вложенных функций в формуле

Функция ЕСЛИ

Функция И

Функция НЕ

Общие сведения о формулах в Excel

Рекомендации, позволяющие избежать появления неработающих формул

Обнаружение ошибок в формулах в Excel 2016

Сочетания клавиш в Excel 2016 для Windows

Сочетания клавиш в Excel 2016 для Mac

Логические функции (справка)

Функции Excel (по алфавиту)

Функции Excel (по категориям)

Совершенствование навыков
Перейти к обучению
Первоочередный доступ к новым возможностям
Присоединиться к программе предварительной оценки Office

Были ли сведения полезными?

Спасибо за ваш отзыв!

Благодарим за отзыв! Возможно, будет полезно связать вас с одним из наших специалистов службы поддержки Office.

×