Схема: отображение связанного с данными документа Visio в веб-части SharePoint

При необходимости представить подробные сведения большой аудитории можно воспользоваться схемой Visio, созданной в качестве веб-части SharePoint, которая обеспечивает визуализацию отчетов. Приложение Visio 2010 позволяет получать данные из внешних источников, таких как службы Excel, сервер SQL Server, списки SharePoint и прочие базы данных OLEDB и ODBC. Для визуализации внешних данных можно применять рисунки, связанные с данными, к фигурам в документе, публиковать документы на сайте SharePoint, а также использовать веб-часть Visio Web Access для отображения схем на сайте SharePoint.

Это идеальное средство создания настраиваемых цифровых панелей для сложных решений для бизнес-аналитики. С его помощью руководители могут быстро получать наглядное представление о бизнес-процессах и принимать обоснованные решения. Дополнительные сведения о возможностях сервера SharePoint в области бизнес-аналитики см. в статье Сервер SharePoint как средство бизнес-аналитики.

Загрузить наглядное руководство

Браузер не поддерживает видео. Установите Microsoft Silverlight, Adobe Flash Player или Internet Explorer 9.

В этой статье

Требования

Загрузка шаблона

Действие 1. Импорт данных в документ Visio

Действие 2. Применение рисунков, связанных с данными, к фигурам

Действие 3. Отображение схемы в веб-части SharePoint

Дополнительное действие. Добавление интерактивности в веб-часть Visio Web Access

Требования

Веб-часть Visio Web Access — это компонент служб Visio, которые входят в состав Microsoft SharePoint Server 2010. Для работы со службами Visio необходимо наличие Microsoft SharePoint Server 2010 с корпоративной лицензией клиентского доступа. Кроме того, службы Visio должны быть развернуты и подготовлены к работе.

Также для сохранения схем на сайте SharePoint необходимо установить приложение Microsoft Visio профессиональный 2010 или Microsoft Visio премиум 2010.

Дополнительные сведения о действиях, необходимых для обеспечения работы служб Visio на сайте SharePoint, см. в статье Администрирование службы графики Visio (на английском языке).

В начало страницы

Загрузка шаблона

Шаблон, который упоминается в видеоролике и наглядном руководстве, можно загрузить и использовать. Он содержит образцы данных и рисунки, связанные с данными, демонстрируемые в этих материалах.

Загрузить образцы схемы и данных

В начало страницы

Действие 1. Импорт данных в документ Visio

  1. В приложении Visio на вкладке Данные в группе Внешние данные нажмите кнопку Связать данные с фигурами.

На первой странице мастера выбора данных выберите необходимый источник данных.

Важно :  Службы Access не могут являться источником данных для веб-документов служб Visio. Некоторые схемы, например сводные, не поддерживают обновление в случае публикации на сайте SharePoint. Для обеспечения надежных результатов источник данных рекомендуется сохранять на том же сайте SharePoint, где расположена веб-часть служб Visio.

  1. Следуйте указаниям мастера выбора данных.

  2. После нажатия кнопки Готово на его последней странице откроется окно Внешние данные, содержащее таблицу со сведениями об импортированных данных.

  3. Чтобы применить данные из внешнего источника к фигуре в документе, перетащите на нее строку из окна Внешние данные.

Дополнительные сведения об импорте данных из внешнего источника в приложение Visio см. в статье Импорт данных в фигуры.

В начало страницы

Действие 2. Применение рисунков, связанных с данными, к фигурам

Чтобы создать рисунок, связанный с данными, выполните указанные ниже действия.

  1. В приложении Visio на вкладке Данные в группе Отображение данных выберите команду Рисунки, связанные с данными, а затем нажмите кнопку Создать рисунок, связанный с данными.

  2. В диалоговом окне Создание элемента выполните указанные ниже действия.

    1. В группе Экран в списке Поле данных щелкните поле Данные фигуры, которое необходимо визуализировать.

    2. Также в группе Экран в списке Отображение выберите рисунок, который наиболее точно представляет поле данных (Текст, Гистограмма, Набор значков или Цвет по значению.)

    3. Снова в группе Экран в списке Стиль выберите стиль рисунка. (Если в качестве типа рисунка выбран вариант «Цвет по значению», появится список Способ раскраски.)

    4. В группе Сведения настройте параметры рисунка.

    5. По завершении редактирования графического элемента нажмите кнопку ОК.

  3. Повторите эту процедуру, пока для каждого поля данных фигуры не будет создан элемент, который требуется отобразить.

Чтобы применить рисунок, связанный с данными, к фигуре в документе, выполните указанные ниже действия.

  1. На странице документа выберите фигуру, к которой будет применяться рисунок, связанный с данными.

Примечание :  Чтобы выбрать несколько фигур на странице документа, нажмите клавишу CTRL и, удерживая ее, выберите все необходимые фигуры.

  1. На вкладке Данные в группе Отображение данных выберите команду Рисунки, связанные с данными и в группе Доступные рисунки, связанные с данными щелкните требуемый рисунок, связанный с данными.

Дополнительные сведения о создании и применении рисунков, связанных с данными, см. в статье Использование рисунков, связанных с данными, для улучшения представления данных.

В начало страницы

Действие 3. Отображение схемы в веб-части SharePoint

  1. На странице сайта SharePoint, на которую планируется добавить веб-часть, откройте вкладку Страница и в группе Правка нажмите кнопку Изменить.

  2. В группе Средства правки откройте вкладку Вставка и в группе Веб-части нажмите кнопку Веб-часть. После этого выполните указанные ниже действия.

    1. В группе Категории выберите команду Бизнес-данные.

    2. В группе Веб-части выберите команду Visio Web Access.

    3. Нажмите кнопку Добавить.

  3. В веб-части Visio Web Access щелкните ссылку, чтобы открыть область инструментов.

  4. В области инструментов разверните раздел Отображение веб-документа и с помощью поля URL-адрес веб-документа укажите веб-документ Visio, который необходимо отобразить.

Важно :  Перед тем как использовать Visio Web Access для отображения схемы в веб-части, файл Visio потребуется опубликовать на сайте SharePoint в качестве веб-документа. Дополнительные сведения о публикации веб-документов Visio на сайте SharePoint см. в статье Схема: публикация документов Visio на сайте SharePoint (на английском языке).

  1. В нижней части области инструментов нажмите кнопку Применить, а затем — кнопку ОК.

Дополнительные сведения о способах отображения веб-документов Visio в веб-частях см. в статье Просмотр веб-документа Visio в веб-части.

В начало страницы

Дополнительное действие. Добавление интерактивности в веб-часть Visio Web Access

Обладая навыками написания кода ECMAScript, в веб-части Visio Web Access можно добавлять визуальные слои, которые отображают дополнительные сведения о фигурах в документах Visio.

Дополнительные сведения о создании интерактивных элементов для документов Visio на страницах веб-частей см. в статье MSDN: создание гибридных документов с использованием кода ECMAScript в приложении Visio 2010 для отображения на сайте SharePoint Server 2010 (на английском языке).

Совершенствование навыков
Перейти к обучению
Первоочередный доступ к новым возможностям
Присоединиться к программе предварительной оценки Office

Были ли сведения полезными?

Спасибо за ваш отзыв!

Благодарим за отзыв! Возможно, будет полезно связать вас с одним из наших специалистов службы поддержки Office.

×