Суммирование значений с учетом нескольких условий

Суммирование значений с учетом нескольких условий

Предположим, что вы хотите суммировать значения с несколькими условиями, например получить сумму продаж определенного продукта в определенном регионе. В этом случае в формуле следует использовать функцию СУММЕСЛИМН.

Вот пример с двумя условиями: необходимо узнать сумму продаж товара Мясо (из столбца C) в регионе Южный (из столбца A).

Данные на листе Excel

Вам понадобится такая формула:

=СУММЕСЛИМН(D2:D11,A2:A11,"Южный",C2:C11,"Мясо")Результат — 14719. Вот как работает эта формула.

=СУММЕСЛИМН — это арифметическая формула. Она подсчитывает числа, которые в этом случае находятся в столбце D. Начнем с того, что укажем формуле на расположение чисел:

  • =СУММЕСЛИМН(D2:D11,

Другими словами, вы хотите, чтобы формула суммировала числа в этом столбце, если они соответствуют определенным условиям. Этот диапазон ячеек является первым аргументом или частью данных, необходимых для запуска функции.

Дальше вам нужно найти данные, которые соответствуют двум условиям, поэтому вы вводите первое условие, указывая функции, где расположены данные (A2:A11), и название условия («Южный»). Обратите внимание, что между аргументами ставится запятая.

  • =СУММЕСЛИМН(D2:D11;A2:A11;"Южный";

Кавычки вокруг слова "Южный" указывают на то, что используются текстовые данные.

Наконец, вы вводите аргументы для второго условия — диапазон ячеек (C2:C11), которые содержат слово "Мясо", а также само слово (заключенное в кавычки), чтобы приложение Excel смогло их сопоставить. Закончите формулу закрывающейся скобкой ), затем нажмите клавишу ВВОД и вы получите результат 14 719.

  • =СУММЕСЛИМН(D2:D11;A2:A11,"Южный";C2:C11,"Мясо")

Если вы вводите в Excel функцию СУММЕСЛИМН и не помните аргументов, помощь рядом. После введения выражения =СУММЕСЛИМН( под формулой появляется автозавершение формул со списком аргументов в правильном порядке.

Если посмотреть на изображение использования функции автозавершения формул и списка аргументов, то в нашем примере диапазон_суммирования — это диапазон D2:D11, представляющий собой столбец с числами, которые вы хотите просуммировать; диапазон_условия1 — это диапазон A2.A11, представляющий собой столбец с данными, в котором находится условие1 — “Южный”.

Использование автозаполнения формул при вводе функции СУММЕСЛИМН

По мере того, как вы вводите формулу, в автозавершении формулы появятся остальные аргументы (здесь они не показаны); диапазон_условия2 — это диапазон C2:C11, представляющий собой столбец с данными, в котором находится условие2 — “Мясо”.

Если вы нажмете СУММЕСЛИМН в автозавершении формулы, откроется статья со справкой.

Попробуйте попрактиковаться

Если вы хотите попрактиковаться с функцией СУММЕСЛИМН, воспользуйтесь предоставленными демонстрационными данными с формулой, в которой фигурирует эта функция.

Вы можете работать с демонстрационными данными непосредственно в этой книге веб-приложения Excel Online. Изменяйте значения и формулы или добавляйте свои собственные, чтобы увидеть, как мгновенно изменятся результаты.

Скопируйте все ячейки из приведенной ниже таблицы и вставьте их в ячейку A1 нового листа Excel. Вы можете отрегулировать ширину столбцов, чтобы формулы лучше отображались.

Регион

Продавец

Что следует ввести

Продажи

Южный

Орехов

Напитки

3571

Западный

Егоров

Молочные продукты

3338

Восточный

Песоцкий

Напитки

5122

Северный

Песоцкий

Молочные продукты

6239

Южный

Маринова

Сельхозпродукты

8677

Южный

Егоров

Мясо

450

Южный

Егоров

Мясо

7673

Восточный

Песоцкий

Сельхозпродукты

664

Северный

Егоров

Сельхозпродукты

1500

Южный

Маринова

Мясо

6596

Формула

 

Описание

Результат

'=СУММЕСЛИМН(D2:D11,A2:A11,
"Южный", C2:C11,"Мясо")

Суммируются продажи по категории "Мясо" из
столбца C в регионе "Южный"
из столбца A (результат — 14 719).

=СУММЕСЛИМН(D2:D11,A2:A11,
"Южный", C2:C11,"Мясо")

Примечания: 

  • Дополнительные примеры можно найти в статьеФункция СУММЕСЛИМН.

  • Если вы хотите подсчитать итоговое значение только для одного диапазона с учетом значения в другом диапазоне, используйте функцию СУММЕСЛИМН.

К началу страницы

Совершенствование навыков работы с Office
Перейти к обучению
Первоочередный доступ к новым возможностям
Присоединиться к программе предварительной оценки Office

Были ли сведения полезными?

Спасибо за ваш отзыв!

Благодарим за отзыв! Возможно, будет полезно связать вас с одним из наших специалистов службы поддержки Office.

×