Суммирование значений с учетом нескольких условий

Если вы сложить суммировать значения с учетом нескольких условий, например получить сумму продаж продукта в определенном регионе, используйте функцию СУММЕСЛИМН в формуле.

Вот пример с двумя условиями: необходимо узнать сумму продаж товара Мясо (из столбца C) в регионе Южный (из столбца A).

Данные на листе Excel

Вам понадобится такая формула:

=СУММЕСЛИМН(D2:D11,A2:A11,"Южный",C2:C11,"Мясо")Результат — 14719. Вот как работает эта формула.

=СУММЕСЛИМН — это арифметическая формула. Она подсчитывает числа, которые в этом случае находятся в столбце D. Начнем с того, что укажем формуле на расположение чисел:

  • =СУММЕСЛИМН(D2:D11,

Другими словами, вы хотите, чтобы формула суммировала числа в этом столбце, если они соответствуют определенным условиям. Этот диапазон ячеек является первым аргументом или частью данных, необходимых для запуска функции.

Дальше вам нужно найти данные, которые соответствуют двум условиям, поэтому вы вводите первое условие, указывая функции, где расположены данные (A2:A11), и название условия («Южный»). Обратите внимание, что между аргументами ставится запятая.

  • =СУММЕСЛИМН(D2:D11;A2:A11;"Южный";

Кавычки вокруг слова "Южный" указывают на то, что используются текстовые данные.

Наконец, вы вводите аргументы для второго условия — диапазон ячеек (C2:C11), которые содержат слово "Мясо", а также само слово (заключенное в кавычки), которое нужно найти. Закончите формулу закрывающейся скобкой ), нажмите клавишу ВВОД, и вы получите результат 14719.

  • =СУММЕСЛИМН(D2:D11;A2:A11,"Южный";C2:C11,"Мясо")

Если вы вводите функцию СУММЕСЛИМН и не помните аргументов, не волнуйтесь. После ввода выражения =СУММЕСЛИМН( под формулой появляется список аргументов в нужном порядке.

Если посмотреть на изображение использования функции автозавершения формул и списка аргументов, то в нашем примере диапазон_суммирования — это диапазон D2:D11, представляющий собой столбец с числами, которые вы хотите просуммировать; диапазон_условия1 — это диапазон A2.A11, представляющий собой столбец с данными, в котором находится условие1 — “Южный”.

Использование автозавершения формулы для введения функции СУММЕСЛИМН

По мере ввода вводите формулы функция автозавершения предлагает остальные аргументы; диапазон_условия2 — это диапазон C2:C11, представляющий собой столбец с данными, в котором находится условие2 — "Мясо".

Попробуйте попрактиковаться

Скопируйте все данные из приведенной ниже таблицы и вставьте их в ячейку A1 нового листа. Вы можете настроить ширину столбцов, чтобы лучше видеть формулы.

Регион

Продавец

Что следует ввести

Продажи

Южный

Орехов

Напитки

3571

Западный

Егоров

Молочные продукты

3338

Восточный

Песоцкий

Напитки

5122

Северный

Песоцкий

Молочные продукты

6239

Южный

Маринова

Сельхозпродукты

8677

Южный

Егоров

Мясо

450

Южный

Егоров

Мясо

7673

Восточный

Песоцкий

Сельхозпродукты

664

Северный

Егоров

Сельхозпродукты

1500

Южный

Маринова

Мясо

6596

Формула

 

Описание

Результат

'=СУММЕСЛИМН(D2:D11,A2:A11,
"Южный", C2:C11,"Мясо")

Суммируются продажи по категории "Мясо" из
столбца C в регионе "Южный"
из столбца A (результат — 14 719).

=СУММЕСЛИМН(D2:D11,A2:A11,
"Южный", C2:C11,"Мясо")

Совершенствование навыков
Перейти к обучению
Первоочередный доступ к новым возможностям
Присоединиться к программе предварительной оценки Office

Были ли сведения полезными?

Спасибо за ваш отзыв!

Благодарим за отзыв! Возможно, будет полезно связать вас с одним из наших специалистов службы поддержки Office.

×