Создать решение отслеживания активов с помощью InfoPath и Excel

Примечание:  Мы стараемся как можно оперативнее обеспечивать вас актуальными справочными материалами на вашем языке. Эта страница переведена автоматически, поэтому ее текст может содержать неточности и грамматические ошибки. Для нас важно, чтобы эта статья была вам полезна. Просим вас уделить пару секунд и сообщить, помогла ли она вам, с помощью кнопок внизу страницы. Для удобства также приводим ссылку на оригинал (на английском языке) .

Microsoft Office InfoPath позволяет создавать шаблоны форм для ввода данных и семейства сайтов. Microsoft Office Excel 2007 позволяет пользователям вычислить, диаграммы и анализ данных. С помощью оба эти программы и XML, можно без труда создавать простой, но вступления в силу, нет кода бизнес-решения для отслеживания активов в компании.

Обзор решения для отслеживания активов

В этой статье

Общие сведения о создании решения для отслеживания активов

Шаг 1: Настройка шаблона формы отслеживания активов

Шаг 2: Сопоставление файла схемы и настроить макет таблицы в Excel

Шаг 3: Создание итогового отчета сводной таблицы и сводной диаграммы

Действие 4: Собирать сведения активов от пользователей

Действие 5: Импорт форм в Excel

Заключительные соображения: рекомендуется использовать SharePoint списка или базы данных Access

Общие сведения о создании решения для отслеживания активов

Можно выполнять обмен данными XML между InfoPath и Excel. Несмотря на то, что команды Экспорт Infopath является простым, просто отправка данных формы в Microsoft Excel, есть другой подход, вы можете попробовать дающие более эффективно. Явно сопоставление файла схемы InfoPath XML (XSD) в Excel, а затем импортировав формы InfoPath файлы (XML) в Microsoft Excel можно настроить макет данных и лучше использовать возможности в Excel, чтобы помочь вам управлять и анализировать данные более эффективно.

В этой статье мы используем шаблон формы InfoPath отслеживания активов образец для демонстрации, как можно сделать InfoPath, XML и совместной работы Microsoft Excel. Представьте, что каждый год организации учитывает активов в office для каждого сотрудника. Отчет Excel запустите, помогающие решить, как распределить бюджет оборудования на следующий год. Следующая диаграмма является узнать, как собрать, отслеживать и отчет данных активов в отделе.

a

1 будет создан шаблон формы отслеживания активов.

2. файл схемы отображается в таблицу Excel и настроенный макет таблицы.

3. будет создана пустой таблиц и сводных диаграмм итогового отчета.

4 отслеживания активов форма используется для сбора данных от пользователей.

5. все данные формы экспортируется в таблицу Excel и обновлении отчетов сводных таблиц и сводных диаграмм.

Это решение включает в себя следующие роли пользователей и продукты:

Значок полной поддержки = необходимые Значок отсутствия поддержки = не требуется

Требования к программному обеспечению

Роли

Office InfoPath 2007

Office Outlook 2007

Office Excel 2007

Конструктор решений

Значок полной поддержки

Значок полной поддержки

Значок полной поддержки

Принимающий решения

Значок полной поддержки

Значок полной поддержки

Значок полной поддержки

Сотрудников

Значок полной поддержки

Значок полной поддержки

Значок отсутствия поддержки

К началу страницы

Шаг 1: Настройка шаблона формы отслеживания активов

Шаблон формы отслеживания активов, которая входит в состав InfoPath, позволяет собирать сведения о каждого средства в office сотрудника, отдел, сотрудника, к которой относится к категории ресурсы и сведения о каждом средстве. В этом решении конструктора форм отправляет шаблона формы для решения maker учетной записи электронной почты с помощью Office Outlook 2007.

Шаблон "Основные фонды"

Задача 1: Открытие и настройка шаблона формы отслеживания активов

Так как не удается Публикация шаблона формы в список получателей электронной почты, если он имеет управления поля форматированного текста, содержащее связанные изображения, необходимо внести небольшое изменение отслеживания активов образец шаблона формы.

  1. В меню файл выберите пункт Создание шаблона формы.

  2. В диалоговом окне Создание шаблона формы в разделе Открытие шаблона формы, нажмите кнопку Настройка образца.

  3. В диалоговом окне " Приступая к работе " выберите пункт Образец - отслеживания активов и в группе Формы задач, нажмите кнопку Изменить эту форму.

  4. Щелкните правой кнопкой мыши элемент управления assetNotes, выберите пункт Свойства Поле форматированного текста, перейдите на вкладку Отображение и затем в разделе Доступное форматирование, снимите флажок Связанные рисунки.

Задача 2: Определение параметры отправки

Чтобы определить параметры отправки, чтобы сотрудники могли отправлять формы уникальным именем файла XML решения maker учетную запись электронной почты как вложенный файл является следующей задачи.

  1. В меню Сервис выберите пункт Параметры отправки.

  2. В диалоговом окне Параметры отправки установите флажок Разрешить пользователям отправлять эту форму.

  3. Нажмите кнопку Отправка данных формы в одном месте и выберите в списке электронной почты.

  4. Нажмите кнопку Добавить.

    Откроется окно Мастера подключения данных.

  5. В поле Кому введите псевдоним этом, который будет получать отправленных форм.

  6. Чтобы указать строку уникальной темой в поле Тема:

    • Нажмите кнопку Вставить формулу Кнопка формулы .

    • Введите следующую формулу:

concat(my:employee/my:employeeName, my:employee/my:employeeDepartment)

  • Нажмите кнопку Проверить формулу, а затем нажмите кнопку ОК.

  • В диалоговом окне Общие сведения введите соответствующее сообщение или добавить важные инструкции для этого решения.

  • Нажмите кнопку Далее.

  • На следующей странице мастера нажмите кнопку Отправка данных формы в виде вложения и установите флажок Присоединение шаблона формы, чтобы убедиться, что пользователи могут открыть форму.

    Это помогает обеспечить сотрудников доступ к файлу шаблона формы (расширением XSN) в случае, если их доступ запрещен из расположения сети.

  • Укажите уникальное имя файла для каждой формы-файла в поле Имя вложения:

    1. Нажмите кнопку Вставить формулу Кнопка формулы .

    2. Введите ту же формулу, в строке Тема:

concat(my:employee/my:employeeName, my:employee/my:employeeDepartment)

  1. Нажмите кнопку Проверить формулу, а затем нажмите кнопку ОК.

  • Нажмите кнопку Далее.

  • На следующей странице мастера в поле Введите имя для этого подключения данных введите описательное имя для этой отправки подключения к данным.

  • Убедитесь, что данные правильно в разделе « Сводка » и нажмите кнопку Готово.

  • Сохраните форму папку сеть общего пользования, доступных в этом и для всех сотрудников.

К началу страницы

Шаг 2: Сопоставление файла схемы и настроить макет таблицы в Excel

Связь между InfoPath и Excel, необходимо три задачи: извлечения файла схемы для шаблона формы отслеживания активов, сопоставление этот файл схемы в Excel и настройка макета по умолчанию в таблице Excel, которая будет содержать импортируемого XML-файла файлы данных формы.

Задача 1: Извлечь файл схемы из InfoPath

  1. В приложении InfoPath откройте файл шаблона форм отслеживания активов.

  2. В меню Сервис выберите Изменить эту форму.

  3. В меню файл выберите Сохранить как исходные файлы.

  4. В диалоговом окне Обзор папок выберите папку или создайте новую папку, где вы хотите сохранить файл схемы.

Обратите внимание, расположение папки, где будут сохранены все исходные файлы и имя файла схемы, в этом случае myschema.xsd, которая содержит определение схемы XML-данных формы.

Задача 2: Сопоставление файла схемы InfoPath в Excel

  1. Создание файла Excel, а затем сохраните его в месте, доступных в этом.

  2. В Excel Если вкладка Разработчик не отображается, сделайте следующее:

    1. Нажмите кнопку Microsoft Office Изображение кнопки Office , а затем — кнопку Параметры Excel.

    2. Выберите категорию Популярные, а затем в разделе Основные параметры работы с Excel установите флажок Показывать вкладку "Разработчик" на ленте и нажмите кнопку ОК.

      Примечание: Лента входит в Пользовательский интерфейс Microsoft Office Fluent.

  3. На вкладке Разработчик в группе XML нажмите кнопку Источник.

    Группа XML на ленте

    Отобразится в области задач Источник XML.

  4. Нажмите кнопку Карты XML и в диалоговом окне Карты XML нажмите кнопку Добавить.

  5. На компьютере под управлением Windows Vista   

    1. В адресной строке выберите диск или папку, содержащую файл myschema.xsd , созданную на шаге 2 раздела, задачи 1: извлечь файл схемы из InfoPath.

      На компьютере под управлением Microsoft Windows XP   

    2. В списке Искать выберите диск или папку, содержащую файл myschema.xsd , созданную на шаге 2 раздела, задачи 1: извлечь файл схемы из InfoPath.

  6. Щелкните файл, а затем нажмите кнопку Открыть.

  7. В появившемся диалоговом окне Нескольких корни щелкните корневой узел assetTracking, определенные в файле myschema.xsd и нажмите кнопку ОК.

    Карта XML отобразится в области задач XML-источник.

  8. Перетащите элемент узел ns1:asset, который является повторяющегося элемента XML, на листе место, где вы хотите разместить таблицу Excel.

    Сопоставление файла схемы Infopath c Excel

Задача 3: Настройка макета таблицы Excel

По умолчанию Excel использует имена XML-элементов в заголовках столбцов в таблице. Однако вы можете изменить заголовки столбцов, изменяя ячейки заголовков столбцов.

  1. Чтобы изменить заголовки столбцов по умолчанию, сохранить выбранные таблицы Excel, найдите следующий префикс строка ns1:asset и удалите его. Например можно изменить ns1:assetIDидентификатору.

    Настройка заголовков таблицы Excel

  2. Чтобы изменить ширину столбца, нажмите кнопку Выделить все и дважды щелкните границу заголовка любого столбца.

К началу страницы

Шаг 3: Создание итогового отчета сводной таблицы и сводной диаграммы

Оценили с помощью сводной таблицы и сводной диаграммы анализа, исследованию и визуализации сводных данных. Настройте отчеты сводных таблиц и сводных диаграмм, которые вы хотите использовать в этом случае досрочно, он будет простой операции для принимающий решения для создания отчета с вставленной данных более поздней версии.

  1. Выделите ячейку в таблице Excel.

  2. На вкладке Вставка в группе таблицы нажмите кнопку Сводная таблица и нажмите кнопку Сводная таблица.

    Изображение ленты Excel

    Откроется диалоговое окно Создание сводной таблицы.

  3. Чтобы поместить отчет сводной таблицы на новый лист, начиная с ячейки A1, выберите Новый лист и нажмите кнопку ОК.

    Excel добавит пустой отчет сводной таблицы в указанное место и откроет Список полей сводной таблицы, можно добавить поля, создать макет и настроить отчет сводной таблицы.

  4. Создание перекрестной табличного отчета по данным, перетащите поле « идентификатор » в область значений, отдел поле в область названия столбцов, поле « Категория » в область метки строк и поле « назначено » в область фильтра отчета.

  5. Щелкните отчет сводной таблицы.

  6. На вкладке Вставка в группе диаграммы выберите тип диаграммы панели.

    Изображение ленты Excel

  7. В разделе плоских линейчатых выберите Линейчатая с группировкой.

  8. Изменение размера и расположения отчета сводной диаграммы для нужного языка.

Пустые отчеты сводной таблицы и сводной диаграммы

К началу страницы

Действие 4: Собирать сведения активов от пользователей

Теперь, что шаблон формы готов для заполнения для всех сотрудников, вам нужно опубликовать форму и отправьте его каждого сотрудника. При каждом сотрудником, заполненной формы, он отправляется как файла данных XML (XML), вложенных в сообщения электронной почты в решения maker учетной записи электронной почты. Затем можно перемещать все сообщения этом выделенный папку InfoPath в Outlook. В этом случае рекомендуется назначении определенного периода времени для всех пользователей для завершения форм, чтобы этом можно запустить отчет с заполненные формы достижении крайний срок сбора данных.

ввод данных в формах отслеживания активов

  1. В приложении InfoPath, откройте шаблон формы (расширением XSN), который вы сохранили в Шаг 1: разработка шаблона формы образец отслеживания активов

  2. В меню Сервис выберите Изменить эту форму.

  3. В меню файл нажмите кнопку Опубликовать.

  4. В мастере публикации нажмите кнопку список получателей электронной почты и нажмите кнопку Далее.

  5. На следующей странице мастера в поле имя шаблона формы введите имя для шаблона формы и нажмите кнопку Далее. Имя шаблона формы будет отображаться в поле Тема заголовок сообщения, которое отправляется получателям сообщения электронной почты.

  6. Кроме того на следующей странице мастера, можно создать столбцы, которые будут отображаться в папке Outlook для упорядочения сообщений электронной почты.

  7. Нажмите кнопку Далее.

  8. Нажмите кнопку Опубликовать.

  9. По завершении мастер публикации публикации шаблона формы, откроется сообщение электронной почты с помощью формы.

  10. Заполните сообщение, введите имена сотрудников или использовать список рассылки и отправьте сообщение.

В Outlook можно организовать этом всех отправляемых XML-форм в одном из двух способов:

  • Если поле формы InfoPath папки сообщение появляется при первом запуске открывает сообщение, нажмите кнопку Создать папку формы.

  • Создание правила в Outlook, чтобы переместить все связанные формы InfoPath в папку InfoPath.

    Управление сообщениями с помощью правилДополнительные сведения, см.

К началу страницы

Действие 5: Импорт форм в Excel

Так как вы уже создали действия книгу Excel, 2 и 3, можно просто для принятие решений для экспорта и просмотра данных формы. Принятие решений просто должен Экспорт XML-файлы (XML) из Outlook, импортировать все файлы формы (XML) в книгу Excel, а затем обновите данные.

Задача 1: Экспорт форм из Outlook в папку Windows

  1. В Outlook выберите папку, содержащую все формы, полученных от сотрудников и нажмите клавиши CTRL + A, чтобы выделить все сообщения электронной почты формы.

  2. Щелкните правой кнопкой мыши выделенного фрагмента, наведите указатель на InfoPath действия и нажмите кнопку Экспорт форм.

  3. В диалоговом окне Экспорт форм выберите папку и нажмите кнопку ОК.

Задача 2: Импорт форм в Excel

  1. В книге Excel, созданной в Шаг 2: сопоставление файла схемы и настроить макет таблицы в Excel, выберите один из сопоставленных ячеек в таблице Excel.

  2. На вкладке Разработчик в группе XML нажмите кнопку Импорт.

    Группа XML на ленте

    Откроется диалоговое окно Импорт XML.

  3. На компьютере под управлением Windows Vista   

  4. Выполните одно из указанных ниже действий.

    • Если данные файлы находятся в смежных, удерживая нажатой клавишу SHIFT и выберите первый и последний файл в списке.

    • Если файлы не являются смежными, нажмите клавишу CTRL и нажмите кнопку каждого файла, который нужно импортировать в списке.

  5. Нажмите кнопку Импорт.

    Таблица Excel с импортированными данными

По умолчанию Excel, перезаписывают всех имеющихся данных в сопоставленных ячейках которой находится нужный конечный результат бизнес-решения. Тем не менее принимающий решения например, импортировать данные несколько раз для отслеживания хода выполнения до запланированной крайнего срока.

Примечание: В Excel, можно добавить данные с помощью параметра добавлять новые данные в существующие XML-таблицы (на вкладке Разработчик в группе XML нажмите Свойства карты ), который может подойти для других решений.

Дополнительные сведения читайте в статье Импорт XML данных.

Задача 3: Обновление отчетов сводных таблиц и сводных диаграмм

  • Щелкните ячейку в отчете сводной таблицы.

  • На вкладке Параметры в группе данные щелкните стрелку рядом с кнопкой Обновить все и нажмите кнопку Обновить.

    Лента Outlook

Итоговый отчет сводной таблицы или сводной диаграммы

Книга Excel теперь содержит все данные и Сводка сообщает о необходимости помогают выделять бюджета оборудования на следующий год. Конечно же, можно сделать дальнейшего анализа в книге Excel, при необходимости, таких как сортировка, фильтрация или условное форматирование данных.

К началу страницы

Заключительные соображения: рекомендуется использовать SharePoint списка или базы данных Access

В качестве альтернативы рекомендуется использовать SharePoint списка или базы данных Access, вместо XML, для перемещения данных между InfoPath и Excel.

Использование списка SharePoint

Из InfoPath можно легко использовать списка SharePoint как источник данных только для чтения. Выполните одно из следующих действий:

  • Из списка SharePoint экспортируйте данные в Excel, которое автоматически создает подключение к данным в Microsoft Excel.

  • В Excel явно создайте подключение к данным к списку SharePoint.

После создания подключения к данным, можно обновить данные в Excel, чтобы получить актуальные данные.

Список SharePoint можно использовать для добавления и обновления данных, чтобы отобразить элемент из списка (например, сложные длинный элемента или лучший отображаться по вертикали) с помощью формы InfoPath и затем с помощью Excel для дальнейшего анализа данных.

Объединение InfoPath, списка SharePoint и Excel

1. Отображение одного элемента для удобного просмотра в InfoPath.

2. Добавление и обновление данных в список SharePoint.

3. обновление и сообщите актуальные с Excel.

Для получения дополнительных сведений обратитесь к статье Добавление подключения к данным в список или библиотеку документов SharePoint

Использование базы данных Access

В InfoPath можно создавать подключение чтение и запись к базе данных Access. В Excel явным образом можно создавать подключение данных к базе данных Access, можно обновить, чтобы получить актуальные данные. Можно даже определения соединения автоматическое обновление при открытии книги или периодически обновлять, таких как каждые 5 минут.

Базы данных Access можно использовать как посредник между InfoPath и Excel. При отправке данных формы InfoPath в Access, обновите базы данных Access. При обновлении подключения к данным в Excel можно получить обновленные данные из Access. В результате вы отправляете данные косвенно из InfoPath в книге Excel.

Объединение InfoPath, Access и Excel

1. отобразите и отправка формы для базы данных Access.

2. хранения данных в базе данных Access.

3. обновление и сообщите актуальные с Excel.

Для получения дополнительных сведений просмотрите Оформление шаблона формы, основанный на базе данных Microsoft Access.

Совет: Знаете ли вы, что можно создать форму Microsoft InfoPath непосредственно из Access 2007? Если ваши пользователи Outlook 2007 и InfoPath 2007, преобразованную в формат, может собирать данные из различных пользователей непосредственно из Access 2007 с помощью мастера собирать данные из сообщения электронной почты. Дополнительные сведения приведены в разделе справки 2007 доступ, Сбор данных по электронной почте.

К началу страницы

Совершенствование навыков работы с Office
Перейти к обучению
Первоочередный доступ к новым возможностям
Присоединиться к программе предварительной оценки Office

Были ли сведения полезными?

Спасибо за ваш отзыв!

Благодарим за отзыв! Возможно, будет полезно связать вас с одним из наших специалистов службы поддержки Office.

×