Создание форм и отчетов Access из списка SharePoint

Важно :  Данная статья переведена с помощью машинного перевода, см. Отказ от ответственности. Используйте английский вариант этой статьи, который находится здесь, в качестве справочного материала.

Можно создания форм и отчетов из списка SharePoint и использовать их в качестве представления. Пользователи сайта SharePoint установлено приложение Access 2007 можно открыть эти формы и отчеты с помощью меню Вид списка SharePoint. Вы можете сделать Access представление по умолчанию для списка.

Представления, созданные с помощью Access 2007 хранятся в файл базы данных на сервере Windows SharePoint Services. При открытии доступа представления списка SharePoint, запускается доступ, и он отображается в форме или отчете. Так как база данных хранится на сайте SharePoint, можно открыть представление другими пользователями сайта. Пользователь не требуется знать местоположение на сайте SharePoint, содержащей представление Access для представления с помощью файла базы данных. Кроме того, пользователь не еще нужно знать, как запустить программу Microsoft Access — это обрабатывается автоматически на сайте SharePoint.

Примечание : Пользователю необходимо приложение Access 2007, установленное на компьютере, чтобы создавать, использовать и изменять представления Access на узле SharePoint.

Выберите действие

Создание представления Access списка SharePoint

Убедитесь в Access представление по умолчанию для списка SharePoint

Использование представления Access списка SharePoint

Изменение представления Access списка SharePoint

Создание представления Access списка SharePoint

При создании представления Access списка SharePoint приложение Access запускается автоматически. В Access представление может быть основано на различных шаблонах форм и отчетов, поэтому представление можно сделать пользовательским. Опубликовав представление на узле SharePoint, нетрудно сделать его доступным для других пользователей.

Примечание : Чтобы создать представление списка SharePoint, необходимо обладать разрешением на управление списками Windows SharePoint Services, которое по умолчанию включено в уровень разрешения работы с макетом.

Выполните следующую процедуру для создания представления Access списка SharePoint, отображаемого в обозревателе.

  1. На узле SharePoint в меню Вид Раскрывающееся меню щелкните команду Создать представление.

  2. На странице Создание представления щелкните Представление Access.

    Запустится приложение Access, после чего будет предложено сохранить локальную копию базы данных, которая будет содержать новое представление.

  3. В диалоговом окне Сохранить локальную копию найдите местоположение компьютера, на котором следует сохранить копию, введите имя локальной копии в поле Имя файла и нажмите кнопку Сохранить.

    Локальная копия сохраняется и открывается, затем появляется диалоговое окно Создание представления Access.

  4. В диалоговом окне Создание представления Access дважды щелкните необходимый тип представления.

    Приложение Access создает новое представление и открывает его в режиме макета.

  5. В этом режиме можно настроить новое представление или переключиться в режим конструктора.

    В режиме макета можно изменить размер и расположение элементов управления в представлении (например, меток и полей), однако невозможно добавить в представление дополнительные элементы управления. В режиме макета предусмотрен просмотр данных, с помощью которого можно увидеть, как вносимые изменения будут выглядеть в завершенном представлении.

    В режиме конструктора можно изменить размер и расположение элементов управления, а также добавить в представление дополнительные элементы управления. Однако в режиме конструктора нет просмотра данных.

    Можно неограниченно переключаться между режимом конструктора и режимом макета. Если режим конструктора используется для добавления элементов управления, то в режиме макета можно просмотреть и изменить местоположение этих элементов, просматривая при этом данные.

  6. После внесения настроек щелкните команду Опубликовать на узле SharePoint на панели сообщений.

    панель инструментов

    Появится диалоговое окно Публикация на веб-сервере.

    Если панель сообщений не появится, отобразить ее можно следующим образом:

    • На вкладке Инструменты для баз данных в группе Показать или скрыть щелкните Панель сообщений.

  7. По умолчанию Access сохраняет представление в файле базы данных, расположенном в библиотеке общих документов на узле SharePoint, — этот узел содержит список, на основе которого создается представление. В большинстве случаев этого достаточно, однако можно выбрать другую библиотеку документов для хранения базы данных путем указания этой библиотеки в поле Сохранить в диалогового окна Публикация на веб-сервере. Это делается для более детального управления доступом к представлению — например, чтобы пользователи могли открыть представление в режиме чтения или редактирования. На узле SharePoint могут также располагаться отдельные библиотеки, предназначенные для публикации представлений Access. В этом случае может понадобиться изменить место, определяемое в поле Сохранить в, для выбора необходимой библиотеки.

    При выборе библиотеки можно обратиться к администратору узла SharePoint.

  8. Access отображает имя базы данных в поле Имя файла диалогового окна Публикация на веб-сервере. Это имя соответствует имени базы данных, которая была сохранена как локальная копия. Можно изменить это имя при необходимости, но в большинстве случаев следует принять предложенное имя, так как будет проще запомнить, какая локальная база данных соответствует базе данных, опубликованной на узле SharePoint.

  9. Щелкните команду Опубликовать, чтобы сохранить базу данных на сайте SharePoint.

К началу страницы

Убедитесь в Access представление по умолчанию для списка SharePoint

При выборе Access представление по умолчанию для списка SharePoint представление Access автоматически открывается при попытке открыть список, если эти пользователи имеют доступ на компьютерах.

Важно : Если сделать представление Access представление по умолчанию, список посетителям не установлена Access 2007 не сможете с помощью списка.

  1. С помощью списка SharePoint, откройте меню Параметры нажмите кнопку Параметры списка.

  2. На странице « Параметры списка » в группе режимы просмотра, щелкните имя Access представление, которое вы хотите сделать представлением по умолчанию.

  3. На странице Изменение представления выберите сделать это представление по умолчанию и нажмите кнопку ОК.

К началу страницы

Использование представления Access списка SharePoint

Чтобы использовать представление Access списка SharePoint, необходимо выбрать представление Access в меню списка Вид.

  • В меню Вид Раскрывающееся меню щелкните имя представления Access. После запуска Access представление будет доступно только для чтения.

    В этом режиме можно изменять данные в представлении, а также печатать представление, однако невозможно изменить макет представления. Если необходимо изменить макет представления, изучите следующий раздел этой статьи — Изменение представления Access списка SharePoint.

К началу страницы

Изменение представления Access списка SharePoint

Чтобы изменить макет представления Access, необходимо сохранить локальную копию базы данных, содержащей представление Access, а затем внести в нее изменения. В дальнейшем можно использовать локальную копию представления или, если имеются соответствующие разрешения на узле SharePoint, опубликовать новое представление.

Примечание : Можно изменить локальную копию представления Access независимо от уровня разрешений Windows SharePoint Services. Однако чтобы опубликовать измененное представление на узле SharePoint, необходимо обладать разрешением на управление списками Windows SharePoint Services, которое по умолчанию включено в уровне разрешения работы с макетом. Если пользователь уже создавал представление Access, у него должно быть разрешение на управление списками. Чтобы узнать о необходимых разрешениях, пользователь должен обратиться к администратору узла SharePoint.

  1. В открытом представлении Access на панели сообщений щелкните Сохранить как.

    Кнопка «Сохранить как» на панели сообщений

    Примечание : Если панель сообщений не появится, отобразить ее можно следующим образом:

    • На вкладке Инструменты для баз данных в группе Показать или скрыть щелкните Панель сообщений.

  2. Нажмите кнопку Да при запросе на закрытие представления и любых других открытых объектов.

    Откроется диалоговое окно Сохранить как.

  3. В диалоговом окне Сохранить в укажите место, где необходимо сохранить локальную копию, введите имя локальной копии в поле Имя файла и нажмите кнопку Сохранить.

    Access сохраняет локальную копию базы данных и открывает ее.

  4. Выполните одно из следующих действий:

    • Чтобы изменить макет представления без добавления новых элементов управления, в области переходов щелкните правой кнопкой мыши представление, затем в контекстном меню выберите Режим макета.

      В режиме макета можно изменить размер и расположение элементов управления в представлении (например, меток и полей), однако невозможно добавить в представление дополнительные элементы управления. В режиме макета предусмотрен просмотр данных, с помощью которого можно увидеть, как вносимые изменения будут выглядеть в завершенном представлении.

    • Чтобы добавить или изменить элементы управления в представлении (например, метки или поля), в области переходов щелкните правой кнопкой мыши представление, затем в контекстном меню выберите Конструктор.

      В режиме конструктора можно изменить размер и расположение элементов управления, а также добавить к представлению дополнительные элементы управления. Однако в режиме конструктора нет просмотра данных.

      Примечание : Если необходимо изменить представление в режиме конструктора, а затем опубликовать измененное представление на узле SharePoint, не добавляйте в представление поля, которые не являются частью списка SharePoint.

  5. Можно неограниченно переключаться между режимом конструктора и режимом макета. Если режим конструктора используется для добавления элементов управления, то в режиме макета можно просмотреть и изменить местоположение этих элементов, просматривая при этом данные.

Публикация измененного представления Access на узле SharePoint

При наличии разрешения на управление списками после внесения изменений в представление можно опубликовать это представление, используя следующую процедуру.

Чтобы получить разрешение на управление списками, обратитесь к администратору узла SharePoint.

  1. Сохраните представление в локальной копии базы данных.

  2. Щелкните Опубликовать на узле SharePoint на панели сообщений.

    панель инструментов

    Примечание : При отсутствии разрешения на управление списками кнопка Опубликовать на узле SharePoint на панели сообщений не отображается. Если панель сообщений не появится, отобразить ее можно следующим образом:

    • На вкладке Инструменты для баз данных в группе Показать или скрыть щелкните Панель сообщений.

  3. В диалоговом окне Публикация на веб-сервере щелкните команду Опубликовать.

К началу страницы

Примечание : Отказ от ответственности относительно машинного перевода. Данная статья была переведена с помощью компьютерной системы без участия человека. Microsoft предлагает эти машинные переводы, чтобы помочь пользователям, которые не знают английского языка, ознакомиться с материалами о продуктах, услугах и технологиях Microsoft. Поскольку статья была переведена с использованием машинного перевода, она может содержать лексические,синтаксические и грамматические ошибки.

Совершенствование навыков
Перейти к обучению
Первоочередный доступ к новым возможностям
Присоединиться к программе предварительной оценки Office

Были ли сведения полезными?

Спасибо за ваш отзыв!

Благодарим за отзыв! Возможно, будет полезно связать вас с одним из наших специалистов службы поддержки Office.

×