Создание условных формул

Во многих задачах требуется проверить истинность условия или выполнить логическое сравнение выражений. Для создания условных формул можно использовать функции И, ИЛИ, НЕ и ЕСЛИ.

Например, в функции ЕСЛИ используются аргументы, указанные ниже.

Формула с функцией ЕСЛИ

Формула с функцией ЕСЛИ

Изображение кнопки  логическое_выражение: условие, которое требуется проверить.

Выноска 2 значение_если_истина: значение, возвращаемое, если условие истинно.

Изображение кнопки значение_если_ложь: значение, возвращаемое, если условие ложно.

Дополнительные сведения о создании формул см. в разделе Создание и удаление формул.

В этой статье

Создание условной формулы с результатом, являющимся логическим значением (ИСТИНА или ЛОЖЬ)

Создание условной формулы с результатом в виде других вычислений или значений, отличных от ИСТИНА или ЛОЖЬ

Создание условной формулы с результатом, являющимся логическим значением (ИСТИНА или ЛОЖЬ)

Для выполнения этой задачи используются функции И, ИЛИ и НЕ, а также операторы (см. пример ниже).

Пример

Чтобы этот пример проще было понять, скопируйте его на пустой лист.

Копирование примера

  1. Выделите пример, приведенный в этой статье.

    Важно : Не выделяйте заголовки строк и столбцов.

    выбор примера из справки в Excel 2013 для Windows

    Выделение примера из справки

  2. Нажмите клавиши CTRL+C.

  3. Создайте пустые книгу или лист в Excel.

  4. На листе выделите ячейку A1 и нажмите клавиши CTRL+V.

Важно : Чтобы пример заработал должным образом, его необходимо вставить в ячейку A1 листа.

  1. Чтобы переключиться между просмотром результатов и просмотром формул, возвращающих эти результаты, нажмите клавиши CTRL+` (апостроф) или на вкладке Формулы в группе Зависимости формул нажмите кнопку Показать формулы.

Скопировав пример на пустой лист, его можно настроить в соответствии с конкретными требованиями.

1

2

3

4

5

6

7



8



9


10


11



12

A

B

Данные

15

9

8

Винты

Шурупы

Формула

Описание (результат)

=И(A2>A3; A2<A4)

Определяет, выполняется ли следующее условие: значение в ячейке A2 больше значения A3 и меньше значения A4 (ЛОЖЬ).

=ИЛИ(A2>A3; A2<A4)

Определяет, выполняется ли следующее условие: значение в ячейке A2 больше значения A3 или меньше значения A4 (ИСТИНА).

=НЕ(A2+A3=24)

Определяет, выполняется ли следующее условие: сумма значений в ячейках A2 и A3 не равняется 24 (ЛОЖЬ).

=НЕ(A5="Винты")

Определяет, выполняется ли следующее условие: значение в ячейке A5 не равняется строке «Винты» (ЛОЖЬ).

=ИЛИ(A5<>"Винты";A6 = "Шурупы")

Определяет, выполняется ли следующее условие: значение в ячейке A5 не равняется строке «Винты» или значение в ячейке A6 равняется строке «Шурупы» (ИСТИНА).

Дополнительные сведения об использовании этих функций см. в разделах Функция И, Функция ИЛИ и Функция НЕ.

К началу страницы

Создание условной формулы с результатом в виде других вычислений или значений, отличных от ИСТИНА или ЛОЖЬ.

Для выполнения этой задачи используются функции ЕСЛИ, И и ИЛИ, а также операторы (см. пример ниже).

Пример

Чтобы этот пример проще было понять, скопируйте его на пустой лист.

Копирование примера

  1. Выделите пример, приведенный в этой статье.

Важно : Не выделяйте заголовки строк и столбцов.

выбор примера из справки в Excel 2013 для Windows

Выделение примера из справки

  1. Нажмите клавиши CTRL+C.

  2. Создайте пустые книгу или лист в Excel.

  3. На листе выделите ячейку A1 и нажмите клавиши CTRL+V.

Важно : Чтобы пример заработал должным образом, его необходимо вставить в ячейку A1 листа.

  1. Чтобы переключиться между просмотром результатов и просмотром формул, возвращающих эти результаты, нажмите клавиши CTRL+` (апостроф) или на вкладке Формулы в группе Зависимости формул нажмите кнопку Показать формулы.

Скопировав пример на пустой лист, его можно настроить в соответствии с конкретными требованиями.

1

2

3

4

5

6

7


8



9



10



11




12



13



14




15



16

A

B

Данные

15

9

8

Винты

Шурупы

Формула

Описание (результат)

=ЕСЛИ(A2=15; "ОК"; "Неверно")

Если значение в ячейке A2 равно 15, возвращается «ОК», в противном случае — «Неверно» (ОК).

=ЕСЛИ(A2<>15; "ОК"; "Неверно")

Если значение в ячейке A2 не равно 15, возвращается «ОК», в противном случае — «Неверно» (Неверно).

=ЕСЛИ(НЕ(A2<=15); "ОК"; "Неверно")

Если значение в ячейке A2 не меньше и не равно 15, возвращается «ОК», в противном случае — «Неверно» (Неверно).

=ЕСЛИ(A5<>"Винты"; "ОК"; "Неверно")

Если значение в ячейке A5 не равно строке «Винты», возвращается «ОК», в противном случае — «Неверно» (Неверно).

=ЕСЛИ(И(A2>A3; A2<A4); "ОК"; "Неверно")

Если значение в ячейке A2 больше значения в ячейке A3 и меньше значения в ячейке A4, возвращается «ОК», в противном случае — «Неверно» (Неверно).

=ЕСЛИ(И(A2<>A3; A2<>A4); "ОК"; "Неверно")

Если значение в ячейке A2 равно значению в ячейке A2 и не равно значению в ячейке A4, возвращается «ОК», в противном случае — «Неверно» (ОК).

=ЕСЛИ(ИЛИ(A2>A3; A2<A4); "ОК"; "Неверно")

Если значение в ячейке A2 больше значения в ячейке A3 или меньше значения в ячейке A4, возвращается «ОК», в противном случае — «Неверно» (ОК).

=ЕСЛИ(ИЛИ(A5<>"Винты"; A6<>"Шурупы"); "ОК"; "Неверно")

Если значение в ячейке A5 не равно строке «Винты» или значение в ячейке A6 не равно строке «Шурупы», возвращается «ОК», в противном случае — «Неверно» (Неверно).

=ЕСЛИ(ИЛИ(A2<>A3; A2<>A4); "ОК"; "Неверно")

Если значение в ячейке A2 не равно значению в ячейке A3 или A4, возвращается «ОК», в противном случае — «Неверно» (ОК).

Дополнительные сведения об использовании этих функций см. в разделах Функция ЕСЛИ, Функция И и Функция ИЛИ.

К началу страницы

Совершенствование навыков
Перейти к обучению
Первоочередный доступ к новым возможностям
Присоединиться к программе предварительной оценки Office

Были ли сведения полезными?

Спасибо за ваш отзыв!

Благодарим за отзыв! Возможно, будет полезно связать вас с одним из наших специалистов службы поддержки Office.

×