Создание схем с помощью визуализатора данных

Вы хотели бы автоматически создавать подробные профессионально оформленные блок-схемы Visio на основе книг Excel? Это можно сделать с помощью шаблонов визуализатора данных. С каждым шаблоном связана книга Excel, которая используется для преобразования данных процесса в блок-схему Visio. Можно также получить собственный настраиваемый шаблон Excel, указать сопоставления в мастере шаблонов и автоматически создать схему. После создания блок-схемы вы можете добавить, изменить или удалить строки в документе Excel, а затем обновить схему в Visio. Кроме того, в книгу Excel можно добавить столбцы с данными, которые будут преобразованы в данные фигур Visio. Визуализатор данных поддерживается в Visio Pro для Office 365.

Обзор визуализатора данных

Шаблоны визуализатора данных доступны только в Visio Pro для Office 365 на канале Current Channel. Если вы не знаете, какую версию Visio используете, на вкладке Файл выберите пункты Учетная запись > О программе Visio. Дополнительные сведения о версии Visio, которая предоставляется по подписке, см. на страницеVisio Pro для Office 365.

Если шаблоны визуализатора данных отсутствуют или у вас есть другие вопросы о начале работы, см. страницу Часто задаваемые вопросы о визуализаторе данных.

Примечание : Она предоставляется только по подписке на Office 365. Если вы подписаны на Office 365, убедитесь в том, что у вас установлена последняя версия Office. ИТ-специалисты, управляющие процессом обновления Office 365, могут узнать о том, какие обновления доступны в каждом канале, на странице выпусков обновлений.

В этой статье

Создание схем с помощью визуализатора данных

Подготовка

Обдумайте свои идеи и предварительно проработайте их на бумаге или с помощью рукописного ввода. Этот черновик послужит отправной точкой, и вам будет проще выполнить следующие действия.

Чтобы создать схему с помощью визуализатора данных, можно работать одновременно в Excel и Visio. Вы можете открыть два окна на устройстве с Windows или, если вам так удобнее, подключить второй монитор. Сравнивая содержимое окон Excel и Visio, вы поймете, получается ли у вас то, что задумано.

Этап 1. Выбор шаблона визуализатора данных

  1. Откройте Visio или выберите Файл > Создать, если вы изменяете схему.

  2. Выберите Шаблоны.

    Команда "Шаблоны"
  3. Выберите Блок-схема.

    Команда "Блок-схема"
  4. Щелкните шаблон Простая блок-схема — визуализатор данных или Функциональная блок-схема — визуализатор данных.

    Шаблоны визуализатора данных

    В левом верхнем углу шаблона визуализатора данных есть значок Excel.

Дополнительные сведения о блок-схемах и их фигурах см. в статьях Создание простой блок-схемы и Создание функциональной блок-схемы.

Этап 2. Создание книги Excel

  1. В окне предварительного просмотра шаблона щелкните Шаблон данных Excel.

    Выбор ссылки "Шаблон данных Excel"

    Обратите внимание: если вы хотите использовать образцы шаблонов Excel, приведенные в этой статье для примера, их можно скачать по указанным ниже ссылкам.

  2. Нажмите Файл > Сохранить, укажите компьютер, сервер в сети или библиотеку документов SharePoint, введите имя файла и нажмите кнопку Сохранить.

  3. Чтобы добавить новый лист, в нижней части книги щелкните значок Новый лист Кнопка "Новый лист" .

  4. Создайте таблицу Excel. Дополнительные сведения о работе с таблицами Excel см. в статьях Общие сведения о таблицах, Создание и удаление таблицы Excel и Как добавить или удалить строку или столбец в таблице.

  5. Добавьте столбцы и строки в таблицу, на основе которой будет создана схема Visio. Для заголовков столбцов и значений таблицы Excel существуют определенные требования. Воспользуйтесь разделом Взаимодействие между столбцами Excel и компонентами блок-схемы Visio в качестве наглядного пособия.

Этап 3. Добавление дополнительных данных фигур в таблицу Excel (необязательно)

  1. В шаблоне Excel просмотрите вкладку Схема процесса Столбцы в таблице Excel выделены синим и зеленым цветами. Цвет служит визуальной подсказкой, которая иллюстрирует различие между столбцами.

    Синие столбцы используются для создания блок-схемы в Visio. Кроме того, все столбцы служат источником данных фигур.

  2. Чтобы добавить дополнительные данные фигур, добавьте один или несколько столбцов в таблицу Excel.

    Зеленые столбцы содержат дополнительные данные, которые можно добавить к каждой фигуре. Вы можете добавить любое количество дополнительных столбцов. По умолчанию эти данные не отображаются на схеме, если вы не добавите рисунки, связанные с данными. Чтобы просмотреть данные фигуры на схеме Visio, выберите Данные > Окно данных фигуры. Дополнительные сведения о данных фигур и рисунках, связанных с данными, см. в статьях Добавление данных в фигуры и Рисунки, связанные с данными: обзор.

Этап 4. Создание схемы Visio с помощью мастера

  1. Вернитесь в Visio, в окне предварительного просмотра шаблона выберите единицу измерения и нажмите кнопку Создать.

  2. На первой странице мастера Создание диаграммы на основе данных сделайте следующее:

    1. В разделе Какую схему вы хотите создать на основе данных? выберите шаблон Простая блок-схема, Функциональная блок-схема (горизонтальная) или Функциональная блок-схема (вертикальная).

    2. В разделе Выберите книгу Excel: выберите книгу из списка последних открытых книг или нажмите кнопку Обзор, чтобы найти файл, созданный на этапе 2.

    3. В разделе Выберите таблицу или настраиваемый диапазон в книге: выберите таблицу Excel, содержащую данные процесса.

    4. Нажмите кнопку Готово. При этом будут приняты все значения по умолчанию, подставленные на остальных страницах мастера в Visio.

В результате схема будет создана автоматически внутри контейнера. В зависимости от размера блок-схемы могут быть добавлены дополнительные страницы Visio.

Этап 5. Сохранение схемы Visio

  • Нажмите Файл > Сохранить, найдите нужную папку, введите имя файла и нажмите кнопку Сохранить.

Рекомендуем хранить файлы Excel и Visio в одной папке, так как это две части одного целого.

Этап 6. Обновление схемы

После создания схемы с помощью визуализатора данных в нее можно вносить изменения. Для визуализатора данных нужны два компонента (книга Excel и схема Visio), поэтому нужно поддерживать схему в актуальном состоянии, обновляя ее в Visio, чтобы отразить изменения в данных таблицы Excel. Важно понимать, что этот процесс синхронизации является односторонним. Сначала вы изменяете данные в Excel, а затем обновляете схему в Visio. Если при обновлении обнаруживаются различия между данными в Excel и Visio, приоритет отдается данным из Excel.

  1. Внесите изменения в данные таблицы Excel. Вы можете добавить, изменить или удалить строки.

  2. Сохраните книгу Excel.

  3. В Visio выберите контейнер схемы, а затем нажмите Данные > Обновить.

В результате изменения, внесенные в книгу Excel, будут отражены на схеме Visio. При обновлении переносятся изменения только для тех фигур и соединений, которые находятся в контейнере. Следите за тем, чтобы все фигуры и соединительные линии схемы оставались внутри контейнера. Если вы вручную добавите фигуру в контейнер и обновите схему, фигура будет удалена. Объекты, расположенные на странице, но вне контейнера, при обновлении не изменяются. Изменения форматирования, внесенные вами для фигур и соединительных линий в контейнере, сохраняются. Дополнительные сведения о контейнерах см. в статье Пояснение структуры схем с помощью контейнеров и списков.

Этап 7. Настройка взаимодействия между таблицей Excel и схемой Visio (необязательно)

Иногда требуется настроить процесс создания схем с помощью визуализатора данных. Например, в соответствии со стандартом, принятым в организации, вам могут быть нужны другие фигуры. Вы также можете использовать при сопоставлении столбцы в таблице Excel, имеющие другие имена.

  1. После того как вы нажали Создать, чтобы открыть мастер Создание диаграммы на основе данных, и ввели значения на первой странице (см. этап 4), вы можете нажимать Далее и Назад для перехода между страницами мастера.

  2. Чтобы просмотреть сведения о настройке каждого параметра на странице, нажмите Справка (?). Дополнительные сведения см. в статье Использование мастера "Создание диаграммы на основе данных".

К началу страницы

Взаимодействие между столбцами Excel и компонентами блок-схемы Visio

Чтобы разобраться, каким образом каждый столбец Excel используется при создании схемы в Visio, обратитесь к пошаговому обзору снимка экрана ниже.

Идентификатор шага процесса.   Это число, которое идентифицирует каждую фигуру блок-схемы. Этот столбец является обязательным, и каждое его значение в таблице Excel должно быть уникальным и не пустым. Это значение не отображается на блок-схеме.

Взаимосвязь карты процесса Excel и блок-схемы Visio: Идентификатор шага процесса

Описание шага процесса.   Это текст, добавляемый к каждой фигуре блок-схемы.

Взаимосвязь карты процесса Excel и блок-схемы Visio: Описание шага процесса

Идентификатор следующего шага.   Это идентификатор шага процесса, соответствующий следующей фигуре в последовательности. Для фигуры ветвления существуют два следующих шага, и их идентификаторы указываются через запятую, например: 4,5. Следующих шагов может быть и больше двух.

Взаимосвязь карты процесса Excel и блок-схемы Visio: Идентификатор следующего шага

Метка соединителя.   Для фигур ветвления метки соединителей представлены в виде текста, разделенного запятыми, например: Да,Нет. В примере "Да" соответствует идентификатору 4, а "Нет" — 5.

Взаимосвязь карты процесса Excel и блок-схемы Visio: Метка соединителя

Тип фигуры.   Это тип фигуры, который вы хотите использовать на схеме Visio, например Процесс или Решение. Рекомендуем использовать раскрывающиеся списки, чтобы можно было выбирать только правильные варианты.

Взаимосвязь карты процесса Excel и блок-схемы Visio: Тип фигуры

Функция и этап.   Это функция (или дорожка) и этап (или временная шкала), к которым относится каждая фигура. Этот столбец нужен только для функциональной блок-схемы, а при создании простой блок-схемы мастер его игнорирует.

Взаимосвязь карты процесса Excel и блок-схемы Visio: Функция и этап

К началу страницы

Создание схемы визуализатора данных с помощью других наборов элементов

Помимо шаблонов простой и функциональной блок-схем, для создания схемы визуализатора данных можно использовать элементы из других шаблонов. Например, существуют другие наборы элементов, предназначенные для регистрации процессов, например Схема аудита, Основные фигуры BPMN или Блок-схема "Шесть сигм". Но вы можете добавлять фигуры из любого набора элементов, например Мои фигуры.

  1. Откройте созданную схему визуализатора данных.

  2. Добавьте наборы элементов в область Фигуры.

    Например, выберите Дополнительные фигуры, а затем щелкните Бизнес > Бизнес-процесс > Фигуры схемы аудита.

    Дополнительные шаблоны в области "Фигуры"
  3. На вкладке Данные нажмите кнопку Создать, чтобы запустить мастер создания схемы на основе данных.

  4. Нажимайте кнопку Далее, пока не появится страница Выберите подходящую фигуру для каждого значения из перечисленных в столбце "Тип фигуры".

  5. В правой стороне страницы выберите набор элементов из списка, например Фигуры схемы аудита.

    Дополнительные шаблоны, добавленные на страницу мастера

Добавление в схему рисунков, связанных с данными

Программа предварительной оценки Office

Возможность добавления рисунков, связанных с данными, в Visio Pro для Office 365 доступна только участникам программы предварительной оценки Office   

Участники программы предварительной оценки — это подписчики Office 365,которые раньше всех знакомятся с новыми возможностями каждый месяц и помогают команде Office оценить свою работу. Примите участие в программе предварительной оценки Office

Чтобы сделать схему более наглядной, можно добавить в нее рисунки, связанные с данными, которые позволят визуально представить данные фигур. Фактически, вы можете превратить схему в информационную панель процесса и использовать рисунки, связанные с данными, для отображения ключевых показателей эффективности (КПЭ), основанных на данных фигур, в виде оригинальных значков.

  1. Откройте схему, созданную с помощью визуализатора данных.

    Выберите контейнер, в который вы хотите добавить рисунки, связанные с данными.

  2. На вкладке Данные установите флажок Поля рисунков, связанных с данными.

  3. Выберите поля рисунков, связанных с данными, которые вы хотите добавить в схему.

    Рисунки, связанные с данными, будут применены ко всей схеме. Чтобы скрыть рисунки, связанные с данными, для определенных фигур, оставьте значения столбцов данных для этих строк в книге Excel пустыми.

  4. При необходимости можно задать дополнительные параметры на вкладке "Данные".

Добавление в схему Visio, созданную с помощью визуализатора данных, рисунков, связанных с данными

К началу страницы

Дальнейшие действия

Возможно, после создания схемы с помощью визуализатора данных вас заинтересуют следующие задачи:

  • Темы.    Тема в Visio представляет собой набор цветов и эффектов, которые можно применить к документу одним щелчком мыши. С помощью тем документам можно легко придать профессиональный вид. Дополнительные сведения см. в статье Применение тем для профессионального оформления документов.

  • Макет.    В Visio есть руководства и автоматические инструменты, которые помогают выровнять и равномерно распределить фигуры на схеме. Благодаря этому ваш документ выглядит четко и профессионально. Дополнительные сведения см. в статье Выравнивание и расстановка фигур на схеме.

  • Экспорт.    Вы можете экспортировать схему, созданную с помощью визуализатора данных, и связанную с ней книгу Excel в пакет шаблона Visio (VTPX). В пакете шаблона Visio сохраняются параметры схемы, наборы элементов и данные, на основе которых другие пользователи смогут быстро создавать собственные схемы с помощью визуализатора данных. Они могут установить пакет шаблона на своих компьютерах. Дополнительные сведения см. в статье Экспорт и установка пакета шаблона "Визуализатор данных".

К началу страницы

Совершенствование навыков
Перейти к обучению
Первоочередный доступ к новым возможностям
Присоединиться к программе предварительной оценки Office

Были ли сведения полезными?

Спасибо за ваш отзыв!

Благодарим за отзыв! Возможно, будет полезно связать вас с одним из наших специалистов службы поддержки Office.

×