Создание схем развертывания UML

Вы можете создавать схемы развертывания UML, отображающие архитектуру развертывания артефактов программного обеспечения на узлах. Прежде всего откройте шаблон Топология UML и выберите один из четырех вариантов шаблона. После этого появится набор элементов Топология UML, а также фигуры, которые соответствуют стандарту UML 2.5.

Набор элементов "Топология UML", примеры фигур на странице

Примечание : Набор элементов Топология UML доступен только при наличии подписки на Visio Pro для Office 365. Если у вас есть подписка, убедитесь, что у вас установлена последняя версия Visio.

  1. Запустите Visio. Если файл уже открыт, щелкните Файл > Создать.

  2. Перейдите в раздел Категории > Программы и базы данных > Топология UML.

  3. Выберите пустой шаблон или одну из трех начальных схем. Выбрав нужный шаблон, нажмите кнопку Создать.

  4. Вы увидите окно Фигуры рядом со схемой. Если оно не отображается, выберите Вид > Области задач и убедитесь, что флажок Фигуры установлен. Если оно по-прежнему не отображается, нажмите кнопку Развернуть окно фигур Кнопка "Развернуть окно фигур" в левой части экрана.

  5. На вкладке Вид установите флажок Точки соединения. Благодаря этому при соединении фигур будут отображаться точки соединения.

  6. Затем перетащите фигуры, которые вы хотите включить в схему, из окна Фигуры на страницу. Чтобы изменить подписи, дважды щелкните их.

Когда использовать

  1. Используйте фигуры Экземпляр узла, когда вы хотите обозначить экземпляры вычислительных или физических устройств.

  2. Поместите фигуры Экземпляр артефакта внутри фигуры "Экземпляр узла", чтобы добавить артефакты.

1, указывает на фигуру "Экземпляр узла" "<<облачная vm>> :MachineInstance" ; 2, указывает на фигуру артефакта: "<<артефакт>> Number Cruncher.py"

Шаг 1

Сначала перетащите фигуру Экземпляр узла на страницу, а затем увеличьте ее, перетащив маркеры.

Увеличенная фигура "Экземпляр узла"

Шаг 2

Перетащите фигуру Экземпляр артефакта внутрь более крупной фигуры узла. Зеленое выделение означает, что более мелкая фигура будет находиться внутри более большой. После этого при перемещении фигуры узла также будет перемещаться фигура артефакта.

Фигура артефакта перетащена на фигуру "Экземпляр узла", зеленое выделение

В наборе элементов Топология UML есть и другие фигуры контейнера. Они используются так же, как и фигура "Экземпляр узла", то есть фигуры, перетащенные на них, приклеиваются и перемещаются вместе с ними. Ниже описаны некоторые из наиболее часто используемых фигур контейнера для схем развертывания.

Иерархические узлы

Вложите фигуры узлов друг в друга, чтобы показать их иерархию.

Узел "КлиентПользователя", содержащий узел "Браузер" с артефактом "HTML5"

Пакет

Используйте фигуру Пакет, чтобы представить контейнер в виде папки.

Фигура "Пакет", содержащая другие фигуры экземпляра узла и артефакта

Обзор схемы

Используйте фигуру Обзор схемы, чтобы заключить все фигуры в рамку.

Фигура "Обзор схемы", содержащая другие фигуры экземпляра узла и артефакта

Выпрямление соединительных линий

Если соединительная линия слишком много изгибается, щелкните ее правой кнопкой мыши и выберите Прямая соединительная линия.

Отображение количества элементов

При необходимости щелкните соединительную линию правой кнопкой мыши и выберите Показать количество элементов. Появятся четыре надписи, в которые можно добавить сведения. Если некоторые из них не нужны, удалите их.

Изменение типа соединительной линии

Вы можете изменить тип соединительной линии. Например, можно изменить тип "Связь" на "Направленная связь". Щелкните соединительную линию правой кнопкой мыши и выберите Задать тип соединителя.

Использование динамических подключений вместо точек соединения

Если предполагается, что фигура будет часто перемещаться, используйте динамическое соединение вместо точки соединения.

Перемещение и поворот текста на соединительных линиях

Скорее всего, вам потребуется поворачивать и перемещать текст на соединительных линиях. Вот как это сделать:

  1. Щелкните в пустом месте страницы, чтобы отменить выбор элементов.

  2. На вкладке Главная в группе Сервис нажмите кнопку Блок текста Кнопка "Блок текста" .

  3. Щелкните соединительную линию с текстом, который вы хотите повернуть или переместить.

  4. Перетащите блок текста, чтобы переместить его, или поверните его с помощью маркера Перетаскивание маркера поворота .

  5. Когда все будет готово, нажмите кнопку Указатель Кнопка "Указатель" .

    Если вы переключаетесь обратно к инструменту Указатель Кнопка "Указатель" , текст остается на прежнем расстоянии от фигуры. При использовании инструмента Указатель Кнопка "Указатель" для перетаскивания текста фигура также перемещается. Чтобы переместить текст независимо от фигуры, используйте инструмент Блок текста Кнопка "Блок текста" .

Когда использовать

Добавьте фигуры компонентов для всех функциональных единиц системы или приложения.

Фигура компонента "Хранилище"

Отображение и скрытие стереотипа

Щелкните фигуру правой кнопкой мыши, чтобы показать или скрыть подпись стереотипа.

Контекстное меню, команда "Показать стереотип", надпись <<компонент>>

Когда использовать

  1. Используйте фигуру Предоставленный интерфейс, если вы хотите указать реализацию интерфейса или класса.

  2. Используйте фигуру Обязательный интерфейс, если нужно указать зависимость от интерфейса или класса.

Два интерфейса подключены, 1: фигура "Предоставленный интерфейс" с кружком, 2: фигура "Обязательный интерфейс" с разъемом

Шаг 1

Перетащите фигуру Предоставленный интерфейс на страницу и выровняйте квадрат порта относительно точки соединения. Когда фигура будет соединена, точка соединения будет выделена зеленым.

Фигура "Предоставленный интерфейс" приклеена к фигуре компонента

Шаг 2

Перетащите фигуру Обязательный интерфейс на страницу и также выровняйте квадрат порта относительно точки соединения. Когда фигура будет соединена, точка соединения будет выделена зеленым.

Фигура "Обязательный интерфейс" приклеена к фигуре компонента

Шаг 3

Чтобы соединить предоставленный и обязательный интерфейсы, сначала выделите фигуру "Обязательный интерфейс". Затем найдите желтый маркер.

Желтый маркер на фигуре "Обязательный интерфейс"

Шаг 4

Перетащите желтый маркер, чтобы создать соединение с фигурой "Предоставленный интерфейс".

Фигура "Обязательный интерфейс", соединенная с фигурой "Предоставленный интерфейс"

См. также

Схемы UML в Visio

Создание схемы компонентов UML

Создание схемы связи UML

Создание схемы последовательностей UML

Совершенствование навыков
Перейти к обучению
Первоочередный доступ к новым возможностям
Присоединиться к программе предварительной оценки Office

Были ли сведения полезными?

Спасибо за ваш отзыв!

Благодарим за отзыв! Возможно, будет полезно связать вас с одним из наших специалистов службы поддержки Office.

×