Создание схем компонентов UML

Вы можете создавать схемы компонентов UML, отображающие компоненты, порты, интерфейсы и связи между ними. Прежде всего откройте шаблон Компоненты UML и выберите один из четырех вариантов шаблона. После этого появится набор элементов Компоненты UML, а также фигуры, которые соответствуют стандарту UML 2.5.

Набор элементов "Компоненты UML" и примеры фигур на странице

Примечание : Набор элементов Компоненты UML доступен только при наличии подписки на Visio Pro для Office 365. Если у вас есть подписка, убедитесь, что у вас установлена последняя версия Visio.

  1. Запустите Visio. Если файл уже открыт, щелкните Файл > Создать.

  2. Перейдите в раздел Категории > Программы и базы данных > Компоненты UML.

  3. Выберите пустой шаблон или одну из трех начальных схем. Выбрав нужный шаблон, нажмите кнопку Создать.

  4. Вы увидите окно Фигуры рядом со схемой. Если оно не отображается, выберите Вид > Области задач и убедитесь, что флажок Фигуры установлен. Если оно по-прежнему не отображается, нажмите кнопку Развернуть окно фигур Кнопка "Развернуть окно фигур" в левой части экрана.

  5. На вкладке Вид установите флажок Точки соединения. Благодаря этому при соединении фигур будут отображаться точки соединения.

  6. Затем перетащите фигуры, которые вы хотите включить в схему, из окна Фигуры на страницу. Чтобы изменить подписи, дважды щелкните их.

Когда использовать

Добавьте фигуры компонентов для всех функциональных единиц системы или приложения.

Фигура компонента "Магазин"

Отображение и скрытие стереотипа

Щелкните фигуру правой кнопкой мыши, чтобы показать или скрыть подпись стереотипа.

Контекстное меню, команда "Показать стереотип", надпись <<компонент>>

Подсистемы

Фигуру компонента можно использовать как фигуру подсистемы, которая содержит другие компоненты. Просто увеличьте ее размер и перетащите на нее другие компоненты. Когда появится зеленое выделение, отпустите кнопку мыши. После этого более крупная фигура будет контейнером, а более мелкие фигуры будут перемещаться вместе с ней.

Совет : Если компонент исчезнет после перетаскивания на другой компонент, переместите его на передний план, нажав клавиши CTRL+SHIFT+F.

Фигура подсистемы "Магазин", на которую перетащена фигура компонента "Заказ"

Когда использовать

  1. Используйте фигуру Предоставленный интерфейс, если вы хотите указать реализацию интерфейса или класса.

  2. Используйте фигуру Обязательный интерфейс, если нужно указать зависимость от интерфейса или класса.

Два интерфейса подключены, 1: фигура "Предоставленный интерфейс" с кружком, 2: фигура "Обязательный интерфейс" с разъемом

Шаг 1

Перетащите фигуру Предоставленный интерфейс на страницу и выровняйте квадрат порта относительно точки соединения. Когда фигура будет соединена, точка соединения будет выделена зеленым.

Фигура "Предоставленный интерфейс" приклеена к фигуре компонента

Шаг 2

Перетащите фигуру Обязательный интерфейс на страницу и также выровняйте квадрат порта относительно точки соединения. Когда фигура будет соединена, точка соединения будет выделена зеленым.

Фигура "Обязательный интерфейс" приклеена к фигуре компонента

Шаг 3

Чтобы соединить предоставленный и обязательный интерфейсы, сначала выделите фигуру "Обязательный интерфейс". Затем найдите желтый маркер.

Желтый маркер на фигуре "Обязательный интерфейс"

Шаг 4

Перетащите желтый маркер, чтобы создать соединение с фигурой "Предоставленный интерфейс".

Фигура "Обязательный интерфейс", соединенная с фигурой "Предоставленный интерфейс"

Выпрямление соединительных линий

Если соединительная линия слишком много изгибается, щелкните ее правой кнопкой мыши и выберите Прямая соединительная линия.

Отображение количества элементов

При необходимости щелкните соединительную линию правой кнопкой мыши и выберите Показать количество элементов. Появятся четыре надписи, в которые можно добавить сведения. Если некоторые из них не нужны, удалите их.

Изменение типа соединительной линии

Вы можете изменить тип соединительной линии. Например, можно изменить тип "Связь" на "Направленная связь". Щелкните соединительную линию правой кнопкой мыши и выберите Задать тип соединителя.

Использование динамических подключений вместо точек соединения

Если предполагается, что фигуру будут часто перемещаться, используйте динамическое соединение вместо точки соединения.

Перемещение и поворот текста на соединительных линиях

Скорее всего, вам потребуется поворачивать и перемещать текст на соединительных линиях. Вот как это сделать:

  1. Щелкните в пустом месте страницы, чтобы отменить выбор элементов.

  2. На вкладке Главная в группе Сервис нажмите кнопку Блок текста Кнопка "Блок текста" .

  3. Щелкните соединительную линию с текстом, который вы хотите повернуть или переместить.

  4. Перетащите блок текста, чтобы переместить его, или поверните его с помощью маркера Перетаскивание маркера поворота .

  5. Когда все будет готово, нажмите кнопку Указатель Кнопка "Указатель" .

    Если вы переключаетесь обратно к инструменту Указатель Кнопка "Указатель" , текст остается на прежнем расстоянии от фигуры. При использовании инструмента Указатель Кнопка "Указатель" для перетаскивания текста фигура также перемещается. Чтобы переместить текст независимо от фигуры, используйте инструмент Блок текста Кнопка "Блок текста" .

См. также

Схемы UML в Visio

Создание схемы связи UML

Создание схемы развертывания UML

Создание схемы последовательностей UML

Совершенствование навыков
Перейти к обучению
Первоочередный доступ к новым возможностям
Присоединиться к программе предварительной оценки Office

Были ли сведения полезными?

Спасибо за ваш отзыв!

Благодарим за отзыв! Возможно, будет полезно связать вас с одним из наших специалистов службы поддержки Office.

×