Создание схемы связей UML

Вы можете создавать схемы связей UML в свободной форме для демонстрации взаимодействия между жизненными циклами, которые используют последовательные сообщения. Прежде всего откройте шаблон Связь UML и выберите один из четырех вариантов шаблона. После этого появится набор элементов Связь UML, а также фигуры, которые соответствуют стандарту UML 2.5.

Набор элементов "Связь UML", примеры фигур на странице

Примечание : Набор элементов Связь UML доступен только при наличии подписки на Visio Pro для Office 365. Если у вас есть подписка, убедитесь, что у вас установлена последняя версия Visio.

  1. Запустите Visio. Если файл уже открыт, щелкните Файл > Создать.

  2. Перейдите в раздел Категории > Программы и базы данных > Связь UML.

  3. Выберите пустой шаблон или одну из трех начальных схем. Если необходимо представить взаимодействие линий жизни путем их связи, выберите начальную схему в левом нижнем углу.

  4. Щелкните Создать.

  5. Вы увидите окно Фигуры рядом со схемой. Если оно не отображается, выберите Вид > Области задач и убедитесь, что флажок Фигуры установлен. Если оно по-прежнему не отображается, нажмите кнопку Развернуть окно фигур Кнопка "Развернуть окно фигур" в левой части экрана.

  6. На вкладке Вид установите флажок Точки соединения. Благодаря этому при соединении фигур будут отображаться точки соединения.

  7. Затем перетащите фигуры, которые вы хотите включить в схему, из окна Фигуры на страницу. Чтобы изменить подписи, дважды щелкните их.

Когда использовать

  1. Перетащите фигуру Субъект на страницу, чтобы представить роль пользователя или внешней системы.

  2. Перетащите фигуру Линия жизни для каждого именованного элемента, представляющего отдельного участника.

1: фигура субъекта с текстом "Кто-то" 2: фигура линии жизни с текстом ":купон"

Шаг 1

Перетащите фигуру сообщения на страницу и приклейте один конец к точке соединения на другой фигуре. Определить то, что он приклеен, можно по зеленому квадрату в точке соединения.

Фигура сообщения с одним окончанием, выделенным зеленым цветом и подключенным к фигуре линии жизни

Шаг 2

Сделайте то же самое с другим концом сообщения, чтобы приклеить его к точке соединения. Точка будет выделена зеленым цветом.

Фигура сообщения с окончанием, выделенным зеленым цветом и подключенным к другой фигуре линии жизни

Шаг 3

Если сообщение должно быть асинхронным, щелкните его правой кнопкой мыши и выберите Асинхронное. При этом закрытая стрелка станет открытой.

Фигура сообщения, контекстное меню, выбрана команда "Асинхронное"

Обзор

  1. Сначала свяжите линии жизни с помощью инструмента Соединительная линия.

  2. Затем покажите взаимодействие между ними с помощью фигур Сообщение и Возвращаемое сообщение.

1, указывает на серую соединительную линию, 2, указывает на линию сообщения с текстом, "4: Execute()"

Шаг 1

На вкладке Главная щелкните инструмент Соединительная линия (1). Наведите указатель мыши на одну из точек соединения линии жизни и удерживайте его, пока не появится зеленое выделение (2).

1, указывает на соединительную линию, 2, показывает на указатель, наведенный на точку соединения на фигуре линии жизни, выделенную зеленым

Шаг 2

Перетащите зеленое выделение на точку соединения другой фигуры линии жизни, пока не появится выделение.

Конец соединительной линии, перетащенный к другой фигуре линии жизни, с точкой соединения, выделенной зеленым

Шаг 3

Нажмите кнопку Указатель, когда завершите соединять фигуры линий жизни.

Надпись "Щелкните здесь, когда закончите", указывающая на указатель

Шаг 4

Перетащите другую фигуру сообщения так, чтобы она находилась параллельно другой линии.

Указатель, перемещающий фигуру в нужное место рядом с соединительной линией

Выпрямление соединительных линий

Если соединительная линия слишком много изгибается, щелкните ее правой кнопкой мыши и выберите Прямая соединительная линия.

Изменение типа соединительной линии

Вы можете изменить тип соединительной линии. Например, можно изменить тип "Связь" на "Направленная связь". Щелкните соединительную линию правой кнопкой мыши и выберите Задать тип соединителя.

Использование динамических подключений вместо точек соединения

Если предполагается, что фигура будет часто перемещаться, используйте динамическое соединение вместо точки соединения.

Перемещение и поворот текста на соединительных линиях

Скорее всего, вам потребуется поворачивать и перемещать текст на соединительных линиях. Вот как это сделать:

  1. Щелкните в пустом месте страницы, чтобы отменить выбор элементов.

  2. На вкладке Главная в группе Сервис нажмите кнопку Блок текста Кнопка "Блок текста" .

  3. Щелкните соединительную линию с текстом, который вы хотите повернуть или переместить.

  4. Перетащите блок текста, чтобы переместить его, или поверните его с помощью маркера Перетаскивание маркера поворота .

  5. Когда все будет готово, нажмите кнопку Указатель Кнопка "Указатель" .

    Если вы переключаетесь обратно к инструменту Указатель Кнопка "Указатель" , текст остается на прежнем расстоянии от фигуры. При использовании инструмента Указатель Кнопка "Указатель" для перетаскивания текста фигура также перемещается. Чтобы переместить текст независимо от фигуры, используйте инструмент Блок текста Кнопка "Блок текста" .

См. также

Схемы UML в Visio

Создание схемы компонентов UML

Создание схемы развертывания UML

Создание схемы последовательностей UML

Совершенствование навыков
Перейти к обучению
Первоочередный доступ к новым возможностям
Присоединиться к программе предварительной оценки Office

Были ли сведения полезными?

Спасибо за ваш отзыв!

Благодарим за отзыв! Возможно, будет полезно связать вас с одним из наших специалистов службы поддержки Office.

×