Создание сводной таблицы с внешним источником данных

Важно :  Данная статья переведена с помощью машинного перевода, см. Отказ от ответственности. Используйте английский вариант этой статьи, который находится здесь, в качестве справочного материала.

Анализ данных часто помогает принимать более эффективные деловые решения. Но иногда непонятно, с чего начинать, особенно при наличии большого количества данных, которые хранятся за пределами Excel (например, в базе данных Microsoft Access или Microsoft SQL Server либо в файле куба OLAP). В этом случае можно подключиться к внешнему источнику данных, а затем создать сводную таблицу для обобщения, анализа, изучения и представления этих данных.

Ниже описано, как создать сводную таблицу с использованием существующего подключения к внешним данным.

  1. Щелкните любую ячейку на листе.

  2. Выберите Вставка > Сводная таблица.

    Кнопка "Сводная таблица" на вкладке "Вставка"

  3. В диалоговом окне Создание сводной таблицы в разделе Выберите данные для анализа щелкните Использовать внешний источник данных.

    Диалоговое окно "Создание сводной таблицы" с выбором и использованием внешнего источника данных

  4. Нажмите кнопку Выбрать подключение.

  5. На вкладке Подключения в поле Показать оставьте вариант Все подключения или укажите категорию подключений с источником данных, к которому требуется подключиться.

Чтобы повторно использовать существующее подключение или воспользоваться общим подключением, выберите вариант Подключения в этой книге.

  1. Выберите нужное подключение из списка и нажмите кнопку Открыть.

  2. В разделе Укажите, куда следует поместить отчет сводной таблицы:, выберите место.

    • Чтобы поместить сводную таблицу на новый лист, начиная с ячейки A1, выберите вариант На новый лист.

    • Чтобы поместить сводную таблицу на активный лист, выберите вариант На существующий лист, а затем в поле Диапазон укажите ячейку, в которой она должна начинаться.

  3. Нажмите кнопку ОК.

    Excel добавит пустую сводную таблицу и отобразит список полей, чтобы отобразить нужные поля и переупорядочить их, чтобы создать собственный макет.

    Список полей с полями внешних данных

  4. В разделе полей установите флажок рядом с именем поля, и оно появится в области по умолчанию в разделе областей списка полей.

    Как правило, нечисловые поля добавляются в область строк, числовые — в область значений, а поля даты и времени — в область столбцов. Поле можно перенести в любую другую область.

    Совет :  Также можно щелкнуть имя поля правой кнопкой мыши и выбрать команду Добавить в фильтр отчета, Добавить в названия столбцов, Добавить в названия строк или Добавить в значения. В результате это поле будет перенесено в соответствующую область в разделе областей. Кроме того, поле можно перетащить из раздела полей в нужную область в соответствующем разделе.

    С помощью Списка полей для дальнейшего переупорядочения данных сводной таблицы , поля в разделе областей правой кнопкой мыши и выбрав нужная вам область или путем перетаскивания полей между областями в разделе областей.

Подключение к новому внешнему источнику данных

Чтобы создать новое подключение к внешним данным на сервере SQL Server и импортировать их в Excel в виде таблицы или сводной таблицы, выполните указанные ниже действия.

  1. На вкладке Данные нажмите кнопку Из других источников.

Кнопка "Из других источников" на вкладке "Данные"

  1. Выберите нужное подключение.

    • Щелкните С сервера SQL Server, чтобы создать подключение к таблице на сервере SQL Server.

    • Щелкните Из служб аналитики, чтобы создать подключение к кубу аналитики на сервере SQL Server.

  2. В мастере подключения к данным установите соединение, выполнив соответствующие действия.

    • На странице 1 укажите имя сервера базы данных и выберите способ подключения к нему.

    • На странице 2 укажите базу данных, таблицу или запрос с необходимыми данными.

    • На странице 3 укажите файл подключения, который требуется создать.

Чтобы создать новое подключение к базе данных Access и импортировать данные в Excel в виде таблицы или сводной таблицы, выполните указанные ниже действия.

  1. На вкладке Данные нажмите кнопку Из Access.

Кнопка ''Из Access'' на вкладке ''Данные''

  1. В диалоговом окне Выбор источника данных найдите базу, к которой требуется подключиться, и нажмите кнопку Открыть.

  2. В диалоговом окне Выбор таблицы выберите нужную таблицу и нажмите кнопку ОК.

Если есть несколько таблиц, установите флажок Разрешить выбор нескольких таблиц, затем — флажки соответствующих таблиц и нажмите кнопку ОК.

  1. В диалоговом окне Импорт данных укажите, в каком виде данные должны отображаться в книге и куда их следует поместить, и нажмите кнопку ОК.

Таблицы будут автоматически добавлены в модель данных, а база данных Access добавляется в список подключений книги.

Подробнее о сводных таблицах

Примечание : Отказ от ответственности относительно машинного перевода. Данная статья была переведена с помощью компьютерной системы без участия человека. Microsoft предлагает эти машинные переводы, чтобы помочь пользователям, которые не знают английского языка, ознакомиться с материалами о продуктах, услугах и технологиях Microsoft. Поскольку статья была переведена с использованием машинного перевода, она может содержать лексические,синтаксические и грамматические ошибки.

Совершенствование навыков
Перейти к обучению
Первоочередный доступ к новым возможностям
Присоединиться к программе предварительной оценки Office

Были ли сведения полезными?

Спасибо за ваш отзыв!

Благодарим за отзыв! Возможно, будет полезно связать вас с одним из наших специалистов службы поддержки Office.

×