Создание сводной диаграммы

Увидеть полную картину непросто, если данные не были обобщены, как в примере ниже. Во многих случаях для обобщения и анализа данных в структурированном формате сначала создается сводная таблица. Это замечательный инструмент, но, к сожалению, не все могут понять, что происходит, по одному взгляду на цифры. Сводные диаграммы — отличный способ наглядного предоставления данных.

Данные о расходах семьи

Соответствующая сводная диаграмма

Пример семейных расходов для создания сводной таблицы с данными по месяцам, категориям и суммам

Пример сводной диаграммы Excel

Если у вас есть просто данные на листе, а не сводная таблица, вы можете выбрать сводную диаграмму, рекомендованную для них. После этого Excel автоматически создаст связанную сводную таблицу. Вот как это сделать:

  1. Выберите любую ячейку данных.

  2. На вкладке Вставка в группе Диаграммы выберите Рекомендуемые диаграммы.

    Кнопка "Рекомендуемые диаграммы" на вкладке "Вставка"

  3. На вкладке Рекомендуемые диаграммы выберите любую диаграмму со значком сводной диаграммы Индикатор сводной диаграммы в верхнем углу. В области просмотра отобразится предварительный вид сводной диаграммы.

    Диалоговое окно "Вставка диаграммы" с рекомендуемыми сводными диаграммами

  4. Выбрав подходящую сводную диаграмму, нажмите ОК. Excel создаст новый лист со сводной таблицей и сводной диаграммой.

  5. Вы можете расположить сводную диаграмму рядом со сводной таблицей, чтобы одновременно видеть их, или же поместить сводную диаграмму поверх данных, если вам нужна только она.

  6. Затем вы можете отформатировать сводную диаграмму.

Если вы попробовали использовать рекомендуемые диаграммы, но ни одна из них вам не понравилась, создайте собственную.

  1. Выделите любую ячейку в данных и выберите Вставка > Сводная диаграмма > Сводная диаграмма.

  2. Excel отобразит диалоговое окно, в котором спрашивается, куда вы хотите поместить сводную диаграмму. Обычно рекомендуется выбрать вариант На новый лист, чтобы поэкспериментировать с тем, как будет выглядеть диаграмма, не влияя на другие объекты на листе.

    "Вставка" > "Сводная диаграмма" в Excel
  3. Нажмите кнопку ОК, и Excel добавит новый лист с пустой сводной таблицей и сводной диаграммой.

    Появится пустая сводная диаграмма с разделом "Список полей", в котором можно добавить и переупорядочить поля сводной диаграммы.

  4. В Списке полей выберите поля, которые нужно показывать в сводной диаграмме.

    Список полей с разделом полей и разделом областей

  5. Затем вы можете отформатировать сводную диаграмму.

Если вы уже создали сводную таблицу и настроили ее так, как хотите, этот метод позволит создать наиболее полную сводную диаграмму.

  1. Выберите любую ячейку в диапазоне сводной таблицы.

  2. Выберите Работа со сводными таблицами > Анализ > Сводная диаграмма.

  3. Выберите нужный тип диаграммы и нажмите клавишу ОК.

    Excel поместит новую сводную диаграмму на тот же лист, где находится сводная таблица. В этом примере выбрана стандартная гистограмма. Если вы не знаете, какой тип диаграммы вам нужен, можно выбирать их по одному и просматривать в режиме реального времени в области вставки диаграммы.

    Пример сводной диаграммы с динамическим просмотром типа диаграммы и выбранной гистограммой

    Некоторые диаграммы не поддерживают данные сводной таблицы. Если выбрать их, появится соответствующее уведомление.

  4. Затем вы можете отформатировать сводную диаграмму.

  1. Нажмите Данные > Из других источников, а затем выберите необходимый источник данных. Например, можно выбрать Из служб аналитики, чтобы подключиться к файлу куба OLAP.

    Кнопка "Из других источников" на вкладке "Данные"

  2. Следуйте инструкциям мастера подключения данных и нажмите кнопку Готово.

  3. В диалоговом окне Импорт данных выберите Сводная диаграмма и расположение, в которое нужно поместить данные, а затем нажмите кнопку ОК.

    Появится пустая сводная диаграмма с разделом "Список полей", в котором можно добавить и переупорядочить поля сводной диаграммы.

  4. В Списке полей выберите поля, которые нужно показывать в сводной диаграмме.

    Список полей с разделом полей и разделом областей

  5. Затем вы можете отформатировать сводную диаграмму.

  1. Нажмите Вставка > Сводная диаграмма.

    Кнопка "Сводная диаграмма" на вкладке "Вставка"

  2. В диалоговом окне Создание сводной диаграммы выберите Использовать внешний источник данных, а затем нажмите Выбор подключения.

  3. В диалоговом окне Существующие подключения на вкладке Подключения дважды щелкните необходимое подключение.

  4. Нажмите кнопку ОК.

    Появится пустая сводная диаграмма с разделом "Список полей", в котором можно добавить и переупорядочить поля сводной диаграммы.

  5. В Списке полей выберите поля, которые нужно показывать в сводной диаграмме.

Список полей с разделом полей и разделом областей

Создав сводную диаграмму, вы можете настроить ее, как любую стандартную диаграмму. Когда вы выберете сводную диаграмму:

  1. возле диаграммы появятся две кнопки, с помощью которых вы сможете быстро добавлять и изменять элементы диаграммы, такие как заголовки и подписи данных, а также изменять стиль и цвета диаграмм на своей сводной диаграмме точно так же, как на стандартной диаграмме;

    Сводная диаграмма с подписями, указывающими на элементы "Кнопки полей" и "Работа с диаграммами"

  2. Кнопки полей: Excel автоматически отображает поля сводной таблицы как кнопки на сводной диаграмме. Они позволяют отфильтровать сводную диаграмму, чтобы отобразить только нужные сведения. Вы также можете использовать срезы в сводных таблицах для фильтрации нескольких сводных таблиц и сводных диаграмм. Чтобы удалить их, щелкните сводную таблицу или сводную диаграмму, а затем на вкладке Анализ снимите флажок кнопки Список полей.

  3. на ленте появится раздел Работа со сводными диаграммами. На вкладках Анализ, Конструктор и Формат можно выбрать параметры для работы со сводной диаграммой или ее настройки.

    Вкладка "Работа со сводными диаграммами" на ленте

  4. Сводная диаграмма не обязательно должна находиться на том же листе, что и сводная таблица, поэтому вы можете вырезать готовую сводную диаграмму и вставить ее в другое место.

  5. Чтобы удалить сводную диаграмму, которая вам больше не нужна, выберите ее, а затем нажмите клавишу DELETE.

Чтобы создать сводную диаграмму на Mac, необходимо сначала создать сводную таблицу, а затем вставить диаграмму. После этого диаграмма будет вести себя как сводная диаграмма при изменении полей в списке полей сводной таблицы. 

  1. Создайте сводную таблицу, если ее еще нет. 

  2. Выберите любую ячейку в таблице.

  3. На вкладке Вставка нажмите кнопку для вставки гистограммы, графика, круговой или лепестковой диаграммы. Обратите внимание на то, что другие типы диаграмм в настоящее время не поддерживают сводные таблицы. Например, диаграммы "дерево", а также статистические и комбинированные диаграммы использовать нельзя.

  4. После вставки гистограммы, графика, круговой или лепестковой диаграммы вы сможете сводить данные в ней путем изменения или перемещения полей в списке полей сводной таблицы.

  5. Вы также можете фильтровать данные в сводной таблице и использовать срезы. При этом также фильтруются данные в диаграмме.

Дополнительные сведения

Вы всегда можете задать вопрос специалисту Excel Tech Community, попросить помощи в сообществе Answers community, а также предложить новую функцию или улучшение на веб-сайте Excel User Voice.

См. также:

Создание сводной таблицы
Упорядочение полей сводной таблицы с помощью списка полей
Использование срезов для фильтрации данных
Создание временной шкалы сводной таблицы для фильтрации дат

Совершенствование навыков
Перейти к обучению
Первоочередный доступ к новым возможностям
Присоединиться к программе предварительной оценки Office

Были ли сведения полезными?

Спасибо за ваш отзыв!

Благодарим за отзыв! Возможно, будет полезно связать вас с одним из наших специалистов службы поддержки Office.

×