Создание решения для учета активов с помощью InfoPath и Excel

Важно :  Данная статья переведена с помощью машинного перевода, см. Отказ от ответственности. Используйте английский вариант этой статьи, который находится здесь, в качестве справочного материала.

Microsoft Office InfoPath позволяет создавать шаблоны форм для ввода и сбора данных, а Microsoft Office Excel 2007 дает возможность вычислять и анализировать данные, а также представлять их в виде диаграмм. Используя обе эти программы и XML, можно легко создать простое, но эффективное бизнес-решение для учета активов компании. Для этого даже не потребуется писать код.

Обзор решения для отслеживания активов

В этой статье

Создание решения для учета активов

Шаг 1. Настройка шаблона формы для учета активов

Шаг 2. Сопоставление файла схемы и настройка макета таблицы в Excel

Шаг 3. Создание отчетов сводной таблицы и сводной диаграммы

Шаг 4. Сбор сведений об активах от пользователей

Шаг 5. Импорт форм в Excel

Заключительные соображения: использование списка SharePoint или базы данных Access

Создание решения для учета активов

Можно выполнять обмен данными XML между InfoPath и Excel. Хотя в Infopath есть команда Экспорт, которая является простым способом отправки данных формы в Excel, существует и другой, более гибкий, способ. Сопоставив файл схемы XML InfoPath (XSD-файл) в приложении Excel, а затем импортировав в него файлы форм InfoPath (XML-файлы), можно настроить макет данных и использовать функции Excel для более эффективного управления данными и их анализа.

В этой статье на примере шаблона формы InfoPath для учета активов показывается, как использовать InfoPath в сочетании с XML и Excel. Предположим, что каждый год в организации учитываются активы в кабинете каждого сотрудника. Затем выполняется отчет Excel, чтобы решить, как распределить бюджет на оборудование в следующем году. На схеме ниже представлен процесс сбора, отслеживания данных об активах отдела, а также создания отчетов по ним.

a

1. Создается шаблон формы для отслеживания активов.

2. Файл схемы сопоставляется с таблицей Excel, настраивается макет таблицы.

3. Создаются пустые отчеты сводной таблицы и сводной диаграммы.

4. С помощью формы для отслеживания активов собираются данные от пользователей.

5. Все данные форм экспортируются в таблицу Excel, а отчеты сводной таблицы и сводной диаграммы обновляются.

Это решение включает в себя следующие роли пользователей и продукты:

Значок полной поддержки = Обязательно Значок отсутствия поддержки = Необязательно

Требования к программному обеспечению

Роли

Office InfoPath 2007

Office Outlook 2007

Office Excel 2007

Разработчик решений

Значок полной поддержки

Значок полной поддержки

Значок полной поддержки

Лицо, принимающее решения

Значок полной поддержки

Значок полной поддержки

Значок полной поддержки

Сотрудники

Значок полной поддержки

Значок полной поддержки

Значок отсутствия поддержки

К началу страницы

Шаг 1. Настройка шаблона формы для отслеживания активов

Шаблон формы для учета активов, который предлагается с InfoPath, позволяет собирать сведения о всех активах в кабинете сотрудника, отделе, к которому относится сотрудник, категориях активов и их характеристиках. В этом решении разработчик формы отправляет ее шаблон на электронный адрес лица, принимающего решения, с помощью Office Outlook 2007.

Шаблон "Основные фонды"

Задача 1. Открытие и настройка шаблона формы для учета активов

Поскольку шаблон формы невозможно опубликовать для списка получателей электронной почты, если он содержит элемент управления "Форматированный текст", содержащий связанные изображения, потребуется внести небольшое изменение в шаблон формы учета активов.

  1. В меню Файл выберите пункт Создать шаблон формы.

  2. В диалоговом окне Создание шаблона формы в группе Открыть шаблон формы выберите Настроить образец.

  3. В диалоговом окне Приступая к работе щелкните Учет активов (образец), а затем в разделе Задачи формы нажмите кнопку Изменить эту форму.

  4. Щелкните правой кнопкой мыши элемент управления assetNotes, наведите указатель мыши на свойства Форматированный текст, откройте вкладку Отображение, а затем в разделе Доступное форматирование снимите флажок Связанные рисунки.

Задача 2. Настройка параметров отправки

Далее нужно определить параметры отправки, чтобы сотрудники могли отправлять XML-файл формы с уникальным именем в виде вложения на электронный адрес лица, принимающего решения.

  1. В меню Сервис выберите команду Параметры отправки.

  2. В диалоговом окне Параметры отправки установите флажок Разрешить пользователям отправлять эту форму.

  3. Нажмите кнопку Отправить данные формы в одно место, а затем в списке выберите пункт Электронная почта.

  4. Нажмите кнопку Добавить.

    Появится мастер подключения к данным.

  5. В поле Кому введите псевдоним лица, принимающего решения, который будет получать все отправленные формы.

  6. Чтобы использовать уникальную тему, в поле Тема:

    • Выберите пункт Вставить формулу Кнопка формулы .

    • Введите следующую формулу:

concat(my:employee/my:employeeName, my:employee/my:employeeDepartment)

  • Нажмите кнопку Проверить формулу, а затем дважды нажмите кнопку ОК.

  • В поле Введение введите сообщение или инструкции для этого решения.

  • Нажмите кнопку Далее.

  • На следующей странице мастера выберите Отправить данные формы как вложение и установите флажок Вложить шаблон формы, чтобы пользователи могли открывать форму .

    Это позволит сотрудникам получать доступ к XSN-файлу шаблона формы, если они не смогут открыть его из сети.

  • Чтобы использовать уникальное имя для каждого XML-файла формы, в поле Имя вложения:

    1. Выберите пункт Вставить формулу Кнопка формулы .

    2. Введите ту же формулу, что и для строки Тема:

concat(my:employee/my:employeeName, my:employee/my:employeeDepartment)

  1. Нажмите кнопку Проверить формулу, а затем дважды нажмите кнопку ОК.

  • Нажмите кнопку Далее.

  • На следующей странице мастера в поле Введите имя подключения данных введите описательное имя для этого подключения данных.

  • Проверьте правильность введенных данных в разделе Сводка, а затем нажмите кнопку Готово.

  • Сохраните форму в общей сетевой папке, доступной лицу, принимающему решения, и всем сотрудникам.

К началу страницы

Шаг 2. Сопоставление файла схемы и настройка макета таблицы в Excel

Для настройки связи между InfoPath и Excel необходимо выполнить три задачи: извлечь файл схемы для шаблона формы учета активов, сопоставить этот файл схемы в Excel и настроить структуру таблицы Excel, которая будет содержать все импортированные XML-файл данных формы.

Задача 1. Извлечение файла схемы из InfoPath

  1. В приложении InfoPath откройте файл шаблона формы для учета активов.

  2. В меню Сервис выберите пункт Изменить эту форму.

  3. В меню Файл выберите команду Сохранить как исходные файлы.

  4. В диалоговом окне Поиск папки выберите или создайте папку, в которой нужно сохранить файл схемы.

Запишите расположение папки, в которой сохраняются все исходные файлы, и имя файла схемы (в этом случае myschema.xsd), который содержит определение схемы для XML-данных формы.

Задача 2. Сопоставление файла схемы InfoPath в Excel

  1. Создайте файл Excel и сохраните его в расположении, доступном лицу, принимающему решения.

  2. Если в Excel не отображается вкладка Разработчик, выполните указанные ниже действия.

    1. Нажмите кнопку Microsoft Office Изображение кнопки Office , а затем — кнопку Параметры Excel.

    2. В категории Основные в разделе Основные параметры работы с Excel установите флажок Показывать вкладку «Разработчик» на ленте, а затем нажмите кнопку ОК.

      Примечание : Лента входит как компонент в Пользовательский интерфейс Microsoft Office Fluent.

  3. На вкладке Разработчик в группе XML нажмите кнопку Источник.

    Группа XML на ленте

    Появится область задач XML-источник.

  4. Нажмите кнопку Карты XML, а затем в диалоговом окне Карты XML нажмите кнопку Добавить.

  5. На компьютере с операционной системой Windows Vista   

    1. В адресной строке выберите диск или папку, где находится файл myschema.xsd, созданный на шаге 2 раздела Задача 1. Извлечение файла схемы из InfoPath.

      На компьютере с операционной системой Microsoft Windows XP   

    2. В списке Папки выберите диск или папку, где находится файл myschema.xsd, созданный на шаге 2 раздела Задача 1. Извлечение файла схемы из InfoPath.

  6. Щелкните этот файл, а затем нажмите кнопку Открыть.

  7. Когда появится диалоговое окно Несколько корней, щелкните корневой узел assetTracking, определенный в файле myschema.xsd, а затем нажмите кнопку ОК.

    Карта XML отображается в области задач XML-источник.

  8. Перетащите узловой элемент ns1:asset, который является повторяющимся XML-элементом, в то место книги, где должна выводиться таблица Excel.

    Сопоставление файла схемы Infopath c Excel

Задача 3. Настройка макета таблицы Excel

По умолчанию в качестве заголовков столбцов для таблицы Excel используются имена XML-элементов. Однако их можно изменить путем редактирования ячеек заголовков столбцов.

  1. Чтобы изменить заголовки столбцов, заданные по умолчанию, выберите таблицу Excel, найдите префикс строки ns1:asset и удалите его. Например, необходимо изменить ns1:assetID на ID.

    Настройка заголовков таблицы Excel

  2. Чтобы настроить ширину столбца, нажмите кнопку Выделить все, а затем дважды щелкните границу заголовка любого столбца.

К началу страницы

Шаг 3. Создание отчетов сводной таблицы и сводной диаграммы

Отчеты сводной таблицы и сводной диаграммы используются для анализа, изучения и визуализации сведенных данные. Если заранее настроить отчеты сводных таблиц и сводных диаграмм, лицу, принимающему решения, будет достаточно выполнить отчет с заполненными данными.

  1. Выберите ячейку в таблице Excel.

  2. На вкладке Вставка в группе Таблицы щелкните Сводная таблица и Сводная таблица.

    Изображение ленты Excel

    Откроется диалоговое окно Создание сводной таблицы.

  3. Чтобы поместить отчет сводной таблицы на новый лист, начиная с ячейки A1, щелкните элемент На новый лист и нажмите кнопку ОК.

    Excel добавит пустой отчет сводной таблицы в указанное место и откроет список полей сводной таблицы, с помощью которого можно добавить поля, создать макет и настроить отчет.

  4. Для создания перекрестного отчета перетащите поле Идентификатор в область значений, поле Отдел в область подписей столбцов, поле Категория в строку подписей строк, а поле Назначено в область фильтра отчета.

  5. Выберите отчет сводной таблицы.

  6. На вкладке Вставка в группе Диаграммы щелкните тип Линейчатая.

    Изображение ленты Excel

  7. В разделе Линейчатая выберите Линейчатая с группировкой.

  8. Настройте размер и расположение отчета сводной диаграммы.

Пустые отчеты сводной таблицы и сводной диаграммы

К началу страницы

Шаг 4. Сбор сведений об активах от пользователей

Теперь, когда шаблон формы готов к заполнению, вам нужно опубликовать форму и отправить ее сотрудникам. Когда сотрудник отправляет заполненную форму, на электронный адрес лица, принимающего решения, отправляется файл данных XML, вложенный в сообщение. Все такие сообщения можно переместить в специальную папку InfoPath в Outlook. В данном случае рекомендуется назначить определенный период, в течение которого все пользователи должны заполнить форму, чтобы после этого можно было создать отчет по всем формам.

ввод данных в формах отслеживания активов

  1. В InfoPath откройте шаблон формы (XSN-файл), сохраненный на шаге 1 (Настройка шаблона формы для учета активов).

  2. В меню Сервис выберите пункт Изменить эту форму.

  3. В меню Файл выберите команду Опубликовать.

  4. В мастере публикаций выберите вариант По списку получателей электронной почты, а затем нажмите кнопку Далее.

  5. На следующей странице мастера в поле Имя шаблона формы введите имя для шаблона формы, а затем нажмите кнопку Далее. Имя шаблона формы будет отображаться в поле для темы сообщения при отправке его по электронной почте.

  6. При необходимости на следующей странице мастера можно создать столбцы, которые будут отображаться в папках Outlook для упорядочения сообщений электронной почты.

  7. Нажмите кнопку Далее.

  8. Нажмите кнопку Опубликовать.

  9. После того как мастер публикаций завершит публикацию шаблона формы, откроется сообщение с формой.

  10. Заполните сообщение, введите имена сотрудников или укажите список рассылки, а затем отправьте сообщение.

В Outlook можно упорядочить все полученные XML-формы одним из двух способов:

  • Если при первом открытии сообщения появляется окно сообщения Папки формы InfoPath, щелкните Создать папку форм.

  • Создайте в Outlook правило, которое перемещает все связанные формы InfoPath в папку InfoPath.

    Управление сообщениями с помощью правилДополнительные сведения, см.

К началу страницы

Шаг 5. Импорт форм в Excel

Поскольку книга Excel уже была создана на шагах 2 и 3, лицу, принимающему решения, достаточно экспортировать и просмотреть данные формы. Для этого нужно просто экспортировать XML-файлы из Outlook, импортировать все XML-файлы формы в книгу Excel, а затем обновить данные.

Задача 1. Экспорт форм из Outlook в папку Windows

  1. В Outlook выберите папку, которая содержит все формы, полученные от сотрудников, и нажмите клавиши CTRL+A, чтобы выделить все сообщения с формами.

  2. Щелкните выбранные формы правой кнопкой мыши, наведите указатель на пункт Действия InfoPath и выберите Экспорт форм.

  3. В диалоговом окне Экспорт форм выберите папку и нажмите клавишу ОК.

Задача 2. Импорт форм в Excel

  1. В книге Excel, созданной на шаге 2 (Сопоставление файла схемы и настройка макета таблицы в Excel), выберите одну из сопоставленных ячеек в таблице Excel.

  2. На вкладке Разработчик в группе XML нажмите кнопку Импорт.

    Группа XML на ленте

    Откроется диалоговое окно Импорт XML.

  3. На компьютере с операционной системой Windows Vista   

  4. Выполните одно из следующих действий.

    • Если файлы являются смежными, нажмите клавишу SHIFT, а затем щелкните первый и последний файл в списке.

    • Если файлы не являются смежными, нажмите клавишу CTRL, а затем щелкните файлы списка, которые нужно импортировать.

  5. Нажмите кнопку Импорт.

    Таблица Excel с импортированными данными

По умолчанию Excel перезаписывает все данные в сопоставленных ячейках, что и требуется сделать в этом случае. Но, предположим, что лицу, принимающему решения, нужно импортировать данные несколько раз, чтобы отследить ход выполнения с учетом запланированного крайнего срока.

Примечание : В Excel можно также добавлять данные, используя параметр добавлять новые данные в существующие XML-таблицы (на вкладке Разработчик в группе XML нажмите кнопку Свойства карты), что может быть приемлемо для других решений.

Подробнее, читайте разделы справки Excel Импорт XML-данных и Добавление или сопоставленных XML-данные будут перезаписаны.

Задача 3. Обновление отчетов сводной таблицы и сводной диаграммы

  • Щелкните ячейку в отчете сводной таблицы.

  • На вкладке Параметры в группе Данные щелкните стрелку рядом с командой Обновить все, а затем выберите пункт Обновить.

    Изображение ленты Outlook

Итоговый отчет сводной таблицы или сводной диаграммы

Теперь книга Excel содержит все данные и сводные отчеты, необходимые для выделения бюджета на оборудование для следующего года. Конечно же, при необходимости можно выполнить дальнейший анализ данных в книге Excel, например применить к ним сортировку, фильтрацию или условное форматирование.

К началу страницы

Заключительные соображения: использование списка SharePoint или базы данных Access

В качестве альтернативы для переноса данных из InfoPath в Excel можно использовать список SharePoint или базу данных Access.

Использование списка SharePoint

В InfoPath можно легко использовать список SharePoint в качестве источника данных, доступного только для чтения. Выполните одно из указанных ниже действий.

  • В списке SharePoint экспортируйте данные в Excel. При этом будет автоматически создано подключение к данным в Excel.

  • В Excel создайте подключение к данным из списка SharePoint.

После создания подключения к данным можно обновить данные в Excel, чтобы получить актуальные данные.

Можно использовать список SharePoint для добавления и обновления данных, форму InfoPath для отображения элементов списка (например, сложные или длинные элементы лучше выводить вертикально), а затем Excel для дальнейшего анализа данных.

Объединение InfoPath, списка SharePoint и Excel

1. Отображение одного элемента для удобного просмотра в InfoPath.

2. Добавление и обновление данных в списке SharePoint.

3. Обновление данных в Excel и создание отчетов по ним.

Дополнительные сведения см. в статьях Добавление подключения к библиотеке или списку документов SharePoint и Импорт данных из списка SharePoint.

Использование базы данных Access

В InfoPath можно создать подключение к базе данных Access с доступом на чтение и запись. Из Excel можно создать подключение к данным в базе данных Access, чтобы получать актуальные данные путем обновления. Подключение также может автоматически обновляться при открытии книги или через регулярные интервалы, например 5 минут.

Базу данных Access можно использовать в качестве посредника между InfoPath и Excel. При отправке формы InfoPath в Access база данных Access обновляется. При обновлении подключения к данным в Excel можно получить обновленные данные из Access. По сути, данные отправляются из InfoPath в книгу Excel.

Объединение InfoPath, Access и Excel

1. Отображение формы и отправка сведений в базу данных Access.

2. Хранение данных в базе данных Access.

3. Обновление данных в Excel и создание отчетов по ним.

Дополнительные сведения см. в статье Разработка шаблона формы, основанного на базе данных Microsoft Access.

Совет : Знаете ли вы, что форму InfoPath можно создать непосредственно в Access 2007? Если на компьютерах пользователей есть Outlook 2007 и InfoPath 2007, можно собирать данные непосредственно из Access 2007, используя мастер Сбор данных по электронной почте. Дополнительные сведения см. в разделе справки Access 2007 Сбор данных по электронной почте.

К началу страницы

Примечание : Отказ от ответственности относительно машинного перевода. Данная статья была переведена с помощью компьютерной системы без участия человека. Microsoft предлагает эти машинные переводы, чтобы помочь пользователям, которые не знают английского языка, ознакомиться с материалами о продуктах, услугах и технологиях Microsoft. Поскольку статья была переведена с использованием машинного перевода, она может содержать лексические,синтаксические и грамматические ошибки.

Совершенствование навыков
Перейти к обучению
Первоочередный доступ к новым возможностям
Присоединиться к программе предварительной оценки Office

Были ли сведения полезными?

Спасибо за ваш отзыв!

Благодарим за отзыв! Возможно, будет полезно связать вас с одним из наших специалистов службы поддержки Office.

×