Создание решения для отслеживания активов с помощью InfoPath и Excel

Примечание: Мы стараемся как можно оперативнее обеспечивать вас актуальными справочными материалами на вашем языке. Эта страница переведена автоматически, поэтому ее текст может содержать неточности и грамматические ошибки. Для нас важно, чтобы эта статья была вам полезна. Просим вас уделить пару секунд и сообщить, помогла ли она вам, с помощью кнопок внизу страницы. Для удобства также приводим ссылку на оригинал (на английском языке).

С помощью Microsoft Office InfoPath можно создавать шаблоны форм для ввода и сбора данных. _з0з_ позволяет пользователям выполнять расчет, построение диаграмм и анализ данных. С помощью обоих этих программ и XML можно легко создать простое, но эффективное бизнес-решение для отслеживания активов в компании.

Обзор решения для отслеживания активов

В этой статье

Общие сведения о создании решения для отслеживания активов

Шаг 1: Настройка шаблона формы регистрации активов

Шаг 2: сопоставление файла схемы и настройка макета таблицы в Excel

Шаг 3: создание сводного отчета сводной таблицы и сводной диаграммы

Шаг 4: сбор сведений о ресурсах для пользователей

Шаг 5: импорт форм в Excel

Заключительные идеи: попробуйте использовать список или базу данных Access в SharePoint

Общие сведения о создании решения для отслеживания активов

Вы можете обмениваться данными XML между InfoPath и Excel. Несмотря на то что команда " Экспорт " InfoPath является простым способом отправки данных формы в Excel, вы можете воспользоваться другим подходом, который обеспечивает большую гибкость. Явным образом сопоставляя файл схемы XML InfoPath (XSD) в Excel, а затем импортируйте файлы форм InfoPath (XML) в Excel, вы можете настроить макет данных и улучшить использование функций Excel для упрощения управления ими и их анализа.

В этой статье мы воспользуемся шаблоном учебной формы "средство регистрации активов" InfoPath, в котором показано, как обеспечить взаимодействие InfoPath, XML и Excel. Представьте, что каждый год ваша организация дополнит инвентаризацию активов в офисе каждого сотрудника. Затем запускается отчет Excel, чтобы выбрать способ выделения бюджета оборудования на следующий год. На следующей схеме показано, как можно собрать, отслеживать и сообщать о ресурсах активов в отделе.

a

1. шаблон формы регистрации активов создан.

2. файл схемы сопоставлен с таблицей Excel, а макет таблицы настроен.

3. создается пустая Сводная таблица и сводный отчет сводной диаграммы.

4. Форма регистрации активов используется для сбора данных от пользователей.

5. все данные в форме экспортируются в таблицу Excel, а отчеты сводных таблиц и сводных диаграмм обновляются.

Это решение включает следующие роли пользователей и продукты.

_з0з_= обязательный _з2з_= не требуется

Требования к программному обеспечению

Роли

Office InfoPath 2007

Office Outlook 2007

Office Excel 2007

Конструктор решений

Значок полной поддержки

Значок полной поддержки

Значок полной поддержки

Решение — лицо

Значок полной поддержки

Значок полной поддержки

Значок полной поддержки

Employees

Значок полной поддержки

Значок полной поддержки

Значок отсутствия поддержки

К началу страницы

Шаг 1: Настройка шаблона формы регистрации активов

Шаблон формы регистрации активов, включенный в InfoPath, позволяет собирать сведения о каждом ресурсе в офисе сотрудника, отделе, которому принадлежит сотрудник, категориях ресурсов и сведения о каждом ресурсе. В этом решении конструктор форм отправляет шаблон формы в учетную запись электронной почты разработчика-производителя с помощью _з0з_.

Шаблон "Основные фонды"

Задача 1: открытие и настройка шаблона формы регистрации активов

Так как вы не можете опубликовать шаблон формы в списке получателей электронной почты, если в ней есть элемент управления "форматированный текст" с связанными изображениями, необходимо внести небольшое изменение в шаблон формы "образец регистрации активов".

  1. В меню файл выберите пункт конструктор шаблонов форм.

  2. В диалоговом окне Создание шаблона формы в разделе Открыть шаблон формы нажмите кнопку Настройка образца.

  3. В диалоговом окне Приступая к работе щелкните ссылку Регистрация активов, а затем в разделе задачи формы нажмите кнопку конструктор форм.

  4. Щелкните правой кнопкой мыши элемент управления ассетнотес, наведите указатель на пункт Свойства поля форматированного текста, откройте вкладку Отображение, а затем в разделе Доступное форматирование снимите флажок связанные изображения.

Задача 2: определение параметров отправки

Следующая задача состоит в том, чтобы определить параметры отправки, чтобы сотрудники могли отправлять в учетную запись электронной почты в качестве вложенного файла файл формы с уникальным именем (XML).

  1. В меню Сервис выберите команду Параметры отправки.

  2. В диалоговом окне " Параметры отправки " установите флажок Разрешить пользователям отправлять форму.

  3. Нажмите кнопку отправить данные формы в одно место назначения, а затем в списке выберите пункт Электронная почта.

  4. Нажмите кнопку Добавить.

    Откроется Мастер подключения к данным.

  5. В поле Кому введите псевдоним решения, который будет получать все отправленные формы.

  6. Чтобы указать уникальную строку Тема, в поле Тема:

    • Нажмите кнопку Вставить формулу_з0з_.

    • Введите следующую формулу:

concat(my:employee/my:employeeName, my:employee/my:employeeDepartment)

  • Нажмите кнопку Проверить формулу, а затем дважды нажмите кнопку ОК.

  • В поле Введение введите соответствующее сообщение или добавьте важные инструкции для этого решения.

  • Нажмите кнопку Далее.

  • На следующей странице мастера выберите команду отправить данные формы в виде вложения, а затем выберите вложенный шаблон формы, чтобы пользователи могли открывать форму.

    Это гарантирует, что сотрудники смогут получить доступ к файлу шаблона формы (XSN) в том случае, если им не удается получить доступ к ней из расположения в сети.

  • Чтобы указать уникальное имя для каждого файла формы (XML) в поле имя вложения, выполните следующие действия:

    1. Нажмите кнопку Вставить формулу_з0з_.

    2. В строке Тема введите формулу, совпадающую с одной.

concat(my:employee/my:employeeName, my:employee/my:employeeDepartment)

  1. Нажмите кнопку Проверить формулу, а затем дважды нажмите кнопку ОК.

  • Нажмите кнопку Далее.

  • На следующей странице мастера в поле введите имя для этого подключения к данным введите описательное имя для этого подключения к данным отправки.

  • Проверьте правильность сведений в разделе " Сводка " и нажмите кнопку "Готово".

  • Сохраните форму в общедоступной сетевой папке, доступной для вашего решения и для всех сотрудников.

К началу страницы

Шаг 2: сопоставление файла схемы и настройка макета таблицы в Excel

Для настройки подключения между InfoPath и Excel необходимо выполнение трех задач: извлечение файла схемы для шаблона формы регистрации активов, сопоставление этого файла схемы в Excel и настройка макета по умолчанию для таблицы Excel, в которой будут содержаться все импортированные XML-данные файлы данных форм.

Задача 1: извлечение файла схемы из InfoPath

  1. В приложении InfoPath откройте файл шаблона формы регистрации активов.

  2. В меню Сервис выберите команду конструктор форм.

  3. В меню файл выберите команду Сохранить как исходные файлы.

  4. В диалоговом окне Обзор папок выберите папку или создайте новую папку, в которой вы хотите сохранить файл схемы.

Обратите внимание на расположение папки, в которой хранятся все исходные файлы, и имя файла схемы, в данном случае мисчема. xsd, которое содержит определение схемы для данных XML формы.

Задача 2: сопоставление файла схемы InfoPath с приложением Excel

  1. Создайте новый файл Excel, а затем сохраните его в расположении, доступном для вашего решения.

  2. Если вкладка разработчик не отображается в Excel, выполните указанные ниже действия.

    1. Нажмите кнопку Microsoft Office Изображение кнопки Office , а затем — кнопку Параметры Excel.

    2. Выберите категорию Популярные, а затем в разделе Основные параметры работы с Excel установите флажок Показывать вкладку "Разработчик" на ленте и нажмите кнопку ОК.

      Примечание: Лента входит в Пользовательский интерфейс Microsoft Office Fluent.

  3. На вкладке Разработчик в группе XML нажмите кнопку Источник.

    Группа XML на ленте

    Откроется область задач XML-источник.

  4. Нажмите кнопку карты XML, а затем в диалоговом окне карты XML нажмите кнопку добавить.

  5. На компьютере под управлением Windows Vista   

    1. В адресной строке выберите диск или папку, в которой находится файл мисчема. xsd , созданный в действии 2 раздела Task 1: извлечение файла схемы из InfoPath.

      На компьютере под управлением Microsoft Windows XP   

    2. В списке Папка выберите диск или папку, в которой находится файл мисчема. xsd , созданный в действии 2 раздела Задача 1: извлечение файла схемы из InfoPath.

  6. Щелкните файл, а затем нажмите кнопку Открыть.

  7. Когда откроется диалоговое окно несколько корней, щелкните корневой узел ассеттраккинг, определенный в файле мисчема. xsd, и нажмите кнопку ОК.

    Карта XML отобразится в области задач XML-источник.

  8. Перетащите элемент node ( NS1 ), который является повторяющимся XML-элементом, в место на листе, где должна отображаться таблица Excel.

    Сопоставление файла схемы Infopath c Excel

Задача 3: Настройка макета таблицы Excel

По умолчанию Excel использует имена XML-элементов в качестве заголовков столбцов таблицы. Однако вы можете изменить заголовки столбцов, изменив ячейки заголовков столбцов.

  1. Чтобы изменить заголовки столбцов по умолчанию, оставьте выбранную таблицу Excel, найдите следующий префикс строки, NS1: ресурс и удалите его. Например, на NS1: ассетид можно изменить значение ID.

    Настройка заголовков таблицы Excel

  2. Чтобы настроить ширину столбца, нажмите кнопку выделить все, а затем дважды щелкните границу заголовка любого столбца.

К началу страницы

Шаг 3: создание сводного отчета сводной таблицы и сводной диаграммы

С помощью отчетов в виде сводной таблицы и сводной диаграммы можно анализировать, просматривать и визуализировать сводные данные. Настроив отчеты сводной таблицы и сводной диаграммы, которые вы хотите использовать в этом сценарии, это будет просто сделать для того, чтобы лицо, принимающее решение, выпустило отчет с заполненными данными позднее.

  1. Выберите ячейку в таблице Excel.

  2. На вкладке Вставка в группе таблицы нажмите кнопку Сводная таблица и выберите пункт Сводная Таблица.

    Изображение ленты Excel

    Откроется диалоговое окно Создание сводной таблицы.

  3. Чтобы поместить отчет сводной таблицы на новый лист, начиная с ячейки a1, установите переключатель на Новый лист и нажмите кнопку ОК.

    Excel добавит пустой отчет сводной таблицы в указанное место и откроет список полей сводной таблицы, в котором можно добавить поля, создать макет и настроить отчет сводной таблицы.

  4. Чтобы создать табличный отчет о данных, перетащите поле ID в область значения, поле отдел в область названия столбцов, поле Категория в область названия строк и поле AssignedTo в область фильтра отчета.

  5. Щелкните отчет сводной таблицы.

  6. На вкладке Вставка в группе диаграммы щелкните тип линейчатой диаграммы.

    Изображение ленты Excel

  7. В разделе двумерной гистограммы выберите пункт линейчатая с группировкой.

  8. Измените размер и расположение отчета сводной диаграммы.

Пустые отчеты сводной таблицы и сводной диаграммы

К началу страницы

Шаг 4: сбор сведений о ресурсах для пользователей

Теперь, когда шаблон формы готов к заполнению всеми сотрудниками, необходимо опубликовать форму и отправить ее каждому сотруднику. Когда каждый сотрудник отправляет заполненную форму, он отправляется в виде файла данных XML (XML), вложенного в сообщение электронной почты, в учетную запись электронной почты производителя. Затем лицо, принимающее решение, может переместить все сообщения в выделенную папку InfoPath в Outlook. В этом случае рекомендуется назначить конкретному периоду времени, чтобы все пользователи заполнили формы таким образом, что при достижении крайнего срока сбора данных разработчик сможет запустить отчет с заполненными формами.

ввод данных в формах отслеживания активов

  1. В InfoPath откройте шаблон формы (XSN-файл), сохраненный на шаге 1: Разработка шаблона формы примера регистрации активов

  2. В меню Сервис выберите команду конструктор форм.

  3. В меню файл выберите пункт опубликовать.

  4. В мастере публикации щелкните список получателей электронной почты, а затем нажмите кнопку Далее.

  5. На следующей странице мастера в поле имя шаблона формы введите имя шаблона формы и нажмите кнопку Далее. Имя шаблона формы появится в заголовке сообщения, которое отправляется получателям сообщения электронной почты.

  6. Кроме того, на следующей странице мастера можно создать столбцы, которые будут отображаться в папках Outlook для упорядочения сообщений электронной почты.

  7. Нажмите кнопку Далее.

  8. Нажмите кнопку Опубликовать.

  9. После того как мастер публикации закончит публикацию шаблона формы, откроется сообщение электронной почты с формой.

  10. ЗаПолните сообщение, введите имена сотрудников или воспользуйтесь списком рассылки, а затем отправьте сообщение.

В Outlook изготовитель решений может упорядочивать все отправленные XML-формы одним из двух способов:

  • Если диалоговое окно " папки форм InfoPath " отображается при первом открытии сообщения, нажмите кнопку создать папку форм.

  • Создание правила в Outlook для перемещения всех связанных форм InfoPath в папку InfoPath.

    Дополнительные сведения см. в статье Управление сообщениями с помощью правил.

К началу страницы

Шаг 5: импорт форм в Excel

Так как вы создали книгу Excel, шаги 2 и 3, можно легко экспортировать и просматривать данные формы. Специалисту по решению просто нужно экспортировать XML-файлы (XML) из Outlook, импортировать все файлы форм (XML) в книгу Excel, а затем обновить данные.

Задача 1: экспорт форм из Outlook в папку Windows

  1. В Outlook выберите папку, которая содержит все формы, полученные от "сотрудники", а затем нажмите клавиши CTRL + A, чтобы выделить все сообщения электронной почты в форме.

  2. Щелкните выделенный фрагмент правой кнопкой мыши, наведите указатель на пункт действия в InfoPath, а затем выберите пункт Экспорт форм.

  3. В диалоговом окне Экспорт форм выберите папку и нажмите кнопку ОК.

Задача 2: импорт форм в Excel

  1. В книге Excel, созданной в действии 2: Сопоставьте файл схемы и настройте макет таблицы в Excel, азатем выберите одну из сопоставленных ячеек в таблице Excel.

  2. На вкладке разработчик в группе XML нажмите кнопку Импорт.

    Группа XML на ленте

    Откроется диалоговое окно Импорт XML.

  3. На компьютере под управлением Windows Vista   

  4. Выполните одно из указанных ниже действий.

    • Если файлы не являются смежными, нажмите клавишу SHIFT, а затем щелкните первый и последний файл в списке.

    • Если файлы не являются смежными, нажмите клавишу CTRL и, удерживая ее, щелкните каждый файл, который нужно импортировать в список.

  5. Нажмите кнопку Импорт.

    Таблица Excel с импортированными данными

По умолчанию Excel перезаписывает все существующие данные в сопоставленных ячейках, что является требуемым конечным результатом для этого бизнес-решения. Тем не менее, решение может, например, импортировать данные несколько раз, чтобы оценить ход выполнения до запланированного срока.

Примечание: В Excel также можно добавить данные с помощью параметра Добавить новые данные в существующие XML-таблицы (на вкладке разработчик в группе XML нажмите кнопку Свойства карты ), что может быть уместным для других решений.

Дополнительные сведения см. в статье Импорт данных XML.

Задача 3: обновление отчетов сводной таблицы и сводной диаграммы

  • Щелкните ячейку отчета сводной таблицы.

  • На вкладке Параметры в группе данные щелкните стрелку рядом с кнопкой Обновить все, а затем выберите пункт Обновить.

    Лента Outlook

Итоговый отчет сводной таблицы или сводной диаграммы

Теперь книга Excel содержит все сводные отчеты, которые вам необходимо выполнить для выделения бюджета оборудования на следующий год. Разумеется, при необходимости можно выполнить дальнейший анализ книги Excel, например сортировку, фильтрацию или условное форматирование данных.

К началу страницы

Заключительные идеи: попробуйте использовать список или базу данных Access в SharePoint

В качестве альтернативы можно использовать список SharePoint или базу данных Access, а не XML, для передачи данных между InfoPath и Excel.

Использование списка SharePoint

В приложении InfoPath список SharePoint можно легко использовать в качестве источника данных, доступного только для чтения. Вы можете выполнить одно из двух действий:

  • Из списка SharePoint экспортируйте данные в Excel, который автоматически создает подключение к данным в Excel.

  • В Excel явным образом создайте подключение данных к списку SharePoint.

После создания подключения к данным можно обновить данные в Excel, чтобы получить актуальные данные.

Вы можете использовать список SharePoint для добавления и обновления данных, использовать форму InfoPath для отображения элемента из списка (например, сложный или длинный элемент, который лучше всего отображать по вертикали), а затем использовать Excel для дальнейшего анализа данных.

Объединение InfoPath, списка SharePoint и Excel

1. Отображение одного элемента для упрощения проверки в InfoPath.

2. Добавление и обновление данных в списке SharePoint.

3. Обновите и сообщите об этом в Excel.

Дополнительные сведения см. в статье Добавление подключения к данным в библиотеке документов SharePoint или списке .

Использование базы данных Access

В приложении InfoPath можно создать подключение к базе данных Access для чтения и записи. В Excel вы можете явно создать подключение к базе данных Access, которое можно обновить для извлечения актуальных данных. Вы даже можете определить подключение, которое будет автоматически обновляться при открытии книги, или периодически обновлять, например каждые 5 минут.

Базу данных Access можно использовать в качестве посредника между InfoPath и Excel. При отправке формы InfoPath в Access обновляется база данных Access. При обновлении подключения к данным в Excel из Access извлекаются обновленные данные. Фактически данные передаются прямо из InfoPath в книгу Excel.

Объединение InfoPath, Access и Excel

1. Отображение и отправка формы в базу данных Access.

2. Сохранение данных в базе данных Access.

3. Обновите и сообщите об этом в Excel.

Дополнительные сведения см. в статье Разработка шаблона формы, основанного на базе данных Microsoft Access.

Совет: Знаете ли вы, что вы можете создать форму InfoPath непосредственно из Access? Если на компьютерах пользователей установлено приложение Outlook 2007 или 2010, а также InfoPath 2007 или 2010, вы можете получать данные от различных пользователей непосредственно из Access с помощью мастера сбора данных из электронной почты. Дополнительные сведения см. в разделе Справка Access, в которую можно добавить данные, полученные по электронной почте, в базу данных Access.

К началу страницы

Совершенствование навыков работы с Office
Перейти к обучению
Первоочередный доступ к новым возможностям
Присоединиться к программе предварительной оценки Office

Были ли сведения полезными?

Спасибо за ваш отзыв!

Благодарим за отзыв! Возможно, будет полезно связать вас с одним из наших специалистов службы поддержки Office.

×