Создание простого отчета

Access позволяет создавать множество различных отчетов любой степени сложности. Прежде чем приступать к работе, следует выбрать источник, из которого будут извлекаться записи отчета. Отчет может представлять собой как простой список, так и подробную сводку данных о продажах, сгруппированных по районам. Однако в любом случае необходимо сначала определить, в каких полях содержатся данные, которые должны войти в отчет, и в каких таблицах или запросах находятся эти поля.

После выбора источника записей проще всего воспользоваться мастером отчетов. Мастер отчетов — это компонент Access, который создает отчеты на основании полученных от вас ответов.

В этой статье

Выбор источника записей

Создание отчета с помощью средства "Отчет"

Создание отчета с помощью мастера отчетов

Создание наклеек с помощью мастера наклеек

Создание отчета с помощью средства "Пустой отчет"

Разделы отчета

Элементы управления

Доработка отчета в режиме макета

Доработка отчета в режиме конструктора

Добавление элементов управления в отчет

Сохранение работы

Просмотр, печать отчета и его отправка по электронной почте

Просмотр отчета

Печать отчета

Отправка отчета по электронной почте

Выбор источника записей

Отчет состоит из данных, полученных из таблиц или запросов, и сведений, хранящихся в макете отчета, таких как подписи, заголовки и рисунки. Таблицы или запросы, в которых содержатся данные, называются также источником записей отчета. Если все необходимые поля содержатся в одной таблице, укажите ее в качестве источника записей. Если поля находятся в нескольких таблицах, в качестве источника записей придется использовать один или несколько запросов. Иногда эти запросы уже существуют в базе данных, но может понадобиться сформировать новые запросы специально для данного отчета.

Создание отчета с помощью средства "Отчет"

Средство "Отчет" — это самый быстрый способ создания отчета, потому что при его использовании отчет формируется сразу же, без запроса дополнительной информации. В отчете будут представлены все записи базовой таблицы или запроса. Хотя получившийся отчет, скорее всего, будет далек от совершенства, он позволит быстро просмотреть базовые данные. После этого отчет можно сохранить и изменить в режиме макета или конструктора в соответствии с поставленной задачей.

  1. В области навигации щелкните таблицу или запрос, на основе которых вы хотите создать отчет.

  2. На вкладке Создание в группе Отчеты выберите Отчет. Выноска 4

    Access создаст отчет и отобразит его в режиме макета.

  3. Дополнительные сведения о просмотре и печати отчета см. в разделе Просмотр, печать отчета и его отправка по электронной почте.

После просмотра отчет можно сохранить, а затем закрыть и его, и источник записей — таблицу или запрос. В следующий раз при открытии отчета Access отобразит в нем самые последние данные из источника записей.

Создание отчета с помощью мастера отчетов

В мастере отчетов можно более точно настроить поля, которые требуется включить в отчет. При этом вы можете указать способ группировки и сортировки данных, а также добавить в отчет поля из нескольких таблиц или запросов, если отношения между ними заданы заранее.

  • На вкладке Создание в группе Отчеты выберите Мастер отчетов.

  • Следуйте указаниям на страницах мастера отчетов. На последней странице нажмите кнопку Готово.

    Предварительный просмотр отчета позволяет увидеть, как он будет выглядеть при печати. Вы также можете увеличить масштаб для просмотра деталей. Дополнительные сведения о просмотре и печати отчета см. в разделе Просмотр, печать отчета и его отправка по электронной почте.

Примечание : Если нужно добавить в отчет поля из нескольких таблиц или запросов, не нажимайте в мастере отчетов кнопку Далее или Готово после выбора полей из первой таблицы или запроса. Повторите процедуру выбора для другой таблицы или запроса, а также выберите щелчком мыши другие поля, которые вы хотите добавить в отчет. Затем для продолжения нажмите кнопку Далее или Готово.

Создание наклеек с помощью мастера наклеек

Мастер наклеек помогает создавать наклейки большинства стандартных размеров.

  1. В области навигации дважды щелкните источник записей для наклеек — таблицу или запрос.

  2. На вкладке Создание в группе Отчеты выберите Наклейки.

  3. Следуйте инструкциям на страницах мастера наклеек. На последней странице нажмите кнопку Готово.

Отобразятся наклейки в режиме предварительного просмотра, дающем представление о том, как они будут выглядеть в напечатанном виде. При помощи ползунка в строке состояния Access можно увеличить масштаб, чтобы просмотреть детали. Дополнительные сведения о просмотре и печати отчета см. в разделе Просмотр, печать отчета и его отправка по электронной почте.

Примечание : Предварительный просмотр — это единственный режим, в котором видны несколько столбцов. В других представлениях данные отображаются в одном столбце.

Создание отчета с помощью средства "Пустой отчет"

Если вам не подходят ни средство "Отчет", ни мастер отчетов, можно создать отчет с нуля при помощи средства "Пустой отчет". Это очень быстрый способ, особенно если в отчет нужно добавить всего несколько полей. Чтобы воспользоваться средством "Пустой отчет", выполните следующие действия:

  • На вкладке Создание в группе Отчеты выберите Пустой отчет. Изображение кнопки

    В режиме макета будет открыт пустой отчет, а в правой части окна Access появится область "Список полей".

  • В области Список полей щелкните знак плюс (+) рядом с одной или несколькими таблицами, содержащими поля, которые вы хотите включить в отчет.

  • По очереди перетащите каждое из полей в отчет либо, нажав и удерживая клавишу CTRL, выберите несколько полей и перетащите их одновременно.

  • С помощью инструментов в группе Колонтитул на вкладке Конструктор можно добавить в отчет логотип компании, название, номера страниц, дату и время. Обратите внимание: если вы используете Access 2007, эти средства находятся в группе Элементы управления на вкладке Формат.

Разделы отчета

Отчет Access состоит из нескольких разделов. Разделы можно просматривать в режиме конструктора. Чтобы создавать полезные отчеты, необходимо понимать, для чего используется каждый раздел. Например, от того, в каком разделе размещается вычисляемый элемент управления, зависит то, как Access рассчитывает результаты. В следующем списке описаны разделы отчета и их использование:

  • Заголовок отчета.    Печатается только один раз в начале отчета. В заголовок включается информация, обычно помещаемая на обложке, например логотип компании, название отчета или дата. Если в заголовок отчета добавлен вычисляемый элемент управления, использующий агрегатную функцию Sum, сумма рассчитывается для всего отчета. Заголовок отчета печатается перед верхним колонтитулом.

  • Верхний колонтитул.    Печатается вверху каждой страницы. Верхний колонтитул используется в тех случаях, когда нужно, например, чтобы название отчета повторялось на каждой странице.

  • Заголовок группы.    Печатается в начале каждой новой группы записей. Заголовок группы служит для печати имени группы. Например, в отчете, сгруппированном по товарам, заголовок группы можно использовать для печати названия товара. Если в заголовке группы есть вычисляемый элемент управления с агрегатной функцией Sum, сумма вычисляется для текущей группы.

  • Область данных.     Этот раздел печатается один раз для каждой строки данных из источника записей. В нем размещаются элементы управления, составляющие основное содержание отчета.

  • Примечание группы.    Печатается в конце каждой группы записей. Примечание группы можно использовать для печати сводной информации о ней.

  • Нижний колонтитул.    Выводится в конце каждой страницы. Используется для нумерации страниц и печати сведений, относящихся к странице.

  • Примечание отчета.    Печатается один раз в конце отчета. Примечание отчета можно использовать для печати итогов и другой сводной информации по всему отчету.

    Примечание : В Конструкторе примечание отчета отображается под нижним колонтитулом. Однако при печати или предварительном просмотре этот раздел помещается над нижним колонтитулом, сразу после последнего примечания группы или последней строки данных на последней странице.

К началу страницы

Сведения об элементах управления

Элементами управления называются объекты, которые используются для отображения данных или выполнения других действий, а также выводят элементы, улучающие пользовательский интерфейс (например, надписи и рисунки), и позволяют работать с ними. Access поддерживает три типа элементов управления: связанные, свободные и вычисляемые.

  • Связанный элемент управления    —это элемент управления, источником данных для которого служит поле в таблице или запросе. Такие элементы управления используются для отображения значений, полученных из полей базы данных. Значениями могут быть текст, даты, числа, логические значения, изображения или графики. Самым распространенным типом связанных элементов управления является текстовое поле. Например, текстовое поле формы, в котором отображается фамилия сотрудника, может получать эти сведения из поля "Фамилия" в таблице "Сотрудники".

  • Свободный элемент управления    —это элемент управления, который не имеет источника данных (такого как поле или выражение). Свободные элементы управления применяются для отображения сведений, линий, прямоугольников и рисунков. Например, метка с названием отчета является свободным элементом управления.

  • Вычисляемый элемент управления    — это элемент управления, источником данных для которого является выражение, а не поле. Вы указываете значение, которое хотите использовать для элемента управления, определив выражение в качестве его источника данных. Выражение может быть сочетанием операторов (таких как = и +), имен элементов управления и полей, функций, возвращающих одно значение, и констант. Например, следующее выражение вычисляет цену товара с 25-процентной скидкой путем умножения значения в поле "Цена за единицу" на постоянное значение (0,75):

    = [Цена за единицу] * 0,75

    Выражения могут использовать данные из поля в базовой таблице или запросе формы, а также данные из другого элемента управления в отчете.

При создании отчета, возможно, эффективнее сначала добавить и разместить все связанные элементы управления, особенно если они составляют большинство элементов управления в отчете. После этого вы можете добавить свободные и вычисляемые элементы управления с помощью средств в группе Элементы управления на вкладке Конструктор.

Элемент управления связывается с полем путем определения поля, из которого он получает данные. Элемент управления, связанный с выбранным полем, можно создать путем перетаскивания поля из списка полей в отчет. В списке полей отображаются поля таблицы или запроса, на основе которых был создан отчет. Чтобы вывести область Список полей, на вкладке Конструктор в группе Элементы управления нажмите кнопку Добавить поля.

Кроме того, вы можете привязать поле к элементу управления, введя его имя в сам элемент управления или в поле значения ControlSource на его странице свойств. Страница свойств определяет характеристики элемента управления, например его имя, источник данных и формат.

Элементы управления рекомендуется создавать с помощью области Список полей по двум причинам:

  • Связанный элемент управления имеет прикрепленную подпись, и эта подпись по умолчанию принимает в качестве заголовка имя поля (или заголовка, определенного для данного поля в базовой таблице или запросе), поэтому не нужно вводить заголовок самостоятельно.

  • Связанный элемент управления наследует многие параметры поля из базовой таблицы или запроса (например, свойства Format, DecimalPlaces и InputMask). Это гарантирует, что значения свойств поля не изменятся при создании связанного с ним элемента управления.

Если вы уже создали свободный элемент управления, который необходимо связать с полем, задайте имя поля в качестве значения свойства ControlSource этого элемента управления. Для получения дополнительных сведений о свойстве ControlSource выполните поиск по слову "ControlSource" в справочной системе.

К началу страницы

Доработка отчета в режиме макета

Созданный отчет легко доработать в режиме макета. Ориентируясь на фактические данные отчета, можно отрегулировать ширину столбцов, изменить их порядок, добавить уровни группировки и итоговые значения. Вы можете добавить в отчет новые поля, а также изменить свойства отчета и входящих в него элементов управления.

Чтобы перейти в режим макета, щелкните правой кнопкой мыши имя отчета в области навигации и выберите команду Режим макета Выноска 4 .

Access выведет отчет в режиме макета.

Для изменения свойств отчета, элементов управления и разделов можно использовать страницу свойств. Чтобы открыть страницу свойств, нажмите клавишу F4.

Вы можете использовать область Список полей, чтобы добавить поля из базовой таблицы или запроса в структуру отчета. Чтобы отобразить область Список полей, выполните одно из следующих действий:

  • На вкладке Конструктор в группе Сервис выберите пункт Добавить существующие поля Выноска 4 . Обратите внимание: если вы используете Access 2007, команда Добавить существующие поля находится в группе Элементы управления на вкладке Формат.

  • Нажмите клавиши ALT+F8.

После этого можно будет добавлять поля в отчет, перетаскивая их из области Список полей.

К началу страницы

Доработка отчета в режиме конструктора

Вы также можете настроить структуру отчета, используя конструктор. Можно добавить новые элементы управления и поля в отчет, поместив их на бланк. На странице свойств можно задать большое количество свойств для настройки отчета.

Чтобы переключиться на конструктор, щелкните правой кнопкой мыши имя отчета в области навигации и выберите команду Конструктор Изображение кнопки .

Access выведет отчет в конструкторе.

Для изменения свойств отчета, элементов управления и разделов можно использовать страницу свойств. Чтобы открыть страницу свойств, нажмите клавишу F4.

Вы можете использовать область Список полей, чтобы добавить поля из базовой таблицы или запроса в структуру отчета. Чтобы отобразить область Список полей, выполните одно из следующих действий:

  • На вкладке Формат в группе Элементы управления нажмите кнопку Добавить поля Выноска 4 . Обратите внимание: если вы используете Access 2007, команда Добавить существующие поля находится в группе Элементы управления на вкладке Формат.

  • Нажмите клавиши ALT+F8.

После этого можно будет добавлять поля в отчет, перетаскивая их из области Список полей.

К началу страницы

Добавление поля из области ''Список полей''

  • Чтобы добавить одно поле, перетащите его из области Список полей в нужный раздел отчета.

  • Чтобы добавить сразу несколько полей, щелкните их, удерживая нажатой клавишу CTRL. Затем перетащите выбранные поля в отчет.

При перетаскивании полей Access создает для каждого из них связанное текстовое поле и автоматически размещает рядом с ним подпись.

К началу страницы

Добавление элементов управления в отчет

Некоторые элементы управления создаются автоматически. Например, при добавлении в отчет поля из области Список полей создается связанный элемент управления. Множество других элементов управления можно создать в конструкторе с помощью средств в группе Элементы управления на вкладке Конструктор.

Определение имени средства

  • Наведите указатель мыши на средство.

    Access отобразит имя средства.

Создание элемента управления с помощью средств в группе "Элементы управления"

  1. Щелкните инструмент для типа элемента управления, который вы хотите добавить. Например, чтобы создать флажок, щелкните Флажок Выноска 4 .

  2. Щелкните в бланке формы место, где должен быть левый верхний угол элемента управления. Щелкните один раз, чтобы создать элемент управления стандартного размера, или щелкните средство и перетащите указатель мыши в бланке, чтобы получить элемент управления нужного размера.

  3. Если вам не удалось с первой попытки поместить элемент управления туда, куда нужно, его можно переместить:

    1. Щелкните элемент управления, чтобы выделить его.

    2. Наведите указатель мыши на край элемента управления и удерживайте его, пока указатель не примет вид четырехсторонней стрелки Указатель перемещения .

    3. Перетащите элемент управления в нужное место.

В результате этой процедуры создается свободный элемент управления. Если тип элемента управления подразумевает отображение данных (например, текстовое поле или флажок), для этого необходимо указать в его свойстве ControlSource имя поля или выражение. Дополнительные сведения см. в разделе Элементы управления.

Отображение страницы свойств

Чтобы отобразить окно свойств в режиме конструктора, выполните одно из следующих действий:

  • На вкладке Конструктор в группе Сервис нажмите кнопку Окно свойств. Обратите внимание: если вы используете Access 2007, команда Окно свойств находится в группе Показать или скрыть на вкладке Конструктор.

  • Нажмите клавишу F4.

К началу страницы

Сохранение документа

Сохранив макет отчета, можно в дальнейшем выполнять отчет по мере необходимости. Макет останется без изменений, однако в сам отчет при печати или просмотре каждый раз будут включаться текущие данные. При необходимости вы можете изменить макет отчета или создать на его основе похожий отчет.

Сохранение макета отчета

  • Щелкните Файл > Сохранить или нажмите клавиши CTRL+S. Если вы используете Access 2007, нажмите кнопку Microsoft Office и выберите команду Сохранить или нажмите клавиши CTRL+S.

    Кроме того, вы можете нажать кнопку Сохранить Изображение кнопки на панели быстрого доступа.

  • Если у отчета нет названия, введите его в поле Имя отчета, а затем нажмите кнопку ОК.

Сохранение макета отчета под новым именем

  • Если вы используете Access 2013 или более поздней версии, выберите Файл > Сохранить как > Сохранить объект как.

    Если вы используете Access 2010, выберите Файл > Сохранить объект как.

    Если вы используете Access 2007, нажмите кнопку Microsoft Office и выберите Сохранить как > Сохранить объект как.

  • В диалоговом окне Сохранение введите имя в поле Сохранение объекта "Отчет" в, а затем нажмите кнопку ОК.

К началу страницы

Просмотр, печать отчета и его отправка по электронной почте

Сохраните макет отчета, чтобы использовать его повторно. Макет отчета останется неизменным, но при его печати будут использованы текущие данные. Если требования к отчету изменятся, вы сможете изменить макет отчета или создать аналогичный отчет на его основе.

Просмотр отчета

Просматривать отчет можно различными способами. Выбор того или иного способа зависит от действий, которые предполагается выполнить с отчетом и включенными в него данными.

  • Если вы хотите временно изменить данные в отчете перед его печатью или скопировать данные отчета в буфер обмена, откройте отчет в режиме отчета.

  • Если вы хотите изменить макет отчета, просматривая его данные, воспользуйтесь режимом макета.

  • Если вы просто хотите просмотреть отчет перед печатью, откройте его в режиме предварительного просмотра.

Примечание : Если в отчете есть несколько столбцов, то они будут видны только в режиме предварительного просмотра. В режиме отчета и в режиме макета в отчете отображается один столбец.

Просмотр в режиме отчета

Режим отчета используется по умолчанию при открытии отчета двойным щелчком в области навигации. Если отчет еще не открыт, дважды щелкните его имя в области навигации: отчет откроется в режиме отчета.

Если отчет уже открыт, щелкните правой кнопкой мыши имя отчета в области навигации и выберите команду Представление отчета.

Работа с данными в режиме отчета

В режиме отчета можно выделить текст отчета и скопировать его в буфер обмена. Чтобы выделить строки целиком, щелкните поле рядом с ними и, не отпуская кнопку мыши, протащите указатель вниз. Выделенные строки можно скопировать в буфер обмена, выполнив следующие действия:

  1. На вкладке Главная в группе Буфер обмена выберите Копировать. Выноска 4

  2. Щелкните выделенные строки правой кнопкой мыши и выберите команду Копировать.

  3. Сочетание клавиш: CTRL+C.

Отображение только нужных строк с помощью фильтров

В режиме отчета можно применять фильтры к данным. Например, если в отчете есть столбец "Страна/регион" и требуется отобразить только строки, содержащие название "Канада", выполните следующие действия:

  1. В отчете найдите слово "Канада" и щелкните его правой кнопкой мыши.

  2. Выберите команду Равно "Канада".

Access создаст и применит фильтр.

Включение и отключение фильтров

Переключаться между режимами отображения с применением и без применения фильтров можно с помощью кнопки Переключить фильтр в группе Сортировка и фильтр на вкладке Главная. При этом фильтр не удаляется — происходит лишь его включение и отключение.

Удаление фильтра

  1. Щелкните правой кнопкой мыши поле, с которого вы хотите снять фильтр.

  2. Щелкните Снять фильтр с поля: имя_поля. (Вместо имя_поля будет указано фактическое имя поля.)

Если фильтр удален, его нельзя включить с помощью команды Переключить фильтр. Вам потребуется заново создать фильтр.

Примечание : Если применить к отчету фильтр, а затем сохранить и закрыть отчет, фильтр также будет сохранен. Однако при следующем открытии отчета Access не применит фильтр. Чтобы повторно применить данный фильтр, в группе Сортировка и фильтр на вкладке Главная нажмите кнопку Переключить фильтр.

Предварительный просмотр отчета

Щелкните правой кнопкой мыши имя отчета в области навигации и в контекстном меню выберите команду Предварительный просмотр.

Для последовательного просмотра страниц отчета или перехода на нужную страницу используйте кнопки навигации.

Кнопки перехода

1. Щелкните, чтобы открыть первую страницу.

2. Щелкните, чтобы вывести предыдущую страницу.

3. Щелкните, чтобы вывести следующую страницу.

4. Щелкните, чтобы открыть последнюю страницу.

5. Введите номер страницы в этом поле и нажмите клавишу ВВОД, чтобы переместиться на указанную страницу.

В режиме предварительного просмотра можно увеличивать масштаб для просмотра деталей или уменьшать его для проверки размещения данных на странице. Щелкните отчет один раз. Чтобы вернуться к исходному масштабу, щелкните еще раз. Для изменения масштаба можно также воспользоваться элементом управления масштабом в строке состояния Access.

Чтобы закрыть предварительный просмотр, выполните следующие действия:

  • На вкладке Предварительный просмотр нажмите кнопку Закрыть окно предварительного просмотра.

  • Щелкните правой кнопкой мыши отчет в области навигации и в контекстном меню выберите команду Режим макета Выноска 4 или Конструктор Изображение кнопки .

Совет : После предварительного просмотра отчета можно экспортировать результаты в Microsoft Word, Microsoft Excel и некоторые другие программы Office. На вкладке Внешние данные в группе Экспорт нажмите кнопку нужного формата и следуйте дальнейшим указаниям.

К началу страницы

Печать отчета

Отчет можно напечатать из любого режима, а также в том случае, если он не открыт. Прежде чем приступать к печати, следует внимательно проверить параметры страницы (например, поля и ориентацию). Access сохраняет параметры страницы вместе с отчетом, поэтому их нужно настроить только один раз. В дальнейшем эти параметры при необходимости можно будет изменить.

Изменение параметров страницы

  1. Откройте отчет в режиме предварительного просмотра. Хотя параметры страницы можно изменить в любом представлении, режим предварительного просмотра для этого наиболее удобен, поскольку он позволяет сразу видеть результаты внесенных изменений.

  2. На вкладке Предварительный просмотр в группах Разметка страницы и Размер страницы нажмите кнопку Книжная Изображение кнопки или Альбомная Выноска 4 , чтобы выбрать ориентацию страницы, Размер Выноска 4 , чтобы задать размер бумаги, Поля Изображение кнопки , чтобы настроить поля, и т. д.

  3. После изменения параметра рекомендуется с помощью кнопок навигации просмотреть несколько следующих страниц, чтобы убедиться, что изменения не нарушили их форматирования.

Отправка отчета на принтер

  1. Откройте отчет в любом представлении или выберите его в области навигации.

  2. На вкладке Файл выберите пункт Печать и нажмите кнопку Печать. Обратите внимание: если вы используете Access 2007, нажмите кнопку Microsoft Office и выберите Печать > Печать.

    Откроется диалоговое окно Печать.

  3. Задайте нужные параметры, такие как принтер, диапазон печати и количество копий.

  4. Нажмите кнопку ОК.

К началу страницы

Отправка отчета по электронной почте

Вместо печати отчета можно отправить его пользователям по электронной почте.

  1. Щелкните отчет в области навигации, чтобы выбрать его. На вкладке Внешние данные в группе Экспорт нажмите Отправить по электронной почте. Обратите внимание: если вы используете Access 2007, щелкните отчет в области навигации, чтобы выбрать его, нажмите кнопку Microsoft Office, а затем выберите Отправить по электронной почте.

  2. В диалоговом окне Отправка объекта выберите в списке Выбор формата вывода нужный формат файла.

  3. Выполните действия в остальных диалоговых окнах.

  4. В почтовом приложении заполните необходимые поля сообщения и отправьте его.

К началу страницы

Совершенствование навыков
Перейти к обучению
Первоочередный доступ к новым возможностям
Присоединиться к программе предварительной оценки Office

Были ли сведения полезными?

Спасибо за ваш отзыв!

Благодарим за отзыв! Возможно, будет полезно связать вас с одним из наших специалистов службы поддержки Office.

×