Создание пользовательского поля

В Microsoft Office Project 2007 можно определить несколько настраиваемых полей в соответствии с нуждами организации. Поле можно настроить, а затем вставить в проект. Если не требуется абсолютно новое поле, можно просто переименовать имеющиеся поля и настроить их.

В этой статье

Настройка поля

Импорт настраиваемого поля

Вставка настраиваемого поля

Переименование поля

Настройка поля

  1. В меню Сервис выберите пункт Настройка, а затем — команду Поля.

  2. Выберите элемент Задача, чтобы поле было доступно в представлениях задач, или элемент Ресурс, чтобы поле было доступно в представлениях ресурсов.

  3. В списке Тип выберите тип настраиваемого поля.

  4. Выберите команду Переименовать, чтобы окончательно переименовать поле в этом проекте. В появившемся диалоговом окне введите новое имя и нажмите кнопку ОК.

  5. В разделе Настраиваемые атрибуты выберите способ ввода данных в поле.

    • Если нужно в настраиваемом поле использовать список (например, для создания списка разных центров затрат в организации), выберите вариант Подстановка. В появившемся диалоговом окне введите каждый элемент списка в столбце Значение, укажите, должен ли один из элементов отображаться по умолчанию, а затем нажмите кнопку Закрыть.

    • Если нужно, чтобы настраиваемое поле заполнялось с помощью формулы, выберите вариант Формула. В появившемся диалоговом окне создайте формулу, используя поля Поле и Функция, а затем нажмите кнопку ОК.

  6. В разделе Расчет для суммарных строк задач и групп выберите способ сведения значений в настраиваемом поле. То есть укажите способ суммирования значений на суммарных уровнях задач и групп для настраиваемого поля.

    Примечание : Текстовые поля и поля кодов структуры при сведении не учитываются. Кроме того, команда Использовать формулу доступна, только если для поля задана формула в разделе Настраиваемые атрибуты.

  7. В разделе Расчет для строк назначений выберите способ распространения значений в настраиваемом поле.

    • Выберите вариант Нет, если содержимое этого настраиваемого поля не должно распространяться по назначениям.

    • Выберите вариант Развертывание при отсутствии данных, введенных вручную, если содержимое этого настраиваемого поля должно распространяться по назначениям, например, в представлении Использование задач или Использование ресурсов. В этом случае данные разделяются между назначениями, если данные не введены вручную в строку назначения.

  8. В разделе Отображаемые значения выберите способ отображения данных в настраиваемом поле.

    • Выберите вариант Данные, чтобы отобразить фактические данные в содержимом поля во всех представлениях, в которых отображается это поле.

    • Выберите вариант Графические индикаторы, чтобы указать критерий и связанные с индикатором изображения для отображения в поле в области данных.

      Примечание : При обновлении полей в Microsoft Office Project Server 2007, включая новое настраиваемое поле, в котором отображается индикатор, возможно, потребуется один раз обновить [то есть "изменить"] сведения в столбце, чтобы новый индикатор отобразился в представлении в Microsoft Office Project Web Access.

Настроенное поле можно вставлять в подходящие представления задач или ресурсов в проекте.

К началу страницы

Импорт настраиваемого поля

Если в другом проекте или шаблоне есть настраиваемое поле, которое вам хотелось бы использовать в своем проекте, вы можете импортировать это поле, чтобы сэкономить время, которое вы потратили бы на создание аналогичного нового поля.

  1. В меню Сервис выберите пункт Настройка, а затем — команду Поля.

  2. Нажмите кнопку Импорт поля.

  3. В списке Проект выберите проект, содержащий поле, которое нужно импортировать.

  4. В области Тип поля выберите тип Задача, Ресурс или Проект.

  5. В списке Поле выберите имя импортируемого поля.

  6. Нажмите кнопку ОК, после чего имя поля, список значений, формула и графические индикаторы будут импортированы в ваш проект. При необходимости эти значения можно изменить, а затем вставить поле в представлениях проекта.

К началу страницы

Вставка настраиваемого поля

Следующее действие после настройки поля — вставка его в представление.

  1. Щелкните заголовок столбца, который должен будет отображаться справа от настраиваемого поля.

  2. В меню Вставка выберите пункт Столбец.

  3. В списке Имя поля выберите имя настраиваемого поля. Если поле было окончательно переименовано при настройке, в списке будет указано его новое имя.

  4. Если вы не хотите использовать это имя настраиваемого столбца, введите новое имя в поле Название.

  5. С помощью списков Выравнивание заголовка и Выравнивание данных выберите способ выравнивания столбца.

  6. В поле Ширина введите ширину столбца. Ширину столбца также можно настроить в самом представлении, перетаскивая край столбца.

  7. Чтобы текст заголовка в узком столбце, не умещающийся на одной строке, переносился на другие строки, установите флажок Перенос заголовка по словам. Чтобы заголовок отображался только на одной строке, снимите этот флажок.

  8. Нажмите кнопку ОК, чтобы вставить столбец в отображаемое представление.

К началу страницы

Переименование поля

Если поле в проекте содержит нужные данные, но для их точного описания больше подошло бы другое название, просто переименуйте поле. Для переименования поля нужно сначала скрыть столбец, а затем снова его отобразить с новым именем поля.

  1. Запишите текущее название поля, которое переименовываете.

  2. Щелкните правой кнопкой мыши заголовок столбца для поля, которое нужно переименовать, и выберите команду Скрыть столбец. Столбец исчезает из текущего представления, но данные, содержащиеся в столбце, по-прежнему хранятся в базе данных.

  3. Щелкните заголовок столбца, который должен будет отображаться справа от поля, которое переименовывается.

  4. В меню Вставка выберите пункт Столбец.

  5. В списке Имя поля выберите исходное имя поля, которое вы ранее записали.

  6. В поле Название введите новое имя поля.

  7. Нажмите кнопку ОК, чтобы переименовать поле.

    Примечание : Новое имя будет использоваться только в текущем представлении. Если это поле отображается в нескольких представлениях, вероятно, имеет смысл выполнить те же действия по переименованию поля и в других представлениях.

К началу страницы

Совершенствование навыков
Перейти к обучению
Первоочередный доступ к новым возможностям
Присоединиться к программе предварительной оценки Office

Были ли сведения полезными?

Спасибо за ваш отзыв!

Благодарим за отзыв! Возможно, будет полезно связать вас с одним из наших специалистов службы поддержки Office.

×