Создание модели данных в Excel

Модель данных — это новый подход к интеграции данных из различных таблиц и эффективному построению источника реляционных данных внутри книги Excel. В Excel модели данных применяются прозрачно, что обеспечивает использование табличных данных в сводных таблицах, сводных диаграммах и отчетах Power View. Прежде чем освоение сведения, может потребоваться вернемся на шаг назад и просмотрите этот видеоролик или выполнить Путеводитель обучения на получение и преобразование "и" Power Pivot.

Примечание : В этой статье описаны моделей данных в Excel 2013. Однако же моделированию данных и возможности Power Pivot, представленные в Excel 2013 также применять для Excel 2016. Нет эффективно мало различия между этих версиях Excel.

В большинстве случаев вы даже не догадаетесь, что используется модель. В Excel модель данных отображается как коллекция таблиц в списке полей. Для непосредственной работы с моделью нужно использовать надстройку Microsoft Office Power Pivot в Microsoft Excel 2013.

Модель создается автоматически, если при импорте реляционных данных выбрано несколько таблиц.

  1. В Excel для импорта данных из Access или из других реляционных баз данных, содержащих несколько связанных таблиц, используйте команды на вкладке Данные в группе Получение внешних данных.

  2. Excel предложит выбрать таблицу. Установите флажок Разрешить выбор нескольких таблиц.

    Диалоговое окно выбора таблицы

  3. Выберите несколько таблиц и нажмите кнопку Далее, а затем Готово.

  4. На вкладке Импорт данных выберите параметры представления данных, например сводную таблицу на новом листе, и постройте отчет.

Будет создана модель данных, содержащая все импортированные таблицы. Так как вы выбрали вариант отчета сводной таблицы, модель будет представлена в списке полей, используемом для построения отчета сводной таблицы.

Список полей сводной таблицы

Как можно использовать эту модель? С ее помощью вы можете создавать сводные таблицы, сводные диаграммы и отчеты Power View в одной книге. Можно изменять модель, добавляя и удаляя таблицы, а при использовании надстройки Power Pivot вы также можете расширить модель путем добавления вычисляемых столбцов, вычисляемых полей, иерархий и ключевых показателей эффективности.

При создании модели данных важен метод визуализации. Можно выбрать для визуализации данных варианты Отчет сводной таблицы, Сводная диаграмма или Отчет Power View. Эти параметры позволяют работать со всеми этими таблицами совместно. Если вместо этого вы выбрали вариант Таблица, то каждая импортированная таблица будет помещаться на отдельный лист. В этом случае таблицы можно использовать индивидуально, однако для одновременного использования всех таблиц требуется сводная таблица, сводная диаграмма или отчет Power View.

Примечания : 

  • Модели создаются неявно, когда вы импортируете в Excel несколько таблиц одновременно.

  • Модели создаются явно, если вы импортируете данные с помощью надстройки Power Pivot. В этой надстройке модель представлена в виде набора вкладок, каждая из которых содержит табличные данные. Общие сведения об импорте данных с помощью базы данных SQL Server см. в статье Получение данных с помощью надстройки Power Pivot.

  • Модель может содержать одну таблицу. Чтобы создать модель на основе только одной таблицы, выберите таблицу и нажмите кнопку Добавить в модель данных в Power Pivot. Это может понадобиться в том случае, если вы хотите использовать функции Power Pivot, например отфильтрованные наборы данных, вычисляемые столбцы, вычисляемые поля, ключевые показатели эффективности и иерархии.

  • Связи между таблицами могут создаваться автоматически при импорте связанных таблиц, у которых есть связи по первичному и внешнему ключу. Excel обычно может использовать импортированные данные о связях в качестве основы для связей между таблицами в модели данных.

  • Советы по уменьшению размера модели данных см. в статье Создание модели данных с эффективным использованием памяти с помощью Excel 2013 и надстройки Power Pivot.

  • Для более детального изучения см. статью Учебник. Анализ данных сводных таблиц с помощью модели данных в Excel 2013.

Совет :  Ваша книга содержит данные, но есть ли в ней модель данных? Наличие модели можно быстро определить, открыв окно Power Pivot. Если данные отображаются на вкладках, значит модель существует. Подробнее об этом см. в статье Определение источников данных, используемых в модели данных книги.

Использование модели данных в другой сводной таблице, сводной диаграмме или отчете Power View

Книга Excel может содержать только одну модель данных, но ее можно использовать многократно по всей книге.

  1. В Excel выберите Вставка > Сводная таблица.

  2. В окне "Создание сводной таблицы" выберите Использовать внешний источник данных, затем Выбрать подключение.

  3. В окне "Существующие подключения" выберите Таблицы.

  4. В разделе "Модель данных этой книги" вариант Таблицы в модели данных книги выбран по умолчанию. Щелкните Открыть и нажмите кнопку ОК. Отображается список полей сводной таблицы, в котором отображаются все таблицы в модели.

Добавление имеющихся несвязанных данных в модель данных

Предположим, было импортировано большое количество данных, которые требуется использовать в модели, но флажок Добавить эти данные в модель данных во время импорта установлен не был. Принудительно отправить новые данные в модель очень просто.

  1. Начнем с данных, которые необходимо добавить в модель. Это может быть любой диапазон данных, но лучше всего подойдет именованный диапазон.

  2. Выделите ячейки, которые требуется добавить, или, если данные содержатся в таблице или диапазоне с именем, поместите курсор в ячейку.

  3. Добавьте данные одним из следующих способов.

  4. Щелкните Power Pivot > Добавить в модель данных.

  5. Выберите Вставка > Сводная таблица и установите флажок Добавить эти данные в модель данных в диалоговом окне "Создание сводной таблицы".

Диапазон или таблица будут добавлены в модель как связанная таблица. Дополнительные сведения о работе со связанными таблицами в модели см. в статье Добавление данных с помощью связанных таблиц Excel в Power Pivot.

Уточнение и расширение модели данных в надстройке Power Pivot

Модель данных в Excel призвана расширить и обогатить возможности создания отчетов, особенно при использовании сводных таблиц и других форматов отчета, предназначенных для просмотра и анализа данных. Несмотря на свою важность, модели данных преднамеренно скрыты, что позволяет сосредоточиться на конкретных задачах.

Предположим, вам нужно поработать непосредственно с моделью. Зная, что список полей основан на модели, возможно, вы захотите удалить ненужные таблицы или поля, просмотреть все базовые данные, представленные в модели, или добавить ключевые показатели эффективности, иерархии или бизнес-логику. Во всех этих и других случаях вам может потребоваться изменить саму модель данных.

Чтобы изменить или Управление моделью данных, используйте надстройку Power Pivot. Она поставляется вместе с приложением Excel 2013 в выпуске Office профессиональный плюс, но по умолчанию не активирована. Дополнительные сведения о Power Pivot запуск надстройки Microsoft Excel.

Различия между таблицей в Power Pivot и таблицей на листе

В Power Pivot невозможно добавить строку в таблицу, введя текст непосредственно в новой строке, как это можно сделать на листе Excel. Но вы можете добавлять строки с помощью команд вставки и путем обновления данных.

Данные на листе Excel часто бывают неоднородными, то есть одна строка может содержать числовые данные, а следующая — графические данные или текст. Таблица в Power Pivot больше похожа на реляционную базу данных, в которой каждая строка имеет одинаковое количество столбцов, а большинство столбцов содержат данные.

Использование модели данных в Power View

Модель данных используется в качестве основы для отчета Power View. С помощью надстройки Power Pivot вы можете оптимизировать модель, чтобы улучшить создание отчетов Power View. Так, можно задать список полей по умолчанию, выбрать основные поля или изображения для уникального обозначения отдельных строк и указать, как в отчете должны обрабатываться строки с повторяющимися значениями (например, при наличии сотрудников или клиентов с одинаковыми именами).

  1. Создайте модель данных, импортировав несколько связанных таблиц.

  2. Щелкните Power Pivot > Управление, чтобы открыть окно Power Pivot.

  3. Выберите таблицу и произведите оптимизацию:

    1. Выберите Дополнительно > Набор полей по умолчанию. Выберите поля, которые должны автоматически отображаться в отчете Power View при нажатии на родительскую таблицу. Подробные сведения см. в разделе Настройка набора полей по умолчанию для отчетов Power View.

    2. Выберите Дополнительно > Поведение таблицы. Оптимизируйте настройки для макетов отчетов, группирующих данные. Группирование зависит от поведения по умолчанию, что иногда дает непредвиденные результаты, например объединение строк, которые должны выводиться отдельно. Подробные сведения см. в разделе Настройка свойств работы таблицы для отчетов Power View.

    3. Выберите Дополнительно > Категория данных. Некоторые представления отчетов специфичны для тех или иных типов данных. Например, если имеется таблица со значениями времени или даты, можно задать категорию "Дата", которая будет полезна в Power View при использовании представлений, связанных со временем.

  4. Повторите для других таблиц.

  5. В Excel выберите Вставка > Power View для создания нового отчета. Дополнительные данные см. в разделе Power View: исследование, визуализация и представление данных.

Примечания : 

  • Отказ от ответственности относительно машинного перевода. Данная статья была переведена с помощью компьютерной системы без участия человека. Microsoft предлагает эти машинные переводы, чтобы помочь пользователям, которые не знают английского языка, ознакомиться с материалами о продуктах, услугах и технологиях Microsoft. Поскольку статья была переведена с использованием машинного перевода, она может содержать лексические,синтаксические и грамматические ошибки.

  • Используйте английский вариант этой статьи, который находится здесь, в качестве справочного материала. Вместе с другими участниками сообщества Майкрософт вы можете улучшить эту статью с помощью Community Translation Framework (CTF). Просто наведите указатель мыши на предложение в статье и выберите команду "УЛУЧШИТЬ ПЕРЕВОД" в мини-приложении CTF. Для получения дополнительных сведений о CTF щелкните здесь. Используя CTF, вы соглашаетесь с нашими условиями предоставления услуг.

Совершенствование навыков
Перейти к обучению
Первоочередный доступ к новым возможностям
Присоединиться к программе предварительной оценки Office

Были ли сведения полезными?

Спасибо за ваш отзыв!

Благодарим за отзыв! Возможно, будет полезно связать вас с одним из наших специалистов службы поддержки Office.

×