Создание модели базы данных (называемой также схемой «объект-отношение»)

Важно :  Данная статья переведена с помощью машинного перевода, см. Отказ от ответственности. Используйте английский вариант этой статьи, который находится здесь, в качестве справочного материала.

С помощью шаблона схемы модели базы данных можно создать новую модель или реконструировать существующую базу данных в модель с использованием реляционных или объектно-реляционных концепций моделирования. Для моделирования баз данных на основе стандарта SQL92 и более ранних стандартов следует воспользоваться набором элементов модели «сущность-связь». Для моделирования баз данных на основе стандарта SQL99 и более поздних стандартов следует воспользоваться набором элементов «Объектно-реляционная схема», содержащим дополнительные фигуры для работы с типами.

Пример модели базы данных

С помощью шаблона схемы модели базы данных можно создать новую модель или реконструировать существующую базу данных в модель с использованием реляционных или объектно-реляционных концепций моделирования. Для моделирования баз данных на основе стандарта SQL92 и более ранних стандартов следует воспользоваться набором элементов модели «сущность-связь». Для моделирования баз данных на основе стандарта SQL99 и более поздних стандартов следует воспользоваться набором элементов «Объектно-реляционная схема», содержащим дополнительные фигуры для работы с типами.

В этой статье описаны способы создания и использования модели базы данных.

Не удается найти возможности модели базы данных?

Функции модели базы данных включены не в каждый выпуск Microsoft Visio. Если вам не удается найти функции, описанные в данной статье, вероятнее всего, что в ваш выпуск Visio они не входят.

  • Выпуск Microsoft Visio Стандартный не включает шаблон схемы модели базы данных.

  • Выпуски Microsoft Visio Профессиональный и Microsoft Visio Premium поддерживают возможности реконструирования для шаблона схемы модели базы данных (т. е. возможности создания модели в Visio с использованием существующей базы данных), но не поддерживают возможности разработки (т. е. возможности создания кода SQL с использованием модель базы данных Visio).

  1. Чтобы начать создание схемы модели базы данных, выполните одно из следующих действий.

    Создание новой схемы модели с нуля

    Если существующая база данных, которую требуется использовать в качестве основы, отсутствует, можно начать с пустой модели базы данных и добавить собственные таблицы и связи.

    1. Откройте вкладку Файл.

    2. Выберите команду Создать и пункт Программное обеспечение и базы данных, а затем дважды щелкните элемент Схема модели базы данных.

    3. На вкладке База данных в группе Управление нажмите кнопку Параметры отображения.

    4. В диалоговом окне Параметры документа базы данных выберите нужный набор символов и другие параметры таблицы и связи, а затем нажмите кнопку ОК.

    Использование существующей базы данных в качестве отправной точки

    Если существует база данных, которую нужно смоделировать для лучшего понимания ее структуры или применения в качестве основы создания новой модели, то для извлечения схемы или структуры базы данных можно воспользоваться мастером реконструирования.

    Прежде чем запустить мастер, выполните указанные ниже действия.

    1. Если выполняется реконструирование книги Microsoft Excel, перед запуском мастера необходимо открыть ее и присвоить имя группе (или диапазону) ячеек, содержащих заголовки столбцов. Если необходимо использовать несколько листов имя следует присвоить группе ячеек столбца на каждом листе. Эти диапазоны обрабатываются в мастере как таблицы. Дополнительные сведения об именовании диапазона ячеек см. в разделе справки Excel «Определение именованных ссылок на ячейки и диапазонов».

    2. Для получения наилучших результатов задайте драйвер по умолчанию для целевой базы данных, которую требуется реконструировать, до запуска мастера реконструирования. Этот шаг обеспечит правильное соответствие внутренних типов данных и корректное отображение текста программы, извлеченного мастером, в окне «Код».

    3. Откройте вкладку Файл.

    4. Выберите команду Создать и пункт Программное обеспечение и базы данных, а затем дважды щелкните элемент Схема модели базы данных.

    5. На вкладке База данных в группе Модель нажмите кнопку Реконструирование.

    6. На первой странице мастера реконструирования выполните следующие действия.

      1. Выберите драйвер базы данных для системы управления базами данных (СУБД). Если драйвер базы данных Visio еще не связан с источником данных ODBC, нажмите кнопку Настройка.

        Примечание : При реконструировании листа Excel выберите универсальный драйвер ODBC.

      2. Выберите источник данных обновляемой базы данных. Если для существующей базы данных еще не создан источник данных, нажмите кнопку Создать, чтобы создать его.

        Имя нового созданного источника будет добавлено в список Источники данных.

      3. Выбрав нужные параметры, нажмите кнопку Далее.

    7. Следуйте инструкциям в диалоговых окнах, связанных с выбранным драйвером.

      Например, в диалоговом окне Подключение источника данных введите имя пользователя и пароль, а затем нажмите кнопку ОК.

      Примечание : При использовании универсального драйвера ODBC может появиться сообщение об ошибке, указывающее на недостаток реконструированных сведений. В большинстве случаев это не проблема  — просто нажмите кнопку ОК и продолжайте действия в мастере.

    8. Установите флажки для типов сведений, которые нужно извлечь, а затем нажмите кнопку Далее.

      Примечание : Некоторые элементы могут быть недоступны (выделены серым цветом), поскольку не все СУБД поддерживают все виды элементов, извлекаемых мастером.

    9. Установите флажки для таблиц (и представлений, если есть), которые требуется извлечь, или нажмите кнопку Выделить все, чтобы извлечь их все, а затем нажмите кнопку Далее.

      Примечание : Если выполняется реконструирование листа Excel и в нем ничего не отображается, вероятно, необходимо присвоить имя диапазону ячеек, содержащему заголовки столбцов.

    10. Если был установлен флажок Хранимые процедуры, выберите процедуры, которые требуется извлечь, или нажмите кнопку Выделить все, чтобы извлечь их все, а затем нажмите кнопку Далее.

    11. Выберите, будут ли реконструированные элементы автоматически добавлены на текущую страницу.

      Примечание : Можно выбрать вариант, при котором мастер автоматически создаст документ, вместе с образованием списка реконструированных элементов в окне «Таблицы и представления». Если возможность автоматического создания документа не выбрана, можно перетащить элементы из окна «Таблицы и представления» на страницу документа для создания модели базы данных вручную.

    12. Просмотрите выбранные параметры, чтобы проверить извлечение нужных сведений, а затем нажмите кнопку Готово.

      Будут извлечены выбранные сведения, и в окне «Вывод» будут отображены примечания о процессе извлечения.

    Импорт и уточнение существующей модели

    Существующие модели VisioModeler или PLATINUM ERwin можно импортировать для создания схемы модели базы данных Visio. Эта возможность применяется только для файлов моделей VisioModeler версии 2.0 или более поздних (IMD) и для файлов моделей PLATINUM ERwin версий 2.6, 3.0 и 3.52 (ERX).

    1. Откройте вкладку Файл.

    2. Выберите команду Создать и пункт Программное обеспечение и базы данных, а затем дважды щелкните элемент Схема модели базы данных.

    3. На вкладке База данных в группе Модель нажмите кнопку Импорт и выберите тип модели.

    4. Введите путь и имя файла для модели, которую требуется импортировать, или нажмите кнопку Обзор, чтобы найти файл модели, а затем нажмите кнопку Открыть.

    5. В диалоговом окне Импорт нажмите кнопку ОК.

      Выполняется импорт файла, ход которого отображается в окне «Вывод». Импортированные таблицы будут отображены в окне «Таблицы и представления».

    6. В окне «Таблицы и представления» выберите таблицы для моделирования, а затем перетащите их на страницу документа.

  2. После создания схемы модели базы данных начинается ее уточнение. Можно добавлять и настраивать таблицы и представления, создавать связи, настраивать столбцы и типы данных.

    Таблицы

    Чтобы создать таблицу в схеме, воспользуйтесь фигурой Сущность.

    1. Из набора элементов Сущности и отношения или Объектно-реляционная схема перетащите фигуру Сущность в документ.

    2. Дважды щелкните фигуру, чтобы открыть окно Свойства базы данных.

    3. В группе Категории выберите вариант Определение и введите имя для таблицы.

    4. В группе Категории выберите вариант Столбцы, введите имя и выберите тип данных.

    5. Установите флажок Обязательное для столбцов, которые не могут иметь значения NULL.

    6. Установите флажок PK (первичный ключ) для столбцов, однозначно определяющих каждую строку таблицы базы данных.

    7. В группе Категории выберите вариант Индексы, Триггеры, Проверка или Дополнительные, чтобы создать эти дополнительные элементы.

    Столбцы

    Чтобы добавить или изменить свойства для столбцов, включая типы данных и первичные ключи, воспользуйтесь окном Свойства базы данных.

    1. Дважды щелкните таблицу в схеме.

    2. В окне Свойства базы данных в списке Категории выберите вариант Столбцы.

    3. Щелкните первую пустую ячейку Физическое имя и введите имя.

    4. Чтобы изменить тип данных для столбца, щелкните его поле Тип данных, а затем из списка выберите тип данных или введите тип данных в список. Например, можно ввести decimal(8,2) или char(30).

    5. Чтобы не допустить значений NULL, установите флажок Обязательное .

    6. Чтобы указать, что столбец является первичным ключом, установите флажок PK.

    7. Для отображения дополнительных свойств наряду со свойствами, появляющимися при выборе категории Столбцы, выделите столбец, а затем нажмите кнопку Изменить.

    Связи

    Связи используют первичные и внешние ключи для возможности сопоставления базой данных строки в одной таблице со строкой в связанной таблице. Эти связи можно увидеть в схеме. Кроме того, можно задать их размерность (например, «один-ко-многим»), для отображения которой использовать нотации — «гусиные лапки», реляционная или IDEF1X. В шаблоне схемы модели базы данных связи размерности «многие-ко-многим» с помощью этих нотаций отобразить нельзя.

    1. Создание связи между таблицами

      1. Убедитесь, что в схеме отображены обе таблицы. Если модель реконструировалась из существующей базы данных, может потребоваться перетащить одну или обе таблицы из окна «Таблицы и представления» на страницу документа.

      2. Дважды щелкните таблицу, которая будет на стороне первичного ключа в связи.

      3. В окне Свойства базы данных в списке Категории выберите вариант Столбцы.

      4. В сетке выделите столбец для однозначного определения каждой строки таблицы и установите флажок PK, чтобы задать его в качестве первичного ключа.

      5. Из набора элементов Объектно-реляционная схема или Сущности и отношения перетащите фигуру Отношение и разместите ее на свободном месте страницы.

      6. Соедините верхний конец фигуры с родительской таблицей.

      7. Соедините другой конец с дочерней таблицей.

        Если во второй таблице отсутствует столбец с тем же именем, что и у первичного ключа, он автоматически добавится во вторую таблицу в качестве внешнего ключа.

        Примечание : Если линии связи отсутствуют, на вкладке База данных в группе Управление нажмите кнопку Параметры отображения. На вкладке Отношения в списке Показать установите флажок Связи.

    2. Задайте размерность связи.

      1. Дважды щелкните связь.

      2. В окне Свойства базы данных в группе Категории выберите вариант Прочее.

      3. В группе Мощность выберите размерность, наиболее подходящую к связи. Для отношения «один-ко-многим» наилучшим вариантом будет 0 или более или 1 или более. Для отношения «один-к-одному» — 0 или 1 или ровно 1.

  3. Для внесения в схему других уточнений (например, создание индексов, проверок и триггеров) можно выполнить следующие действия.

    Создание индексов

    Использование индексов повышает производительность или скорость работы базы данных при выполнении запроса.

    1. Откройте схему модели базы данных.

    2. Дважды щелкните таблицу, к которой требуется добавить индекс, а затем в окне Свойства базы данных в списке Категории выберите вариант Индексы.

    3. Выберите команду Создать.

    4. В диалоговом окне Создать индекс введите имя для индекса, а затем нажмите кнопку ОК.

    5. В списке Тип индекса выберите тип создаваемого индекса — уникальный или неуникальный.

    6. В списке Доступные столбцы выберите имя каждого столбца, который требуется включить в этот индекс, а затем нажмите кнопку Добавить >.

    7. В списке Индексированные столбцы установите флажок Возрастание, чтобы создать индекс с возрастающим порядком сортировки, или снимите флажок, чтобы создать индекс с убывающим порядком сортировки.

      Схема модели базы данных будет обновлена.

    Создание представлений.

    Представление можно представить в виде хранимого запроса. Использование представлений очень удобно при многократном доступе к одним и тем же сведениям из нескольких таблиц или при предоставлении данных пользователям без возможности изменить данные реальных таблиц.

    Из набора элементов Сущности и отношения или Объектно-реляционная схема перетащите фигуру Представление на страницу документа.

    Настройки расширенных свойств для таблиц и представлений

    В зависимости от системы управления базами данных (СУБД) таблицам или представлениям можно задать дополнительные свойства для определения их места хранения.

    Дважды щелкните таблицу или представление, для которого требуется задать дополнительные свойства, и в окне Свойства базы данных в списке Категории выберите вариант Дополнительные.

    Создание правил контроля

    Применение предложений проверки гарантирует, что данные, введенные в столбец, находятся в пределах конкретного диапазона значений. Например, можно создать предложение проверки того, что значения столбца «Возраст» превышают 65.

    1. Дважды щелкните таблицу, чтобы открыть окно Свойства базы данных.

    2. В группе Категории выберите вариант Столбцы, а затем выберите столбец, которому требуется добавить предложение проверки.

    3. Нажмите кнопку Изменить.

    4. На вкладке Проверка диалогового окна Свойства столбца введите нужные ограничения.

      Предложение проверки будет добавлено в окне кода в группу Локальный код.

    Создание хранимых процедур и пользовательских функций

    Хранимые процедуры и пользовательские функции предназначены для создания наборов кодов, которые многократно применяются для выполнения повторяющихся действий. Их главное различие состоит в том, что пользовательская функция возвращает значение, тогда как хранимая процедура выполняется без возвращения значения.

    1. На вкладке База данных в группе Показать или скрыть установите флажок Код, чтобы открыть окно Код.

    2. Выберите вариант Глобальный код, а затем нажмите кнопку Создать.

    3. На вкладке Свойства диалогового окна Редактор кода выберите вид текста программы, который требуется создать, а затем введите для нее имя.

    4. На вкладке Основной текст введите текст программы, а затем нажмите кнопку ОК.

    Создание переключателей

    В триггере выполняется содержащийся в нем текст программы SQL при возникновении в базе данных определенного события.

    1. Дважды щелкните таблицу, чтобы открыть окно Свойства базы данных.

    2. В группе Категории выберите вариант Триггеры, а затем нажмите кнопку Добавить.

    3. На вкладке Свойства введите имя для триггера.

    4. На вкладке Основной текст введите текст программы, а затем нажмите кнопку ОК.

      Триггер будет добавлен в окно «Код» в группу Локальный код.

В этой статье рассматриваются способы создания и использования модели базы данных. Для быстрой установки в меню Файл последовательно выберите пункты Создать, Программное обеспечение и базы данных, а затем — команду Схема модели базы данных.

Не удается найти возможности модели базы данных?

Вероятно, в используемой версии Microsoft Office Visio отсутствуют нужные возможности. Чтобы узнать, в какой версии Visio ведется работа, щелкните раздел О программе Microsoft Office Visio в меню Справка. Название версии находится в верхней строке диалогового окна.

  • Версия Microsoft Office Visio Стандартный не включает шаблон схемы моделирования баз данных.

  • Версия Microsoft Office Visio Профессиональный поддерживает возможности реконструирования для шаблона схемы моделирования баз данных (т. е. возможности создания модели в Visio с использованием существующей базы данных), но не поддерживает возможности разработки (т. е. возможности создания кода SQL, используя модель базы данных Visio).

  • В версии Visio for Enterprise Architects можно найти полный набор возможностей моделирования баз данных, включая как реконструирование, так и разработку. Версия Visio for Enterprise Architects включена в пакет MSDN Premium Subscription, доступный с версиями Visual Studio Профессиональный и Visual Studio Team System на основе ролей.

  1. Чтобы начать создание схемы модели базы данных, выполните одно из следующих действий.

    Создание новой схемы модели с нуля

    Если существующая база данных, которую требуется использовать в качестве основы, отсутствует, можно начать с пустой модели базы данных и добавить собственные таблицы и связи.

    1. В меню Файл последовательно выберите пункты Создать, Программное обеспечение и базы данных, а затем — команду Схема модели базы данных.

    2. В меню База данных выберите пункт Параметры, а затем — команду Документ.

    3. В диалоговом окне Параметры документа базы данных выберите нужный набор символов и другие параметры таблицы и связи, а затем нажмите кнопку ОК.

    Использование существующей базы данных в качестве отправной точки

    Если существует база данных, которую нужно смоделировать для лучшего понимания ее структуры или применения в качестве основы создания новой модели, то для извлечения схемы или структуры базы данных можно воспользоваться мастером реконструирования.

    Примечание : Прежде чем начать действия в мастере:

    1. Если выполняется реконструирование книги Microsoft Office Excel, перед запуском мастера ее необходимо открыть и присвоить имя группе (или диапазону) ячеек, содержащих заголовки столбцов. При использовании нескольких листов имя присваивается группе ячеек столбца на каждом листе. Эти диапазоны рассматриваются в мастере как таблицы. Дополнительные сведения об именовании диапазона ячеек см. в разделе справки Microsoft Office Excel «Определение именованных ссылок на ячейки и диапазоны».

    2. Для получения наилучших результатов задайте драйвер по умолчанию для целевой базы данных, которую требуется реконструировать, до запуска мастера реконструирования. Этот шаг обеспечит правильное соответствие внутренних типов данных и корректное отображение текста программы, извлеченного мастером, в окне «Код».

    3. В меню Файл последовательно выберите пункты Создать, Программное обеспечение и базы данных, а затем — команду Схема модели базы данных.

    4. В меню База данных выберите команду Реконструировать.

    5. На первой странице мастера реконструирования выполните следующие действия.

      1. Выберите драйвер базы данных Microsoft Office Visio для системы управления базами данных (СУБД). Если драйвер базы данных Visio еще не связан с определенным источником данных ODBC, нажмите кнопку Настройка.

        Примечание : При реконструировании листа Excel выберите универсальный драйвер ODBC.

      2. Выберите источник данных обновляемой базы данных. Если для существующей базы данных еще не создан источник данных, нажмите кнопку Создать, чтобы создать его.

        Имя нового созданного источника будет добавлено в список Источники данных.

      3. Выбрав нужные параметры, нажмите кнопку Далее.

    6. Следуйте инструкциям в диалоговых окнах, связанных с выбранным драйвером.

      Например, в диалоговом окне Подключение источника данных введите имя пользователя и пароль, а затем нажмите кнопку ОК. Если источник данных не защищен паролем, просто нажмите кнопку ОК.

      Примечание : При использовании универсального драйвера ODBC может появиться сообщение об ошибке, указывающее на недостаток реконструированных сведений. В большинстве случаев это не проблема  — просто нажмите кнопку ОК и продолжайте действия в мастере.

    7. Установите флажки для типов сведений, которые нужно извлечь, а затем нажмите кнопку Далее.

      Примечание : Некоторые элементы могут быть недоступны (выделены серым цветом), поскольку не все СУБД поддерживают все виды элементов, извлекаемых мастером.

    8. Установите флажки для таблиц (и представлений, если есть), которые требуется извлечь, или нажмите кнопку Выделить все, чтобы извлечь их все, а затем нажмите кнопку Далее.

      Примечание : Если выполняется реконструирование листа Excel и в нем ничего не отображается, вероятно, необходимо присвоить имя диапазону ячеек, содержащему заголовки столбцов.

    9. Если в шаге 5 был установлен флажок Хранимые процедуры, выберите процедуры, которые требуется извлечь, или нажмите кнопку Выделить все, чтобы извлечь их все, а затем нажмите кнопку Далее.

    10. Выберите, будут ли реконструированные элементы автоматически добавлены на текущую страницу.

      Примечание : Можно выбрать вариант, при котором мастер автоматически создаст документ, вместе с образованием списка реконструированных элементов в окне «Таблицы и представления». Если возможность автоматического создания документа не выбрана, можно перетащить элементы из окна «Таблицы и представления» на страницу документа для создания модели базы данных вручную.

    11. Просмотрите выбранные параметры, чтобы проверить извлечение нужных сведений, а затем нажмите кнопку Готово.

      Будут извлечены выбранные сведения, и в окне «Вывод» будут отображены примечания о процессе извлечения.

    Импорт и уточнение существующей модели

    Существующие модели VisioModeler или PLATINUM ERwin можно импортировать для создания схемы модели базы данных Visio. Эта возможность применяется только для файлов моделей VisioModeler версии 2.0 или более поздних (IMD) и для файлов моделей PLATINUM ERwin версий 2.6, 3.0 и 3.52 (ERX).

    1. В меню Файл последовательно выберите пункты Создать, Программное обеспечение и базы данных, а затем — команду Схема модели базы данных.

    2. В меню База данных выберите пункт Импорт, а затем — команду Импорт <тип_модели>.

    3. Введите путь и имя файла для модели, которую требуется импортировать, или нажмите кнопку Обзор, чтобы найти файл модели, а затем нажмите кнопку Открыть.

    4. В диалоговом окне Импорт нажмите кнопку ОК.

      Выполняется импорт файла, ход которого отображается в окне «Вывод». Импортированные таблицы будут отображены в окне «Таблицы и представления».

    5. В окне «Таблицы и представления» выберите таблицы для моделирования, а затем перетащите их на страницу документа.

  2. После создания схемы модели базы данных начинается ее уточнение. Можно добавлять и настраивать таблицы и представления, создавать связи, настраивать столбцы и типы данных.

    Таблицы

    Чтобы создать таблицу в схеме, воспользуйтесь фигурой Сущность.

    1. Из набора элементов Сущности и отношения или Объектно-реляционная схема перетащите фигуру Сущность в документ.

    2. Дважды щелкните фигуру, чтобы открыть окно «Свойства базы данных».

    3. В группе Категории выберите вариант Определение и введите имя для таблицы.

    4. В группе Категории выберите вариант Столбцы, введите имя и выберите тип данных.

    5. Установите флажок Обязательное для столбцов, которые не могут иметь значения NULL.

    6. Установите флажок PK (первичный ключ) для столбцов, однозначно определяющих каждую строку таблицы базы данных.

    7. В группе Категории выберите вариант Индексы, Триггеры, Проверка или Дополнительные, чтобы создать эти дополнительные элементы.

    Столбцы

    Чтобы добавить или изменить свойства для столбцов, включая типы данных и первичные ключи, воспользуйтесь окном «Свойства базы данных».

    1. Дважды щелкните таблицу в схеме.

    2. В окне «Свойства базы данных» в группе Категории выберите вариант Столбцы.

    3. Щелкните первую пустую ячейку Физическое имя и введите имя.

    4. Чтобы изменить тип данных для столбца, щелкните его поле Тип данных, а затем из списка выберите тип данных или введите тип данных в список. Например, можно ввести decimal(8,2) или char(30).

    5. Чтобы не допустить значений NULL, установите флажок Обязательное .

    6. Чтобы указать, что столбец является первичным ключом, установите флажок PK.

    7. Для отображения дополнительных свойств наряду со свойствами, появляющимися при выборе категории Столбцы, выделите столбец, а затем нажмите кнопку Изменить.

    Связи

    Связи используют первичные и внешние ключи для возможности сопоставления базой данных строки в одной таблице со строкой в связанной таблице. Эти связи можно увидеть в схеме. Кроме того, можно задать их размерность (например, «один-ко-многим»), для отображения которой использовать нотации — «гусиные лапки», реляционная или IDEF1X. В шаблоне схемы модели базы данных связи размерности «многие-ко-многим» с помощью этих нотаций отобразить нельзя.

    1. Создание связи между таблицами

      1. Убедитесь, что в схеме отображены обе таблицы. Если модель реконструировалась из существующей базы данных, может потребоваться перетащить одну или обе таблицы из окна «Таблицы и представления» на страницу документа.

      2. Дважды щелкните таблицу, которая будет на стороне первичного ключа в связи.

      3. В окне «Свойства базы данных» в группе Категории выберите вариант Столбцы.

      4. В сетке выделите столбец для однозначного определения каждой строки таблицы и установите флажок PK, чтобы задать его в качестве первичного ключа.

      5. Из набора элементов Объектно-реляционная схема или Сущности и отношения перетащите фигуру Отношение и разместите ее на свободном месте страницы.

      6. Соедините верхний конец фигуры с родительской таблицей.

      7. Соедините другой конец с дочерней таблицей.

        Если во второй таблице отсутствует столбец с тем же именем, что и у первичного ключа, он автоматически добавится во вторую таблицу в качестве внешнего ключа.

        Примечание : Если линии связи отсутствуют, в меню База данных выберите пункт Параметры, а затем — команду Документ. На вкладке Отношения в группе Показывать установите флажок Отношения.

    2. Задайте размерность связи.

      1. Дважды щелкните связь.

      2. В окне «Свойства базы данных» в группе Категории выберите вариант Прочее.

      3. В группе Мощность выберите размерность, наиболее подходящую к связи. Для отношения «один-ко-многим» наилучшим вариантом будет 0 или более или 1 или более. Для отношения «один-к-одному» — 0 или 1 или ровно 1.

  3. Для внесения в схему других уточнений (например, создание индексов, проверок и триггеров) можно выполнить следующие действия.

    Создание индексов

    Использование индексов повышает производительность или скорость работы базы данных при выполнении запроса.

    1. Откройте схему модели базы данных.

    2. Дважды щелкните таблицу, к которой требуется добавить индекс, и в окне «Свойства базы данных» в списке Категории выберите вариант Индексы.

    3. Выберите команду Создать.

    4. В диалоговом окне Создать индекс введите имя для индекса, а затем нажмите кнопку ОК.

    5. В списке Тип индекса выберите тип создаваемого индекса — уникальный или неуникальный.

    6. В списке Доступные столбцы выберите имя каждого столбца, который требуется включить в этот индекс, а затем нажмите кнопку Добавить >.

    7. В списке Индексированные столбцы установите флажок Возрастание, чтобы создать индекс с возрастающим порядком сортировки, или снимите флажок, чтобы создать индекс с убывающим порядком сортировки.

      Схема модели базы данных будет обновлена.

    Создание представлений.

    Представление можно представить в виде хранимого запроса. Использование представлений очень удобно при многократном доступе к одним и тем же сведениям из нескольких таблиц или при предоставлении данных пользователям без возможности изменить данные реальных таблиц.

    Из набора элементов Сущности и отношения или Объектно-реляционная схема перетащите фигуру Представление на страницу документа.

    Настройки расширенных свойств для таблиц и представлений

    В зависимости от системы управления базами данных (СУБД) таблицам или представлениям можно задать дополнительные свойства для определения их места хранения.

    Дважды щелкните таблицу или представление, для которого требуется задать дополнительные свойства, и в окне «Свойства базы данных» в списке Категории выберите Дополнительные.

    Создание правил контроля

    Применение правил контроля гарантирует, что данные, введенные в столбец, находятся в пределах конкретного диапазона значений. Например, можно создать правило контроля того, что значения столбца «Возраст» должны превышать 65.

    1. Дважды щелкните таблицу, чтобы открыть окно Свойства базы данных.

    2. В группе Категории выберите вариант Столбцы, а затем выберите столбец, которому требуется добавить правило контроля.

    3. Нажмите кнопку Изменить.

    4. На вкладке Проверка диалогового окна Свойств столбца введите ограничения, которые вы хотите. Дополнительные сведения о нужные значения отображается диалоговое столбцов и свойства поля (вкладка «Проверка»).

      Правила контроля будут добавлены в окно «Код» в группу Локальный код.

    Создание хранимых процедур и пользовательских функций

    Хранимые процедуры и пользовательские функции предназначены для создания наборов кодов, которые многократно применяются для выполнения повторяющихся действий. Их главное различие состоит в том, что пользовательская функция возвращает значение, тогда как хранимая процедура выполняется без возвращения значения.

    1. Чтобы открыть окно «Код», в меню База данных выберите пункт Представление, а затем — команду Код.

    2. Выберите вариант Глобальный код, а затем нажмите кнопку Создать.

    3. На вкладке Свойства диалогового окна Редактор кода выберите вид текста программы, который требуется создать, а затем введите для нее имя.

    4. На вкладке Основной текст введите текст программы, а затем нажмите кнопку ОК.

    Создание переключателей

    В триггере выполняется содержащийся в нем текст программы SQL при возникновении в базе данных определенного события.

    1. Дважды щелкните таблицу, чтобы открыть окно «Свойства базы данных».

    2. В группе Категории выберите вариант Триггеры, а затем нажмите кнопку Добавить.

    3. На вкладке Свойства введите имя для триггера.

    4. На вкладке Основной текст введите текст программы, а затем нажмите кнопку ОК.

      Триггер будет добавлен в окно «Код» в группу Локальный код.

Примечание : Отказ от ответственности относительно машинного перевода. Данная статья была переведена с помощью компьютерной системы без участия человека. Microsoft предлагает эти машинные переводы, чтобы помочь пользователям, которые не знают английского языка, ознакомиться с материалами о продуктах, услугах и технологиях Microsoft. Поскольку статья была переведена с использованием машинного перевода, она может содержать лексические,синтаксические и грамматические ошибки.

Совершенствование навыков
Перейти к обучению
Первоочередный доступ к новым возможностям
Присоединиться к программе предварительной оценки Office

Были ли сведения полезными?

Спасибо за ваш отзыв!

Благодарим за отзыв! Возможно, будет полезно связать вас с одним из наших специалистов службы поддержки Office.

×