Создание модели базы данных (другое название — схема отношений сущностей)

Создание модели базы данных (другое название — схема отношений сущностей)

С помощью шаблона "Схема модели базы данных" можно создать новую модель или реконструировать модель существующей базы данных, используя концепции реляционного или объектно-реляционного моделирования. Для моделирования баз данных на основе SQL92 и более ранних стандартов используйте набор элементов "Отношение сущности". Для моделирования баз данных на основе SQL99 и более поздних стандартов используйте набор элементов "Объектно-реляционная схема", в котором есть дополнительные фигуры для работы с типами.

Пример модели базы данных

С помощью шаблона "Схема модели базы данных" можно создать новую модель или реконструировать модель существующей базы данных, используя концепции реляционного или объектно-реляционного моделирования. Для моделирования баз данных на основе SQL92 и более ранних стандартов используйте набор элементов "Отношение сущности". Для моделирования баз данных на основе SQL99 и более поздних стандартов используйте набор элементов "Объектно-реляционная схема", в котором есть дополнительные фигуры для работы с типами.

В этой статье описаны способы создания модели базы данных и последующей работы с ней.

Не удается найти инструменты для моделей баз данных?

Инструменты для работы с моделями баз данных доступны не во всех выпусках Microsoft Visio. Если вы не можете найти инструменты, описанные в этой статье, вероятнее всего, в вашем выпуске Visio их нет.

  • В выпуске Microsoft Visio стандартный шаблон "Схема модели базы данных" отсутствует.

  • В выпусках Microsoft Visio профессиональный и премиум поддерживаются возможности реконструирования для шаблона "Схема модели базы данных" (т. е. создание модели в Visio из существующей базы данных), но прямая разработка (т. е. создание кода SQL на основе модели базы данных в Visio) недоступна.

  1. Чтобы начать работу со схемой модели базы данных, выполните одну из указанных ниже процедур.

    Создание схемы модели с нуля

    Если у вас нет базы данных, которая может служить отправной точкой, начните с пустой модели базы данных и добавьте в нее собственные таблицы и отношения.

    1. Откройте вкладку Файл.

    2. Выберите Создать > Программы и базы данных и дважды щелкните элемент Схема модели базы данных.

    3. На вкладке База данных в группе Управление нажмите Параметры отображения.

    4. В диалоговом окне Параметры документа базы данных выберите нужный набор символов и другие параметры таблиц и отношений и нажмите кнопку ОК.

    Использование существующей базы данных как отправной точки

    Если есть база данных, модель которой вы хотите построить, чтобы лучше понимать ее структуру, или которая может служить основой для новой модели, можно использовать мастер реконструирования для извлечения схемы, или структуры, базы данных и создания новой модели.

    Перед началом работы с мастером

    1. Если вы реконструируете книгу Microsoft Excel, то перед запуском мастера нужно открыть ее и присвоить имя группе (или диапазону) ячеек, содержащих заголовки столбцов. Если вы хотите использовать несколько листов, просто присвойте имя группе ячеек с заголовками столбцов на каждом из них. Мастер интерпретирует эти диапазоны как таблицы. Дополнительные сведения о том, как присвоить имя диапазону ячеек, см. в статье справки Excel, посвященной определению именованных ссылок на ячейки и диапазонов ячеек.

    2. Чтобы добиться наилучших результатов, перед запуском мастера реконструирования настройте драйвер по умолчанию для целевой базы данных. Это гарантирует, что мастер правильно сопоставит собственные типы данных, а весь извлеченный им код будет правильно отображаться в окне "Код".

    3. Откройте вкладку Файл.

    4. Выберите Создать > Программы и базы данных и дважды щелкните элемент Схема модели базы данных.

    5. На вкладке База данных в группе Модель нажмите Реконструировать.

    6. На первом экране мастера реконструирования выполните указанные ниже действия.

      1. Выберите драйвер базы данных для своей системы управления базами данных (СУБД). Если вы еще не связали драйвер базы данных Visio с конкретным источником данных ODBC, нажмите кнопку Настройка.

        Примечание: если вы выполняете реконструирование листа Excel, выберите универсальный драйвер ODBC.

      2. Выберите источник данных для базы данных, которую вы хотите обновить. Если вы еще не создали источник данных для существующей базы данных, нажмите Создать, чтобы сделать это сейчас.

        Когда новый источник будет создан, его имя появится в списке Источники данных.

      3. Завершив настройку параметров, нажмите кнопку Далее.

    7. Следуйте инструкциям в диалоговых окнах для конкретного драйвера.

      Например, в диалоговом окне Подключение источника данных введите имя пользователя и пароль и нажмите кнопку ОК.

      Примечание: если используется универсальный драйвер ODBC, иногда появляется сообщение об ошибке, которое означает, что реконструированная информация может быть неполной. В большинстве случаев это не указывает на реальную проблему, так что можно нажать кнопку ОК, чтобы продолжить работу мастера.

    8. Установите флажки для тех типов данных, которые нужно извлечь, и нажмите Далее.

      Примечание: некоторые элементы могут быть недоступны (затенены), потому что не каждая система управления базами данных поддерживает все типы элементов, которые может извлечь мастер.

    9. Установите флажки для таблиц (и представлений, если они есть), которые нужно извлечь, или нажмите Выделить все, чтобы извлечь все элементы, и нажмите кнопку Далее.

      Примечание: если вы реконструируете лист Excel, а этот список пуст, скорее всего, нужно присвоить имя диапазону ячеек, который содержит заголовки столбцов на листе.

    10. Если вы установили флажок Хранимые процедуры, выберите процедуры, которые нужно извлечь, или щелкните Выделить все, чтобы извлечь их все, а затем нажмите Далее.

    11. Укажите, нужно ли автоматически добавлять реконструируемые элементы на текущую страницу.

      Примечание: вы можете задать автоматическое создание документа в дополнение к списку реконструируемых элементов в окне "Таблицы и представления". Если вы решили не создавать документ автоматически, то можете перетащить элементы из окна "Таблицы и представления" на страницу документа, чтобы построить модель базы данных вручную.

    12. Просмотрите выбранные параметры, чтобы убедиться в том, что будут извлечены все нужные данные, и нажмите кнопку Готово.

      Мастер извлечет выбранные данные, отображая замечания о процедуре извлечения в окне вывода.

    Импорт и настройка существующей модели

    Если у вас уже есть модель VisioModeler или PLATINUM ERwin, можно импортировать ее, чтобы создать схему модели базы данных Visio. Эта возможность доступна только для IMD-файлов модели словаря VisioModeler 2.0 или более поздней версии и ERX-файлов PLATINUM ERwin 2.6, 3.0 и 3.52.

    1. Откройте вкладку Файл.

    2. Выберите Создать > Программы и базы данных и дважды щелкните элемент Схема модели базы данных.

    3. На вкладке База данных в группе Модель нажмите Импорт и выберите тип модели.

    4. Введите путь и имя файла для модели, которую вы хотите импортировать, или нажмите Обзор, чтобы указать расположение файла модели, а затем нажмите Открыть.

    5. В диалоговом окне Импорт нажмите кнопку ОК.

      Visio импортирует файл, отображая ход выполнения в окне вывода. Импортированные таблицы отображаются в окне "Таблицы и представления".

    6. В окне "Таблицы и представления" выделите таблицы, которые нужно включить в модель, и перетащите их на страницу документа.

  2. Создав схему модели базы данных, перейдите к ее настройке. Вы можете добавить и настроить таблицы и представления, создать отношения и настроить типы столбцов и данных.

    Таблицы

    Чтобы создать таблицу на схеме, используйте фигуру Сущность.

    1. Перетащите фигуру Сущность из набора элементов Отношение сущности или Объектно-реляционная схема на страницу документа.

    2. Дважды щелкните фигуру,чтобы открыть окно Свойства базы данных.

    3. В списке Категории щелкните Определение и введите имя таблицы.

    4. В списке Категории щелкните Столбцы, введите имя и выберите тип данных.

    5. Установите флажок Обязательное для столбцов, которые не могут содержать пустых значений.

    6. Установите флажок PK (первичный ключ) для столбцов, которые однозначно определяют каждую строку в таблице базы данных.

    7. В списке Категории щелкните Индексы, Триггеры, Проверка или Дополнительные, чтобы создать эти необязательные элементы.

    Столбцы

    В окне Свойства базы данных добавьте или измените свойства для столбцов, включая типы данных и первичные ключи.

    1. Дважды щелкните таблицу на схеме.

    2. В окне Свойства базы данных в списке Категории щелкните Столбцы.

    3. Щелкните первую пустую ячейку Физическое имя и введите имя.

    4. Чтобы изменить тип данных столбца, щелкните поле Тип данных и введите или выберите из списка необходимый тип. Например, можно указать тип decimal(8,2) или char(30).

    5. Чтобы запретить пустые значения, установите флажок Обязательное.

    6. Чтобы указать, что столбец является первичным ключом, установите флажок PK.

    7. Чтобы отобразить дополнительные свойства категории Столбцы, выделите столбец и нажмите Изменить.

    Отношения

    Отношения используются для сопоставления строк в двух таблицах базы данных с помощью первичных и внешних ключей. Эти отношения можно показать на схеме. Кроме того, можно задать кратность отношения (например, "один-ко-многим") и показать ее, используя нотацию Crow's foot, IDEF1X или реляционную. В шаблоне "Схема модели базы данных" отношения "многие-ко-многим" невозможно показать с помощью этих нотаций.

    1. Создайте отношение между таблицами.

      1. Убедитесь в том, что обе таблицы видны на схеме. Если вы реконструировали модель из существующей базы данных, возможно, потребуется перетащить одну или обе таблицы из окна "Таблицы и представления" на страницу документа.

      2. Дважды щелкните таблицу, первичный ключ из которой нужно использовать для отношения.

      3. В окне Свойства базы данных в списке Категории щелкните Столбцы.

      4. В таблице щелкните столбец, который должен однозначно определять строки, и установите флажок PK, чтобы сделать его первичным ключом.

      5. Перетащите фигуру Отношение из набора элементов Объектно-реляционная схема или Отношение сущности в пустую часть страницы.

      6. Свяжите верхнее соединение фигуры с родительской таблицей.

      7. Свяжите другое соединение с дочерней таблицей.

        Если во второй таблице еще нет столбца с тем же именем, что у первичного ключа, он будет добавлен автоматически и станет внешним ключом.

        Примечание: если линии отношений исчезают, на вкладке База данных в группе Управление нажмите Параметры отображения. На вкладке Отношения в разделе Показывать установите флажок Отношения.

    2. Задайте кратность отношения.

      1. Дважды щелкните отношение.

      2. В окне Свойства базы данных в списке Категории щелкните Прочее.

      3. В разделе Мощность выберите кратность, которая лучше всего подходит для отношения. Для отношений "один-ко-многим" лучше всего подходит вариант 0 или более или 1 или более. Для отношений "один-к-одному" лучше всего подходит вариант 0 или 1 или Ровно 1.

  3. Чтобы дополнительно настроить схему (например, создать индексы, предложения проверки и триггеры), можно выполнить указанные ниже действия.

    Создание индексов

    Индексы повышают быстродействие базы данных при выполнении запросов.

    1. Откройте схему модели базы данных.

    2. Дважды щелкните таблицу, в которую нужно добавить индекс, и в окне Свойства базы данных в списке Категории выберите Индексы.

    3. Щелкните Создать.

    4. В диалоговом окне Создать индекс введите имя для индекса и нажмите кнопку ОК.

    5. В списке Тип индекса выберите тип индекса, который нужно создать (уникальный или неуникальный).

    6. В списке Доступные столбцы выберите имена всех столбцов, которые необходимо включить в этот индекс, а затем нажмите Добавить >.

    7. В списке Индексированные столбцы установите флажок Возрастание, чтобы создать индекс с сортировкой по возрастанию, или снимите флажок, чтобы в индексе использовалась сортировка по убыванию.

      Схема модели базы данных обновится.

    Создание представлений

    Представление можно рассматривать как сохраненный запрос. Представления особенно удобны, если нужно периодически обращаться к одним и тем же данным из нескольких таблиц или показать данные пользователям без возможности изменения таблиц.

    Перетащите фигуру Представление из набора элементов Отношение сущности или Объектно-реляционная схема на страницу документа.

    Настройка расширенных свойств таблиц и представлений

    В зависимости от системы управления базами данных (СУБД) для таблиц или представлений можно указать место хранения с помощью расширенных свойств.

    Дважды щелкните таблицу или представление, для которого нужно настроить расширенные свойства, и в окне Свойства базы данных в списке Категории щелкните Дополнительные.

    Создание предложений проверки

    С помощью предложений проверки можно ограничить ввод значений в столбец таким образом, чтобы они находились в заданном диапазоне. Например, вы можете создать предложение проверки, которое разрешает вводить в столбец "Возраст" только значения больше 65.

    1. Дважды щелкните таблицу, чтобы открыть окно Свойства базы данных.

    2. В списке Категории щелкните Столбцы и выберите столбец, для которого нужно добавить предложение проверки.

    3. Нажмите Изменить.

    4. В диалоговом окне Свойства столбца на вкладке Проверка введите необходимые ограничения.

      Предложение проверки будет добавлено в окно "Код" в разделе Локальный код.

    Создание хранимых процедур и определяемых пользователем функций

    Применяйте хранимые процедуры и определяемые пользователем функции для создания пакетов кода, которые можно повторно использовать для многократного выполнения одних и тех же действий. Основное отличие между этими возможностями состоит в том, что определяемая пользователем функция возвращает значение, а хранимая процедура просто выполняет код, не возвращая значения.

    1. На вкладке База данных в группе Показать или скрыть установите флажок Код, чтобы открыть окно Код.

    2. Щелкните Глобальный код, а затем нажмите Создать.

    3. В окне Редактор кода на вкладке Свойства выберите тип и введите имя создаваемого кода.

    4. На вкладке Текст введите код, а затем нажмите кнопку ОК.

    Создание триггеров

    Триггеры запускают указанный вами код SQL при наступлении определенных событий в базе данных.

    1. Дважды щелкните таблицу, чтобы открыть окно Свойства базы данных.

    2. В списке Категории щелкните Триггеры, а затем нажмите Добавить.

    3. На вкладке Свойства введите имя триггера.

    4. На вкладке Текст введите код, а затем нажмите кнопку ОК.

      Триггер будет добавлен в окно "Код" в разделе Локальный код.

В этой статье описаны способы создания модели базы данных и последующей работы с ней. Чтобы быстро приступить к работе, в меню Файл последовательно наведите указатель мыши на пункты Создать и Программы и базы данных и выберите пункт Схема модели базы данных.

Не удается найти инструменты для моделей баз данных?

Вероятно, этих возможностей нет в вашем выпуске Microsoft Office Visio. Чтобы узнать, какой выпуск Visio у вас установлен, в меню Справка щелкните О программе Microsoft Office Visio. Название выпуска указано в диалоговом окне в верхней строке текста.

  • В выпуске Microsoft Office Visio Стандартный шаблон "Схема модели базы данных" отсутствует.

  • В выпуске Microsoft Office Visio Профессиональный поддерживается реконструирование для шаблона "Схема модели базы данных" (т. е. создание модели в Visio из существующей базы данных), но прямая разработка (т. е. создание кода SQL на основе модели базы данных в Visio) недоступна.

  • Полный набор функций для моделирования баз данных, включая возможности реконструирования и прямой разработки, доступен в выпуске Visio for Enterprise Architects. Visio for Enterprise Architects входит в подписку MSDN Premium, которая предлагается вместе с продуктом Visual Studio Professional и ролевыми выпусками системы Visual Studio Team System.

  1. Чтобы начать работу со схемой модели базы данных, выполните одну из указанных ниже процедур.

    Создание схемы модели с нуля

    Если у вас нет базы данных, которая может служить отправной точкой, начните с пустой модели базы данных и добавьте в нее собственные таблицы и отношения.

    1. В меню Файл последовательно наведите указатель мыши на пункты Создать и Программы и базы данных и выберите пункт Схема модели базы данных.

    2. В меню База данных наведите указатель мыши на пункт Параметры и выберите пункт Документ.

    3. В диалоговом окне Параметры документа базы данных выберите нужный набор символов и другие параметры таблиц и отношений и нажмите кнопку ОК.

    Использование существующей базы данных как отправной точки

    Если есть база данных, модель которой вы хотите построить, чтобы лучше понимать ее структуру, или которая может служить основой для новой модели, можно использовать мастер реконструирования для извлечения схемы, или структуры, базы данных и создания новой модели.

    Примечание: перед началом работы с мастером

    1. Если вы реконструируете книгу Microsoft Office Excel, то перед запуском мастера нужно открыть ее и присвоить имя группе (или диапазону) ячеек, содержащих заголовки столбцов. Если вы хотите использовать несколько листов, просто присвойте имя группе ячеек с заголовками столбцов на каждом из них. Мастер интерпретирует эти диапазоны как таблицы. Дополнительные сведения о том, как присвоить имя диапазону ячеек, см. в статье справки Microsoft Office Excel, посвященной определению именованных ссылок на ячейки и диапазонов ячеек.

    2. Чтобы добиться наилучших результатов, перед запуском мастера реконструирования настройте драйвер по умолчанию для целевой базы данных. Это гарантирует, что мастер правильно сопоставит собственные типы данных, а весь извлеченный им код будет правильно отображаться в окне "Код".

    3. В меню Файл последовательно наведите указатель мыши на пункты Создать и Программы и базы данных и выберите пункт Схема модели базы данных.

    4. В меню База данных выберите команду Реконструировать.

    5. На первом экране мастера реконструирования выполните указанные ниже действия.

      1. Выберите драйвер базы данных Microsoft Office Visio для своей системы управления базами данных (СУБД). Если вы еще не связали драйвер базы данных Visio с конкретным источником данных ODBC, нажмите кнопку Настройка.

        Примечание: если вы выполняете реконструирование листа Excel, выберите универсальный драйвер ODBC.

      2. Выберите источник данных для базы данных, которую вы хотите обновить. Если вы еще не создали источник данных для существующей базы данных, нажмите Создать, чтобы сделать это сейчас.

        Когда новый источник будет создан, его имя появится в списке Источники данных.

      3. Завершив настройку параметров, нажмите кнопку Далее.

    6. Следуйте инструкциям в диалоговых окнах для конкретного драйвера.

      Например, в диалоговом окне Подключение источника данных введите имя пользователя и пароль и нажмите кнопку ОК. Если источник данных не защищен паролем, просто нажмите ОК.

      Примечание: если используется универсальный драйвер ODBC, иногда появляется сообщение об ошибке, которое означает, что реконструированная информация может быть неполной. В большинстве случаев это не указывает на реальную проблему, так что можно нажать кнопку ОК, чтобы продолжить работу мастера.

    7. Установите флажки для тех типов данных, которые нужно извлечь, и нажмите Далее.

      Примечание: некоторые элементы могут быть недоступны (затенены), потому что не каждая система управления базами данных поддерживает все типы элементов, которые может извлечь мастер.

    8. Установите флажки для таблиц (и представлений, если они есть), которые нужно извлечь, или нажмите Выделить все, чтобы извлечь все элементы, и нажмите кнопку Далее.

      Примечание: если вы реконструируете лист Excel, а этот список пуст, скорее всего, нужно присвоить имя диапазону ячеек, который содержит заголовки столбцов на листе.

    9. Если на шаге 3 вы установили флажок Хранимые процедуры, выберите процедуры, которые нужно извлечь, или щелкните Выделить все, чтобы извлечь их все, а затем нажмите кнопку Далее.

    10. Укажите, нужно ли автоматически добавлять реконструируемые элементы на текущую страницу.

      Примечание: вы можете задать автоматическое создание документа в дополнение к списку реконструируемых элементов в окне "Таблицы и представления". Если вы решили не создавать документ автоматически, то можете перетащить элементы из окна "Таблицы и представления" на страницу документа, чтобы построить модель базы данных вручную.

    11. Просмотрите выбранные параметры, чтобы убедиться в том, что будут извлечены все нужные данные, и нажмите кнопку Готово.

      Мастер извлечет выбранные данные, отображая замечания о процедуре извлечения в окне вывода.

    Импорт и настройка существующей модели

    Если у вас уже есть модель VisioModeler или PLATINUM ERwin, можно импортировать ее, чтобы создать схему модели базы данных Visio. Эта возможность доступна только для IMD-файлов модели словаря VisioModeler 2.0 или более поздней версии и ERX-файлов PLATINUM ERwin 2.6, 3.0 и 3.52.

    1. В меню Файл последовательно наведите указатель мыши на пункты Создать и Программы и базы данных и выберите пункт Схема модели базы данных.

    2. В меню База данных наведите указатель мыши на пункт Импорт и щелкните Импорт <тип модели>.

    3. Введите путь и имя файла для модели, которую вы хотите импортировать, или нажмите Обзор, чтобы указать расположение файла модели, а затем нажмите Открыть.

    4. В диалоговом окне Импорт нажмите кнопку ОК.

      Visio импортирует файл, отображая ход выполнения в окне вывода. Импортированные таблицы отображаются в окне "Таблицы и представления".

    5. В окне "Таблицы и представления" выделите таблицы, которые нужно включить в модель, и перетащите их на страницу документа.

  2. Создав схему модели базы данных, перейдите к ее настройке. Вы можете добавить и настроить таблицы и представления, создать отношения и настроить типы столбцов и данных.

    Таблицы

    Чтобы создать таблицу на схеме, используйте фигуру Сущность.

    1. Перетащите фигуру Сущность из набора элементов Отношение сущности или Объектно-реляционная схема на страницу документа.

    2. Дважды щелкните фигуру,чтобы открыть окно "Свойства базы данных".

    3. В списке Категории щелкните Определение и введите имя таблицы.

    4. В списке Категории щелкните Столбцы, введите имя и выберите тип данных.

    5. Установите флажок Обязательное для столбцов, которые не могут содержать пустых значений.

    6. Установите флажок PK (первичный ключ) для столбцов, которые однозначно определяют каждую строку в таблице базы данных.

    7. В списке Категории щелкните Индексы, Триггеры, Проверка или Дополнительные, чтобы создать эти необязательные элементы.

    Столбцы

    В окне "Свойства базы данных" добавьте или измените свойства для столбцов, включая типы данных и первичные ключи.

    1. Дважды щелкните таблицу на схеме.

    2. В окне "Свойства базы данных" в списке Категории щелкните Столбцы.

    3. Щелкните первую пустую ячейку Физическое имя и введите имя.

    4. Чтобы изменить тип данных столбца, щелкните поле Тип данных и введите или выберите из списка необходимый тип. Например, можно указать тип decimal(8,2) или char(30).

    5. Чтобы запретить пустые значения, установите флажок Обязательное.

    6. Чтобы указать, что столбец является первичным ключом, установите флажок PK.

    7. Чтобы отобразить дополнительные свойства категории Столбцы, выделите столбец и нажмите Изменить.

    Отношения

    Отношения используются для сопоставления строк в двух таблицах базы данных с помощью первичных и внешних ключей. Эти отношения можно показать на схеме. Кроме того, можно задать кратность отношения (например, "один-ко-многим") и показать ее, используя нотацию Crow's foot, IDEF1X или реляционную. В шаблоне "Схема модели базы данных" отношения "многие-ко-многим" невозможно показать с помощью этих нотаций.

    1. Создайте отношение между таблицами.

      1. Убедитесь в том, что обе таблицы видны на схеме. Если вы реконструировали модель из существующей базы данных, возможно, потребуется перетащить одну или обе таблицы из окна "Таблицы и представления" на страницу документа.

      2. Дважды щелкните таблицу, первичный ключ из которой нужно использовать для отношения.

      3. В окне "Свойства базы данных" в списке Категории щелкните Столбцы.

      4. В таблице щелкните столбец, который должен однозначно определять строки, и установите флажок PK, чтобы сделать его первичным ключом.

      5. Перетащите фигуру Отношение из набора элементов Объектно-реляционная схема или Отношение сущности в пустую часть страницы.

      6. Свяжите верхнее соединение фигуры с родительской таблицей.

      7. Свяжите другое соединение с дочерней таблицей.

        Если во второй таблице еще нет столбца с тем же именем, что у первичного ключа, он будет добавлен автоматически и станет внешним ключом.

        Примечание: если линии отношений исчезают, в меню База данных наведите указатель мыши на пункт Параметры и щелкните Документ. На вкладке Отношения в разделе Показывать установите флажок Отношения.

    2. Задайте кратность отношения.

      1. Дважды щелкните отношение.

      2. В окне "Свойства базы данных" в списке Категории щелкните Прочее.

      3. В разделе Мощность выберите кратность, которая лучше всего подходит для отношения. Для отношений "один-ко-многим" лучше всего подходит вариант 0 или более или 1 или более. Для отношений "один-к-одному" лучше всего подходит вариант 0 или 1 или Ровно 1.

  3. Чтобы дополнительно настроить схему (например, создать индексы, предложения проверки и триггеры), можно выполнить указанные ниже действия.

    Создание индексов

    Индексы повышают быстродействие базы данных при выполнении запросов.

    1. Откройте схему модели базы данных.

    2. Дважды щелкните таблицу, в которую нужно добавить индекс, и в окне "Свойства базы данных" в списке Категории выберите Индексы.

    3. Щелкните Создать.

    4. В диалоговом окне Создать индекс введите имя для индекса и нажмите кнопку ОК.

    5. В списке Тип индекса выберите тип индекса, который нужно создать (уникальный или неуникальный).

    6. В списке Доступные столбцы выберите имена всех столбцов, которые необходимо включить в этот индекс, а затем нажмите Добавить >.

    7. В списке Индексированные столбцы установите флажок Возрастание, чтобы создать индекс с сортировкой по возрастанию, или снимите флажок, чтобы в индексе использовалась сортировка по убыванию.

      Схема модели базы данных обновится.

    Создание представлений

    Представление можно рассматривать как сохраненный запрос. Представления особенно удобны, если нужно периодически обращаться к одним и тем же данным из нескольких таблиц или показать данные пользователям без возможности изменения таблиц.

    Перетащите фигуру Представление из набора элементов Отношение сущности или Объектно-реляционная схема на страницу документа.

    Настройка расширенных свойств таблиц и представлений

    В зависимости от системы управления базами данных (СУБД) для таблиц или представлений можно указать место хранения с помощью расширенных свойств.

    Дважды щелкните таблицу или представление, для которого нужно настроить расширенные свойства, и в окне "Свойства базы данных" в списке Категории щелкните Дополнительные.

    Создание предложений проверки

    С помощью предложений проверки можно ограничить ввод значений в столбец таким образом, чтобы они находились в заданном диапазоне. Например, вы можете создать предложение проверки, которое разрешает вводить в столбец "Возраст" только значения больше 65.

    1. Дважды щелкните таблицу, чтобы открыть окно "Свойства базы данных".

    2. В списке Категории щелкните Столбцы и выберите столбец, для которого нужно добавить предложение проверки.

    3. Нажмите Изменить.

    4. В диалоговом окне Свойства столбца на вкладке Проверка введите необходимые ограничения. Дополнительные сведения о доступных вариантах см. в статье Диалоговые окна "Свойства столбца" и "Свойства поля" (вкладка "Проверка").

      Предложения проверки будут добавлены в окно "Код" в разделе Локальный код.

    Создание хранимых процедур и определяемых пользователем функций

    Применяйте хранимые процедуры и определяемые пользователем функции для создания пакетов кода, которые можно повторно использовать для многократного выполнения одних и тех же действий. Основное отличие между этими возможностями состоит в том, что определяемая пользователем функция возвращает значение, а хранимая процедура просто выполняет код, не возвращая значения.

    1. В меню База данных наведите указатель мыши на пункт Вид и щелкните Код, чтобы открыть окно "Код".

    2. Щелкните Глобальный код, а затем нажмите Создать.

    3. В окне Редактор кода на вкладке Свойства выберите тип и введите имя создаваемого кода.

    4. На вкладке Текст введите код, а затем нажмите кнопку ОК.

    Создание триггеров

    Триггеры запускают указанный вами код SQL при наступлении определенных событий в базе данных.

    1. Дважды щелкните таблицу, чтобы открыть окно "Свойства базы данных".

    2. В списке Категории щелкните Триггеры, а затем нажмите Добавить.

    3. На вкладке Свойства введите имя триггера.

    4. На вкладке Текст введите код, а затем нажмите кнопку ОК.

      Триггер будет добавлен в окно "Код" в разделе Локальный код.

Совершенствование навыков работы с Office
Перейти к обучению
Первоочередный доступ к новым возможностям
Присоединиться к программе предварительной оценки Office

Были ли сведения полезными?

Спасибо за ваш отзыв!

Благодарим за отзыв! Возможно, будет полезно связать вас с одним из наших специалистов службы поддержки Office.

×