Создание и печать писем с помощью слияния

Если вам нужно отправить почту людям из списка рассылки, вы можете создать персонализированные письма с помощью слияния. У всех писем будут одинаковые структура, форматирование, текст и рисунки. В них будут различаться только определенные разделы.

Процесс слияния включает следующие действия:

  1. Подготовка основного документа. Основной документ содержит текст и рисунки, которые будут одинаковыми во всех версиях документа, например обратный адрес или приветствие в письме.

  2. Подключение документа к источнику данных. Источник данных — это файл, содержащий данные для слияния, например имена или адреса получателей писем.

  3. Уточнение списка получателей или записей. Microsoft Office Word создает копию основного документа для каждого элемента (записи) в файле данных. Если файл данных представляет собой список рассылки, такими элементами, скорее всего, являются получатели. Если вы хотите создать копии только определенных элементов из файла данных, вы можете указать, какие элементы (записи) требуется включить.

  4. Добавление в документ заполнителей (полей слияния). При выполнении слияния поля заполняются сведениями из файла данных.

  5. Предварительный просмотр и завершение слияния. Перед печатью всех документов можно просмотреть каждый из них.

Слияние выполняется с помощью команд вкладки Рассылки.

Важно : Если вы планируете использовать настраиваемые поля в списке контактов Microsoft Office Outlook, необходимо начать слияние почты в Outlook.

Примечание : 

Вы также можете выполнить слияние с помощью области задач Слияния, в которой есть мастер, предлагающий пошаговые инструкции. Чтобы воспользоваться им, в группе Начало слияния на вкладке Рассылки нажмите кнопку Начать слияние и выберите пункт Пошаговый мастер слияния.

Изображение ленты Word

Шаг 1. Подготовка основного документа

  1. Запустите программу Word.

    По умолчанию будет открыт пустой документ. Пусть он остается открытым, поскольку, если его закрыть, команды, которые нужно будет выполнить в дальнейшем, станут недоступны.

  2. На вкладке Рассылки в группе Начало слияния выберите команду Начать слияние.

    Изображение ленты Word

  3. Щелкните Письма.

С помощью слияния также можно создавать следующие документы:

Примечание : 

Если необходимо прервать слияние, можно сохранить основной документ и возобновить слияние позже. Microsoft Office Word сохранит источник данных и описание полей. Если была открыта область задач Слияние, при возобновлении процесса Word откроет область задач в том же месте.

  1. Когда потребуется возобновить слияние, откройте этот документ.

    В Word появится запрос на подтверждение открытия документа, после чего будет выполнена команда SQL.

  2. Поскольку этот документ подключен к источнику данных, и требуется их извлечь, нажмите кнопку Да. Если было неизвестно, что документ, который нужно открыть, подключен к источнику данных, можно нажать кнопку Нет, чтобы предотвратить потенциально опасный доступ к данным.

    Будет отображен текст документа вместе со всеми вставленными полями.

  3. Откройте вкладку Рассылки и продолжите работу.

К началу страницы

Шаг 2. Подключение документа к источнику данных

Чтобы включить данные в основной документ, необходимо подключить документ к источнику данных, который иначе называется файлом данных. Если файла данных пока не существует, его можно создать в процессе слияния.

Важно : При использовании существующего списка убедитесь в том, что он содержит все необходимые сведения, включая столбцы и строки. В ходе слияния можно внести определенные изменения, однако открыть источник отдельно во время этой процедуры невозможно. Выполнить слияние проще, если источник данных заранее подготовлен.

Выбор файла данных

  1. На вкладке Рассылки в группе Начало слияния нажмите кнопку Выбрать получателей.

    Изображение ленты Word

  2. Выполните одно из указанных ниже действий.

    • Используйте контакты Outlook.    Если нужно использовать список контактов Outlook, выберите в меню пункт Выбрать из контактов Outlook.

      Дополнительные сведения об использовании списка контактов см. в разделе Советы по работе со списком контактов Outlook.

    • Используйте файл источника данных.    Если у вас есть лист Excel, база данных Microsoft Access или файл данных другого типа, выберите пункт Использовать существующий список и найдите этот файл в диалоговом окне Выбор источника данных.

      В приложении Excel можно выбрать в качестве источника данных любой лист или именованный диапазон книги, в Access — любую таблицу или запрос, определенный в данной базе данных.

      Советы по форматированию данных на листах Excel для слияния см. в разделе Советы по форматированию данных в Excel.

      Чтобы использовать файл данных другого типа, выберите его в диалоговом окне Выбор источника данных. Если нужного файла нет в списке, выберите соответствующий тип либо пункт Все файлы в списке Тип файлов. При слиянии можно использовать файлы данных указанных ниже типов.

      • Файлы одноуровневых файловых СУБД, для которых установлен соответствующий поставщик OLE DB или драйвер ODBC. Несколько таких драйверов входят в состав Microsoft Office.

      • Файл HTML, содержащий одну таблицу. Первая строка таблицы должна содержать названия столбцов, а остальные — данные.

      • Электронные адресные книги:

        • адресная книга Microsoft Outlook

        • список контактов Microsoft Schedule+ 7.0

        • другие аналогичные списки адресов, созданные с помощью систем обмена сообщениями, поддерживающих MAPI, например Microsoft Outlook.

      • Документ Microsoft Word. Этот документ должен включать одну таблицу. Первая строка таблицы должна содержать заголовки, а остальные строки — записи, которые вы хотите добавить в составной документ. Вы также можете использовать источник заголовков в качестве источника данных.

      • Любой текстовый файл, содержащий поля данных, разделенные знаками табуляции или запятыми, и записи данных, разделенные знаками абзаца.

    • Создайте новый файл данных в Word.    Если готового файла данных не существует, выберите пункт Ввести новый список и создайте список в появившейся форме. Этот список сохраняется в виде файла базы данных (MDB), который можно использовать многократно. Дополнительные сведения см. в разделе Создание списка.

Если установлен Выпуск 2007 набора Microsoft Office (а не только Microsoft Word), вы также можете воспользоваться приложением Microsoft Query для создания запроса и извлечения необходимых данных из внешнего источника данных.

Когда все будет готово, перейдите к следующему действию.

Если у вас возникли вопросы о работе со списком контактов Outlook, форматировании данных в Excel или вводе нового списка, перейдите к разделу Советы и дополнительные инструкции.

Шаг 3. Уточнение списка получателей или записей

При подключении к определенному файлу данных, возможно, потребуется перенести в основной документ содержимое не всех, а только некоторых его записей.

Если нужно использовать весь список, пропустите этот этап и перейдите к следующему.

Чтобы ограничить список получателей или использовать подмножество записей файла данных, выполните указанные ниже действия.

  1. На вкладке Рассылки в группе Начало слияния нажмите кнопку Изменить список получателей.

    Изображение ленты Word

  2. В диалоговом окне Получатели слияния выполните одну из описанных ниже процедур.

    • Выбор отдельных записей.    Этот метод целесообразно использовать, если список достаточно короткий. Установите флажки рядом с нужным получателями и снимите флажки для остальных людей.

      Если известно, что при слиянии нужно использовать только несколько записей, можно снять флажок в строке заголовков и выбрать только необходимые записи. Аналогично, если вы хотите использовать большую часть записей, установите флажок в строке заголовков и снимите флажки для записей, которые вам не нужны.

    • Сортировка записей.    Щелкните заголовок столбца элемента, по которому вы хотите выполнить сортировку. Список будет отсортирован в алфавитном порядке по возрастанию (от A до Я). Чтобы отсортировать список в алфавитном порядке по убыванию (от Я до А), щелкните заголовок столбца еще раз.

      Чтобы задать более сложные параметры сортировки, в разделе Уточнить список получателей выберите пункт Сортировка, а затем укажите параметры на вкладке Сортировка записей в диалоговом окне Фильтр и сортировка. Например, вы можете отсортировать адреса получателей с одним и тем же почтовым индексом по фамилии, а индексы в порядке возрастания.

    • Фильтрация записей.    Фильтрация записей полезна, если список содержит записи, которые вы не хотите просматривать или использовать для слияния. Выполнив фильтрацию, можно устанавливать и снимать флажки, чтобы включить или исключить отдельные записи.

      Для отбора записей выполните перечисленные ниже действия.

      А.

      В разделе Уточнить список получателей выберите пункт Фильтр.

      Б.

      В диалоговом окне Фильтр и сортировка на вкладке Отбор записей выберите условие фильтрации.

      Например, чтобы создать копии документа только для адресов в Казахстане, выберите в списке Поле элемент Страна или регион, в списке Оператор — равно, а в списке Значение — Казахстан.

      В.

      Чтобы уточнить фильтр, щелкните оператор И или Или и задайте дополнительные условия.

      Например, чтобы создать копии документа только для предприятий Минска, следует отобрать записи, в которых поле Город содержит название Минск, а поле Организация не является пустым. Если в этом условии отбора вместо И использовать оператор Или, в слияние будут включены все адреса в Минске, а также все адреса, содержащие название компании, независимо от города.

    • Добавление получателей.    Чтобы добавить получателей в список, выполните указанные ниже действия.

      А.

      На вкладке Рассылки в группе Начало слияния нажмите кнопку Изменить список получателей.

      Б.

      В разделе Источник данных щелкните имя файла данных.

      В.

      Нажмите кнопку Изменить.

      Г.

      В диалоговом окне Изменение источника данных нажмите кнопку Создать запись и введите сведения о получателе.

      Совет : В зависимости от типа источника данных некоторые функции могут быть недоступны. По возможности проверьте полноту файла данных перед его подключением к основному документу.

    • Поиск получателя

      Вы можете найти определенного получателя или группу получателей с одинаковыми атрибутами (такими как фамилия, почтовый индекс или месяц рождения), выполнив поиск в списке.

      А.

      В диалоговом окне Получатели слияния нажмите кнопку Найти получателя.

      Б.

      В диалоговом окне Поиск элемента в текстовое поле Найти введите значение атрибута, которое вы хотите найти, укажите нужные поля и нажмите кнопку Найти далее.

Если установлено программное обеспечение для проверки адреса, можно нажать кнопку Проверить адреса в диалоговом окне Адресаты слияния для проверки адресов получателей.

К началу страницы

Шаг 4. Добавление в документ заполнителей (полей слияния)

После подключения основного документа к файлу данных можно начинать вводить текст и добавлять заполнители, указывающие, где в каждой из копий документа будет выводиться уникальная информация.

Если вы знаете, как работают поля слияния, перейдите к инструкциям по сопоставлению и объединению.

Чтобы получить дополнительные сведения о работе полей слияния, обратитесь к разделу Советы по использованию полей слияния.

Сопоставление полей слияния с файлом данных

Чтобы не было сомнений, что приложение Word найдет в файле данных столбец, соответствующий каждому адресу или элементу приветствия, необходимо установить соответствие полей слияния в Word столбцам в файле данных.

Чтобы установить соответствие полей, на вкладке Рассылки в группе Составление документа и вставка полей нажмите кнопку Подбор полей.

Группа "Составление документа и вставка полей" на вкладке "Рассылки" в Word

Откроется диалоговое окно Подбор полей.

Диалоговое окно «Подбор полей»

Элементы адреса и приветствия приводятся слева. Заголовки столбцов из файла данных приводятся справа.

Word подыскивает соответствующий столбец для каждого элемента. На иллюстрации показано, что Word автоматически нашел соответствие столбца Фамилия файла данных полю Фамилия. Но он не смог противопоставить друг другу другие элементы. В частности, из этого файла данных Word не нашел соответствия полю Имя.

В списке справа можно выбрать столбец файла данных, соответствующий элементу слева. Теперь на иллюстрации столбец Имя соответствует элементу Имя. Нормально, что для элементов Обращение, Уникальный код и Отчество не установлено соответствие. Для документа не требуется использовать все поля. Если добавить поле, не содержащее данных из файла данных, в документе слияния оно будет отображаться в виде пустого заполнителя — обычно это пустая строка или скрытое поле.

Диалоговое окно «Подбор полей»

Ввод содержимого и добавление заполнителей (полей)

  1. В основном документе введите содержимое, которое должно отображаться во всех его копиях.

    Чтобы добавить рисунок (например, логотип), нажмите на вкладке Главная в группе Иллюстрации кнопку Рисунок.

  2. Щелкните то место, куда нужно вставить поле.

  3. Воспользуйтесь командами группы Составление документа и вставка полей на вкладке Рассылки.

    Группа "Составление документа и вставка полей" на вкладке "Рассылки" в Word

  4. Добавьте нужные поля из перечисленных ниже.

    Блок адреса с именем, почтовым адресом и прочими сведениями

    1. Выберите команду Блок адреса.

    2. В диалоговом окне Вставка блока адреса выберите элементы адреса, которые требуется включить, и нужные форматы. Затем нажмите кнопку ОК.

    3. Если появится диалоговое окно Подбор полей, значит приложение Word не смогло найти некоторые сведения, необходимые для блока адреса. Щелкните стрелку рядом с пунктом (нет соответствия), а затем выберите соответствующее поле в источнике данных, требуемое для слияния.

    Строка приветствия

    1. Выберите поле Строка приветствия.

    2. Задайте формат строки приветствия, включая обращение, формат имени и знак пунктуации, следующий за ним.

    3. Выберите текст, который должен отображаться в случаях, когда Microsoft Word не может интерпретировать имя получателя, например когда источник данных не содержит имени или фамилии получателя, а содержит только название предприятия.

    4. Нажмите кнопку ОК.

    5. Если появится диалоговое окно Подбор полей, значит, приложение Word не смогло найти некоторые сведения, необходимые для строки приветствия. Щелкните стрелку рядом с пунктом (нет соответствия), а затем выделите соответствующее поле в источнике данных, требуемое для слияния.

    Отдельные поля

    Можно вставить данные из отдельных полей, например фамилию, номер телефона или объем взноса, сделанного спонсором. Чтобы быстро добавить в основной документ поле из файла данных, щелкните стрелку рядом с пунктом Вставить поле слияния и щелкните имя поля.

    Чтобы получить доступ к дополнительным параметрам вставки индивидуальных полей в документ, выполните указанные ниже действия.

    1. На вкладке Рассылки в группе Составление документа и вставка полей выберите команду Вставить поле слияния.

    2. В диалоговом окне Вставить поле слияния выполните одно из следующих действий:

      • Чтобы выделить поля адреса, которые будут автоматически соответствовать полям источника данных, даже если поля источника данных имеют другие названия, выберите пункт Поля адреса.

      • Чтобы выбрать поля, в которые всегда подставляются данные непосредственно из столбца файла данных, установите переключатель Поля базы данных.

    3. В списке Поля: щелкните нужное поле.

    4. Нажмите кнопку Вставить, а затем — Закрыть.

    5. Если отобразится диалоговое окно Подбор полей, Microsoft Word, возможно, не смог найти некоторые данные, которые нужны для вставки поля. Щелкните стрелку рядом с пунктом (нет соответствия), а затем выберите поле в источнике данных, соответствующее полю, которое требуется для слияния.

      Примечание : Если первоначально поле было вставлено из списка Поля базы данных, а затем документ был переключен на другой источник данных, не имеющий столбца с тем же, что и поле, именем, приложение Word не сможет вставить сведения в это поле в составном документе.

Настраиваемые поля из списка контактов приложения Outlook

Единственный способ включить настраиваемые поля контактов в основной документ — запустить слияние из Outlook. Предварительно нужно настроить отображение списка контактов с применением именно тех полей, которые вы хотите использовать при слиянии, и лишь затем начать слияние. После выбора необходимых параметров автоматически запустится Word, и слияние можно будет завершить.

Настройка вида списка контактов, включающего настраиваемые поля

  1. В представлении Контакты Outlook в меню Вид наведите указатель мыши на пункт Текущее представление и выберите команду Список телефонов.

  2. Щелкните правой кнопкой мыши заголовок любого столбца и выберите команду Выбрать поля.

  3. В раскрывающемся списке в верхней части диалогового окна Выбор полей выберите пункт Поля пользователя в папке.

  4. Перетащите поля, которые требуется добавить, из диалогового окна в заголовки столбцов. Маленькая красная стрелка помогает поместить поле в нужное место.
      Перетаскивание настраиваемого поля из диалогового окна "Выбор полей" в представление папки "Контакты"

    В диалоговом окне Выбрать поля можно добавить новое поле, нажав кнопку Новое в верхней части.

  5. Добавив в представление настраиваемые поля, закройте диалоговое окно Выбор полей.

  6. Чтобы удалить поле, которое не должно использоваться при слиянии, поместите указатель мыши на имя поля в заголовке столбца представления "Список телефонов" и стащите поле из заголовка.

  7. Чтобы запустить слияние из Outlook, в представлении "Контакты" Outlook выберите отдельные контакты, выделив мышью диапазон контактов при нажатой клавише SHIFT или отдельные контакты при нажатой клавише CTRL. Если вы хотите использовать при слиянии все контакты, которые отображаются в данный момент, выделения не требуется.

  8. В меню Сервис выберите команду Слияние.

  9. Если для включения в составной документ выделены только отдельные контакты, выберите пункт Только выбранные контакты. Если в составной документ нужно включить все отображаемые в представлении контакты, выберите пункт Все контакты в текущем представлении.

  10. Если представление "Список телефонов" настроено таким образом, что оно отображает как раз те самые поля, которые нужно использовать при слиянии, выберите пункт Поля контактов в текущем представлении. Если же выбрать пункт Все поля контактов, то все поля списка контактов будут доступны для слияния.

  11. Если для слияния нужно создать новый основной документ, выберите пункт Новый документ. В противном случае выберите пункт Существующий документ и, чтобы найти необходимый основной документ, нажмите кнопку Обзор.

  12. Если нужно сохранить выделенные контакты и поля для использования в дальнейшем, установите флажок Постоянный файл и для сохранения файла нажмите кнопку Обзор. Разделенные запятыми данные будут сохранены в документе Word.

  13. Задайте параметры слияния:

    • Документы на бланке    :  подготовка набора писем для массовой рассылки.

    • Почтовые наклейки    : настройка наклеек с адресами для массовой рассылки.

    • Конверты    : настройка конвертов для массовой рассылки

    • Каталог    : создание документа, который содержит список адресов или каталог.

    • Новый документ    : создание объединенных документов, которые можно изменять по отдельности в Word.

    • Принтер    : отправка объединенных документов на принтер, используемый по умолчанию.

    • Электронная почта    : создание объединенных сообщений электронной почты. Когда вы будете готовы к завершению слияния, на вкладке Рассылки в группе Завершение нажмите кнопку Найти и объединить и выберите Отправить электронные сообщения. В строке Тема отобразится текст, который вы ввели в диалоговом окне Контакты для слияния в Outlook.

  14. Нажмите кнопку ОК. Когда документ откроется в Word, на вкладке Рассылки в группе Составление документа и вставка полей щелкните стрелку рядом с командой Вставить поле слияния и выберите поля, которые вы хотите добавить в документ.

  • Знаки поля слияния («« »») невозможно ввести вручную или вставить с помощью команды Символ в меню Вставка. Необходимо использовать слияние.

  • Если поля слияния отображаются внутри фигурных скобок, например { MERGEFIELD Город }, приложение Word отображает коды полей, а не значения полей. Это никак не влияет на слияние, но если вы хотите просмотреть значения, правой кнопкой мыши щелкните код поля, а затем выберите пункт Коды/значения полей.

Форматирование объединенных данных

Приложения для работы с базами данных и электронными таблицами, такие как Microsoft Office Access и Microsoft Office Excel, сохраняют вводимые сведения в ячейки в необработанном виде. Форматирование, применяемое в Access или Excel, такое выбор шрифта и цвета, не сохраняется вместе с необработанными данными. При слиянии из файла с данными в документ Word производится слияние необработанных данных без примененного к ним форматирования.

  1. Выделите поле слияния вместе с угловыми кавычками (« »), в которые оно заключено.

  2. На вкладке Главная в группе Шрифт задайте параметры форматирования или нажмите кнопку запуска диалогового окна Шрифт, чтобы получить доступ к дополнительным параметрам.

Важно : Чтобы уменьшить интервал между строками адресов на наклейках, выделите эти строки, нажмите на вкладке Главная кнопку вызова диалогового окна Абзац и введите значение 0 в полях "Перед" и "После" в разделе "Интервал". Если вы используете поле слияния "Блок адреса", выделите его целиком, включая шевроны («»), а затем измените интервал.

К началу страницы

Шаг 5. Предварительный просмотр, завершение слияния и печать документов

После того как вы добавите поля в основной документ, можно предварительно просмотреть результаты слияния. Если эти результаты соответствуют вашим ожиданиям, завершите слияние.

Предварительный просмотр результатов слияния

Перед завершением слияния вы можете просмотреть объединенные документы и внести необходимые изменения.

Для предварительного просмотра в группе Просмотр результатов на вкладке Письма и рассылки выполните перечисленные ниже действия.

Изображение ленты Word

  • Нажмите кнопку Просмотреть результаты.

  • Просмотрите поочередно каждый документ с помощью кнопок Следующая запись и Предыдущая запись в группе Просмотр результатов.

  • Чтобы просмотреть конкретный документ, выберите команду Найти получателя.

Чтобы открыть диалоговое окно Адресаты слияния, позволяющее отфильтровать список или исключить получателей, если в список попали нежелательные записи, на вкладке Рассылки в группе Начать слияние выберите пункт Изменить список получателей.

Изображение ленты Word

Завершение слияния

Объединенные документы можно печатать или изменять по отдельности. Вы можете напечатать или изменить все документы либо только их часть.

Если нужно напечатать часть документов, укажите диапазон номеров их записей. Если вы хотите напечатать страницы, а не указывать номера записей, выполните инструкции в разделе Изменение отдельных копий документа.

Печать объединенных документов
  1. На вкладке Рассылки в группе Завершение нажмите кнопку Найти и объединить и выберите команду Печать документов.

    Изображение ленты Word

  2. Выберите, следует ли напечатать весь набор документов, только копию, отображаемую в данный момент, или документы, номера записей которых вы указали.

Изменение отдельных копий документа
  1. На вкладке Рассылки в группе Завершение нажмите кнопку Найти и объединить и выберите команду Изменить отдельные документы.

    Изображение ленты Word

  2. Выберите, следует ли изменить весь набор документов, только копию, отображаемую в данный момент, или документы, номера записей которых вы указали. Word сохраняет копии, которые требуется отредактировать, в виде единого файла, где они отделены друг от друга с помощью разрывов страницы.

После завершения редактирования вы можете распечатать документы, нажав кнопку Microsoft Office Изображение кнопки Office и выбрав Печать.

Сохранение основного документа

Помните, что объединенные документы сохраняются отдельно от основного. Сохраните сам основной документ, если вы планируете использовать его для другого слияния.

При сохранении основного документа сохраняется и его подключение к файлу данных. Когда вы откроете его в следующий раз, вам будет предложено подтвердить, нужно ли снова добавить в него сведения из файла данных.

  • Если выбрать ответ Да, документ будет открываться с данными из первой записи, полученными в результате слияния.

  • Если щелкнуть Нет, подключение между основным документом и файлом данных разрывается. Основной документ становится стандартным документом Word. Поля заменяются уникальными данными из первой записи.

К началу страницы

Советы и дополнительные инструкции

Чтобы узнать больше о работе со списком контактов, форматировании данных в Excel или создании списка, просмотрите разделы ниже.

Советы по работе со списком контактов Outlook

Советы по форматированию данных в Excel

Советы по использованию полей слияния

Ввод нового списка

Советы по работе со списком контактов Outlook

Подключение к папке "Контакты" в Outlook обычно не составляет трудностей, но время от времени могут возникать неполадки. Выберите свою проблему из раскрывающегося списка, чтобы просмотреть решение.

Возможно, необходимо включить свойство Показать эту папку как адресную книгу приложения Outlook, а возможно, изменить профиль пользователя Outlook.

Включение свойства "Показать эту папку как адресную книгу"

  1. В Microsoft Office Outlook в меню Перейти выберите Контакты.

  2. Правой кнопкой мыши щелкните папку Контакты, содержащую нужные сведения, а затем щелкните Свойства.
    Свойства контактов в Outlook

  3. Убедитесь, что на вкладке Адресная книга Outlook установлен флажок Показать эту папку как адресную книгу, и нажмите кнопку ОК.

Изменение профиля пользователя Outlook

Профиль пользователя Outlook — это группа учетных записей электронной почты и адресных книг. Обычно необходим только один профиль — однако, если данным компьютером пользуется несколько человек или, если для разных целей предназначены различные адресные книги, можно использовать дополнительные профили. Если при слиянии используется профиль, не включающий требуемую папку "Контакты", она окажется недоступной.

Чтобы переключиться на другой профиль пользователя, следует перезапустить приложение Outlook. Следуя подсказке, выберите тот профиль, который включает в себя именно ту папку "Контакты", которую нужно использовать при слиянии.

Если подсказка о выборе профиля не отображается, но точно известно, что профилей более одного, можно настроить приложение Outlook так, чтобы она отображалась. Для этого выполните указанные ниже действия.

  1. Закройте Outlook.

  2. В панели управления переключитесь на классический вид и нажмите кнопку Почта.

  3. Нажмите кнопку Показать.

  4. Чтобы получать напоминание о необходимости выбора профиля каждый раз, когда запускается приложение Outlook, выберите пункт запрашивать конфигурацию и нажмите кнопку ОК.


Вернуться к советам по работе с Outlook

Если при попытке подключиться к папке "Контакты" во время процедуры слияния в приложении Word обнаруживается, что приложение Outlook не указано в настройках приложения Windows Internet Explorer в качестве почтового клиента по умолчанию, на экране появится сообщение об ошибке, приведенное ниже.

"Не выбран почтовый клиент по умолчанию, или текущий клиент не может выполнить запрос. Запустите Microsoft Outlook и установите клиента по умолчанию."

Чтобы избежать появления такого сообщения во время слияния, выполните указанные ниже действия.

  1. Закройте Word.

  2. В Internet Explorer выберите в меню Сервис пункт Свойства браузера и откройте вкладку Программы

  3. В разделе Электронная почта установите флажок Microsoft Office Outlook, а затем нажмите кнопку ОК.

Снова запустите приложение Word, откройте документ слияния и подключитесь к папке контактов Outlook.

Вернуться к советам по работе с приложением Outlook

Если начать слияние в приложении Word и попытаться подключиться к папке "Контакты" приложения Outlook через общие папки, на экране появится сообщение об ошибке, приведенное ниже.

"Не удается завершить операцию из-за ошибки окна диалога или обработчика базы данных. Повторите попытку позже."

При повторном выполнении этих действий будет отображаться это же сообщение об ошибке.

Чтобы использовать папку "Контакты" через общие папки в качестве файла данных для слияния, необходимо начинать слияние из Outlook.

Вернуться к советам по работе с Outlook

Такую адресную книгу невозможно подключить непосредственно во время слияния. Вместо этого экспортируйте ее в CSV-файл и затем подключитесь к нему.

Экспорт адресной книги Outlook Express

  1. Запустите Microsoft Outlook Express.

  2. В меню Файл наведите указатель на пункт Экспорт и выберите команду Адресная книга.

  3. В диалоговом окне Экспорт адресной книги щелкните Текстовый файл с разделителями-запятыми и нажмите кнопку Экспорт.

  4. В поле Сохранить экспортируемый файл как введите имя файла и нажмите кнопку Обзор.

  5. В диалоговом окне Сохранение документа в списке Папка выберите папку, в которую вы хотите сохранить файл, а затем нажмите кнопку Сохранить. Удобно сохранять файлы данных в папку Мои источники данных в папке Мои документы. Во время слияния Word прежде всего ищет файлы данных в этой папке.

  6. Нажмите кнопку Далее. Установите флажки рядом с полями, которые вы хотите экспортировать, и нажмите кнопку Готово.

    Примечание : При выборе полей подумайте о том, какие бланки писем, сообщения электронной почты или наклейки вы планируете создавать с помощью слияния. Например, если вы никогда не указываете псевдонимы или личные веб-сайты, не экспортируйте эти поля.

  7. Когда появится сообщение о том, что экспорт завершен, нажмите кнопку ОК.

  8. Закройте диалоговое окно Экспорт адресной книги, нажав кнопку Закрыть, и выйдите из Outlook Express.

Когда при слиянии в Word вы дойдете до шага, на котором нужно подключиться к файлу данных, выберите пункт Использовать существующий список и укажите экспортированный CSV-файл. Прежде чем файл откроется, вам может быть предложено выбрать разделитель столбцов в списке адресов. Щелкните Запятая и нажмите кнопку ОК.


Вернуться к советам по работе с Outlook

Советы по форматированию данных в приложении Excel

Если файл данных представляет собой электронную таблицу Excel, включающую величины в процентах, в денежных единицах или почтовые индексы, можно сохранить численное форматирование этих данных с помощью динамического обмена данными, подключившись к таблице Excel из приложения Word. Например, гарантируется, что почтовый индекс 07865 из файла данных, состоящий из пяти цифр, не будет отображаться, как число 7865 (без стоящего впереди нуля).

Прежде чем подключаться к листу, выполните в приложении Word указанные ниже действия.

  1. Нажмите кнопку Microsoft Office Изображение кнопки Office , а затем — Параметры Word.

  2. Выберите пункт Дополнительно.

  3. Перейдите к разделу Общие и установите флажокПодтверждать преобразование формата файла при открытии.

  4. Нажмите кнопку ОК.

  5. При открытом основном документе слияния в группе Начало слияния на вкладке Рассылки нажмите кнопку Выбрать получателей и выберите пункт Использовать существующий список.

  6. В диалоговом окне Выбор источника данных найдите лист Excel и дважды щелкните его.

  7. В диалоговом окне Преобразование источника данных щелкните Листы MS Excel через DDE (*.xls) и нажмите кнопку ОК.

    Если пункт Листы MS Excel с помощью DDE (*.xls) не отображается, установите флажок Показать все.

  8. В диалоговом окне Microsoft Office Excel в поле Диапазон или имя выберите диапазон ячеек или лист, содержащий данные, которые нужно использовать при слиянии, а затем нажмите кнопку ОК.

    Чтобы предотвратить запросы при каждом открытии файла данных, снимите флажок Подтверждать преобразование при открытии после подключения к листу.

Вернуться в раздел "Советы и дополнительные инструкции"

Советы по использованию полей слияния

Заполнители, такие как адрес и приветствие, называются полями слияния. Поля в Word соответствуют заголовкам столбцов выбранного файла данных.

Файл данных со столбцами (категориями) и строками (записями)

1. Столбцы в файле данных представляют собой категории данных. Поля, добавляемые в основной документ, являются для этих категорий заполнителями.

2. Строки в файле данных представляют собой записи, в которых хранятся некоторые данные. При слиянии Word создает копию основного документ для каждой записи.

Путем помещения поля в основной документ указывается, какая категория данных, например имя или адрес, должна отображаться в этом месте.

Поля, вставленные в документ Word

При вставке поля слияния в основной документ имя поля всегда заключается в угловые кавычки (« »). Эти угловые кавычки не отображаются в документах, полученных в результате — они используются только для того, чтобы поля в основном документе отличались от обычного текста.

Что происходит при слиянии

При слиянии данные из первой строки файла данных замещают поля в основном документе, создавая первый объединенный документ. Данные из второй строки файла данных замещают поля, создавая второй документ, и т. д.

Слияние данных из файла данных с документом

Работа с полями: примеры

Любой заголовок столбца из файла данных можно добавить в основной документ в качестве поля. Эта возможность обеспечивает гибкость при создании документов на бланке, наклеек, электронных сообщений и других объединенных документов. Например:

  • Допустим, вы создаете письмо, оповещающее местные предприятия о том, что они будут включены в ежегодный справочник. Если файл данных содержит столбец "Организация" с названием каждого предприятия, в документ можно вставить поле "Организация", а не вводить названия по отдельности.

  • Рассмотрим случай, когда заказчикам ежеквартально рассылаются уведомления о новых товарах и скидках. Чтобы персонализировать эти сообщения для самых ценных заказчиков, в файл данных можно добавить столбец "ЛичнаяЗаметка" для примечаний типа "Госпожа Покровская, мы создали новое приложение, именно такое, как вы просили". Поместив поле "ЛичнаяЗаметка" в основной документ, можно включать такие примечания в нижнюю часть отдельных сообщений.

  • Предположим, что список рассылки содержит подписчиков бюллетеня, а в файле данных есть столбец "ДатаИстеченияСрока", предназначенный для хранения дат окончания подписки. Если поместить поле "ДатаИстеченияСрока" в основной документ наклеек перед началом слияния, каждый подписчик увидит на наклейке дату окончания действия своей подписки.

Вы можете объединять поля и отделять их знаками препинания. Например, чтобы создать адрес, можно настроить поля в основном документе следующим образом:

"Имя" "Фамилия"

"Адрес"

"Город", "Страна или регион", "Почтовый индекс"

Для часто используемых элементов, таких как блоки адреса и строки приветствия, в Word предусмотрены составные поля, в которых группируются несколько отдельных полей. Например:

  • Поле "Блок адреса" — это сочетание таких полей, как "Имя", "Фамилия", "Адрес", "Город" и "Индекс".

    Элементы поля ''Блок адреса''

  • Поле "Строка приветствия" может содержать одно или несколько полей имен в зависимости от формы приветствия.

Содержимое каждого из этих составных полей можно настроить. Например, при составлении адреса можно использовать формальный формат имени ("Г-н Глеб Селезнев"), а в приветствии можно опустить слово "Уважаемый".

Вернуться в раздел "Советы и дополнительные инструкции"

Ввод нового списка

  1. В диалоговом окне Создание списка адресов введите данные первого адреса (записи), который вы хотите включить в слияние.

    Чтобы добавить или удалить столбцы, нажмите кнопку Настройка столбцов и внесите нужные изменения.

  2. После ввода всех данных для первой записи нажмите кнопку Создать запись и введите сведения для следующей записи. Повторяйте это действие до тех пор, пока не будут введены сведения для всех записей, которые требуется включить.

  3. Завершив создание списка, нажмите кнопку ОК.

  4. В диалоговом окне Сохранение списка адресов введите имя для списка и нажмите кнопку Сохранить.

Вернуться в раздел "Советы и дополнительные инструкции"

Поделиться Facebook Facebook Twitter Twitter Электронная почта Электронная почта

Были ли сведения полезными?

Отлично! Что-то еще?

Что мы могли бы улучшить?

Спасибо за ваш отзыв!

×