Создание и изменение CSV-файлов для импорта в Outlook

Создание и изменение CSV-файлов для импорта в Outlook

CSV-файл содержит значения, разделенные запятыми. Сохранение текста и чисел в CSV-файле позволяет легко переносить их из одной программы в другую. Например, вы можете экспортировать контакты из Google в формате CSV, а затем импортировать их в Outlook.

CSV-файлы можно использовать в Excel и других редакторах электронных таблиц. Они отличаются от других типов файлов электронных таблиц тем, что в них невозможно сохранять форматирование и формулы.

Скачивание и открытие образца CSV-файла для импорта контактов в Outlook

  1. Скачайте этот образец CSV-файла на свой компьютер. При появлении запроса нажмите кнопку Сохранить и сохраните файл на своем компьютере в формате CSV. Если сохранить файл в формате Excel (XLS или XLSM) все данные будет добавлены в один столбец.

    После скачивания образца CSV-файла сохраните его на своем компьютере с типом CSV.

  2. Откройте Excel на компьютере.

  3. В Excel выберите Файл > Открыть и перейдите к CSV-файлу, скачанному на компьютер. Чтобы найти CSV-файл, выберите Все файлы. Щелкните CSV-файл, чтобы открыть его.

    Чтобы найти CSV-файл, выберите "Все файлы".

При работе с этим CSV-файлом нужно помнить о нескольких вещах.

  • В Outlook в первой строке должны находиться заголовки столбцов, поэтому не заменяйте их другими данными.

    Образец CSV-файла, открытый в Excel

  • Вы можете удалить данные из строк 2–6 (например, имена, телефонные номера, адреса электронной почты и т. д).

  • Вводить данные во всех столбцах необязательно. Укажите только необходимые сведения.

  • Сохраните файл в формате CSV под другим именем. Если вы работаете с этим файлом в Excel, то при его сохранении получите несколько запросов такого типа: "Вы действительно хотите сохранить файл в формате CSV?" Всегда выбирайте ответ "Да". Если вы нажмете "Нет", файл будет испорчен и вам придется снова начинать с пустого шаблона.

  • Попробуйте импортировать CSV-файл с несколькими контактами, чтобы убедиться в получении правильных результатов. После этого можно удалить импортированные контакты, добавить все нужные контакты в CSV-файл и снова импортировать его.

    Если импортировать данные из образца CSV-файла, вот как это будет выглядеть в Office 365 (Outlook в Интернете):

    После импорта контактов они выглядят в Outlook в Интернете примерно так.

Изменение CSV-файла с контактами, которые нужно импортировать в Outlook

Предположим, вы хотите изменить CSV-файл, экспортированный из Outlook, а затем снова импортировать его в это приложение или другую почтовую службу. Вы можете легко сделать это с помощью Excel.

При изменении CSV-файла учитывайте перечисленные ниже моменты.

  • Заголовки столбцов должны оставаться в первой строке.

  • При сохранении CSV-файла в Excel несколько раз появятся запросы такого типа: "Вы действительно хотите сохранить файл в формате CSV?" Всегда выбирайте ответ "Да". Если нажать кнопку "Нет", файл будет испорчен и вам придется начинать с начала.

Проблема: все данные выводятся в первом столбце

Пример CSV-файла, сохраненного в формате XLS.

Это могло произойти по нескольким причинам, поэтому можно попробовать несколько решений.

  • Если вы сохраните CSV-файл в другом формате, например XLS или XLM, все данные будут отображаться в первом столбце. Вернитесь к исходному файлу CSV-файлу и сохраните его как CSV.

  • Возможно, программа, в которой был создан CSV-файл, добавляет к данным дополнительные кавычки, из-за чего Excel считает их одной строкой. Предположим, например, что у вас такие данные:

    a, b, c, d — Excel поместит каждую букву в отдельный столбец.

    "a, b, c, d", e — Excel поместит a, b, c, d в один столбец, а e — в другой.

    Чтобы проверить, не в этом ли проблема, откройте файл в Блокноте: Щелкните CSV-файл правой кнопкой мыши, выберите Открыть с помощью > Блокнот. Выполните поиск дополнительных кавычек.

    Если они есть, вот как можно исправить файл:

    1. Откройте CSV-файл в Excel. Все данные будут добавлены в столбец A, а кавычки будут потеряны.

    2. Используйте мастер распределения текста по столбцам, чтобы разделить данные в столбце A на столбцы: в строке меню выберите Данные > Текст по столбцам.

      Щелкните "Данные" > "Текст по столбцам".

    3. Выберите С разделителями > Далее. Выберите запятая > Готово.

    4. Сохраните файл в формате CVS, чтобы можно было импортировать его в Outlook.

См. также

Импорт контактов в Outlook

Экспорт контактов из Outlook

Совершенствование навыков
Перейти к обучению
Первоочередный доступ к новым возможностям
Присоединиться к программе предварительной оценки Office

Были ли сведения полезными?

Спасибо за ваш отзыв!

Благодарим за отзыв! Возможно, будет полезно связать вас с одним из наших специалистов службы поддержки Office.

×