Создание и запуск макроса

В Word можно автоматизировать часто выполняемые задачи с помощью макросов. Макрос — это набор команд и инструкций, группируемых вместе в виде единой команды для автоматического выполнения задачи.

Чтобы сэкономить время при выполнении часто повторяющихся задач, объедините несколько действий в макрос. Сначала необходимо записать макрос. Затем вы сможете запускать его нажатием кнопки на панели быстрого доступа или с помощью сочетания клавиш. Способ запуска зависит от того, как вы настроите макрос.

  1. В меню Вид последовательно выберите пункты Макросы и Записать макрос.

    Запись макрокоманды

  2. Введите имя макроса.

    Поле имени макроса

  3. Чтобы использовать этот макрос во всех новых документах, проверьте, что в поле Сохранить изменения в указано значение Всех документов (Normal.dotm).

    Поле для выбора места сохранения макроса

  4. Чтобы запускать макрос нажатием кнопки, выберите пункт Кнопка.

    Выберите этот пункт, чтобы назначить макрос кнопке

  5. Щелкните новый макрос (у него будет имя примерно следующего вида: Normal.NewMacros.<имя вашего макроса>), а затем нажмите кнопку Добавить.

    Макрос и кнопка "Добавить"

  6. Нажмите кнопку Изменить.

    Кнопка "Изменить" в окне "Настройка панели быстрого доступа"

  7. Выберите изображение для кнопки, введите нужное имя и дважды нажмите OK.

    Параметры кнопок в окне "Изменение кнопки"

  8. Теперь необходимо записать все шаги макроса. Выбирайте команды или нажимайте клавиши для каждого шага задачи. Word будет записывать все, что вы щелкаете мышью, и все клавиши, которые вы нажимаете.

    Примечание : Во время записи макроса для выделения текста используйте клавиатуру. Макрос не записывает выделения, сделанные с помощью мыши.

  9. Чтобы остановить запись, в меню Вид последовательно выберите пункты Макросы и Остановить запись.

    Команда "Остановить запись"

На панели быстрого доступа появится кнопка для вашего макроса.

Кнопка макроса на панели быстрого запуска

Чтобы запустить макрос, нажмите эту кнопку.

  1. В меню Вид последовательно выберите пункты Макросы и Записать макрос.

    Запись макрокоманды

  2. Введите имя макроса.

    Поле имени макроса

  3. Чтобы использовать этот макрос во всех новых документах, проверьте, что в поле Сохранить изменения в указано значение Всех документов (Normal.dotm).

    Поле для выбора места сохранения макроса

  4. Чтобы запускать макрос с помощью сочетания клавиш, выберите пункт Клавиатура.

    Выберите этот пункт, чтобы назначить макрос сочетанию клавиш на клавиатуре

  5. Введите сочетание клавиш в поле Новое сочетание клавиш.

  6. Проверьте, не назначено ли такое же сочетание клавиш какой-либо другой команде. Если такое сочетание клавиш назначено какой-либо другой команде, то попробуйте использовать другое сочетание клавиш.

  7. Чтобы использовать этот макрос во всех новых документах, проверьте, что в поле Сохранить в указано значение Normal.dotm.

  8. Нажмите кнопку Назначить.

  9. Теперь необходимо записать все шаги макроса. Выбирайте команды или нажимайте клавиши для каждого шага задачи. Word будет записывать все, что вы щелкаете мышью, и все клавиши, которые вы нажимаете.

    Примечание : Во время записи макроса для выделения текста используйте клавиатуру. Макрос не записывает выделения, сделанные с помощью мыши.

  10. Чтобы остановить запись, в меню Вид последовательно выберите пункты Макросы и Остановить запись.

    Команда "Остановить запись"

Чтобы запустить макрос, нажмите сочетание клавиш.

Чтобы запустить макрос, нажмите кнопку на панели быстрого доступа, нажмите сочетание клавиш или запустите макрос из списка Макросы.

  1. В меню Вид последовательно выберите пункты Макросы и Просмотр макросов.

    Команда "Просмотр макросов"

  2. В пункте Имя макроса выберите в списке макрос, который вы хотите запустить.

  3. Нажмите кнопку Запустить.

Чтобы сделать макрос в одном документе доступным во всех новых документах, добавьте его в шаблон Normal.dotm.

  1. Откройте документ, в котором содержится макрос.

  2. В меню Вид последовательно выберите пункты Макросы и Просмотр макросов.

    Команда "Просмотр макросов"

  3. Нажмите кнопку Организатор.

    Копка "Организатор" в поле "Просмотр макросов"

  4. Щелкните макрос, который вы хотите добавить в шаблон Normal.dotm, а затем нажмите кнопку Копировать.

  1. В меню Файл последовательно выберите пункты Параметры и Настроить ленту.

  2. В пункте Выбрать команды из выберите пункт Макросы.

  3. Выберите нужный макрос.

  4. В пункте Настройка ленты выберите вкладку и настраиваемую группу, в которую вы хотите добавить макрос.

Если у вас нет настраиваемой группы, то нажмите кнопку Новая группа. Затем нажмите кнопку Переименовать и введите имя настраиваемой группы.

  1. Нажмите кнопку Добавить.

  2. Чтобы изменить изображение для макроса и ввести нужное имя, нажмите кнопку Переименовать.

  3. Дважды нажмите кнопку OK.

  1. На вкладке Разработчик в группе Код нажмите кнопку Макросы.

  2. В поле Имя макроса введите имя нового макроса.

    Примечание : Если новому макросу присвоить то же самое имя, что и макросу, встроенному в Word, новые макрокоманды будут выполняться вместо встроенных. Чтобы просмотреть список встроенных макросов, выберите пункт Команды Word в списке Макросы из.

  3. В списке Макросы из щелкните шаблон или документ, в котором нужно сохранить макрос.

    Чтобы макрос был доступен во всех документах, выберите Normal.dotm.

  4. Нажмите кнопку Создать, чтобы вызвать редактор Visual Basic.

После запуска редактора Visual Basic могут потребоваться дополнительные сведения о работе с языком Visual Basic для приложений. Для получения сведений выберите в меню Help (Справка) пункт Microsoft Visual Basic Help (Справка по Microsoft Visual Basic) или нажмите клавишу F1.

Вы можете записать последовательность действий или создать макрос с нуля, введя код на языке Visual Basic для приложений в редактор Visual Basic.

Примечание : Чтобы работать с макросами в приложении Office Word 2007, необходимо отобразить вкладку Разработчик.

  1. Нажмите кнопку Microsoft Office  Изображение кнопки Office и выберите пункт Параметры Word.

  2. Выберите категорию Основные.

  3. В группе Основные параметры работы с Word установите флажок Показывать вкладку "Разработчик" на ленте.

    Примечание : Лента входит в Пользовательский интерфейс Microsoft Office Fluent.

  1. На вкладке Разработчик в группе Код нажмите кнопку Запись макроса.

    Группа "Код" на вкладке "Разработчик"
  2. В поле Имя макроса введите имя нового макроса.

    Примечание : Если новому макросу присвоить то же самое имя, что и макросу, встроенному в Office Word 2007, новые макрокоманды будут выполняться вместо встроенных. Чтобы просмотреть список встроенных макросов, на вкладке Разработчик в группе Код нажмите кнопку Макросы. В списке Макросы из выберите вариант Команды Word.

  3. В списке Макрос доступен для щелкните шаблон или документ, в котором нужно сохранить макрос.

    Важно : Чтобы макрос был доступен во всех документах, выберите Normal.dotm.

  4. Введите описание макроса в поле Описание.

  5. Выполните одно из указанных ниже действий.

    • Начните запись.    Чтобы начать запись макроса, не связывая его с кнопкой на панели быстрого доступа или сочетанием клавиш, нажмите кнопку ОК.

    • Создайте кнопку.    Чтобы связать макрос с кнопкой на панели быстрого доступа, сделайте следующее:

      1. Щелкните кнопке.

      2. В группе Настройка панели быстрого доступа выберите документ или все документы, для которых требуется добавить макрос на панель быстрого доступа.

        Важно : Чтобы макрос был доступен во всех документах, выберите Normal.dotm.

      3. В диалоговом окне Выбрать команды из выберите макрос, который требуется записать, и нажмите кнопку Добавить.

      4. Чтобы настроить кнопку, нажмите кнопку Изменить.

      5. В поле Символ выберите нужный символ для кнопки.

      6. В поле Отображаемое имя введите имя макроса, которое должно отображаться.

      7. Чтобы начать запись макроса, нажмите кнопку ОК два раза.

        На панели быстрого доступа будет показан выбранный символ. Заданное имя отображается при наведении указателя на символ.

    • Назначьте сочетание клавиш.    Чтобы назначить макросу сочетание клавиш, сделайте следующее:

      1. Выберите пункт Клавиатура.

      2. В списке Команды выберите макрос, который требуется записать.

      3. В поле Новое сочетание клавиш введите любую последовательность клавиш и нажмите кнопку Назначить.

      4. Чтобы начать запись макроса, нажмите кнопку Закрыть.

  6. Выполните действия, которые следует включить в макрос.

    Примечание : При записи макроса вы можете с помощью мыши щелкать команды и параметры, но не выделять текст. Для выделения текста необходимо использовать клавиатуру. Дополнительные сведения о выделении текста с помощью клавиатуры см. в статье Выделение текста.

  7. Чтобы остановить запись макрокоманд, выберите команду Остановить запись в группе Код.

Изменение сочетания клавиш для макроса

  1. Нажмите кнопку Microsoft Office Изображение кнопки Office , а затем — Параметры Word.

  2. Выберите команду Настройка .

  3. Рядом с полем Сочетания клавиш нажмите Настройка.

  4. В списке Категории выберите пункт Макросы.

  5. В списке Макросы выберите макрос, который нужно изменить.

  6. Щелкните поле Новое сочетание клавиш и нажмите клавиши, которые следует назначить.

  7. В поле Текущие сочетания проверьте, не используется ли назначаемое сочетание для выполнения другой задачи.

  8. В списке Сохранить изменения в выберите вариант, который соответствует месту, в котором должен запускаться макрос.

    Важно : Чтобы макрос был доступен во всех документах, выберите Normal.dotm.

  9. Нажмите кнопку Закрыть.

  1. На вкладке Разработчик в группе Код выберите пункт Макросы.

    Группа "Код" на вкладке "Разработчик"

  2. В списке Имя макроса выберите макрос, который необходимо запустить.

  3. Нажмите кнопку Выполнить.

  1. На вкладке Разработчик в группе Код нажмите кнопку Макросы.

    Группа "Код" на вкладке "Разработчик"

  2. В поле Имя макроса введите имя нового макроса.

    Примечание : Если новому макросу присвоить то же самое имя, что и макросу, встроенному в Office Word 2007, новые макрокоманды будут выполняться вместо встроенных. Чтобы просмотреть список встроенных макросов, выберите пункт Команды Word в списке Макросы из.

  3. В списке Макросы из щелкните шаблон или документ, в котором нужно сохранить макрос.

    Чтобы макрос был доступен во всех документах, выберите Normal.dotm.

  4. Нажмите кнопку Создать, чтобы вызвать редактор Visual Basic.

После запуска редактора Visual Basic могут потребоваться дополнительные сведения о работе с языком Visual Basic для приложений. Для получения сведений выберите в меню Help (Справка) пункт Microsoft Visual Basic Help (Справка по Microsoft Visual Basic) или нажмите клавишу F1.

Совершенствование навыков
Перейти к обучению
Первоочередный доступ к новым возможностям
Присоединиться к программе предварительной оценки Office

Были ли сведения полезными?

Спасибо за ваш отзыв!

Благодарим за отзыв! Возможно, будет полезно связать вас с одним из наших специалистов службы поддержки Office.

×