Создание гистограммы в Excel

Важно :  Данная статья переведена с помощью машинного перевода, см. Отказ от ответственности. Используйте английский вариант этой статьи, который находится здесь, в качестве справочного материала.

Гистограмма или диаграмма Парето (Отсортированная гистограмма) — это Столбчатая диаграмма, которая показывает частоту повторяемости значений.

  1. Убедитесь, что загрузки пакета анализа. Дополнительные сведения читайте в статье загрузки пакета анализа в Excel.

  2. В один столбец на листе введите исходные данные. При необходимости добавьте в первую ячейку подпись.

    Используйте количественные числовые данные, например, количество элементов или результаты тестов. Мастер гистограмм не будет работать с такими количественными числовыми данными, как идентификационные номера, введенные в виде текста.

  3. В следующий столбец введите интервалы в возрастающем порядке. При необходимости добавьте в первую ячейку подпись.

    Используйте собственные интервалы, поскольку они могут лучше соответствовать целям вашего анализа. Если вы не введете их, мастер гистограмм создаст равномерно распределенные интервалы, используя минимальное и максимальное значение во введенном диапазоне в качестве начальной и конечной точек.

  4. Откройте вкладку Данные и выберите команду Анализ данных.

    Кнопка «Анализ данных» в группе «Анализ»

  5. Выберите пункт Гистограмма и нажмите кнопку OK.

    Диалоговое окно «Анализ данных»

  6. В разделе Ввод выполните указанные ниже действия:

    1. В поле Формировать список по диапазону введите ссылку на ячейку с диапазоном данных, который содержит исходные числа.

    2. В поле Интервал карманов введите ссылку на ячейку с диапазоном, который содержит числа интервала.

      Если на листе использовались подписи столбцов, можно включать их в ссылки на ячейки.

      Совет :  Вместо того, чтобы вводить ссылки вручную,можно нажать кнопку Кнопка "Свернуть" , чтобы временно свернуть диалоговое окно для выбора диапазонов на листе. При повторном нажатии этой кнопки диалоговое окно опять разворачивается.

  7. Если подписи столбцов были включены в ссылки на ячейки, установите флажок Подписи.

  8. В группе Параметры вывода выберите местоположение выходных данных.

    Гистограмму можно расположить на том же листе, новом листе в текущей книге или в новой книге.

  9. Установите один или несколько флажков:

    Парето (отсортированная гистограмма). Отображает частоту данных по убыванию.

    Суммарный процент    . Отображает суммарные проценты и добавляет в гистограмму строку суммарных процентов.

    Вывод диаграммы    . Отображает встроенную гистограмму.

  10. Нажмите кнопку ОК.

    Если вы хотите настроить гистограмму, можно изменить подписи и, щелкнув в любом месте гистограммы, использовать кнопки Элементы диаграммы, Стили диаграммы и Фильтры диаграммы справа от диаграммы.

  1. Выделите данные.

    (Это типичный пример данных для гистограммы).

    Данные, использованные для создания образца гистограммы выше
  2. Выберите Вставка > Вставить диаграмму статистики > Гистограмма.

    Команда "Гистограмма", отображающаяся при нажатии кнопки "Вставка статистической диаграммы"

    Гистограмму также можно создать с помощью вкладки Все диаграммы в разделе Рекомендуемые диаграммы.

Советы : 

  • На вкладках Конструктор и Формат можно настроить внешний вид диаграммы.

  • Если они не отображаются, щелкните в любом месте гистограммы, чтобы добавить на ленту область Работа с диаграммами.

Вкладки "Конструктор" и "Формат" в разделе "Работа с диаграммами"

  1. Правой кнопкой мыши щелкните горизонтальную ось диаграммы, выберите Формат оси, а затем щелкните Параметры оси.

    Команда "Формат оси" в контекстном меню
  2. Руководствуясь приведенной ниже таблицей, вы сможете выбрать параметры, которые нужно задать в области задач Формат оси.

    Параметр

    Описание

    По категориям

    Выберите этот вариант, если категории (горизонтальная ось) текстовые, а не числовые. На гистограмме одинаковые категории будут сгруппированы, а значения на оси значений — просуммированы.

    Совет : Чтобы подсчитать количество появлений текстовых строк, добавьте столбец и укажите в нем значение "1", а затем отобразите гистограмму и выберите параметр По категориям.

    Автоматическая

    Это вариант по умолчанию для гистограмм. Длина интервала вычисляется по формуле Скотта.

    Длина интервала

    Введите положительное десятичное число, задающее количество точек данных в каждом диапазоне.

    Количество интервалов

    Введите количество интервалов гистограммы (включая интервалы для значений, выходящих за верхнюю и нижнюю границы).

    Выход за верхнюю границу интервала

    Установите этот флажок, чтобы создать интервал для всех значений, превышающих значение в поле справа. Чтобы изменить его, введите в поле другое десятичное число.

    Выход за нижнюю границу интервала

    Установите этот флажок, чтобы создать интервал для всех значений, не превышающих значение в поле справа. Чтобы изменить его, введите в поле другое десятичное число.

    Область задач "Формат оси"

Совет : Дополнительные сведения о гистограммах и их пользе для визуализации статистических данных см. в этой записи о гисторамме, диаграммах Парето и "ящик с усами" блога группы разработчиков Excel. Дополнительные сведения о других новых типах диаграмм приведены в этой записи блога.

Вариант "Автоматическая" (формула Скотта)   

Формула для параметра "Автоматически"

Формула Скотта минимизирует отклонение вариационного ряда на гистограмме по сравнению с набором данных, исходя из предположения о нормальном распределении данных.

Вариант "Выход за верхнюю границу интервала"   

Формула для параметра ячейки "Переполнение"

Вариант "Выход за нижнюю границу интервала"   

Формула для параметра ячейки "Потеря значимости"

  1. Выделите данные.

    (Это типичный пример данных для гистограммы).

    Данные, использованные для создания образца гистограммы выше
  2. На вкладке Вставка нажмите кнопку Диаграмма.

    Кнопка "Диаграмма" в группе "Иллюстрации"на вкладке "Вставка" в Word
  3. В диалоговом окне Вставка диаграммы в разделе Все диаграммы выберите пункт Гистограмма и нажмите кнопку ОК.

Советы : 

  • Используйте вкладки Конструктор и Формат на ленте, чтобы настроить внешний вид диаграммы.

  • Если они не отображаются, щелкните в любом месте гистограммы, чтобы добавить на ленту область Работа с диаграммами.

Вкладки "Конструктор" и "Формат" в разделе "Работа с диаграммами"

  1. Правой кнопкой мыши щелкните горизонтальную ось диаграммы, выберите Формат оси, а затем щелкните Параметры оси.

    Команда "Формат оси" в контекстном меню
  2. Руководствуясь приведенной ниже таблицей, вы сможете выбрать параметры, которые нужно задать в области задач Формат оси.

    Параметр

    Описание

    По категориям

    Выберите этот вариант, если категории (горизонтальная ось) текстовые, а не числовые. На гистограмме одинаковые категории будут сгруппированы, а значения на оси значений — просуммированы.

    Совет : Чтобы подсчитать количество появлений текстовых строк, добавьте столбец и укажите в нем значение "1", а затем отобразите гистограмму и выберите параметр По категориям.

    Автоматическая

    Это значение по умолчанию для гистограмм.

    Длина интервала

    Введите положительное десятичное число, задающее количество точек данных в каждом диапазоне.

    Количество интервалов

    Введите количество интервалов гистограммы (включая интервалы для значений, выходящих за верхнюю и нижнюю границы).

    Выход за верхнюю границу интервала

    Установите этот флажок, чтобы создать интервал для всех значений, превышающих значение в поле справа. Чтобы изменить его, введите в поле другое десятичное число.

    Выход за нижнюю границу интервала

    Установите этот флажок, чтобы создать интервал для всех значений, не превышающих значение в поле справа. Чтобы изменить его, введите в поле другое десятичное число.

    Область задач "Формат оси"

Совет : Дополнительные сведения о гистограммах и их пользе для визуализации статистических данных см. в этой записи о гисторамме, диаграммах Парето и "ящик с усами" блога группы разработчиков Excel. Дополнительные сведения о других новых типах диаграмм приведены в этой записи блога.

Примечание : Не удается создать гистограмму в Excel для Mac 2011, как пакет анализа не поддерживается для этой версии.

Выполните следующие действия для создания гистограммы в Excel 2016 для Mac:

  1. Убедитесь, что загрузки пакета анализа. Дополнительные сведения читайте в статье загрузки пакета анализа в Excel.

  2. На листе введите входные данные в одном столбце, добавляя при необходимости название в первой ячейке. Используйте количественные числовые данные, например количество элементов или результаты тестов. Мастер гистограмм не будет работать с такими количественными числовыми данными, как идентификационные номера, введенные в виде текста.

  3. В следующем столбце введите интервалы в возрастающем порядке. При необходимости добавьте название в первой ячейке. Если вы не знаете, что ввести в качестве интервалов, взгляните данные и попробуйте определить естественные интервалы. На основе этих интервалов мастер гистограмм отобразит ваши данные.

    Используйте собственные интервалы, поскольку они могут лучше соответствовать целям вашего анализа. Если вы не введете их, мастер гистограмм создаст равномерно распределенные интервалы, используя минимальное и максимальное значение во введенном диапазоне в качестве начальной и конечной точек.

    Вот пример двух столбцов, которые можно использовать для гистограммы:

    Пример двух столбцов

  4. На вкладке Данные выберите элемент Анализ данных.

    Кнопка "Анализ данных"

  5. Выберите элемент Гистограмма и нажмите кнопку OK.

  6. В разделе Ввод выполните указанные ниже действия.

    1. Щелкните в поле Формировать список по диапазону и выберите ячейки в первом столбце данных.

    2. Щелкните в поле Интервал карманов и выберите ячейки во втором столбце данных.

      Если на листе использовались подписи столбцов, можно включать их в ссылки на ячейки.

      Совет : Можно также нажать кнопку Кнопка "Свернуть" , чтобы временно свернуть диалоговое окно и выбрать диапазоны на листе. При повторном нажатии кнопки диалоговое окно снова разворачивается.

  7. Если названия столбцов были включены в ссылки на ячейки, установите флажок Подписи.

  8. В разделе Параметры вывода укажите расположение гистограммы.

    • Чтобы поместить гистограмму на тот же лист, выберите элемент Диапазон вывода, а затем щелкните в поле Диапазон вывода. Щелкните на листе, на который нужно поместить гистограмму.

    • Чтобы поместить гистограмму на новый лист, выберите Новый лист.

    • Чтобы поместить гистограмму в новую книгу, выберите Новая книга.

  9. Установите один или несколько флажков:

    • Парето (отсортированная гистограмма). Отображает частоту данных по убыванию.

    • Суммарный процент    . Отображает суммарные проценты и добавляет в гистограмму строку суммарных процентов.

    • Вывод диаграммы    . Отображает встроенную гистограмму.

  10. Нажмите кнопку ОК.

В Excel Online можно просмотреть гистограмму (столбчатую диаграмму, которая позволяет сравнить повторяющиеся данные), но нельзя ее создать, поскольку для этого нужен пакет анализа (надстройка для классического приложения Excel), который не поддерживается в Excel Online.

Если у вас есть классическое приложение Excel, можно с помощью кнопки Открыть в Excel откройте Excel на рабочий стол и Создайте гистограмму.

Кнопка "Открыть в Excel"

  1. Коснитесь, чтобы выбрать данные.

    Данные, использованные для создания образца гистограммы выше
  2. Если на телефоне, коснитесь значка изменить Значок ''Изменить'' чтобы отобразить ленту. и выберите вкладку Главная.

  3. Выберите Вставка > диаграммы > Гистограмма.

    При необходимости вы можете настроить элементы диаграммы.

    Примечание : Эта функция доступна только при наличии подписки на Office 365. Если у вас есть подписка на Office 365, убедитесь, что у вас установлена последняя версия Office.

    Попробуйте поработать с Office 365 или последней версией Excel

  1. Коснитесь, чтобы выбрать данные.

    Данные, использованные для создания образца гистограммы выше
  2. Если у вас на телефоне, коснитесь значка изменить Значок ''Изменить'' чтобы отобразить ленту и выберите вкладку Главная.

  3. Выберите Вставка > диаграммы > Гистограмма.

Чтобы создать гистограмму в Excel, предоставляют два типа данных — данные, которые требуется проанализировать и количеством интервалов, представляющих интервалы, на которые вы хотите измерить частоту. Необходимо организовать данные в двух столбцов на листе. Эти столбцы должны содержать следующие данные:

  • Ввод данных    Это данные, которые требуется проанализировать с помощью инструмента гистограмма.

  • Количеством интервалов    Эти значения представляют чисел, которые интервалов гистограммы средство для оценки ввода данных при анализе данных.

При использовании инструмента гистограмму Excel подсчитывает количество точек данных в каждой ячейке данных. Точки данных включается в конкретной ячейке, если число больше, чем наименьшего привязан и равно или меньше, чем наибольшее присоединенной для данных ячейки. Если опустить интервал карманов Excel создает набор равномерно распределенные интервалов между минимальные и максимальные значения входных данных.

Результаты анализа Гистограмма отображается на новый лист (или в новой книге) и отображается гистограмма, который отражает данные в таблице гистограммы и таблица гистограммы.

Дополнительные сведения

Вы всегда можете задать вопрос специалисту Excel Tech Community, попросить помощи в сообществе Answers community, а также предложить новую функцию или улучшение на веб-сайте Excel User Voice.

Примечание : Отказ от ответственности относительно машинного перевода. Данная статья была переведена с помощью компьютерной системы без участия человека. Microsoft предлагает эти машинные переводы, чтобы помочь пользователям, которые не знают английского языка, ознакомиться с материалами о продуктах, услугах и технологиях Microsoft. Поскольку статья была переведена с использованием машинного перевода, она может содержать лексические,синтаксические и грамматические ошибки.

Совершенствование навыков
Перейти к обучению
Первоочередный доступ к новым возможностям
Присоединиться к программе предварительной оценки Office

Были ли сведения полезными?

Спасибо за ваш отзыв!

Благодарим за отзыв! Возможно, будет полезно связать вас с одним из наших специалистов службы поддержки Office.

×