Создание внешней ссылки на диапазон ячеек в другой книге

В приложении Excel можно ссылаться на содержимое ячеек другой рабочей книги, создавая внешнюю ссылку. Внешняя ссылка — это ссылка на ячейку или на диапазон ячеек в другой книге Excel либо ссылка на определенное имя в другой книге. Можно указывать ссылки на определенный диапазон ячеек, на определенное имя диапазона ячеек или определять имя для внешней ссылки.

В этой статье

Дополнительные сведения о внешних ссылках

Создание внешней ссылки на ячейки в другой книге

Внешняя ссылка на определенное имя в другой книге

Определение имени, которое содержит ссылку на ячейки в другой книге

Дополнительные сведения о внешних ссылках

Хотя внешние ссылки подобны ссылкам на ячейки, между ними есть важные различия. Внешние ссылки применяются при работе с большими объемами данных или со сложными формулами в нескольких книгах. Они создаются другим способом и по-другому отображаются в ячейке или в строке формул.

Эффективное использование внешних ссылок

Применение внешних ссылок особенно эффективно, если нецелесообразно совместно хранить модели больших рабочих листов в одной книге.

  • Слияние данных нескольких книг   .   С помощью связывания книг отдельных пользователей или коллективов распределенные данные можно интегрировать в одну итоговую книгу. Исходные книги по-прежнему могут изменяться независимо от итоговой книги.

  • Создание различных представлений одних и тех же данных   . Все данные и формулы можно ввести в одну книгу или в несколько книг, а затем создать книгу отчетов, содержащую ссылки только на требуемые данные.

  • Последовательная разработка больших и сложных моделей обработки данных   .   Если разделить сложную модель обработки данных на последовательность взаимосвязанных книг, можно работать с отдельными частями модели без открытия всех составляющих модель книг. При работе с небольшими книгами легче вносить изменения, открывать и сохранять файлы, выполнять пересчет листов; при этом размер памяти, запрашиваемой у компьютера для выполнения указанных действий, может быть незначительным.

Способы создания внешних ссылок

Если для создания внешней ссылки используется ссылка на ячейку, к данным можно применять формулы. Изменяя тип ссылок на ячейки, можно управлять тем, на какие ячейки будет указывать внешняя ссылка при ее перемещении. Например, если используются относительные ссылки, то при перемещении внешней ссылки ячейки, на которые она указывает, изменятся в соответствии с ее новым положением на листе.

При создании внешней ссылки из одной книги на другую необходимо использовать имя для ссылки на ячейки, с которыми создается связь. Можно создать внешнюю ссылку, используя уже определенное имя, или определить имя при создании ссылки. Использование имени упрощает запоминание содержимого тех ячеек, с которыми создается связь. Внешние ссылки, использующие определенное имя, не изменяются при перемещении, поскольку имя ссылается на конкретную ячейку (диапазон ячеек). Если нужно, чтобы внешняя ссылка, использующая определенное имя, изменялась при перемещении, можно изменить имя, используемое в этой внешней ссылке, или ячейки, на которые ссылается имя.

Как выглядит внешняя ссылка на другую книгу

Формулы с внешними ссылками на другие книги отображаются двумя способами в зависимости от того, закрыта или открыта исходная книга (предоставляющая данные для формулы).

Когда книга открыта, внешняя ссылка содержит имя книги в квадратных скобках ([ ]), за которым следует имя листа, восклицательный знак (!) и адреса ячеек, влияющих на формулу. Например, приведенная ниже формула суммирует ячейки C10:C25 из книги, которая называется Budget.xls.

Внешняя ссылка

=СУММ([Budget.xlsx]Годовой!C10:C25)

Когда книга закрыта, внешняя ссылка описывает полный путь.

Внешняя ссылка

=СУММ('C:\Reports\[Budget.xlsx]Годовой'!C10:C25)

Примечание : Если имя листа или книги содержит знаки, не являющиеся буквами, необходимо заключать имя (или путь) в апострофы.

Формулы, связанные с определенным имя в другой книге, используют имя книги, за которым следует восклицательный знак (!) и имя. Например приведенная ниже формула суммирует ячейки из диапазона "Продажи" книги, которая называется Budget.xlsx.

Внешняя ссылка

=СУММ(Budget.xlsx!Продажи)

К началу страницы

Создание внешней ссылки на ячейки в другой книге

  1. Откройте книгу, которая будет содержать внешнюю ссылку (книга назначения), и книгу, содержащую данные, с которыми создается связь (исходная книга).

  2. В исходной книге нажмите кнопку Сохранить Изображение кнопки на панели быстрого доступа.

  3. Выделите одну или несколько ячеек, для которых нужно создать внешнюю ссылку.

  4. Введите = (знак равенства). Если необходимо выполнить вычисления со значением внешней ссылки или применить к нему функцию, введите оператор или функцию, которые должны предшествовать внешней ссылке.

  5. Перейдите к исходной книге, а затем щелкните лист, содержащий ячейки, на которые нужно сослаться.

  6. Выделите ячейку или ячейки, ссылку на которые требуется вставить.

  7. Вернитесь в книгу назначения и обратите внимание на добавленную в нее ссылку на исходную книгу и ячейки, выбранные на предыдущем шаге.

  8. При необходимости отредактируйте или измените формулу в конечной книге.

  9. Нажмите клавиши CTRL+SHIFT+ВВОД.

К началу страницы

Внешняя ссылка на определенное имя в другой книге

  1. Откройте книгу, которая будет содержать внешнюю ссылку (книга назначения), и книгу, содержащую данные, с которыми создается связь (исходная книга).

  2. В исходной книге нажмите кнопку Сохранить Изображение кнопки на панели быстрого доступа.

  3. Выделите одну или несколько ячеек, для которых нужно создать внешнюю ссылку.

  4. Введите = (знак равенства). Если необходимо выполнить вычисления со значением внешней ссылки или применить к нему функцию, введите оператор или функцию, которые должны предшествовать внешней ссылке.

  5. На вкладке Режим в группе Окно нажмите кнопку Переключить окна, выберите исходную книгу, а затем выберите лист, содержащий ячейки, на которые необходимо создать ссылку.

    Группа "Окно" на вкладке "Вид"

  6. Нажмите клавишу F3, а затем выберите имя, на которое нужно сослаться.

К началу страницы

Определение имени, которое содержит ссылку на ячейки в другой книге

  1. Откройте книгу назначения и книгу-источник.

  2. В книге назначения на вкладке Формулы в группе Определенные имена нажмите кнопку Присвоить имя.

    Изображение ленты Excel

  3. В диалоговом окне Создание имени введите имя диапазона в поле Имя.

  4. Удалите содержимое поля Диапазон и оставьте курсор в этом поле.

    Если имя содержит формулу, введите ее и поместите курсор туда, куда нужно вставить внешнюю ссылку. Например, введите =СУММ(), а затем поместите курсор между скобками.

  5. На вкладке Режим в группе Окно нажмите кнопку Переключить окна, выберите исходную книгу, а затем выберите лист, содержащий ячейки, на которые необходимо создать ссылку.

    Группа "Окно" на вкладке "Вид"

  6. Выделите ячейку или диапазон ячеек, на которые нужно сослаться.

  7. В диалоговом окне Создание имени нажмите кнопку ОК.

К началу страницы

Совершенствование навыков
Перейти к обучению
Первоочередный доступ к новым возможностям
Присоединиться к программе предварительной оценки Office

Были ли сведения полезными?

Спасибо за ваш отзыв!

Благодарим за отзыв! Возможно, будет полезно связать вас с одним из наших специалистов службы поддержки Office.

×