Создание блочной диаграммы

Важно :  Данная статья переведена с помощью машинного перевода, см. Отказ от ответственности. Используйте английский вариант этой статьи, который находится здесь, в качестве справочного материала.

Если вы выполняете статистический анализ, вам может потребоваться создать стандартную блочную диаграмму, чтобы показать распределение набора данных. На такой диаграмме числовые данные разделены на квартили, а между первым и третьим квартилем находится прямоугольник с дополнительной линией, проходящей через второй квартиль и обозначающей медиану. На некоторых блочных диаграммах минимальные и максимальные значения, которые выходят за пределы первого и третьего квартилей, представлены в виде линий, которые часто называют усами.

Различные части блочной диаграммы

Хотя в Excel 2013 нет шаблона для блочной диаграммы, вы можете создать ее, выполнив следующие действия:

  1. Рассчитайте значения квартилей на основе исходного набора данных.

  2. Вычислите разницу между квартилями.

  3. Создайте гистограмму с накоплением из диапазонов квартилей.

  4. Преобразуйте гистограмму в блочную диаграмму.

В нашем примере исходный набор источник содержит три столбца. Каждый столбец включает по 30 элементов из следующих диапазонов:

  • Столбец 1 (2013 г.): 100–200

  • Столбец 2 (2014 г.): 120–200

  • Столбец 3 (2015 г.): 100–180

Таблица исходных данных

В этом разделе...

Шаг 1. Вычисление значений квартилей

Прежде всего необходимо рассчитать минимальное, максимальное значение и медиану, а также первый и третий квартили для набора данных.

  1. Для этого создайте вторую таблицу и заполните ее следующими формулами:

    Значение

    Формула

    Минимальное значение

    МИН(диапазон_ячеек)

    Первый квартиль

    КВАРТИЛЬ.ВКЛ (диапазон_ячеек; 1)

    Медиана

    КВАРТИЛЬ.ВКЛ (диапазон_ячеек; 2)

    Третья квартиль

    КВАРТИЛЬ.ВКЛ (диапазон_ячеек; 3)

    Максимальное значение

    МАКС(диапазон_ячеек)

  2. В результате должна получиться таблица, содержащая нужные значения. При использовании примера данных получаются следующие квартили:

    Конечная таблица и значения

К началу страницы

Шаг 2. Вычисление разницы между квартилями

Затем нужно вычислить разницу между каждой парой показателей. Необходимо рассчитать разницу между следующими значениями:

  • первым квартилем и минимальным значением;

  • медианой и первым квартилем;

  • третьим квартилем и медианой;

  • максимальным значением и третьим квартилем.

  1. Для начала создайте третью таблицу и скопируйте в нее минимальные значения из последней таблицы.

  2. Вычислите разницу между квартилями с помощью формулы вычитания Excel (ячейка1 — ячейка2) и заполните третью таблицу значениями разницы.

Для примера данных третья таблица выглядит следующим образом:

К началу страницы

Шаг 3. Создание гистограммы с накоплением

Данные в третьей таблице хорошо подходят для построения блочной диаграммы. Создадим гистограмму с накоплением, а затем изменим ее.

  1. Выделите все данные в третьей таблице и щелкните Вставка > Вставить гистограмму > Гистограмма с накоплением.

    Для начала выберите гистограмму с накоплением.

    Пока диаграмма не похожа на блочную, так как Excel по умолчанию рисует столбцы с накоплением на основе наборов данных по горизонтали, а не по вертикали.

    Диаграмма по умолчанию со столбцами с накоплением
  2. Чтобы поменять местами оси диаграммы, щелкните ее правой кнопкой мыши и выберите Выбор данных.

  3. Щелкните Строка/столбец.

    Советы : 

    • Чтобы переименовать столбцы, в области Подписи горизонтальной оси (категории) щелкните Изменить, выберите в третьей таблице диапазон ячеек с нужными именами категорий и нажмите кнопку ОК. Выделите диапазон ячеек, который нужно переименовать.

    • Для переименования записей легенды в разделе Элементы легенды (ряды) щелкните Изменить и введите нужное значение.

  4. Нажмите кнопку ОК.

График должен выглядеть так, как показано ниже. В этом примере также было изменено название диаграммы, а легенда скрыта.

Теперь ваша диаграмма должна иметь такой вид.

К началу страницы

Шаг 4. Преобразование гистограммы с накоплением в блочную диаграмму

Скрытие нижнего ряда данных

Чтобы преобразовать гистограмму с накоплением в блочную диаграмму, сначала нужно скрыть нижний ряд данных:

  1. Выберите нижнюю часть столбцов.

    Примечание : При щелчке одного из столбцов будут выбраны все вхождения того же ряда.

  2. Щелкните Формат > Текущий фрагмент > Формат выделенного фрагмента. В правой части появится панель Формат.

    Элемент "Формат выделенного" находится на вкладке "Формат".
  3. На вкладке Заливка панели Формат выберите пункт Нет заливки.

    Нижний ряд данных будет скрыт.

    На этой диаграмме данные внизу скрыты.

Создание усов для построения блочной диаграммы

Далее нужно заменить верхний и второй снизу ряды (выделены на рисунки темно-синим и оранжевым) линиями (усами).

  1. Выберите верхний ряд данных.

  2. На вкладке Заливка панели Формат выберите пункт Нет заливки.

  3. На ленте щелкните Конструктор > Добавить элемент диаграммы > Предел погрешностей > Стандартное отклонение.

    Меню "Добавить элемент диаграммы" и "Предел погрешностей"
  4. Выберите один из нарисованных пределов погрешностей.

  5. Откройте вкладку Параметры предела погрешностей и в области Формат задайте следующие параметры:

    • В разделе Направление установите переключатель Минус.

    • Для параметра Конечный стиль задайте значение Без точки.

    • Для параметра Величина погрешности укажите процент, равный 100.

      В области "Величина погрешности" в поле "Процент" должно быть указано значение 100 %.
  6. Повторите предыдущие действия для второго снизу ряда данных.

    Гистограмма с накоплением теперь должна напоминать блочную диаграмму.

    На конечной диаграмме теперь есть "усы".

Закрашивание центральных областей

Блочные диаграммы обычно отображаются с одним цветом заливки и тонкими границами. Ниже описано, как завершить их оформление.

  1. Выберите верхнюю часть блочной диаграммы.

  2. На вкладке Заливка и границы области Формат щелкните Сплошная заливка.

  3. Выберите цвет заливки.

  4. Щелкните Сплошная линия на этой же вкладке.

  5. Выберите цвет контура, а также ширину штриха.

  6. Задайте те же значения для других областей блочной диаграммы.

    В результате должна получиться блочная диаграмма.

    Так должна выглядеть конечная блочная диаграмма.

К началу страницы

Примечание : Отказ от ответственности относительно машинного перевода. Данная статья была переведена с помощью компьютерной системы без участия человека. Microsoft предлагает эти машинные переводы, чтобы помочь пользователям, которые не знают английского языка, ознакомиться с материалами о продуктах, услугах и технологиях Microsoft. Поскольку статья была переведена с использованием машинного перевода, она может содержать лексические,синтаксические и грамматические ошибки.

См. также

Доступные типы диаграмм

Диаграммы и другие элементы представления в Power View

Совершенствование навыков
Перейти к обучению
Первоочередный доступ к новым возможностям
Присоединиться к программе предварительной оценки Office

Были ли сведения полезными?

Спасибо за ваш отзыв!

Благодарим за отзыв! Возможно, будет полезно связать вас с одним из наших специалистов службы поддержки Office.

×