Создание базы данных Access для публикации в Интернете

Access 2010 и службы Access — компонент SharePoint —можно использовать для создания приложений веб-базы данных. Это позволяет:

  • организовать доступ к данным и обеспечить его безопасность;

  • предоставлять общий доступ к корпоративным данным через интрасеть или Интернет.

    Примечание :  Для работы с веб-базой данных необходима учетная запись пользователя. Анонимный доступ не поддерживается.

  • создавать приложения для работы с базами данных, не требующие использования Access.

В этой статье приведены общие сведения о проектировании веб-баз данных Access. Введение в проектирование баз данных для настольных компьютеров см. в статьях Создание базы данных на компьютере и Основные сведения о создании баз данных.

В этом разделе...

Обзор

Создание веб-базы данных

Публикация приложения и синхронизация изменений

Обзор

Access 2010 и службы Access (дополнительный компонент SharePoint) предоставляют платформу для создания баз данных, которые можно использовать в Интернете. Для проектирования и публикации веб-базы данных используется Access 2010 и SharePoint, а пользователи, у которых есть учетная запись SharePoint, работают с ней через веб-браузер.

Принцип действия

При публикации веб-базы данных службы Access создают сайт SharePoint, на котором она размещается. Все объекты и данные базы попадают в списки SharePoint на этом сайте. В видео ниже показан этот процесс.

Браузер не поддерживает видео. Установите Microsoft Silverlight, Adobe Flash Player или Internet Explorer 9.

После публикации посетители SharePoint могут использовать вашу базу данных на основе своих разрешений для сайта SharePoint.

  • Полный доступ   : позволяет вносить изменения в данные и схему базы данных.

  • Участие   : позволяет изменять данные, но не структуру базы данных.

  • Чтение   : позволяет считывать данные без возможности вносить изменения.

Вы можете открыть веб-базу данных в Access, внести изменения в ее структуру, а затем синхронизировать изменения, т. е. фактически сохранить их на сайте SharePoint. В видео ниже показано, как внести изменения в структуру после публикации веб-базы данных.

Браузер не поддерживает видео. Установите Microsoft Silverlight, Adobe Flash Player или Internet Explorer 9.

Вы также можете перевести веб-базу данных в автономный режим, использовать автономную версию и синхронизировать изменения после подключения к сети.

Примечание : Чтобы создать веб-базу данных, необходимо иметь разрешение на полный доступ к сайту SharePoint, где нужно ее опубликовать. Дополнительные сведения о разрешениях SharePoint см. в разделе См. также.

Формы и отчеты, запускаемые в браузере

Формы, отчеты и большинство макросов запускаются в браузере. Благодаря этому приложение Access может обновлять данные на экране, не создавая заново всю страницу.

Можно создать форму, помогающую пользователям перемещаться по приложению. Новый элемент управления для навигации упрощает добавление на форму стандартных веб-кнопок навигации.

Примечание : Область навигации (функция, с помощью которой пользователи Access просматривают объекты базы данных) недоступна в браузере.

Данные хранятся в списках SharePoint

Все таблицы преобразуются в списки SharePoint, а записи в этих таблицах — в элементы списков. Благодаря этому управлять доступом к веб-базе данных можно с помощью разрешений SharePoint. Кроме того, можно использовать и другие возможности SharePoint.

Примечание по безопасности :  Строка подключения в связанных таблицах не зашифровывается, также как имя пользователя и пароль, если эти сведения предварительно были сохранены (и адрес соответствующей ссылки поддерживает учетные записи пользователя). Если база данных содержит ссылку на список SharePoint, в которой отображается имя пользователя и пароль, злоумышленник может воспользоваться этими учетными данными, чтобы изменить целевой список ссылки. Даже если учетные данные не были сохранены вместе со строкой подключения, злоумышленник может изменить разрешения на сайте SharePoint при помощи сообщника, у которого есть нужные права. Соблюдайте осторожность, открывая доступ к копиям базы данных, содержащей ссылки на списки в опубликованной веб-базе данных.

Запросы и макросы данных выполняются на сервере

Все операции обработки в SQL выполняются на сервере. Это повышает производительность сети, так как по ней передаются лишь результирующие наборы.

Интрасеть или Интернет

Вы можете публиковать данные на собственном сервере SharePoint в интрасети или в Интернете. Корпорация Майкрософт предлагает размещенное решение SharePoint, доступное через Интернет.

К началу страницы

Создание веб-базы данных

В этом разделе описаны основные новые возможности и приведены инструкции по основным задачам проектирования, необходимым для завершения создания веб-базы данных.

В этом разделе:

Подготовка

Использование шаблона

Начало работы с пустой веб-базой данных

Проектирование веб-таблицы

Добавление вычисляемого поля

Настройка правил проверки данных

Создание отношения между двумя веб-таблицами

Изменение поля подстановки в режиме таблицы

Обеспечение целостности данных с помощью макросов данных

Создание веб-запроса

Создание веб-формы

Создание веб-отчета

Создание формы навигации и ее выбор в качестве формы, отображаемой по умолчанию

Подготовка

Перед проектированием веб-базы данных необходимо выполнить ряд задач. Кроме того, существуют определенные различия в проектировании веб-баз данных и баз данных для настольных компьютеров, о которых необходимо знать, особенно опытным разработчикам решений Access.

  • Определите назначение базы данных   . Необходим четкий план, позволяющий принимать правильные решения при проектировании базы данных.

  • Найдите и систематизируйте необходимые сведения   . Использовать связанные таблицы в веб-базе данных нельзя. Перед публикацией необходимо импортировать все нужные данные, которые будут отсутствовать в самой базе данных. Систематизировав данные перед началом проектирования, можно избежать необходимости вносить в схему изменения в связи с непредвиденными изменениями данных.

  • Выберите сайт SharePoint, который будет использоваться для публикации   . Для публикации данных необходима среда SharePoint. Чтобы проверить работу схемы в браузере еще на этапе проектирования (рекомендуется так и сделать), необходимо сначала опубликовать ее.

  • Спланируйте систему обеспечения безопасности   . Для управления доступом к веб-базе данных можно использовать средства безопасности SharePoint. Систему обеспечения безопасности следует спланировать заранее, чтобы можно было встроить ее в схему.

Различия структур веб-баз данных и баз данных для настольных компьютеров

Некоторые возможности, которые можно использовать в базах данных для настольных компьютеров, недоступны в службах Access. Однако существуют новые возможности, поддерживающие многие аналогичные сценарии.

В приведенной ниже таблице указаны возможности, доступные только в базах данных для настольных компьютеров, а также соответствующие новые возможности, позволяющие реализовать такие же сценарии.

Сценарий

Возможность, доступная только в базах данных для настольных компьютеров

Новая возможность

Проектирование объектов баз данных

Конструктор

Расширенный режим таблицы; режим макета

Просмотр сводных данных, таких как суммы, средние значения и группы

Функции группировки

Макросы данных; функции группировки в отчетах

События программирования

VBA

Макросы и макросы данных; новый интерфейс разработки макросов с поддержкой технологии IntelliSense

Переход к объектам базы данных

Область навигации; кнопочные формы

Элемент навигации или другой элемент формы

Важно : В веб-базе данных можно создавать множество клиентских объектов, но их невозможно использовать в браузере. Однако они являются частью веб-базы данных и могут использоваться в Access 2010 на настольном компьютере. Пользователи могут открывать веб-базы данных в Access и использовать клиентские объекты. Это эффективный способ совместного использования базы данных, который открывает новые возможности для совместной работы через Интернет. Проблемы одновременного доступа к данным решает среда SharePoint.

Возможности, доступные только в базах данных для настольных компьютеров и не имеющие аналогов в службах Access

Примечание : Приведенный ниже список не является исчерпывающим.

  • Запросы на объединение

  • Перекрестные запросы

  • Перекрывающиеся элементы управления на формах

  • Отношения между таблицами

  • Условное форматирование

  • Различные действия и выражения макросов

Рекомендуется использовать шаблон

Определив задачи приложения, подумайте, можно ли воспользоваться шаблоном базы данных. Шаблоны баз данных — это встроенные приложения, которые можно использовать в готовом виде или настроить в соответствии с вашими потребностями.

Доступные шаблоны можно просмотреть на вкладке Создать в представлении Backstage. Дополнительные сведения о шаблонах, которые предлагаются в Access 2010, см. в статье Выбор и использование шаблона Access.

Начало работы с пустой веб-базой данных

  • На вкладке Файл нажмите кнопку Создать.

    Вкладка "Создать" в представлении Backstage

Вкладка Файл открывает представление Backstage, новую часть интерфейса Access, где вы найдете команды, применимые ко всей базе данных, например Публикация в SharePoint.

В представлении Backstage на вкладке Создать находятся команды для создания базы данных.

Возможности на вкладке "Создать" в представлении Backstage

1. В разделе Доступные шаблоны щелкните элемент Пустая веб-база данных.

2. Просмотрите предложенное имя файла в поле Имя файла и путь к файлу базы данных ниже. Можно изменить имя файла, введя в его в поле Имя файла.

3. Чтобы изменить путь, щелкните значок папки рядом с полем Имя файла и выберите расположение для размещения файла базы данных.

4. Нажмите кнопку Создать. Откроется новая веб-база данных с новой пустой таблицей.

Проектирование веб-таблицы

Для проектирования веб-таблицы используется режим таблицы.

При первом создании пустой веб-базы данных в Access создается таблица, которая открывается в режиме таблицы. С помощью команд на вкладке "Поля" и "Таблица" можно добавлять поля, индексы, правила проверки и макросы данных — это новая функция, позволяющая изменять данные на основе событий.

После изменения и использования новой таблицы может потребоваться создать дополнительные.

Создание веб-таблицы

В открытой веб-базе данных:

  • на вкладке Создание в группе Таблицы нажмите кнопку Таблица.

Любая только что созданная таблица содержит одно поле — "Счетчик". В таблицу можно добавить и другие поля для хранения данных, соответствующих ее предназначению. Например, можно добавить поле, в котором будет храниться дата начала отслеживания какого-либо процесса.

Добавление поля из коллекции полей

Можно выбрать любой вариант из множества готовых полей и добавить его в таблицу с помощью коллекции полей.

  • На вкладке Поля в группе Добавить и удалить выберите нужный тип поля.

Добавление поля щелчком в области таблицы

  1. В открытой таблице щелкните элемент Щелкните, чтобы добавить и выберите тип поля.

  2. Присвойте полю имя, соответствующее его содержимому.

    Совет : Чтобы изменить имя существующего поля, дважды щелкните его имя.

  3. Повторите эти действия для каждого поля, которое нужно создать.

Изменение свойств поля

Форматирование и свойства поля определяют его поведение, например данные, которые могут в нем храниться. Эти параметры можно настроить в соответствии с конкретными требованиями.

  1. Выберите поле, форматирование и свойства которого требуется изменить.

  2. На ленте откройте вкладку Поля.

  3. С помощью команд в группах Форматирование и Свойства настройте нужные параметры.

Добавление вычисляемого поля

В таблицу можно добавить поле, в котором будет отображаться значение, рассчитываемое на основе других данных таблицы. Использовать в качестве источника вычисляемых данных другие таблицы нельзя. Вычисляемые поля не поддерживают некоторые выражения.

  1. В открытой таблице щелкните элемент Щелкните, чтобы добавить.

  2. Наведите указатель мыши на элемент Вычисляемое поле и выберите для поля тип данных.

    Откроется построитель выражений.

  3. С помощью построителя выражений создайте для поля вычисляемое выражение. Имейте в виду, что в качестве источника данных для вычисления можно использовать только другие поля той же таблицы. Инструкции по работе с построителем выражений см. в статье Использование построителя выражений.

Настройка правил проверки данных

Для проверки входных данных большинства полей можно использовать выражения. Кроме того, с помощью выражений можно также проверять входные данные таблиц (это может пригодиться, если требуется проверить входные данные в поле, не поддерживающем проверку, либо выполнить их проверку на основе значений в других полях таблицы). Более подробные сведения о проверке см. в статье Ограничение ввода данных при помощи правила проверки.

Кроме того, можно указать сообщение, которое будет выводиться каждый раз, когда правило проверки запрещает ввод (такое сообщение называется сообщением проверки).

Создание правила проверки поля и соответствующего сообщения

  1. Выберите поле, для которого требуется добавить правило проверки.

  2. На ленте откройте вкладку Поля.

  3. В группе Проверка поля выберите пункт Проверка, а затем — Правило проверки поля.

    Откроется построитель выражений.

  4. С помощью построителя выражений создайте правило проверки. Инструкции по работе с построителем выражений см. в статье Использование построителя выражений.

  5. В группе Проверка поля выберите пункт Проверка, а затем — Сообщение проверки поля.

  6. Введите сообщение, которое нужно отображать, если входные данные неверны, и нажмите кнопку ОК.

Настройка правила проверки записи и соответствующего сообщения

С помощью правила проверки записи можно предотвратить создание повторяющихся записей либо потребовать, чтобы для записей выполнялись некоторые условия (можно, например, указать, что значение [Дата начала] должно быть больше 1 января 2010 года и меньше значения [Дата окончания]).

  1. Откройте таблицу, для которой требуется добавить правило проверки.

  2. На ленте откройте вкладку Поля.

  3. В группе Проверка поля щелкните элемент Проверка, а затем — Правило проверки записи.

    Откроется построитель выражений.

  4. С помощью построителя выражений создайте правило проверки. Инструкции по работе с построителем выражений см. в статье Использование построителя выражений.

  5. В группе Проверка поля щелкните элемент Проверка, а затем — Сообщение проверки записи.

  6. Введите сообщение, которое нужно отображать, если входные данные неверны, и нажмите кнопку ОК.

Создание отношения между двумя веб-таблицами

Чтобы создать отношение в веб-базе данных, необходимо создать поле подстановки с помощью мастера подстановок. Поле подстановки добавляется в таблицу, которая находится на стороне "много" создаваемого отношения, и указывает на таблицу, которая находится на стороне "один".

Создание поля подстановки в режиме таблицы

  1. Откройте нужную таблицу на стороне "много" создаваемого отношения.

  2. Щелкните стрелку рядом с элементом Щелкните, чтобы добавить и выберите элемент Подстановка и отношение.

  3. Следуя инструкциям мастера подстановок, создайте поле подстановки.

Изменение поля подстановки в режиме таблицы

  1. Откройте таблицу, содержащую поле подстановки, которое требуется изменить.

  2. Выполните одно из указанных ниже действий.

    • На вкладке Поля в группе Свойства нажмите кнопку Изменить подстановки.

    • Щелкните поле подстановки правой кнопкой мыши и выберите команду Изменить подстановки.

  3. Следуйте инструкциям мастера подстановок.

Обеспечение целостности данных с помощью макросов данных

Макросы данных позволяют реализовать каскадное обновление и удаление. С помощью команд на вкладке "Таблица" можно создавать внедренные макросы, изменяющие данные. В видеоролике ниже показаны основные сведения.

Браузер не поддерживает видео. Установите Microsoft Silverlight, Adobe Flash Player или Internet Explorer 9.

Дополнительные сведения о создании макросов данных см. в статье Создание макросов данных.

Создание веб-запроса

Запросы можно использовать в качестве источников данных для форм и отчетов. Запросы выполняются на сервере, что позволяет сократить объем сетевого трафика.

Предположим, что веб-база данных используется для хранения сведений о благотворительных пожертвованиях. Необходимо узнать, кто пожертвовал деньги в ходе мероприятия. Извлечь нужные данные и подготовить их к использованию в формах и отчетах можно с помощью запроса.

Примечание : В этой процедуре в качестве примера используется шаблон благотворительных пожертвований. Следуя приведенным ниже инструкциям, создайте базу данных с помощью этого шаблона.

  1. На вкладке Создать в группе Запросы нажмите кнопку Запрос.

  2. В диалоговом окне Добавление таблицы дважды щелкните каждую таблицу, которую требуется включить, а затем нажмите кнопку Закрыть.

    В этом примере дважды щелкните таблицы "Благотворители", "Пожертвования", "Мероприятия" и "ПосетителиМероприятия".

  3. Создайте необходимые соединения, перетаскивая поля из одного объекта в другой в окне конструктора запросов.

    В этом примере перетащите поле кода из таблицы "Благотворители" на поле "КодСпонсора" в таблице "Пожертвования", а затем — поле "КодСпонсора" из таблицы "Пожертвования" на поле "КодБлаготворителя" в таблице "ПосетителиМероприятия".

  4. Добавьте необходимые поля, перетащив их в таблицу. Кроме того, можно дважды щелкнуть поле, чтобы добавить его.

    В этом примере добавьте поле "Мероприятие" из таблицы "Мероприятия", поле "ДатаПожертвования" из таблицы "Пожертвования", а также поля "Обращение", "Имя" и "Фамилия" из таблицы "Благотворители".

  5. Добавьте необходимые условия.

    В этом примере значение "ДатаПожертвования" должно находиться в интервале между значениями "ДатаНачала" и "ДатаОкончания" мероприятия. В таблице конструктора запросов в строке Условия столбца "ДатаПожертвования" введите >=[ДатаНачала] и<=[ДатаОкончания].

Создание веб-формы

Формы являются основным средством ввода и редактирования данных в веб-базе данных и могут использоваться для их просмотра. Формы запускаются в браузере, что позволяет оптимизировать производительность системы. При открытии формы браузер получает необходимые данные с сервера SharePoint. Данные в форме можно затем фильтровать и сортировать без их повторного получения с сервера.

Совет : Чтобы добиться оптимальной производительности, ограничивайте количество записей, получаемых основными формами и отчетами.

  1. Выберите таблицу или запрос, которые нужно использовать в качестве источника данных.

    Примечание : Если требуется создать несвязанную форму, пропустите это действие.

  2. На вкладке Создать в группе Формы нажмите одну из указанных ниже кнопок.

    • Форма   : создание простой формы, которая отображает одну запись за раз, используя указанный объект в качестве источника данных.

      Примечание : При создании несвязанной формы эта кнопка недоступна.

    • Несколько элементов   : создание формы, которая отображает сразу несколько записей, используя указанный объект в качестве источника данных.

      Примечание : При создании несвязанной формы эта кнопка недоступна.

    • Пустая форма   : создание формы без содержимого.

    • Таблица   : создание формы, которая выглядит и работает как таблица, используя указанный объект в качестве источника данных.

      Примечание : При создании несвязанной формы эта кнопка недоступна.

Создание веб-отчета

Отчеты являются основным средством просмотра и вывода на печать данных из веб-базы. Отчеты запускаются в браузере, что позволяет оптимизировать производительность системы. При открытии отчета браузер получает необходимые данные с сервера SharePoint. Данные в отчете можно затем фильтровать и сортировать без повторного получения с сервера.

Совет : Чтобы добиться оптимальной производительности, ограничивайте количество записей, получаемых основными формами и отчетами.

  1. Выберите таблицу или запрос, которые нужно использовать в качестве источника данных.

  2. На вкладке Создать в группе Отчеты нажмите одну из указанных ниже кнопок.

    • Отчет   : создание простого отчета с использованием указанного объекта в качестве источника данных.

    • Пустой отчет   : создание отчета без содержимого.

Создание формы навигации и ее выбор в качестве формы, отображаемой по умолчанию

Пользователям необходимы средства навигации по приложению. Помните, что в веб-браузере недоступна область навигации. Чтобы пользователи могли работать с объектами базы данных, им необходимо предоставить для этого соответствующие средства. Можно создать форму навигации и указать, что она должна отображаться при открытии приложения в веб-браузере. Следует помнить, что, если форма, отображаемая при запуске приложения, не выбрана, приложение откроется без формы. Работать с таким приложением будет невозможно.

Совет : Форму навигации можно создать в последнюю очередь, чтобы добавить на нее сразу все необходимые объекты.

  1. На ленте откройте вкладку Создать.

  2. В группе Формы щелкните элемент Навигация и выберите в списке макет навигации.

  3. Чтобы добавить элемент, перетащите его из области навигации на элемент навигации.

    Примечание : На элемент навигации можно добавлять только формы и отчеты.

  4. Добавьте на тело формы навигации все необходимые элементы управления. Например, можно создать инструмент для поиска по всем формам, добавив на форму навигации соответствующие компоненты.

Назначение формы навигации в качестве веб-формы, отображаемой по умолчанию

  1. На вкладке Файл в разделе Справка щелкните элемент Параметры.

  2. В диалоговом окне "Параметры Access" щелкните элемент Текущая база данных.

  3. В группе Параметры приложений щелкните элемент Веб-форма просмотра и выберите в списке нужную форму.

    Примечание :  Выбирать в качестве веб-формы просмотра форму навигации необязательно: можно указать любую веб-форму.

К началу страницы

Публикация приложения и синхронизация изменений

Публикация веб-базы данных

Вы можете просмотреть видео об этом процессе в разделе Обзор.

  1. На вкладке Файл нажмите кнопку Сохранить и опубликовать, а затем — Опубликовать в службах Access.

  2. Нажмите кнопку Проверить совместимость.
    Кнопка "Проверить совместимость" в представлении Backstage приложения Access
    Проверка совместимости обеспечивает корректную публикацию базы данных. Если она находит какие-либо проблемы, решите их до публикации.

    Примечание :  Информация о выявленных проблемах сохраняется в таблице под заголовком "Ошибки веб-совместимости". Каждая строка в таблице содержит ссылку на сведения об устранении неполадок.

  3. В разделе Публикация в службах Access введите указанные ниже сведения.

    • В поле URL-адрес сервера укажите веб-адрес сервера SharePoint, на котором вы хотите опубликовать базу данных, например http://Contoso/.

    • В поле Имя сайта укажите имя веб-базы данных. Это имя в сочетании с URL-адресом сервера образует URL-адрес приложения. Например, если URL-адрес сервера — http://Contoso/, а имя сайта — CustomerService, то URL-адрес приложения будет http://Contoso/CustomerService.

  4. Щелкните элемент Опубликовать в службах Access.

Синхронизация веб-базы данных

После изменения схемы базы данных в автономном режиме в конечном итоге придется выполнить ее синхронизацию. Это устраняет различия между файлом базы данных на компьютере и на сайте SharePoint.

Вы можете просмотреть видео об этом процессе в разделе Обзор.

  1. Откройте веб-базу данных в приложении Access и внесите изменения в ее структуру.

  2. По окончании выберите вкладку Файл и нажмите кнопку Синхронизировать все.
    Кнопка "Синхронизировать все" в представлении Backstage приложения Access

К началу страницы

Совершенствование навыков
Перейти к обучению
Первоочередный доступ к новым возможностям
Присоединиться к программе предварительной оценки Office

Были ли сведения полезными?

Спасибо за ваш отзыв!

Благодарим за отзыв! Возможно, будет полезно связать вас с одним из наших специалистов службы поддержки Office.

×